Subject: [Hipsec] SHA1 broken?

From: [email-masked] (Miika Komu)
Date: Wed Feb 16 04:34:01 2005

http://www.schneier.com/blog/archives/2005/02/sha1_broken.html

-- 
Miika Komu              [email-masked]          http://www.iki.fi/miika/

---

From: [email-masked] (Tim Shepard)
Date: Wed Feb 16 07:00:01 2005

> http://www.schneier.com/blog/archives/2005/02/sha1_broken.html

Does this mean that HITs will need to be 256 bits long now (for there
are no crypto hash functions left standing with output shorter than
256 bits)?     I think so.

I wonder how long SHA256 will remain standing.

			-Tim Shepard
			 [email-masked]

---

From: [email-masked] (Jari Arkko)
Date: Wed Feb 16 07:05:01 2005

> are no crypto hash functions left standing with output shorter than

Well, if those other functions are secure, do you have to use
all the output bits? Seems like an output cut to 128 would
suffice too, unless there's some weakness in the hash
function. Presumably the SHA-1 weaknesses, if real,
relate to some problem in the definition of the function
rather than the mere insufficiency of the bits...

--Jari

---

From: [email-masked] (Greg Perkins)
Date: Tue Feb 22 16:33:02 2005

The HIT needs two properties:

1) probably unique
2) a identifier for the HI

SHA1 will still supply property 1).

As for property 2), I thought HIP was using a non-keyed SHA1 hash for
HI=>HIT computation?  Basically, HIP is using SHA1's "randomness" property
to meet property 1), yes?  In this case, there is nothing to break and
property 2) holds as well.  As for using keyed SHA1 for say, signing a
packet or whatnot, then yes, looks like SHA256 will have to be used soon.

Greg Perkins

----- Original Message ----- 
From: "Jari Arkko" <[email-masked]>
To: "Tim Shepard" <[email-masked]>
Cc: "Miika Komu" <[email-masked]>; <[email-masked]>
Sent: Wednesday, February 16, 2005 7:02 AM
Subject: Re: [Hipsec] SHA1 broken?

> _______________________________________________
> Hipsec mailing list
> [email-masked]
> http://honor.trusecure.com/mailman/listinfo/hipsec
>