Subject: [Hipsec] RE: Numbering of TLVs

From: "Henderson, Thomas R" <[email-masked]>
Date: Tue, 31 May 2005 08:03:47 -0700

> Comments on the following values?
> 
> 		OLD 	NEW
> ESP draft:
> ESP_INFO	1	41
> 
> Base draft:
> R1_COUNTER    	2	64
> PUZZLE      	5	91
> SOLUTION    	7	101
> SEQ		11	131
> ACK		13	141
> DIFFIE_HELLMAN 	15	171
> HIP_TRANSFORM  	17	201
> ENCRYPTED      	21	257
> HOST_ID        	35	321
> CERT           	64	384
> NOTIFY         	256	448
> 

I strongly support getting improved spacing.  I have been staring at the
above list for a few minutes, trying to discern the numbering pattern.
Is there one?  The numbering patterns that seem to be in effect are:

- parameters protected by signature are in the range 1-4096
  - except for nonces and transforms, the range is really 1-511
- nonces are numbered in the range 1022-1024
- transforms are numbered 2048-4096
- crypto parameters are numbered between (2^16 - 291) and (2^16 - 257)

While we are doing this, we should consider also the known parameters
that exist in the other core drafts, and that are likely to form the
complete set of parameters approved in this cycle of WG documents:

			OLD
ESP_INFO		1
R1_COUNTER		2
LOCATOR		3
PUZZLE		5
SOLUTION		7
SEQ			11
ACK			13
DIFFIE_HELLMAN 	15
HIP_TRANSFORM  	17
ENCRYPTED   	21
HOST_ID     	35
CERT        	64
NOTIFY      	256

ECHO_REQUEST 	1022
ECHO_RESPONSE 	1024

ESP_TRANSFORM 	2048	

HMAC			65245
HMAC_2		65247
HIP_SIGNATURE_2  	65277
HIP_SIGNATURE    	65279
ECHO_REQUEST      65281
ECHO_RESPONSE     65283

FROM			65470
RVS_HMAC		65472
VIA_RVS		65474

I think it might be useful to state the numbering rationale, and then go
for equal spacing in the various sub-ranges:

"Because the ordering (from lowest to highest) of HIP parameters is
strictly enforced, the parameter type values for existing parameters
have been spaced to allow for future protocol extensions.  Parameters
numbered between 0-1023 are used in HIP handshake and update procedures
and are covered by signatures. Parameters numbered between 1024-2047 are
reserved. Parameters numbered between 2048-4095 are used for parameters
related to HIP transform types.  Parameters numbered between 4096 and
(2^16 - 2^12) 61439 are reserved.  Parameters numbered beteween
61440-62463 are used for signatures and signed MACs.  Parameters
numbered between 62464-63487 are used for parameters that fall outside
of the signed area of the packet.  Parameters numbered between
63488-64511 are used for rendezvous and other relaying services.
Parameters numbered between 64512-65535 are reserved."

Then, I suggest taking these ranges and allocating each parameter to be
roughly equally spaced by some increment, and in the future, if we need
to insert a new parameter between two existing ones, it is numbered to
split the difference between the two, etc.

For example:
			OLD		NEW
ESP_INFO		1		65 (2^6+1)
R1_COUNTER		2		128 (2*2^6)
LOCATOR		3		193 (3*2^6 + 1, etc.)
PUZZLE		5		257
SOLUTION		7		321
SEQ			11		385
ACK			13		449
DIFFIE_HELLMAN 	15		513
HIP_TRANSFORM  	17		577
ENCRYPTED   	21		641
HOST_ID     	35		705
CERT        	64		768
NOTIFY      	256		832

ECHO_REQUEST 	1022		896
ECHO_RESPONSE 	1024		960

ESP_TRANSFORM 	2048		2048

HMAC			65245		61505	
HMAC_2		65247		61569
HIP_SIGNATURE_2  	65277		61633
HIP_SIGNATURE    	65279		61697

ECHO_REQUEST      65281		63661
ECHO_RESPONSE     65283		63425

FROM			65470		63552
RVS_HMAC		65472		63616
VIA_RVS		65474		63680

_______________________________________________
Hipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hipsec

---

From: Petri Jokela <[email-masked]>
Date: Wed, 01 Jun 2005 11:03:11 +0300

> numbered between 0-1023 are used in HIP handshake and update procedures

Was there any reasoning ealier to put them below 512?

> split the difference between the two, etc.

Ok. Any objections to the proposed numbering?

> ECHO_RESPONSE     65283		63425

/petri

-- 
Petri Jokela                        Tel:    +358 9 299 2413
Research scientist                  Fax:    +358 9 299 3535
NomadicLab, Ericsson Research       Mobile: +358 44 299 2413
Oy L M Ericsson Ab                  email: [email-masked]