Subject: RE: [Hipsec] moving from R2-SENT to UNASSOCIATED

From: "Henderson, Thomas R" <[email-masked]>
Date: Mon, 23 May 2005 09:04:56 -0700

> -----Original Message-----
> From: Julien Laganier [mailto:[email-masked]] 
> Sent: Monday, May 23, 2005 8:40 AM
> To: [email-masked]
> Cc: Henderson, Thomas R
> Subject: Re: [Hipsec] moving from R2-SENT to UNASSOCIATED
> 
> I think we should at least move this signification in the ESTABLISHED 
> state text, and perhaps define it properly prior to states 
> description. For wxample: "When a HIP node hasn't used a HIP 
> association for Unused Association Lifetime (UAL) minutes, it will 
> begin to tear down the association".
> 
> It might also be good to suggest a typical value (5 min?) for 
> implementors.
> 

5 minutes seems short to me.  I don't know what magic number (if
any) is appropriate.

Here is what IKEv2 Section 2.8 says about the matter:

"  ... If an SA bundle has been inactive for a long time and
   if an endpoint would not initiate the SA in the absence of traffic,
   the endpoint MAY choose to close the SA instead of rekeying it when
   its lifetime expires. It SHOULD do so if there has been no traffic
   since the last time the SA was rekeyed."

_______________________________________________
Hipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hipsec

---

From: Pekka Nikander <[email-masked]>
Date: Mon, 23 May 2005 20:49:41 +0300

>> [About UAL]

UAL has been traditionally 15 minutes, but I don't know the
origin of that value.  It came from Bob Moskowitz, and I don't
know the rationale behind that.

IMHO each implementation SHOULD implement per-HIT configuration
of UAL, allowing statically configured HIP associations to stay
alive days, even when inactive.

--Pekka

---

From: Lars Eggert <[email-masked]>
Date: Mon, 23 May 2005 22:54:25 +0200

> alive days, even when inactive.

Yes, please. We're pushing a similar change to TCP right now.

Lars
-- 
Lars Eggert                                     NEC Network Laboratories