Subject: [Hipsec] Re: [hipsec ]I-D Action:draft-ietf-hip-native-api-03.txt

From: Miika Komu <[email-masked]>
Date: Mon, 19 Nov 2007 18:48:26 +0200 (EET)

Hi,

> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories. This draft is a work item of the Host Identity Protocol 
> Working Group of the IETF.
>
>	Title           : Using the Host Identity Protocol with Legacy
>                         Applications
>	Author(s)       : T. Henderson, et al.
>	Filename        : draft-ietf-hip-applications-02.txt
>	Pages           : 18
>	Date            : 2007-11-19
>
> This document is an informative overview of how legacy applications
> can be made to work with the Host Identity Protocol (HIP).  HIP
> proposes to add a cryptographic name space for network stack names.
> From an application viewpoint, HIP-enabled systems support a new
> address family of host identifiers, but it may be a long time until
> such HIP-aware applications are widely deployed even if host systems
> are upgraded.  This informational document discusses implementation
> and Application Programming Interface (API) issues relating to using
> HIP in situations in which the system is HIP-aware but the
> applications are not, and is intended to aid implementors and early
> adopters in thinking about and locally solving systems issues
> regarding the incremental deployment of HIP.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-hip-applications-02.txt

here is a summary of the changes between 02 and 03 version:

   * Clarifications to the use of opportunistic mode
   * Replaced SHIM generalization with just "HIP"
   * The locator was removed from the HIT data structure
   * Discussion on error handling in section 4.3
   * Removed section "Layering Model"
   * New section 4.3 "Manual Handling of Locators"
   * Added a summary of new definitions to the appendix
   * Comments on hostname mapping to multiple HITs
   * Comments on HIT mapping to multiple locators
   * HITs are now compared now with memcmp (no more endpoint descriptors)
   * Clarified the ordering of identifiers returned by the resolver
   * Added a reserved field to sockaddr_hip for forwards compatibility
   * Added #include statements to the code blocks
   * Dependencies to SHIM6 removed and/or referenced better now
   * AI_PASSIVE clafications; added AI_PASSIVE_PUB and AI_PASSIVE_ANON
   * Added HIP_IS_IPV6_ADDR_ANON_HIT macro
   * Lot's of editorial nits and corrections to spelling
   * Updated references (note: the reference
     to I-D.henderson-hip-applications is still outdated)

For details, please dig in here:

http://www1.ietf.org/mail-archive/web/hipsec/current/msg02249.html
http://www1.ietf.org/mail-archive/web/hipsec/current/msg02230.html
http://www1.ietf.org/mail-archive/web/hipsec/current/msg02224.html
http://www1.ietf.org/mail-archive/web/hipsec/current/msg02230.html
http://www1.ietf.org/mail-archive/web/hipsec/current/msg02187.html

Thanks for the reviewers for great comments! Please post further comments 
to the mailing list.

-- 
Miika Komu                                       http://www.iki.fi/miika/

_______________________________________________
Hipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hipsec

---

From: Miika Komu <[email-masked]>
Date: Mon, 19 Nov 2007 19:19:07 +0200 (EET)

On Mon, 19 Nov 2007, Miika Komu wrote:

Hi,

sorry, the draft pointer was incorrect. The current version is number 
three and it is here:

http://www.ietf.org/internet-drafts/draft-ietf-hip-native-api-03.txt

The summary of draft changes applies to version three.

> Thanks for the reviewers for great comments! Please post further comments to 
> the mailing list.
>
> --