Subject: [Hipsec] HMAC Key material

From: Robert Moskowitz <[email-masked]>
Date: Tue, 15 Dec 2009 11:39:47 -0500

In 5.2's table, HMAC and HMAC_2 are defined as "HMAC based message 
authentication code, with key material from HIP_TRANSFORM."  And of 
course there is NO keying material in HIP_TRANSFORM....

Then in 5.2.9 & 5.2.10 there is no mention of keying material.

But in 6.4.1 KEYMAT is referenced as the source of the D-H derived 
keying material.

 From this I ASSuME the 5.2 table is in error?  It should either 
directly reference KEYMAT or indirectly DIFFIE_HELLMAN TLV?

---

From: "Ahrenholz, Jeffrey M" <[email-masked]>
Date: Tue, 15 Dec 2009 09:03:51 -0800

> course there is NO keying material in HIP_TRANSFORM....
...
> directly reference KEYMAT or indirectly DIFFIE_HELLMAN TLV?

Yes it would make most sense to reference the KEYMAT generation section. In terms of TLVs, you need DIFFIE_HELLMAN, SOLUTION, and HIP_TRANSFORM to generate the KEYMAT and choose an HMAC key, so indeed it doesn't make sense to only mention HIP_TRANSFORM. 

The table probably meant to indicate that HIP_TRANSFORM determines the hash function used.

-Jeff

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 15 Dec 2009 12:45:24 -0500

> The table probably meant to indicate that HIP_TRANSFORM determines the hash function used.

And that will change with the addtion of a HASH HIP Parameter,