Subject: [Hipsec] OPS-DIE review of draft-ietf-hip-over-hip-05

From: <[email-masked]>
Date: Fri, 25 Feb 2011 14:07:31 -0500

I have performed an Operations Directorate review of draft-ietf-hip-over-hip-05

Operations directorate reviews are solicited primarily to help the area directors improve their efficiency, particularly when preparing for IESG telechats, and allowing them to focus on documents requiring their attention and spend less time on the trouble-free ones.  Improving the documents is important, but clearly a secondary purpose.  A third purpose is to broaden the OpsDir reviewers' exposure to work going on in other parts of the IETF.

Reviews from OpsDir members do not in and of themselves cause the IESG to raise issue with a document. The reviews may, however, convince individual IESG members to raise concern over a particular document requiring further discussion. The reviews, particularly those conducted in last call and earlier, may also help the document editors improve their documents.

--------------

Summary: This draft is basically ready for publication, but has nits that should be fixed before publication.

HIP is in a related functional space to IPsec, and in both cases IETF protocols are not typical means for operation and management (e.g., the IPsec SPD MIB is not widely used for configuring IPsec).  This draft specifies minor extensions to HIP in that it defines two additional HIP transports, so it's not a reasonable vehicle for a general discussion of HIP operations and management.  As a result, this review focuses on operational characteristics of the extensions specified in the draft.

This draft defines two new fully encrypted transports for HIP signaling messages - ESP and ESP over TCP.  The draft includes details on negotiation of these modes as extensions to existing HIP signaling, providing support for incremental deployment, a migration path and backwards compatibility.  While it is probably best to start out with the intended transport (i.e., negotiate it in the HIP base exchange), means are also specified to negotiate a transport change later.  An error report is defined for use when a HIP node policy requires use of one of these fully encrypted transports, but none is offered in negotiation.  Fallback to a non-encrypted transport is specified and recommended (SHOULD) when the encrypted transport fails.

I have one recommendation for change - this draft is somewhat inconsistent about support for a HIP node policy that requires use of an encrypted transport for HIP signaling.  Section 3.3 provides an essential building block, the error signaling mechanism to indicate that an encrypted transport is required and none was proposed.  On the other hand, Section 5 is unclear with respect to this class of policy in that it strongly recommends (SHOULD) fallback to a non-encrypted HIP connection but requires (MUST) that "messages that are intended to be sent only encrypted" not be sent unencrypted.  If the "messages that are intended to be sent only encrypted" are all HIP messages after the base exchange, these two requirements appear to be in conflict.

I suggest adding a short explanation to Section 5 of what would be reasonable vs. unreasonable policy for "messages that are intended to be sent only encrypted", and how to use the Section 3.3 error report when a failed encrypted connection is recovered by attempting to fall back to an unencrypted connection when HIP node policy requires encryption of all signaling after the base exchange.

Thanks,
--David
----------------------------------------------------
David L. Black, Distinguished Engineer
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

---

From: <[email-masked]>
Date: Fri, 25 Feb 2011 14:14:26 -0500

Freudian slip - that should be OPS-DI*R* in the subject line ...

Thanks,
--David

> -----Original Message-----
> From: Black, David
> Sent: Friday, February 25, 2011 2:08 PM
> To: [email-masked]; [email-masked]'
> Cc: Black, David; David Ward; Gonzalo Camarillo; Ralph Droms; [email-masked]
> Subject: OPS-DIE review of draft-ietf-hip-over-hip-05
> 
> Operations directorate reviews are solicited primarily to help the area directors improve their
> efficiency, particularly when preparing for IESG telechats, and allowing them to focus on documents
> requiring their attention and spend less time on the trouble-free ones.  Improving the documents is
> important, but clearly a secondary purpose.  A third purpose is to broaden the OpsDir reviewers'
> exposure to work going on in other parts of the IETF.
> 
> Reviews from OpsDir members do not in and of themselves cause the IESG to raise issue with a document.
> The reviews may, however, convince individual IESG members to raise concern over a particular document
> requiring further discussion. The reviews, particularly those conducted in last call and earlier, may
> also help the document editors improve their documents.
> 
> --------------
> 
> HIP is in a related functional space to IPsec, and in both cases IETF protocols are not typical means
> for operation and management (e.g., the IPsec SPD MIB is not widely used for configuring IPsec).  This
> draft specifies minor extensions to HIP in that it defines two additional HIP transports, so it's not
> a reasonable vehicle for a general discussion of HIP operations and management.  As a result, this
> review focuses on operational characteristics of the extensions specified in the draft.
> 
> This draft defines two new fully encrypted transports for HIP signaling messages - ESP and ESP over
> TCP.  The draft includes details on negotiation of these modes as extensions to existing HIP
> signaling, providing support for incremental deployment, a migration path and backwards compatibility.
> While it is probably best to start out with the intended transport (i.e., negotiate it in the HIP base
> exchange), means are also specified to negotiate a transport change later.  An error report is defined
> for use when a HIP node policy requires use of one of these fully encrypted transports, but none is
> offered in negotiation.  Fallback to a non-encrypted transport is specified and recommended (SHOULD)
> when the encrypted transport fails.
> 
> I have one recommendation for change - this draft is somewhat inconsistent about support for a HIP
> node policy that requires use of an encrypted transport for HIP signaling.  Section 3.3 provides an
> essential building block, the error signaling mechanism to indicate that an encrypted transport is
> required and none was proposed.  On the other hand, Section 5 is unclear with respect to this class of
> policy in that it strongly recommends (SHOULD) fallback to a non-encrypted HIP connection but requires
> (MUST) that "messages that are intended to be sent only encrypted" not be sent unencrypted.  If the
> "messages that are intended to be sent only encrypted" are all HIP messages after the base exchange,
> these two requirements appear to be in conflict.
> 
> I suggest adding a short explanation to Section 5 of what would be reasonable vs. unreasonable policy
> for "messages that are intended to be sent only encrypted", and how to use the Section 3.3 error
> report when a failed encrypted connection is recovered by attempting to fall back to an unencrypted
> connection when HIP node policy requires encryption of all signaling after the base exchange.
> 
> Thanks,
> --David

---

From: Ari Keränen <[email-masked]>
Date: Mon, 28 Feb 2011 15:11:09 +0200

Hi David,

Thanks for the review!

On Feb 25, 2011, at 9:07 PM, <[email-masked]> <[email-masked]> wrote:
[...]
> Summary: This draft is basically ready for publication, but has nits that should be fixed before publication.
[...]
> I have one recommendation for change - this draft is somewhat inconsistent about support for a HIP node policy that requires use of an encrypted transport for HIP signaling.  Section 3.3 provides a…

That's a valid point. A policy that would prevent sending the re-establishing UPDATEs un-encrypted after a failed encrypted connection would be unreasonable since then one could never re-establish such a connection or even close it properly. This is already explicit for the receiving end (MUST accept without encryption), but making it explicit also for the sender makes sense.

The first SHOULD refers to the fact that one may also do something else than re-establish the connection (e.g., close it).

> I suggest adding a short explanation to Section 5 of what would be reasonable vs. unreasonable policy for "messages that are intended to be sent only encrypted", and how to use the Section 3.3 erro…

If we explicitly prevent a policy that would not allow un-encrypted connection re-establisihing UPDATEs, I think we have this fixed, and we would not need to use error messages for informing about this. I would change the text in section 5 into (added the last sentence and changed the second-to-last one):

   [...] If encryption was
   previously used, hosts SHOULD send outside of the encrypted
   connection only HIP messages that are used to re-establish the
   encrypted connection.  Especially, messages for which the policy is
   to send them only encrypted (e.g., DATA messages using an encrypted
   transport mode) MUST be sent only using the encrypted connection.
   Note that a policy MUST NOT prevent sending un-encrypted UPDATE
   messages used for re-establishing the encrypted connection, since
   that would prevent recovering from failed encrypted connections.

Cheers,
Ari