Subject: [Hipsec] RFC5201-bis status

From: "Henderson, Thomas R" <[email-masked]>
Date: Mon, 12 Mar 2012 14:09:51 -0700

The new version of RFC5201-bis was just published at:
http://www.ietf.org/internet-drafts/draft-ietf-hip-rfc5201-bis-08.txt

This version had the following changes:

   o  Removed lingering references to SHA-1 as the mandatory hash
      algorithm (which was changed to SHA-256 in the -02 draft version).

   o  For parameter type number changes, changed "IETF Review" to "IETF
      Review or IESG Approval".

   o  Updated Appendix C checksum examples to conform to HIPv2 packets.

There remain nine open issues in the tracker for this draft:
http://trac.tools.ietf.org/wg/hip/trac/query?component=rfc5201-bis

I believe that three could be closed immediately as being already done, and I will plan to do so in a week if there are no comments:

#18 Selection of 160-bit ECC curve
#26 IESG: Randomize hashing in signatures
#28 IESG: support combined encryption modes

I believe that two can be closed with some brief list discussion (will open separate discussion threads):

#30 Handle interactions with complex SPDs
#32 normative text on when to have Domain Identifier

There are four that seem to require more work and discussion to close out:

#26 Orchid Generation Algorithm (OGA) in ORCHID document (requires coordination with 4843-bis)
#29 IESG: Use different RSA mode OAEP/PSS
#33 reusing DH public values
#35 Limiting ECC to co-factor of 1

- Tom

---

From: "Henderson, Thomas R" <[email-masked]>
Date: Thu, 22 Mar 2012 03:38:02 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Henderson, Thomas R
> Sent: Monday, March 12, 2012 2:10 PM
> To: [email-masked]
> Subject: [Hipsec] RFC5201-bis status
> 
> I believe that three could be closed immediately as being already done,
> and I will plan to do so in a week if there are no comments:
> 

I have now closed the above issues.  We have closed 10 of the 14 issues against RFC5201-bis, and the four below remain.  There are no open issues logged against RFC5202-bis.  

> coordination with 4843-bis)

This is a matter of coordinating changes that have been made to 5201 into the revised 4843-bis.  I will have some time next week to review this and make a proposal.

> #29 IESG: Use different RSA mode OAEP/PSS

Will open separate thread on this.

> #33 reusing DH public values

Tobias has proposed text here:  http://trac.tools.ietf.org/wg/hip/trac/ticket/33

Are there any comments or should we adopt the proposed text and close this issue?

> #35 Limiting ECC to co-factor of 1

Bob has proposed text here:  http://trac.tools.ietf.org/wg/hip/trac/ticket/35

Are there any comments or should we adopt the proposed text and close this issue?

- Tom

---

From: Miika Komu <[email-masked]>
Date: Thu, 22 Mar 2012 13:28:07 +0200

Hi,

On 03/22/2012 12:38 PM, Henderson, Thomas R wrote:
> Tobias has proposed text here:http://trac.tools.ietf.org/wg/hip/trac/ticket/33
>
> Bob has proposed text here:http://trac.tools.ietf.org/wg/hip/trac/ticket/35
>

I am not an expert on the topic, but proposals seem fine to me.