Subject: [Hipsec] HIP and UDP

From: Robert Moskowitz <[email-masked]>
Date: Wed, 12 Sep 2012 16:21:49 -0400

I really should know this, and if I dig a bit, I will find it I suspect, 
but are UDP apps (eg tftp) bound to IP addresses as TCP apps (via the 
TCB).  Is there a UCB?  I can't find my intro to TCP/IP by Stevens book....

Why I ask, you ask?

I am assuming the same address mapping is occuring in UDP apps as in TCP 
apps.

Just some musings at the end of the day.  Like I said, I am having some 
random thoughts here....

---

From: Andrew McGregor <[email-masked]>
Date: Thu, 13 Sep 2012 10:24:18 +1200

The same address mapping has to be possible, yes.  This isn't necessarily done by socket information, as binding UDP sockets is optional.  But, in the kernel, after source address selection, all the necessary information is available anyway.

On 13/09/2012, at 8:21 AM, Robert Moskowitz <[email-masked]> wrote:

> I really should know this, and if I dig a bit, I will find it I suspect, but are UDP apps (eg tftp) bound to IP addresses as TCP apps (via the TCB).  Is there a UCB?  I can't find my intro to TCP/IP by Stevens book....
> 
> Why I ask, you ask?
> 
> I am assuming the same address mapping is occuring in UDP apps as in TCP apps.
> 
> Just some musings at the end of the day.  Like I said, I am having some random thoughts here....
> 
> 
> _______________________________________________
> Hipsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hipsec