Subject: Re: [Hipsec] I-D Action: draft-ietf-hip-rfc6253-bis-00.txt

From: Samu Varjonen <[email-masked]>
Date: Mon, 26 Aug 2013 14:45:24 +0300

On 01/07/13 16:25, Henderson, Thomas R wrote:
>
>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On
>> Behalf Of Samu Varjonen
>> Sent: Wednesday, April 03, 2013 1:14 AM
>> To: [email-masked]
>> Subject: Re: [Hipsec] I-D Action: draft-ietf-hip-rfc6253-bis-00.txt
>>
>> Hi all,
>>
>> I have some cycles that I can use to get this document forward. This is
>> the initial submission it does not differ from the RFC6253. What would
>> be the next steps for this document? Has anyone raised any
>> comments/questions that should be fixed before this can be taken
>> forward? To my knowledge there are none.
>
>
> Samu,
> I reviewed this draft, compared it with the RFC, and found some small editorial differences (perhaps applied by the RFC Editor) that should be reapplied, in my opinion.   Also, the document should point to the bis version of RFC5201.  I'll send those to you off list.  Other than that, I do not think any changes are needed and I think that this is ready for WGLC.
>

Hi,

sorry for the delay. I will include the nits in to the next revision.

BR,
Samu

> - Tom

---

From: Samu Varjonen <[email-masked]>
Date: Tue, 27 Aug 2013 11:36:09 +0300

On 02/07/13 02:05, David Mattes wrote:
> Hi Samu,
>
> I have reviewed the draft as well.  I just have a couple
> questions/comments about Section 3.  Other than this I think this is
> ready to move forward.
>
> Section 3, Paragraph 1:
> Why do you use normative MUSTs for the Issuer and Subject Alternative
> Names?  Is it because these certificates would not otherwise have
> Distinguished Names?  If you could add a sentence about the rationale
> behind these MUSTs, that would be helpful.

These MUSTs should be SHOULDs in my opinion. Other fields can be used to convey 
the HITs but the rationale for recommending IAN and SAN is that the information 
would always be in the same place.

  It is not clear why I
> might have the situation described in paragraph 1 versus paragraph 2.
>

HIP aware PKI vs. not HIP aware PKI

> Section 3, Paragraph 3:
> Can the MUST be changed to a SHOULD?  I ask because a remote peer may
> be pre-configured with the CA chain, and is therefore unnecessary to
> send the intermediate CAs.

I agree this can be relaxed to SHOULD as it may be the case that it is 
unnecessary to include the whole chain.

BR,
Samu

> Thank you,
> David