Subject: [Hipsec] Fwd: New Version Notification for draft-moskowitz-hip-dex-01.txt

From: Rene Hummen <[email-masked]>
Date: Tue, 4 Mar 2014 12:40:50 +0000

Hi all,

this updated version of HIP DEX (individual submission) aligns the protocol specification with RFC5201-bis and adds new protocol features. The main changes with respect to the previous version are as follows:

* Numerous editorial changes.
* New retransmission strategy.
* New HIT generation mechanism.
* Modified layout of ENCRYPTED_KEY parameter.
* Clarify to use puzzle difficulty of zero under normal network conditions.
* Align inclusion directive of R1_COUNTER with HIPv2 (from SHOULD to MUST).
* Align inclusion of TRANSPORT_FORMAT_LIST with HIPv2 (added to R1 and I2).
* HIP_CIPHER, HIT_SUITE_LIST, and TRANSPORT_FORMAT_LIST must now be echoed in R2 packet.
* Added new author.

Feedback is much appreciated.

Cheers,
René

Begin forwarded message:
From: <[email-masked]>
> Subject: New Version Notification for draft-moskowitz-hip-dex-01.txt
> Date: 4 Mar 2014 10:54:03 GMT+1
> To: Robert Moskowitz <[email-masked]>, Rene Hummen <[email-masked]>, Rene Hummen <[email-masked]>, Robert Moskowitz <[email-masked]>
> 
> 
> A new version of I-D, draft-moskowitz-hip-dex-01.txt
> has been successfully submitted by Rene Hummen and posted to the
> IETF repository.
> 
> Name:		draft-moskowitz-hip-dex
> Revision:	01
> Title:		HIP Diet EXchange (DEX)
> Document date:	2014-03-04
> Group:		Individual Submission
> Pages:		39
> URL:            http://www.ietf.org/internet-drafts/draft-moskowitz-hip-dex-01.txt
> Status:         https://datatracker.ietf.org/doc/draft-moskowitz-hip-dex/
> Htmlized:       http://tools.ietf.org/html/draft-moskowitz-hip-dex-01
> Diff:           http://www.ietf.org/rfcdiff?url2=draft-moskowitz-hip-dex-01
> 
> Abstract:
>   This document specifies the Host Identity Protocol Diet EXchange (HIP
>   DEX), a variant of the HIP Base EXchange (HIP BEX) [rfc5201-bis].
>   The HIP DEX protocol design aims at reducing the overhead of the
>   employed cryptographic primitives by omitting public-key signatures
>   and hash functions.  In doing so, the main goal is to still deliver
>   similar security properties to HIP BEX.
> 
>   The HIP DEX protocol is primarily targeted at computation or memory-
>   constrained sensor devices.  Like HIP BEX, it is expected to be used
>   together with another suitable security protocol such as the
>   Encapsulated Security Payload (ESP) [rfc5202-bis] for the protection
>   of upper layer protocols.  HIP DEX can also be used as a keying
>   mechanism for a MAC layer security protocol as is supported by IEEE
>   802.15.4 [IEEE.802-15-4.2011].
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 

--
Dipl.-Inform. Rene Hummen, Ph.D. Student
Chair of Communication and Distributed Systems
RWTH Aachen University, Germany
tel: +49 241 80 21426
web: http://www.comsys.rwth-aachen.de/team/rene-hummen/

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 12 Mar 2014 11:35:39 -0700

> * New HIT generation mechanism.

Please look at the HIT generation.  I want to get this locked down. I 
was always a bit unsure of the trunc I was using previously.  FOLD 
SHOULD do it.  Or is MMO needed?  (I think it is MMO...)

> _______________________________________________
> Hipsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hipsec