Subject: [Hipsec] transition from CLOSING state to state I1-SENT

From: Tom Henderson <[email-masked]>
Date: Mon, 28 Jul 2014 15:14:19 -0700

This issue with RFC5201-bis is being tracked as issue 48:
http://trac.tools.ietf.org/wg/hip/trac/ticket/48

When a HIP association is in state CLOSING and new data arrives to send 
to the peer, Table 7 states to send another I1 but stay in CLOSING, 
while our state machine diagram implies that there is a transition to 
state I1-SENT.

I propose to fix this by changing the Table 7 to read that the state 
machine transitions to state I1-SENT in this case.

Any comments or objections?

- Tom

---

From: Miika Komu <[email-masked]>
Date: Wed, 30 Jul 2014 12:40:07 +0300

Hi,

> Any comments or objections?

seems ok to me.