Subject: Re: [Hipsec] AUTH48 [LB]: 5201-bis - Re: Reference problem in 5201-bis wrt SECP160R1

From: Robert Moskowitz <[email-masked]>
Date: Wed, 28 Jan 2015 10:54:49 -0500

We have a dangling reference in 5201-bis.

It seems that the old reference for secp160r1 is no longer available.  I 
cannot find anything in my searching.

Can anyone point to a reference for it?

thanks

On 08/08/2012 02:35 PM, Rene Struik wrote:
> Hi Bob:
>
> You are correct that SECG removed the prime curve secp160r1 from the
> SEC1 specification, when moving from v1.0 to v2.0. However, you can
> still access this under the "superseded specifications" tab: the weblink
> should be http://www.secg.org/download/aid-386/sec2_final.pdf.
>
> You may also find this curve specified elsewhere, e.g., (if memory
> serves me well) with some copy protection schemes, such as DTCP.
>
> I hope this helps.
>
> Best regards,
>
> Rene
>
> On 08/08/2012 9:24 AM, Robert Moskowitz wrote:
>> For low security we have SECP160R1 from:
>>
>>     [SECG]                      SECG, "Recommended Elliptic Curve Domain
>>                                 Parameters", SEC 2 , 2000,
>>                                 <http://www.secg.org/>.
>>
>> I went there yesterday to look up some of the information on actual
>> sizes and got to:
>>
>> http://www.secg.org/download/aid-784/sec2-v2.pdf, published Jan 27, 2010.
>>
>> And no SECP160R1, the smallest keysize now is SECP192R1 (sec 2.2.2).
>>
>> So we have a reference problem here as well as giving a developer the
>> parameter values needed to implement SECP160R1.
>>
>> Corrective action options:
>>
>> 1) Directly supply the parameters for SECP160R1 in Appendix D and
>> reference the version of secg they were pulled from.
>>
>> 2) Find a more stable source for SECP160R1 to reference.
>>
>> 3) Move to SECP192R1 (which I am leary of as ver 3.0 of secg could
>> drop that!).
>>
>> I vote for 1) and ask whoever has the older version of secg to forward
>> the parameters for inclusion.
>>
>> BTW, HIP DEX works a bit differently in that the keys generated from
>> the ECDH exchange are only used in protecting HIP packets and a
>> wrapped key exchange within HIP provides the keying material for
>> session keys (eg ESP or 802.15.4 security).  So in DEX, using
>> SECP160R1 may not be as much of a risk as in BEX, so I DO plan on
>> providing the SECP160R1 parameters in DEX.
>>
>>
>> _______________________________________________
>> Hipsec mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/hipsec
>

---

From: Miika Komu <[email-masked]>
Date: Wed, 28 Jan 2015 20:35:16 +0200

Hi,

you mean this?

http://perso.univ-rennes1.fr/sylvain.duquesne/master/standards/sec2_final.pdf

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 28 Jan 2015 14:16:24 -0500

WONDERFUL!

thanks