Subject: Re: [Hipsec] WGLC draft-ietf-hip-native-nat-traversal

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 15 Feb 2016 09:06:46 +0200

Hi,

I am resending Petri's comments below.

Cheers,

Gonzalo

On 15/02/2016 8:08 AM, Petri Jokela wrote:
> Hi, 
> 
> I read through the draft (draft-ietf-hip-native-nat-traversal) and from
> technical perspective it seems to be ok. Some thoughts about the
> document itself:
> 
> HIP Relay server came up suddenly and it was hard to understand the
> operation of the node.  At some point I also mixed HIP data relay and
> HIP relay server. Which node is doing NATting? A short intro that would
> explain the operation of these nodes would help.
> 
> The same issue came up with Address candidates. Reading the referenced
> document might help, but now the document does not give direct
> understanding what candidates we are looking after. Again, a short intro
> makes it clearer.
> 
> Flow charts would help to understand the message exchange. 
> 
> In general, the document refers a lot to other RFCs. My suggestion is to
> check the document and add some introductory sentences for
> clarifications whenever a “new” node or operation is introduced.
> 
> Petri
> 
> -- 
> Petri Jokela
> Senior researcher
> NomadicLab, Ericsson Research
> Oy L M Ericsson Ab                  
> 
> E-mail: [email-masked] <mailto:[email-masked]>
> Mobile: +358 44 299 2413
> 
> 
>

---

From: Ari Keränen <[email-masked]>
Date: Tue, 16 Feb 2016 15:59:29 +0200

Thank you for the review Petri! We will add introductory text to the 
draft to cover your comments.

Cheers,
Ari

On 15/02/16 09:06, Gonzalo Camarillo wrote:
> _______________________________________________
> Hipsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hipsec
>