Subject: [hops] Middlebox on your device

From: Szilveszter Nadas <[email-masked]>
Date: Mon, 23 Mar 2015 23:02:58 +0000

Hi,

What if the "middlebox" blocking some transport feature/field is on the end-user device, e.g. a firewall software? Maybe saying the obvious here, just wanted to mention that sometimes it might not be the ISP the one to blame. Maybe it is not even important who to blame. Probably/hopefully firewall software is easier to update though, but it can have quite an effect on the measurement results.

(slightly related to this thread: http://www.ietf.org/mail-archive/web/spud/current/msg00028.html)

Cheers,
Sz.

---

From: "Honda, Michio" <[email-masked]>
Date: Tue, 24 Mar 2015 08:57:01 +0000

In addition to those software you should be a bit careful about NICs.
For example, TSO copies options in the original big segment into all the split segments, and LRO only aggregates packets that do not accompany options (except for Timestamps)
Our paper (http://conferences.sigcomm.org/imc/2011/docs/p181.pdf) shows this behavior on some NICs.

It should be noted that whether packets are affected by NICs or not also depends on how we generate and receive packets.
For example, if we generate and receive raw packets using BPF or netmap, those packets will not be affected.
However, I have no idea if we do so using raw sockets and AF_PACKET, because they let certain level of packet processing, such as checksum calculation to occur in the network stack.

Cheers,
- Michio

> On Mar 24, 2015, at 00:02, Szilveszter Nadas <[email-masked]> wrote:
> 
> Hi,
>  
> What if the “middlebox” blocking some transport feature/field is on the end-user device, e.g. a firewall software? Maybe saying the obvious here, just wanted to mention that sometimes it might not be the ISP the one to blame. Maybe it is not even important who to blame. Probably/hopefully firewall software is easier to update though, but it can have quite an effect on the measurement results.
>  
> _______________________________________________
> hops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hops