Subject: [hops] Proposed Charter for Measurement and Analysis for Protocols (MAP) Research Group

From: Brian Trammell <[email-masked]>
Date: Thu, 26 Nov 2015 12:35:15 +0100

Greetings, all,

Following discussions at the HOPS proposed RG meetings in Prague and Yokohama, as well as at the RAIM workshop before Yokohama, we've revised the charter to reflect what we think the community wants out of such an RG. Note that given the slightly expanded scope of this charter, though, we've decided to rename the proposed RG to Measurement and Analysis for Protocols (MAP).

Comments on the proposed charter below are welcome at [email-masked]:

Measurement and Analysis for Protocols (MAP) RG
===============================================

Our Internet has grown into something that differs from what was envisioned.
Its protocols sometimes operate in an environment other than than that for
which they were designed. For instance, some network elements treat some
protocols differently than others and those protocols themselves are sometimes
reused and abused in ways initially unforseen. The Measurement and Analysis
for Protocols (MAP) Research Group (RG) explores such phenomena by measurement
with the aim to inform protocol engineering and practice.

Many protocol engineering efforts in a standards development context, as well
as best practices for the operation of IETF-defined protocols, can benefit
from insight provided by Internet measurements of various kinds. Likewise,
Internet measurement research efforts can stand to gain from contacts with the
IETF. The Measurement and Analysis for Protocol Engineering (MAP) Research
Group aims to provide a forum for interchange between these two communities,
supporting:

- exchange of measurement-derived insight,
- discussion of techniques for measurement relevant for protocol engineering
  and network operations,
- collaborations to share data supporting these measurements, and
- a "landing pad" in general for the Internet measurement community to
  introduce its efforts to the IETF

Measurements of any layer of the Internet protocol stack or aspect of Internet
operations are in-scope for the RG, provided they are relevant to protocol
engineering work within the IETF, or the operation of IETF protocols.

Membership
----------

Membership in the MAP RG is open to all interested parties.

Meetings
--------

The MAP RG will meet one to three times per year, as deemed necessary by the
chairs and according to demand. At least one MAP RG meeting will be co-located
with an IETF meeting per year. Given the MAP RG's charter to bridge the gap
between Internet standards and measurement communities, the MAP RG may also
meet colocated with relevant academic conferences or network operator forums,
as appopriate.

Meetings are by default open with open attendance and published proceedings,
with remote participation and recording as provided by the meeting venue,
according to the IRTF's IPR policy. This is always the case with at least one
MAP RG meeting co-located with an IETF meeting noted above. However, as deemed
necessary, the chairs may hold virtual or physical meetings with restricted
attendance to discuss observations which cannot be shared openly, provided
that some outcome of such a meeting may be openly shared with the community.

Chairs
------

Mirja Kühlewind <[email-masked]>
Dave Plonka <[email-masked]>

Many thanks,

Brian

---

From: marcelo bagnulo braun <[email-masked]>
Date: Thu, 26 Nov 2015 13:42:42 +0100

Looks good to me

I support the creation of this RG

Thanks for doing this.

Regards, marcelo

El 26/11/15 a las 12:35, Brian Trammell escribió:
> _______________________________________________
> hops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hops

---

From: Michael Welzl <[email-masked]>
Date: Thu, 26 Nov 2015 13:44:04 +0100

+1

> On 26 Nov 2015, at 13:42, marcelo bagnulo braun <[email-masked]> wrote:
> 
> Looks good to me
>

---

From: Wassim Haddad <[email-masked]>
Date: Thu, 26 Nov 2015 21:00:00 +0000

+1

Wassim H.

Sent from my iPad

> On Nov 26, 2015, at 04:44, Michael Welzl <[email-masked]> wrote:
> 
> +1
> 
>

---

From: Ethan Katz-Bassett <[email-masked]>
Date: Thu, 26 Nov 2015 22:18:05 +0000

Looks good. I like expliticly calling out the role as a "landing pad" for
academic work.
On Thu, Nov 26, 2015 at 1:00 PM Wassim Haddad <[email-masked]>
wrote:

> >>> Following discussions at the HOPS proposed RG meetings in Prague and
> Yokohama, as well as at the RAIM workshop before Yokohama, we've revised
> the charter to reflect what we think the community wants out of such an RG.
> Note that given the slightly expanded scope of this charter, though, we've
> decided to rename the proposed RG to Measurement and Analysis for Protocols
> (MAP).
> >>>
> >>>

---

From: Joachim Fabini <[email-masked]>
Date: Fri, 27 Nov 2015 16:47:29 +0100

Hi Brian,

I support the charter, thanks for revising it, and full consent to
Ethan's statement: "landing pad" for the IMC community reads
excellent, nice wording.

One question (perhaps a minor rewording can help): is "collaborations
to share data supporting these measurements" equivalent to "defining
repositories and sharing meaningful methods, measurement results,
measurement context and limitations of data sets" as discussed in
Yokohama? It's not clear to me what "supporting these measurements"
refers to exactly. It could mean "sharing of successful measurement
methods and setups" rather than "sharing of measurement results".

Second, is it needed|meaningful to explicitly mention legal aspects
related to data sharing as within/outside of the MAP charter? Sharing
data means dealing with country-specifics, licensing terms, privacy
vs. usability, etc. As such, legal aspects are implicitly part of the
charter. My feeling is that MAP should propose guidelines for sharing
measurement data, and that such guidelines could be really helpful for
the community. However, the discussion on the ietf94-attendees mailing
list is a fair warning to be _very_ careful with discussions on any
legal aspects (in particular privacy). There's a high risk to lose
focus - perhaps we can delegate this subtask to the hrpc RG. ;)

many thanks,
Joachim

On 26.11.2015 12:35, Brian Trammell wrote:
> Greetings, all,
> 
> Following discussions at the HOPS proposed RG meetings in Prague
> and Yokohama, as well as at the RAIM workshop before Yokohama,
> we've revised the charter to reflect what we think the community
> wants out of such an RG. Note that given the slightly expanded
> scope of this charter, though, we've decided to rename the proposed
> RG to Measurement and Analysis for Protocols (MAP).
> 
> 
> Our Internet has grown into something that differs from what was
> envisioned. Its protocols sometimes operate in an environment other
> than than that for which they were designed. For instance, some
> network elements treat some protocols differently than others and
> those protocols themselves are sometimes reused and abused in ways
> initially unforseen. The Measurement and Analysis for Protocols
> (MAP) Research Group (RG) explores such phenomena by measurement 
> Many protocol engineering efforts in a standards development
> context, as well as best practices for the operation of
> IETF-defined protocols, can benefit from insight provided by
> Internet measurements of various kinds. Likewise, Internet
> measurement research efforts can stand to gain from contacts with
> the IETF. The Measurement and Analysis for Protocol Engineering
> (MAP) Research Group aims to provide a forum for interchange
> between these two communities, supporting:
> 
> - exchange of measurement-derived insight, - discussion of
> techniques for measurement relevant for protocol engineering and
> network operations, - collaborations to share data supporting these
> measurements, and - a "landing pad" in general for the Internet
> measurement community to introduce its efforts to the IETF
> 
> Measurements of any layer of the Internet protocol stack or aspect
> of Internet operations are in-scope for the RG, provided they are
> relevant to protocol engineering work within the IETF, or the
> operation of IETF protocols.
> 
> Membership ----------
> 
> Meetings --------
> The MAP RG will meet one to three times per year, as deemed
> necessary by the chairs and according to demand. At least one MAP
> RG meeting will be co-located with an IETF meeting per year. Given
> the MAP RG's charter to bridge the gap between Internet standards
> and measurement communities, the MAP RG may also meet colocated
> with relevant academic conferences or network operator forums, as
> appopriate.
> 
> Meetings are by default open with open attendance and published
> proceedings, with remote participation and recording as provided by
> the meeting venue, according to the IRTF's IPR policy. This is
> always the case with at least one MAP RG meeting co-located with an
> IETF meeting noted above. However, as deemed necessary, the chairs
> may hold virtual or physical meetings with restricted attendance to
> discuss observations which cannot be shared openly, provided that
> some outcome of such a meeting may be openly shared with the
> community.
> 
> Chairs ------
> 
> Mirja Kühlewind <[email-masked]> Dave Plonka
> <[email-masked]>
> 
> 
> Many thanks,
> 
> Brian
> 
> 
> 
> _______________________________________________ hops mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/hops
>

---

From: Aaron Falk <[email-masked]>
Date: Fri, 27 Nov 2015 11:19:50 -0500

Hi Joachim-

Good points but I would suggest the charter stay fairly vague on the
subjects other than allowing them to be in-scope for the RG, for exactly
the reason you suggest (it can be a distraction).  Perhaps just adding "and
best practices" to the end of the first bullet would open the door without
becoming an attractive nuisance. [*]

--aaron

* - https://en.wikipedia.org/wiki/Attractive_nuisance_doctrine

On Fri, Nov 27, 2015 at 10:47 AM, Joachim Fabini <
[email-masked]> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Hi Brian,
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v2.0.22 (MingW32)
>
> iQEcBAEBAgAGBQJWWHsRAAoJEKCP3BPvRqfSEN0IAL6c4Ze0q4HsDmONuh6WvbwF
> 4rLv1QEOgSGVCJzYGgfPSTdz5sgxjKWJ9X822CHe8PXDnjBlFvjJPg+da0IbyY9p
> SaDNZXY1YxUjt+YU+TwJctAZilMs8uWIOvv9Dq/WIfvXiBd1yWfB5PZ5HTYy+V/b
> 0Mup4gtmPcuR4cBgOKogRRz8iIMgxlOYFMfcrn18ZWy1HpOuIj9bHciA/T51QCGZ
> lOGCVsuzesg30qwEMpv0H5vusz9eaYZCw2h9B7k7hHkP3ahuNO5u+raNUVSE4NYN
> JFpHBngwPy7MiJdetYEba8p1o557hDgb+R5AtlnUwDxGMAuzbiPxkrmgTAi4/sc=
> =ZvWy
> -----END PGP SIGNATURE-----
>

---

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Fri, 27 Nov 2015 17:17:22 +0000

Hi,

I support this charter, and Aaron’s suggestion as well.

Be goode,

On 27 Nov 2015, at 17:19 , Aaron Falk <[email-masked]<mailto:[email-masked]>> wrote:

Hi Joachim-

Good points but I would suggest the charter stay fairly vague on the subjects other than allowing them to be in-scope for the RG, for exactly the reason you suggest (it can be a distraction).  Perhaps just adding "and best practices" to the end of the first bullet would open the door without becoming an attractive nuisance. [*]

--aaron

On Fri, Nov 27, 2015 at 10:47 AM, Joachim Fabini <[email-masked]<mailto:[email-masked]>> wrote:

Hi Brian,

many thanks,
Joachim

On 26.11.2015 12:35, Brian Trammell wrote:
> Comments on the proposed charter below are welcome at
> [email-masked]<mailto:[email-masked]>:
>
>
> Mirja Kühlewind <[email-masked]<mailto:[email-masked]>> Dave Plonka
> <[email-masked]<mailto:[email-masked]>>
>
>
> Many thanks,
>
> Brian
>
>
>
> [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/hops
>

_______________________________________________
hops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/hops

_______________________________________________
hops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/hops

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Dirk Kutscher <[email-masked]>
Date: Fri, 27 Nov 2015 18:29:49 +0000

Hi Brian and all,

first off, I welcome everyone who wants to do work in the IRTF.

With the very general scope as it is described now, I wonder a bit how this relates to the IRTF's objective of " creating focused, long-term Research Groups working on topics related to Internet protocols, applications, architecture and technology."

Measurements, in my view, are a tool for networking research and development, and in fact most of us are doing measurements in different forms for validating assumptions, assessing performance etc. Research groups such as ICCRG are often discussing measurement results.

So in that sense, it's a meta topic that is daily business for IRTF RGs. I am fully aware of the fact that measurement methodology is itself a research topic, but it's not quite clear to me what we want to achieve.

- are we trying to do/promote constructive work towards advancing Internet measurement tools and infrastructure?
- are we planning to discuss middlebox issues?
- do we want offer discussion platform for general measurement topics?

I am bit skeptical with respect to creating an RG for general measurement discussions. There are existing conferences and workshops that are doing that already. Also, it's unclear how that would contribute to the IRTF objectives.

Please enlighten me. :-)

Dirk

> -----Original Message-----
> From: hops [mailto:[email-masked]] On Behalf Of Brian Trammell
> Sent: Donnerstag, 26. November 2015 12:35
> To: [email-masked]
> Subject: [hops] Proposed Charter for Measurement and Analysis for Protocols
> (MAP) Research Group
> 
> Greetings, all,
> 
> for Protocols (MAP) Research Group (RG) explores such phenomena by
> measurement with the aim to inform protocol engineering and practice.
> 
> as best practices for the operation of IETF-defined protocols, can benefit from
> insight provided by Internet measurements of various kinds. Likewise, Internet
> measurement research efforts can stand to gain from contacts with the IETF.
> The Measurement and Analysis for Protocol Engineering (MAP) Research Group
> aims to provide a forum for interchange between these two communities,
> supporting:
> 
> chairs and according to demand. At least one MAP RG meeting will be co-
> located with an IETF meeting per year. Given the MAP RG's charter to bridge the
> gap between Internet standards and measurement communities, the MAP RG
> may also meet colocated with relevant academic conferences or network
> operator forums, as appopriate.
> 
> according to the IRTF's IPR policy. This is always the case with at least one MAP
> RG meeting co-located with an IETF meeting noted above. However, as deemed

---

From: Tim Wicinski <[email-masked]>
Date: Sat, 28 Nov 2015 05:04:14 -0500

I like Brian's charter, but Aaron's suggestions on being vague actually 
allows for flexibility down the road.

Is the output from the WG Internet Drafts or something else?

tim

On 11/27/15 11:19 AM, Aaron Falk wrote:
> the reason you suggest (it can be a distraction).  Perhaps just adding
> "and best practices" to the end of the first bullet would open the door
> without becoming an attractive nuisance. [*]
>
> --aaron
>
> On Fri, Nov 27, 2015 at 10:47 AM, Joachim Fabini
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>      > [email-masked] <mailto:[email-masked]>:
>      >
>      >
>      > Mirja Kühlewind <[email-masked]
>     <mailto:[email-masked]>> Dave Plonka
>      > <[email-masked] <mailto:[email-masked]>>
>      >
>      >
>      > Many thanks,
>      >
>      > Brian
>      >
>      >
>      >
>     >[email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: Dave Plonka <[email-masked]>
Date: Sat, 28 Nov 2015 13:01:50 -0500

Hi Dirk and others,

[Speaking only for myself below, but along the lines of why I am
 willing to co-chair the propsed RG.]

On Fri, Nov 27, 2015 at 06:29:49PM +0000, Dirk Kutscher wrote:
> With the very general scope as it is described now, I wonder a bit
> how this relates to the IRTF's objective of " creating focused,
> long-term Research Groups working on topics related to Internet
> protocols, applications, architecture and technology."

The broadening of the scope beyond HOPS was intentional.
I too am interested in focused work, and we intend to have individual
items be focused, but from a RG perspective, something broad enough
to accept yet-to-be proposed topics was desired; so that the RG
can span multiple efforts potentially without rechartering, i.e.,
administrative work.

> Measurements, in my view, are a tool for networking research and
> development, and in fact most of us are doing measurements in
> different forms for validating assumptions, assessing performance
> etc. Research groups such as ICCRG are often discussing measurement
> results.
> 
> So in that sense, it's a meta topic that is daily business for IRTF
> RGs. I am fully aware of the fact that measurement methodology is
> itself a research topic, but it's not quite clear to me what we
> want to achieve.
> 
> - are we trying to do/promote constructive work towards advancing
>   Internet measurement tools and infrastructure?

No, neither tools nor infrastructure (are inherently in scope),
but rather measurement techniques and discovery of how the Internet
exists and is "playing out" in ways that directly affect IETF goals
re: standards and BCP.

The charter as proposed specifically mentions towards advancing
(only) protocol design and operation.

> - are we planning to discuss middlebox issues?

Yes. We expect to transition this and continue this effort from the
non-RG-forming HOPS meetings, to the degree that there are people
to do the work.

In my mind, the effect iddlebox's have on protocol performance is
the "poster child" topic for our proposed MAP RG; if successful,
it will demonstrate how discovering substrate characteristics can
inform protocol development and operation/practice.

> - do we want offer discussion platform for general measurement topics?

No. There are other forums for that, e.g., the IPPM Working Group and
the Internet Measurement Conference.

Building measurement infrastructures, e.g., databases, is also
something we currently consider out of scope.

> I am bit skeptical with respect to creating an RG for general
> measurement discussions. There are existing conferences and workshops
> that are doing that already. Also, it's unclear how that would
> contribute to the IRTF objectives.

It might help if I offer some example topics (that Brian or I considered
as strawmen) that I find would be in scope:

- A survey of the IPv6 WWW, to inform practice with respect to privacy,
  e.g. service address assignment, virtual hosting, and SNI.
  Basically, "Are we building an IPv6 web that we want?"

- Large scale examination of IPv4 address utilization or "churn",
  and how it's changing in cooperation with IPv6.

- For operational purposes such as DoS mitigation, how should
  "IP reputation" likely need to change for IPv6.
  What needs to be measured (differently)?

These are use (semi-imaginary) examples, but I know of researchers
working on each of these that might benefit from bringing them to
an IRTF forum such as the proposed MAP RG.

> Please enlighten me. :-)

You be the judge. If you find that the charter doesn't jibe with
my comments above, please offer your suggested change(s).

Thanks Dirk!

Dave

<snip>

-- 
[email-masked]  http://www.cs.wisc.edu/~plonka/  Cambridge, MA

---

From: Brian Trammell <[email-masked]>
Date: Sun, 29 Nov 2015 14:53:04 +0100

hi Dirk,

I had an editor open to answer your question, but I'll throw my answer away and say "what Dave said".

One point of emphasis below, inline.

> On 28 Nov 2015, at 19:01, Dave Plonka <[email-masked]> wrote:

<snip>

> an IRTF forum such as the proposed MAP RG.

The common theme here is applicability to protocol engineering and operations -- the point of doing this within the IRTF is the relative closeness of the IRTF to the IETF community, especially compared to the academic network measurement community. We're not trying to replace academic venues; if anything, MAP would be more like RIPE MAT for the IETF community, which tries to get interesting work in measurement in front of people who might not otherwise hear about it, and feed comments on applicability and usefulness back into the measurement community.

Cheers,

Brian