Subject: Re: [Idnet] Applying AI into network management//FW: [nmrg] 45th NMRG meeting: Call for Contributions

From: "Diego R. Lopez" <[email-masked]>
Date: Tue, 19 Sep 2017 19:06:25 +0000

Hi,

I'd like to propose a presentation on the results of the COGNET project, including the double closed loop we have been devising as main architecture, and the results on dataset generation.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

On 19/9/2017, 09:34 , "IDNET on behalf of Ciavaglia, Laurent (Nokia - FR/Nozay)" <[email-masked] on behalf of [email-masked]> wrote:

    Dear Yansen, all,

    We (NMRG chairs) will coordinate with Sheng/IDNET for defining the agenda.
    Please send your proposal to either lists.

    Thanks, Laurent.

    -----Original Message-----
    From: IDNET [mailto:[email-masked]] On Behalf Of yanshen
    Sent: Tuesday, September 19, 2017 8:48 AM
    To: Sheng Jiang <[email-masked]>; [email-masked]
    Subject: Re: [Idnet] Applying AI into network management//FW: [nmrg] 45th NMRG meeting: Call for Contributions

    Hi Sheng,

    I would like to have a short presentation about the Use case of Traffic Prediction/QoS Model.

    My question is how to "register"? I directly send Email to the NMRG chair or we have a pre-registration in IDNet ?

    I attach the brief summary of use cases in the end. Hope it helpful.

    Yansen

    ==========================================
    1. Gap and Requirement Analysis
        1.1 Network Management requirement
        1.2 TBD
    2. Use Cases
        2.1 Traffic Prediction
    Proposed by: [email-masked]
    Track: https://www.ietf.org/mail-archive/web/idnet/current/msg00131.html
    Abstract: Collect the history traffic data and external data which may influence the traffic. Predict the traffic in short/long/specific term. Avoid the congestion or risk in previously.

        2.2 QoS Management
    Proposed by: [email-masked]
    Track: https://www.ietf.org/mail-archive/web/idnet/current/msg00131.html
    Abstract: Use multiple paths to distribute the traffic flows. Adjust the percentages. Avoid congestion and ensure QoS.

        2.3 Application (and/or DDoS) detection
    Proposed by: [email-masked]
    Track: https://www.ietf.org/mail-archive/web/idnet/current/msg00133.html
    Abstract: Detect the application (or attack) from network packets (HTTPS or plain) Collect the history traffic data and identify a service or attack (ex: Skype, Viber, DDoS attack etc.)

    2.4 QoE Management
    Proposed by: [email-masked]
    Track: https://www.ietf.org/mail-archive/web/idnet/current/msg00137.html
    Abstract: Collect low-level metrics (SNR, latency, jitter, losses, etc) and measure QoE. Then use ML to understand what is the relation between satisfactory QoE and the low-level metrics. As an example learn that when delay>N then QoE is degraded, but when M<delay<N then QoE is satisfactory for the customers (please note that QoE cannot be measured directly over your network). This is useful to understand how the network must be operated to provide satisfactory QoE.

    2.5 (Encrypted) Traffic Classification
    Proposed by: [email-masked]; [email-masked]
    Track: [Jerome] https://www.ietf.org/mail-archive/web/idnet/current/msg00141.html ; [Min-Suk Kim] https://www.ietf.org/mail-archive/web/idnet/current/msg00153.html
    Abstract:
    [Jerome] collect flow-level traffic metrics such as protocol information but also meta metrics such as distribution of packet sizes, inter-arrival times... Then use such information to label the traffic with the underlying application assuming that the granularity of classification may vary (type of application, exact application name, version...)
    [Min-Suk Kim]continuously collect packet data, then applying learning process for traffic classification with generating application using deep learning models such as CNN (convolutional neural network) and RNN (recurrent neural network). Data-set to apply into the models are generated by precessing with features of information from flow in packet data.

    2.6 Anomaly Detection
    Proposed by: [email-masked]
    Track: https://www.ietf.org/mail-archive/web/idnet/current/msg00186.html
    Abstract:
    [Jerome] collect flow-level traffic metrics such as protocol information but also meta metrics such as distribution of packet sizes, inter-arrival times... Then use such information to label the traffic with the underlying application assuming that the granularity of classification may vary (type of application, exact application name, version...)
    [Min-Suk Kim]continuously collect packet data, then applying learning process for traffic classification with generating application using deep learning models such as CNN (convolutional neural network) and RNN (recurrent neural network). Data-set to apply into the models are generated by precessing with features of information from flow in packet data.

    3. Data Focus
        3.1 Data attribute
        3.2 Data format
        3.3 TBD

    4. Support Technologies
        4.1 Benchmarking Framework
    Proposed by: [email-masked]
    Track: https://www.ietf.org/mail-archive/web/idnet/current/msg00146.html
    Abstract: A proper benchmarking framework comprises a set of reference procedures, methods, and models that can (or better *must*) be followed to assess the quality of an AI mechanism proposed to be applied to the network management/control area. Moreover, and much more specific to the IDNET topics, is the inclusion, dependency, or just the general relation of a standard format enforced to the data that is used (input) and produced (output) by the framework, so a kind of "data market" can arise without requiring to transform the data. The initial scope of input/output data would be the datasets, but also the new knowledge items that are stated as a result of applying the benchmarking procedures defined by the framework, which can be collected together to build a database of benchmark results, or just contrasted with other existing entries in the database to know the position of the solution just evaluated. This increases the usefulness of IDNET.

        4.2 TBD

    =========================================

    > -----Original Message-----
    > From: IDNET [mailto:[email-masked]] On Behalf Of Sheng Jiang
    > Sent: Wednesday, September 13, 2017 10:20 PM
    > To: [email-masked]
    > Subject: [Idnet] Applying AI into network management//FW: [nmrg] 45th
    > NMRG
    > meeting: Call for Contributions
    >
    > Hi, IDNet,
    >
    > After coordinating with NMRG chairs, a Call for Contributions message
    > (see
    > below) has been sent by them to the NMRG mailing list regarding to the
    > topic of applying AI into network management. This is in line with our
    > earlier discussion to have a session on this in NMRG, Singapore. You
    > could send email to volunteer for presentations in either NMRG or
    > IDNet mailing list (I will bridge to NMRG chairs in the IDNet case) or cross post.
    >
    > Looking forward for your contributions and good discussion in Singapore.
    >
    > Best regards,
    >
    > Sheng
    >
    > -----Original Message-----
    > From: nmrg [mailto:[email-masked]] On Behalf Of Lisandro
    > Zambenedetti Granville
    > Sent: Wednesday, September 13, 2017 9:57 PM
    > To: [email-masked]
    > Subject: [nmrg] 45th NMRG meeting: Call for Contributions
    >
    > Call for Contributions
    > 45th NMRG meeting at IETF 100
    >
    > In the next IETF100/Singapore we will be organizing the 45th NMRG meeting.
    > We would like to center the upcoming meeting around the use of
    > artificial intelligence (AI) for network management, including related
    > topics as diverse as machine-learning and intelligent-defined networks, for example.
    >
    > AI for network management is not a new topic, as can be easily
    > observed in the literature produced by the network management community already years ago.
    > On the other hand, AI has matured a lot, finding applications is several areas.
    > People interested in the subject also formed communities that can
    > contribute too. As such, revisiting AI for network management is not
    > only appropriate but also timely.
    >
    > In this Call for Contributions we would like to receive proposals of
    > presentations/discussions for the upcoming 45th NMRG meeting. That
    > includes, for example:
    >
    > - Use cases where AI could/should be used in network management
    > - Real-life experiments, results, and findings on AI for network
    > management
    > - Disruptive and/or new management paradigms based on AI
    > - Potential standard requirements for applying AI for network
    > management
    > - Both preliminary and mature approaches
    >
    > Please contribute and feel free to distribute this call to other
    > mailing lists whose members you believe would be interested and could contribute too.
    >
    > Best regards, Lisandro and Laurent.
    > _______________________________________________
    > nmrg mailing list
    > [email-masked]
    > https://www.irtf.org/mailman/listinfo/nmrg
    > _______________________________________________
    > IDNET mailing list
    > [email-masked]
    > https://www.ietf.org/mailman/listinfo/idnet

    _______________________________________________
    IDNET mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/idnet

    _______________________________________________
    IDNET mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/idnet

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Sheng Jiang <[email-masked]>
Date: Wed, 20 Sep 2017 03:28:52 +0000

Thanks, Diego & Shen, for your volunteer & contribution. Your presentations have been counted in. We are waiting for more volunteers & presentations. Hopefully, we would be able to work out a agenda before the end of this month.

Best regards,

Sheng

> From: Diego R. Lopez [mailto:[email-masked]]
> Sent: Wednesday, September 20, 2017 3:06 AM
> To: Ciavaglia, Laurent (Nokia - FR/Nozay); yanshen; Sheng Jiang;
> [email-masked]
> Subject: Re: [Idnet] Applying AI into network management//FW: [nmrg]
> 45th NMRG meeting: Call for Contributions
> 
> Hi,
> 
> I'd like to propose a presentation on the results of the COGNET project,
> including the double closed loop we have been devising as main
> architecture, and the results on dataset generation.
> 
> Be goode,
> 
> --
> On 19/9/2017, 09:34 , "IDNET on behalf of Ciavaglia, Laurent (Nokia -
> FR/Nozay)" <[email-masked] on behalf of
> [email-masked]> wrote:
> 
>     Dear Yansen, all,
> 
>     Subject: Re: [Idnet] Applying AI into network management//FW:
> [nmrg] 45th NMRG meeting: Call for Contributions
> 
>     Hi Sheng,
> 
>     My question is how to "register"? I directly send Email to the NMRG
> chair or we have a pre-registration in IDNet ?
> 
>     Track:
> https://www.ietf.org/mail-archive/web/idnet/current/msg00131.html
>     Abstract: Collect the history traffic data and external data which may
> influence the traffic. Predict the traffic in short/long/specific term. Avoid
> the congestion or risk in previously.
> 
>         2.2 QoS Management
>     Track:
> https://www.ietf.org/mail-archive/web/idnet/current/msg00131.html
>     Abstract: Use multiple paths to distribute the traffic flows. Adjust the
> percentages. Avoid congestion and ensure QoS.
> 
>     Track:
> https://www.ietf.org/mail-archive/web/idnet/current/msg00133.html
>     Abstract: Detect the application (or attack) from network packets
> (HTTPS or plain) Collect the history traffic data and identify a service or
> attack (ex: Skype, Viber, DDoS attack etc.)
> 
>     2.4 QoE Management
>     Track:
> https://www.ietf.org/mail-archive/web/idnet/current/msg00137.html
>     Abstract: Collect low-level metrics (SNR, latency, jitter, losses, etc) and
> measure QoE. Then use ML to understand what is the relation between
> satisfactory QoE and the low-level metrics. As an example learn that when
> delay>N then QoE is degraded, but when M<delay<N then QoE is
> satisfactory for the customers (please note that QoE cannot be measured
> directly over your network). This is useful to understand how the network
> must be operated to provide satisfactory QoE.
> 
>     Track: [Jerome]
> https://www.ietf.org/mail-archive/web/idnet/current/msg00141.html ;
> [Min-Suk Kim]
> https://www.ietf.org/mail-archive/web/idnet/current/msg00153.html
>     Abstract:
>     [Jerome] collect flow-level traffic metrics such as protocol information
> but also meta metrics such as distribution of packet sizes, inter-arrival
> times... Then use such information to label the traffic with the underlying
> application assuming that the granularity of classification may vary (type
> of application, exact application name, version...)
>     [Min-Suk Kim]continuously collect packet data, then applying learning
> process for traffic classification with generating application using deep
> learning models such as CNN (convolutional neural network) and RNN
> (recurrent neural network). Data-set to apply into the models are
> generated by precessing with features of information from flow in packet
> data.
> 
>     2.6 Anomaly Detection
>     Track:
> https://www.ietf.org/mail-archive/web/idnet/current/msg00186.html
>     Abstract:
>     [Jerome] collect flow-level traffic metrics such as protocol information
> but also meta metrics such as distribution of packet sizes, inter-arrival
> times... Then use such information to label the traffic with the underlying
> application assuming that the granularity of classification may vary (type
> of application, exact application name, version...)
>     [Min-Suk Kim]continuously collect packet data, then applying learning
> process for traffic classification with generating application using deep
> learning models such as CNN (convolutional neural network) and RNN
> (recurrent neural network). Data-set to apply into the models are
> generated by precessing with features of information from flow in packet
> data.
> 
>     3. Data Focus
>         3.1 Data attribute
>         3.2 Data format
>         3.3 TBD
> 
>     4. Support Technologies
>     Track:
> https://www.ietf.org/mail-archive/web/idnet/current/msg00146.html
>     Abstract: A proper benchmarking framework comprises a set of
> reference procedures, methods, and models that can (or better *must*)
> be followed to assess the quality of an AI mechanism proposed to be
> applied to the network management/control area. Moreover, and much
> more specific to the IDNET topics, is the inclusion, dependency, or just the
> general relation of a standard format enforced to the data that is used
> (input) and produced (output) by the framework, so a kind of "data
> market" can arise without requiring to transform the data. The initial
> scope of input/output data would be the datasets, but also the new
> knowledge items that are stated as a result of applying the benchmarking
> procedures defined by the framework, which can be collected together to
> build a database of benchmark results, or just contrasted with other
> existing entries in the database to know the position of the solution just
> evaluated. This increases the usefulness of IDNET.
> 
>         4.2 TBD
> 
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
> puede contener información privilegiada o confidencial y es para uso
> exclusivo de la persona o entidad de destino. Si no es usted. el
> destinatario indicado, queda notificado de que la lectura, utilización,
> divulgación y/o copia sin autorización puede estar prohibida en virtud de
> la legislación vigente. Si ha recibido este mensaje por error, le rogamos
> que nos lo comunique inmediatamente por esta misma vía y proceda a
> su destrucción.
> 
> The information contained in this transmission is privileged and
> confidential information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution or
> copying of this communication is strictly prohibited. If you have received
> this transmission in error, do not read it. Please immediately reply to the
> sender that you have received this communication in error and then
> delete it.
> 
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu
> destinatário, pode conter informação privilegiada ou confidencial e é
> para uso exclusivo da pessoa ou entidade de destino. Se não é vossa
> senhoria o destinatário indicado, fica notificado de que a leitura,
> utilização, divulgação e/ou cópia sem autorização pode estar proibida
> em virtude da legislação vigente. Se recebeu esta mensagem por erro,
> rogamos-lhe que nos o comunique imediatamente por esta mesma via e
> proceda a sua destruição