Subject: Re: [Idnet] Seminar from Andrea Goldsmith (Stanford) on AI and Communication Systems

From: Pedro Martinez-Julia <[email-masked]>
Date: Mon, 2 Apr 2018 10:43:50 +0900

Dear Marie-Jose,

Thank you for sharing the report but, IMHO, without some backing slides
or similar, such information just makes us anxious of more details about
the solution :-D. Please, if possible, share the slides, a more detailed
report, a video of the event, or something that we can use to study such
solution. Thank you very much.

Regards,
Pedro

On Wed, Mar 28, 2018 at 04:48:59PM -0400, Marie-Jose Montpetit wrote:
> Andrea was in MIT yesterday and she presented a seminar entitiled: Can machine learning beat theory in communication system design?”
> (fo those of you who do not know Andrea I suggest you Google her but in any case she is a highly reknowned wireless researcher from Stanford)
> 
> She first explained why communications theory may not be enough to analyse next gen networks (she called them nG) because time-variance or lack of a real channel model (molecular communication which is like diffusion) and the need maybe to design new PHY especially for cellular for example questioning the frequency re-use model still used to define the cells and deal with interference.
> 
> SHe went on to describe how her team use subject specific knowledge to define a new type of neural networks with sliding windows (a reference actually to coding where sliding window codes usually have the best performance).
> 
> She applied the new ML to 2 cases: one estimation and the other for words recognition in the presence of noise (the famous source-destination joint coding problem) and 2 channels: a traditional Poisson channel and a molecular channel with base/acid representing 0s and 1s (another model BTW is the “vodka model where 1 shot is 1 and water is 0).  The comparison on the Poisson channel was of course with the Viterbi Algorithm which is optimal when the channel is perfectly known. 
> 
> The results (to be published) show that of course when there is no uncertainty on the channel Viterbi is good. But the ML is consistently as much as good as optimal even as the uncertainty increases (like in a fast varying channel) and when under that uncertainty the Viterbi estimation degrades rapidly.
> 
> With the pure molecular channel of course ML is the only solution and the results with the word recognition were excellent (next is imaging and video) because ML allows to dd semantics not just bit detection. Molecular channels BTW are considered for in-body communications.
> 
> The conclusion was that with the nG communications ML may provide better results than traditional methods given that they are driven by subject experts not just a generic ML algorithm. Questions that remain include timing and repeating of the neural network training that of course would be system dependent.
> 
> 
> mjm
> 
> Marie-Jose Montpetit, Ph.D.
> [email-masked]
> [email-masked]
> +1-781-526-2661
> @SocialTVMIT
> 
> 
> 
> 
> _______________________________________________
> IDNET mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idnet

-- 
Pedro Martinez-Julia
Network Science and Convergence Device Technology Laboratory
Network System Research Institute
National Institute of Information and Communications Technology (NICT)
4-2-1, Nukui-Kitamachi, Koganei, Tokyo 184-8795, Japan
Email: [email-masked]
---------------------------------------------------------
*** Entia non sunt multiplicanda praeter necessitatem ***

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Sun, 1 Apr 2018 22:11:10 -0400

I will try to find the information. There will be an article in JSAC soon also.
> On Apr 1, 2018, at 9:43 PM, Pedro Martinez-Julia <[email-masked]> wrote:
> 
> Dear Marie-Jose,
>

---

From: Pedro Martinez-Julia <[email-masked]>
Date: Mon, 2 Apr 2018 11:15:41 +0900

> I will try to find the information. There will be an article in JSAC soon also.

OK, thank you. Once the paper is published, please share it linked to
this topic. Thank you very much.

Regards,
Pedro

---

From: Pedro Martinez-Julia <[email-masked]>
Date: Thu, 5 Apr 2018 08:27:15 +0900

On Wed, Apr 04, 2018 at 06:33:08PM +0000, Hesham ElBakoury wrote:
> Hi Pedro, Marie and all

Dear Hesham,

> I found this email thread while catching up on my emails .....
> 
> Attached you find Professor Andrea MIT presentation. The papers are
> generally posted to Nariman's publication website:
> http://narimanfarsad.com/publications.html

Thank you very much for sharing the slides. I think they are very useful
for our objective.

> I started the discussion on using ML for communications with professor
> John Cioffi (Stanford) in the 2nd half of last year.  My idea is to
> use ML for slot management in FlexE PHY to support hybrid multiplexing
> in x-Ethernet. Both professor Andrea and Cioffi research in using ML
> in the PHY is very interesting and I am hoping we can take advantage
> of it in our Lab.

Regarding your idea to use ML for slot management, I think such case can
exploit broader AI methods beyond ML. It is one reason to evolve "MLRG"
to "IDNET" and such case is quite interesting to explore from the wider
perspective of general AI. If you like the idea, please let me know so I
can find some common points to work with you. Thank you very much.

> Hope this helps.
> Thanks
> Hesham

Regards,
Pedro