Subject: RE: IPP> Killing off draft-ietf-ipp-ops-set2 ?

From: "Zehler, Peter" <[email-masked]>
Date: Wed, 30 Jun 2004 13:44:41 -0400

All,
The draft-ietf-ipp-ops-set2 should not be killed off.  The Semantic Model
does contain operations and attributes that are defined in the draft
document. 

Carl,
I have talked with Tom and he will help get the document finished off.
Please give him a call to work out the details.

Pete

Peter Zehler 
XEROX 
Xerox Innovation Group 
Email: [email-masked] 
Voice:    (585) 265-8755 
FAX:      (585) 422-7961 
US Mail: Peter Zehler
              Xerox Corp. 
              800 Phillips Rd. 
              M/S 128-25E 
              Webster NY, 14580-9701 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, June 30, 2004 12:32 PM
To: Ipp@Pwg. Org
Subject: IPP> Killing off draft-ietf-ipp-ops-set2 ?

To the IPP WG Members,

I got this message from our Area Director a few days ago:

----

Carl,

A reminder: I still need to know what's going on with
this document.  If no definitive info is available by Friday
2 July (per my message of Thursday 17 June sent to the WG
mailing list) I'm going to drop it.

-Scott-

----

I have since had contact with Harry Lewis who had orignally planned to do
the final editing for this document (it is now the very last of our IETF IPP
drafts), but it has turned out that Harry will not be able to finish that
task.

In an earlier message I had offered to step in as editor if nobody else
could do it.

However, Harry raised the question whether we really want this document to
go forward on the IETF standards track, suggesting that current work on the
WIMS protocol would be a better solution.

This view also seems to be supported by some other key IPP WG members.

In that ligth it seems that further work on draft-ietf-ipp-ops-set2 aka "IPP
management" seems rather fruitless and my current suggestion is to just let
this draft die.

If there is anybody out there who is already working on implementation of
the draft and would be eager to see the document finalized I need your input
rigth away.

I know that this news comes at a time where a number of WG members have
already started their summer vacations, but we have been very close to
killing off this document earlier without any major objections being
expressed.

At one stage it seemed that Easy Software were about to start on the
management part of IPP. I have tried to contact Michael Sweet, the key
developer of CUPS, but he is currently on vacation. Is there anybody else
who knows what the status of CUPS is in this area? As CUPS already contains
various non-standard extentions to IPP, I assume that they can still do the
management part as another private extension if they want to.

Carl-Uno

Carl-Uno Manros
Chair of IETF IPP WG
700 Carnegie Street #3724
Henderson, NV 89052, USA
Tel +1-702-617-9414
Fax +1-702-617-9417
Mob +1-702-525-0727
Email [email-masked]
Web    www.manros.com

> > > 	Carl,
> > >
> > > 	A reminder: I still need to know what's going on with
> > > this document.  If no definitive info is available by Friday
> > > 2 July (per my message of Thursday 17 June sent to the WG
> > > mailing list) I'm going to drop it.
> > >
> > > 	-Scott-
> > >
> > > 	-----Original Message-----
> > > 	From: Harry Lewis [mailto:[email-masked]]
> > > 	Sent: Wednesday, June 09, 2004 12:05 AM
> > > 	To: Scott Hollenbeck
> > > 	Cc: [email-masked]; Carl Kugler;
> > > [email-masked]; [email-masked]
> > > 	Subject: Re: FW: Security Review of draft-ietf-ipp-ops-set2
> > >
> > >
> > >
> > > 	Yea... REAL hard time getting to this. Will try to bump
> > > up the priority over the next few weeks. If I hit the wall...
> > > I'll just have to live with "splat". It would be a shame but
> > > I understand there are limits. Little I can do to alter the
> > > circumstances.
> > > 	----------------------------------------------
> > > 	Harry Lewis
> > > 	IBM STSM
> > > 	Chairman - IEEE-ISTO Printer Working Group
> > > 	http://www.pwg.org
> > > 	IBM Printing Systems
> > > 	http://www.ibm.com/printers
> > > 	303-924-5337
> > > 	----------------------------------------------
> > >
> > >
> > >
> > > "Scott Hollenbeck" <[email-masked]>
> > >
> > > 06/08/2004 04:31 PM
> > >
> > > To
> > > Carl Kugler/Boulder/IBM@IBMUS, <[email-masked]>,
> > > Harry Lewis/Boulder/IBM@IBMUS cc <[email-masked]>,
> > > <[email-masked]> Subject
> > > FW: Security Review of draft-ietf-ipp-ops-set2
> > >
> > >
> > >
> > >
> > >
> > >
> > > 	Have you guys made any progress in revising the
> > > Security Considerations
> > > 	section of the subject document?  That's all that's
> > > holding this document up
> > > 	from being approved by the IESG, and I want to get it
> > > off of my plate ASAP.
> > >
> > > 	WGs that don't make any progress in finishing documents
> > > tend to get shut
> > > 	down before their time (hint, hint). ;-)  This document
> > > has been sitting
> > > 	like this for *two years*.
> > >
> > > 	-Scott-
> > >
> > > 	-----Original Message-----
> > > 	From: Russ Housley [mailto:[email-masked]]
> > > 	Sent: Friday, April 09, 2004 10:27 AM
> > > 	To: [email-masked]
> > > 	Cc: [email-masked]; [email-masked]
> > > 	Subject: Fwd: Security Review of draft-ietf-ipp-ops-set2
> > >
> > >
> > > 	Kurt:
> > >
> > > 	On behalf of the Security Directorate, please help
> > > these folks compose a
> > > 	reasonable security considerations section.  The
> > > current one leave much to
> > > 	be desired.
> > >
> > > 	Russ
> > >
> > >
> > > 	>From: "Hollenbeck, Scott" <[email-masked]>
> > > 	>To: "'Russ Housley'" <[email-masked]>,
> > > 	>         "'Steve Bellovin'"
> > > 	>         <[email-masked]>
> > > 	>Subject: Security Review of draft-ietf-ipp-ops-set2
> > > 	>Date: Thu, 8 Apr 2004 08:52:46 -0400
> > > 	>Importance: high
> > > 	>
> > > 	>Russ, Steve:
> > > 	>
> > > 	>A long time ago (April 2002) Jeff Schiller entered a
> > > discuss comment for
> > > 	the
> > > 	>subject document.  I found this while working through
> > > the backlog of Ned's
> > > 	>documents.
> > > 	>
> > > 	>The authors need some help in crafting appropriate
> > > security considerations.
> > > 	>Can you point me to someone who might be able to help them?
> > > 	>
> > > 	>-Scott-
> > >
> > >
> > >
> > >
> > >
> >
>
>

---

From: <[email-masked]>
Date: Wed, 30 Jun 2004 18:52:13 -0700

Hi all,

Well things seem to be changing by the day on this subject.

It is now clear that at least the Xerox folks would like to see the document
finalized and the main IPP editor Tom Hastings has now stated to me and the
Area Director that he is prepared to have the revised version ready for Area
Director approval by the deadline on July 19. (I think Tom volonteered in
order not to have his draft scr**ed up by an editing amateur like myself).

I just want to remind you all that formally the IPP WG agreed on this
document some eons ago, and we can now get it approved quickly by just
responding to the security comments that our previous Area Director gave
back on the current draft. Following the strict rules of the IETF, the draft
is really in the hands of the Area Director at this stage and doesn't
necessarily need further approval from the IPP WG, but I am still prepared
to hear further comments from you all.

I am now leaning towards getting the document published, but would hope to
see some other people support that before the last word is said and done.

Does Peter's comment about the relationship between this document and the
PWG Semantic Model, which is referenced by several other (non-IETF)
standards, carry enough weigth to go ahead with the publishing?

In summary, we have now made the commitment that the document CAN be edited
and sent back to the Area Director within the given cut-off date, the only
remaining question is whether we actually WANT to have it published.

Carl-Uno

Carl-Uno Manros

> From: [email-masked] [mailto:[email-masked]]On Behalf Of Zehler,
> Peter
> Sent: Wednesday, June 30, 2004 10:45 AM
> To: [email-masked]'; Ipp@Pwg. Org; Hastings, Tom N
> Cc: [email-masked]'
> Subject: RE: IPP> Killing off draft-ietf-ipp-ops-set2 ?
>
>
> All,