Subject: IPP> Re:

From: karthik bala guru <[email-masked]>
Date: Thu, 1 Jul 2004 03:56:26 -0700 (PDT)

Hi,
Has anyone come across / used a XHTML Parser generator
tool in Opensource community developed in C ?
Do Kindly post the link / tool name .

I saw Amaya but it is big and will consume time
to get just the XHTML Parser / Generator from it.

1) GENX is XML Parser and No XHTML Parser / Generator
tool
developed using GENX by GENX till now.

2) EXPAT doesnt provide a opensource XHTML Parser /
Generator till today.

3) X-Smiles is simple and good but Java Based .

4) LibXml is also a library and no XHTML parser /
Generator Tool by them in opensource till today.

Has Someone got a simple setup with just
the XHTML Parser and Generator alone developed in C 
available in OpenSource 
or 
A tool Develped Using the above library tools ?

Kindly let me know And Do Give me your link.

Thanks & Regards,
karthik bala guru

__________________________________
Do you Yahoo!?
New and Improved Yahoo! Mail - Send 10MB messages!
http://promotions.yahoo.com/new_mail

---

From: Michael Sweet <[email-masked]>
Date: Thu, 01 Jul 2004 09:02:39 -0400

karthik bala guru wrote:
 > ...

As far as an XML parser/generator, libxml and libxml2 are two very
common solutions in the open source world.  If you want something
smaller and simpler, my Mini-XML library might provide the
functionality you need:

     http://www.easysw.com/~mike/mxml/

Also, if you are looking for a tool to turn HTML/XHTML into a
printable form, my HTMLDOC software will do the trick (contains
some C++ code):

     http://www.easysw.com/htmldoc/

-- 
______________________________________________________________________
Michael Sweet, Easy Software Products           mike at easysw dot com
Printing Software for UNIX                       http://www.easysw.com