Subject: PWG-ANNOUNCE> FW: Micro Job Ticket

From: "McDonald, Ira" <[email-masked]>
Date: Thu, 12 Aug 2004 07:17:46 -0700

Hi folks,

People interested in next Monday morning's discussion of the
Micro Job Ticket should look at the note below for links and
context.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

-----Original Message-----
From: McDonald, Ira 
Sent: Tuesday, August 10, 2004 9:42 PM
To: 'Harry Lewis'; McDonald, Ira; [email-masked]'
Subject: RE: Micro Job Ticket

Hi Paul and Harry,

The document (never reviewed at May PWG, due to change
of direction during CE Printing BOF) is at the link in
the original release note below, which is:

    ftp://ftp.pwg.org/pub/pwg/BOFs/ce/tb-cesjt10-20040510.htm

I still believe it applies well to the embedded/CE/mobile
environment.  

It avoids at least 90% of the overhead of XML encodings 
(you could write a parser in 20 lines of C, using a small 
symbol table).

[Harry has renamed it Micro Job Ticket, which is far more
descriptive - after all, what is 'Simple'?]

[This Micro Job Ticket could easily be extended for other
imaging services, like copy, transform, etc.]

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked] 
-------------------------------------------
Hi folks,                                           Monday (10 May 2004)

[For review at the next PWG face-to-face meeting in Vancouver, BC,
during the Consumer Electronice BOF on Thursday (27 May 2004)]

Based on our discussions during the Consumer Electronics BOF at the PWG
face-to-face meeting in April 2004 in Washington, DC, I have just posted
an initial draft of a non-XML, string-encoded PWG Simple Job Ticket at:

    ftp://ftp.pwg.org/pub/pwg/BOFs/ce/tb-cesjt10-20040510.htm

Please read the SJT/1.0 example in Appendix D (see below) and the brief
ABNF in Appendix C before reading the body of this document.

Please send comments to the [email-masked]' mailing list.

Cheers,
- Ira

[PS - Jerry - I cut and pasted the cover page style and boilerplate from
Harry's most recent PWG Process 2.0 draft - please point out any errors
- the boldface didn't cut and paste in titles such as 'About IEEE']

------------------------------------------------------------------------
[example SJT/1.0 JobTicket instance, excerpted from Appendix D]

.pwg:JobTicket              -- begin job ticket
101="sjt10"                 -- type and version
155="201,252"               -- media and finishings on job mandatory
156="vnd,http://example.com/sjt-namespace.txt" -- Vendor ABNF

.pwg:Job                    -- begin job
201="iso_a4_210x297mm"      -- ISO A4 letter
251=3                       -- 3 copies of this job
252="4,6"                   -- staple and cover finishings on job
vnd:251=50                  -- vendor extension 'JobZoom'

.pwg:Document               -- begin document
301=202                     -- JPEG document format
302="http://example.com/pictures/778.jpg" -- document URI
355="Bermuda Sunset"        -- document name
vnd:351=3                   -- vendor extension 'DocumentSharpening'
./pwg:Document              -- end document
./pwg:Job                   -- end job
./pwg:JobTicket             -- end job ticket

------------------------------------------------------------------------

-----Original Message-----
From: Harry Lewis [mailto:[email-masked]]
Sent: Tuesday, August 10, 2004 6:57 PM
To: [email-masked]
Subject: Fw: Micro Job Ticket

Ira, do you have anything most recent that you would like Paul to review? 
---------------------------------------------- 
Harry Lewis 
IBM STSM
Chairman - IEEE-ISTO Printer Working Group
http://www.pwg.org
IBM Printing Systems 
http://www.ibm.com/printers
303-924-5337
---------------------------------------------- 
----- Forwarded by Harry Lewis/Boulder/IBM on 08/10/2004 04:56 PM ----- 
Paul Danbold <[email-masked]> 
08/10/2004 04:52 PM ToHarry Lewis/Boulder/IBM@IBMUS 
cc
SubjectMicro Job Ticket

Harry,

In preparation for next week's meeting, can you please point me to the 
current micro-job ticket documentation?  I browsed the PWG ftp site but 
I guess I missed it.  Thanks in advance, and of course, looking forward 
to fully engaging with the PWG starting next week.

Regards,

-Paul

---

From: Nagasaka Fumio <[email-masked]>
Date: Sun, 15 Aug 2004 06:06:39 +0900

Ira,

>7.1.1 JobMedia(String)
.....
>See: "Media Type Names" section 3 of [PWG5101.1]

Is this reference section proper?
Section 3 of [PWG5101.1] is describing the model of this semantics.
A PWG Semantic Model Sub-Schemas "MediaWellKnownValues.xsd" lists "Media Type Names".

Fumio Nagasaka /Epson IJP

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of McDonald, Ira
Sent: Thursday, August 12, 2004 11:18 PM
To: [email-masked]'
Subject: PWG-ANNOUNCE> FW: Micro Job Ticket

Hi folks,

Cheers,
- Ira

-----Original Message-----
From: McDonald, Ira 
Sent: Tuesday, August 10, 2004 9:42 PM
To: 'Harry Lewis'; McDonald, Ira; [email-masked]'
Subject: RE: Micro Job Ticket

Hi Paul and Harry,

Cheers,
- Ira

Cheers,
- Ira

.pwg:Job                    -- begin job

----- Forwarded by Harry Lewis/Boulder/IBM on 08/10/2004 04:56 PM ----- 

Harry,

Regards,

-Paul