Subject: [IPP] Revised IPP Everywhere Charter (21 February 2011)

From: Ira McDonald <[email-masked]>
Date: Mon, 21 Feb 2011 17:36:03 -0500

Hi,

I've just posted a new IPP Everywhere Project charter at:

ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeverywhere-charter-20110221.pdf / doc
- line numbers and redlines

Major revision that adds all of the following specs:

- IPP over HTTPS Transport Binding and 'ipps' URI Scheme (IETF
standards-track)
- LDAP Printer Schema (IETF informational)
- PWG Raster (w/ IANA MIME type registration)
- IPP Everywhere First Edition (printing) - clarified scope as printing only
- IPP Scan Service
- IPP System Control Service
- IPP Fax Service (leveraging previous IPP Fax project)
- IPP Everywhere Second Edition (multifunction)

Added initial draft and prototype draft milestones for all these specs (but
not
PWG Last Call except for Requirements because prototyping may change them).

Revised many milestone dates - Bill - please check them for plausibility.

Comments?

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Hardcopy WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Christmas through April:
  579 Park Place  Saline, MI  48176
  734-944-0094
May to Christmas:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 21 Feb 2011 22:40:28 -0800

On Feb 21, 2011, at 2:36 PM, Ira McDonald wrote:
> - IPP over HTTPS Transport Binding and 'ipps' URI Scheme (IETF standards-track)
> Added initial draft and prototype draft milestones for all these specs (but not

Lines 27-30: Change to read:

Multifunction devices supporting network scan, fax, and other imaging services are now common and have similar discovery, driver, and document format issues. Extending the IPP printing model to support these multifunction imaging services and leverage the existing widespread IPP support in multifunction devices is an important long term goal for this project as well.

Lines 34-36: Remove (no longer have a separate requirements document)

Lines 39-40: Replace the reference to IPP Everywhere Requirements with "define a small set of new IPP Job and Printer operations and attributes to support driverless and mobile printing."

Lines 43-44: "to always starts TLS first (before HTTP session layer)" should be "to always start TLS first before the HTTP session layer"

Line 51: The filename I've been using is wd-ippraster10-yyyymmdd

Lines 120, 127: Drop REQ

__________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair