Subject: [IPP] (Very) Draft IPP Job and Printer Extensions - Set 3 posted

From: Michael Sweet <[email-masked]>
Date: Fri, 25 Feb 2011 15:41:53 -0800

All,

I have just uploaded an initial draft of the IPP Job and Printer Extensions - Set 3 (JPS3) specification containing most of the combined additions we have discussed for IPP Everywhere:

    ftp://ftp.pwg.org/pub/ipp/wd/wd-ippjobprinterext3v10-20110225.docx
    ftp://ftp.pwg.org/pub/ipp/wd/wd-ippjobprinterext3v10-20110225.pdf

There is still a bunch of stuff I need to fill in, and I noticed (just after uploading) that I forgot to include the job-uuid, printer-uuid, and subscription-uuid attributes, but otherwise it should be relatively complete from the "this is what we need to work on" point of view.

Comments, etc. welcome. For possible discussion at Monday's IPP telecon...

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Fri, 25 Feb 2011 16:24:41 -0800

All,

Sorry, the correct URLs are:

    ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext3v10-20110225.docx
    ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext3v10-20110225.pdf

> Comments, etc. welcome. For possible discussion at Monday's IPP telecon...

__________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Ira McDonald <[email-masked]>
Date: Sat, 26 Feb 2011 16:41:14 -0500

Hi Mike,

Editorial - You didn't regenerate the Table of Contents
from the template, so the TOC is useless for browsing
the document.

Editorial - I dislike this new references format - it's very
different from IETF and W3C references and leaves out
the important month and year of publication (which warns
the reader to check for a newer version when it's an old
RFC, etc.).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Hardcopy WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Christmas through April:
  579 Park Place  Saline, MI  48176
  734-944-0094
May to Christmas:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

On Fri, Feb 25, 2011 at 7:24 PM, Michael Sweet <[email-masked]> wrote:

> I have just uploaded an initial draft of the IPP Job and Printer Extensions
> - Set 3 (JPS3) specification containing most of the combined additions we
> have discussed for IPP Everywhere:
>
> There is still a bunch of stuff I need to fill in, and I noticed (just
> after uploading) that I forgot to include the job-uuid, printer-uuid, and
> subscription-uuid attributes, but otherwise it should be relatively complete
> from the "this is what we need to work on" point of view.
>
> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
> believed to be clean.
> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
> believed to be clean.
>

---

From: Michael Sweet <[email-masked]>
Date: Sat, 26 Feb 2011 20:22:30 -0800

> from the template, so the TOC is useless for browsing

Oops!  I wish Word would auto-regenerate on save... :(

> the reader to check for a newer version when it's an old

I'll see what other formats are in use by our published specs; if there is a common format, I'll just change to that and update the template to include examples.