Subject: [IPP] Third revised IPP Everywhere Charter (28 February 2011)

From: Ira McDonald <[email-masked]>
Date: Mon, 28 Feb 2011 18:58:32 -0500

Hi,

I've just posted a *third* draft of our new IPP Everywhere Project charterat:

ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeverywhere-charter-20110228.pdf / doc
- line numbers and redlines

After talking with Mike Sweet just now and reviewing his minutes from
today's
IPP WG teleconference, I've tweaked it accordingly.

Major revision that *deletes* the following spec:

- IPP Everywhere Requirements - to be included in each spec

Major revision that *adds* all of the following specs:

- IPP over HTTPS Transport Binding and 'ipps' URI Scheme (IETF
standards-track)
- LDAP Printer Schema (IETF informational)
- PWG Raster (w/ IANA MIME type registration)
- IPP Everywhere First Edition (printing) - clarified scope as printing only
- IPP Scan Service
- IPP System Control Service
- IPP FaxIn Service (leveraging previous IPP Fax project and MFD FaxIn)
- IPP FaxOut Service (leveraging previous IPP Fax project and MFD FaxOut)
- IPP Everywhere Second Edition (multifunction)

Note:  The IPP over HTTPS Transport Binding and 'ipps' URI Scheme spec
MUST be IETF standards-track (i.e., the PWG may not consider it a new
transport binding, but the IETF will so consider it).

Added initial draft and prototype draft milestones for all these specs (but
not
PWG Last Call because prototyping may change them).

Revised many milestone dates - Bill - please check them for plausibility.

Comments?

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Hardcopy WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Christmas through April:
  579 Park Place  Saline, MI  48176
  734-944-0094
May to Christmas:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 28 Feb 2011 16:27:17 -0800

Minor correction:

    Line 107: remove "see OBJ-4 above" from OBJ-7...

Also, in order to mitigate risk for the first edition of IPP Everywhere, we can make the reference to the "ipps" RFC informational (pointing to the current draft) with the corresponding background text (in wide use for many years, IPP over HTTPS, etc.)

On Feb 28, 2011, at 3:58 PM, Ira McDonald wrote:

> Hi,
> 
> I've just posted a third draft of our new IPP Everywhere Project charter at:
> 
> After talking with Mike Sweet just now and reviewing his minutes from today's
> Major revision that deletes the following spec:
> 
> Major revision that adds all of the following specs:
> 
> - IPP over HTTPS Transport Binding and 'ipps' URI Scheme (IETF standards-track)
> Added initial draft and prototype draft milestones for all these specs (but not

__________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Ira McDonald <[email-masked]>
Date: Mon, 28 Feb 2011 20:51:29 -0500

Hi,

Thanks for that catch Mike - I slightly revised the charter
and posted it over the earlier copy at:

Additional changes:

- Added Andrew Mitchell as an editor (for IPP Scan)

- Removed the assumptions about IETF document status
  from specs (b) 'ipps' and (c) LDAP, since this is at the
  discretion of the IESG and current IETF best practice

- Removed reference to (deleted) OBJ-4 from OBJ-7

Cheers,
- Ira

On Mon, Feb 28, 2011 at 7:27 PM, Michael Sweet <[email-masked]> wrote:

> Also, in order to mitigate risk for the first edition of IPP Everywhere, we
> can make the reference to the "ipps" RFC informational (pointing to the
> current draft) with the corresponding background text (in wide use for many
> years, IPP over HTTPS, etc.)
>