Subject: [IPP] "print-color-mode" or "imaging-color-mode"?

From: Michael Sweet <[email-masked]>
Date: Mon, 18 Apr 2011 13:52:30 -0700

All,

If we consider scanning and printing of forms, the "bi-level" (threshold) mode makes sense for both. Do we want to rename "print-color-mode" to "imaging-color-mode" in anticipation of using is for other MFD services in IPP?

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Petrie, Glen" <[email-masked]>
Date: Mon, 18 Apr 2011 14:01:35 -0700

I still disagree that we, the PWG, are doing "imaging"; that's what
cameras do.  We do print, scan, fax and copy.  In today's world of
computer programming is the amount of space to define
"print-color-color" and "scan-color-mode" that wasteful and having the
two provides more understanding to either a source device or a target
device. 

Glen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Michael Sweet
Sent: Monday, April 18, 2011 1:53 PM
To: [email-masked]
Subject: [IPP] "print-color-mode" or "imaging-color-mode"?

All,

If we consider scanning and printing of forms, the "bi-level"
(threshold) mode makes sense for both. Do we want to rename
"print-color-mode" to "imaging-color-mode" in anticipation of using is
for other MFD services in IPP?

---

From: Michael Sweet <[email-masked]>
Date: Mon, 18 Apr 2011 14:16:46 -0700

On Apr 18, 2011, at 2:11 PM, Tim McCann wrote:
> Granted, I am still getting up to speed on much of this (so please forgive
> me in advance if I'm stepping into something already covered), but didn't
> Lexmark recently really blur the difference of scan capture and camera
> capture when they put a camera in their Genesis print/mfp device in order to
> capture data as their scanning device?  
> 
> It seems to me that a name like "capture-color-mode" might eliminate the
> scan, scan, fax, and camera issue.

But you aren't "capturing" when you print - "capture" really only works as an adjective when taking something in (scan, fax-in, email-in) while "imaging" covers anything image-related.

I agree with Glen that "imaging" is an unfortunately broad term, however we haven't come up with a suitable replacement word that is limited to printing, facsimile, scanning, copying, transform, etc. in multifunction devices.

> Tim
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Petrie,
> Glen
> Sent: Monday, April 18, 2011 3:02 PM
> To: Michael Sweet; [email-masked]
> Subject: RE: [IPP] "print-color-mode" or "imaging-color-mode"?
> 
> I still disagree that we, the PWG, are doing "imaging"; that's what cameras
> do.  We do print, scan, fax and copy.  In today's world of computer
> programming is the amount of space to define "print-color-color" and
> "scan-color-mode" that wasteful and having the two provides more
> understanding to either a source device or a target device. 
> 
> Glen
> 
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael
> Sweet
> "print-color-mode" to "imaging-color-mode" in anticipation of using is for
> other MFD services in IPP?
> 
> This message has been scanned for viruses and dangerous content by
> MailScanner, and is believed to be clean.
> 
> This message has been scanned for viruses and dangerous content by
> MailScanner, and is believed to be clean.
>

---

From: "Petrie, Glen" <[email-masked]>
Date: Mon, 18 Apr 2011 14:18:32 -0700

Thanks Mike.  I hope we can get ahead of the people prototyping so that
we can get more concise terms (and everyone will use them!).

-----Original Message-----
From: Michael Sweet [mailto:[email-masked]] 
Sent: Monday, April 18, 2011 2:13 PM
To: Petrie, Glen
Cc: [email-masked]
Subject: Re: [IPP] "print-color-mode" or "imaging-color-mode"?

Glen,

There may in fact be reasons to keep the two attributes separate (e.g.
for copy), but I wanted to mention this now rather than in 6 months when
everyone has prototyped using "print-color-mode"...

---

From: "Petrie, Glen" <[email-masked]>
Date: Mon, 18 Apr 2011 14:16:02 -0700

I like "capture" versus "imaging".  But I believe the IPP team wants a
single work for Print, scan, fax, copy; and, "capture" does not work
well for print.  But if you have other ideas please suggest them.

-----Original Message-----
From: Tim McCann [mailto:[email-masked]] 
Sent: Monday, April 18, 2011 2:12 PM
To: Petrie, Glen; 'Michael Sweet'; [email-masked]
Subject: RE: [IPP] "print-color-mode" or "imaging-color-mode"?

Granted, I am still getting up to speed on much of this (so please
forgive
me in advance if I'm stepping into something already covered), but
didn't
Lexmark recently really blur the difference of scan capture and camera
capture when they put a camera in their Genesis print/mfp device in
order to
capture data as their scanning device?  

Tim

-----Original Message-----
Petrie,

cameras

Glen

-----Original Message-----
Michael

All,

for

---

From: Michael Sweet <[email-masked]>
Date: Mon, 18 Apr 2011 14:13:16 -0700

Glen,

There may in fact be reasons to keep the two attributes separate (e.g. for copy), but I wanted to mention this now rather than in 6 months when everyone has prototyped using "print-color-mode"...

---

From: Ira McDonald <[email-masked]>
Date: Mon, 18 Apr 2011 18:34:45 -0400

Hi Mike,

My two cents.

No - let's keep the name "print-color-mode" to cohere with the
zillion other print-xxx or printer-xxx attributes.

In the new IPP Scanner and Fax objects lets just globally apply
most/many existing IPP Printer attributes in big table(s) with
a rationale for why some attributes are not applicable to the
other multifunction objects.

Unless almost all Printer attributes *are* applicable, which I begin
to suspect is the case (and have a short table of the exceptions).

I think we should reserve use of he "imaging-" prefix for only new
attributes defined first for Scanner, Fax, etc. objects for IPP
Everywhere Second Edition.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Hardcopy WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Christmas through April:
  579 Park Place  Saline, MI  48176
  734-944-0094
May to Christmas:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

On Mon, Apr 18, 2011 at 4:52 PM, Michael Sweet <[email-masked]> wrote:

> All,
>
> If we consider scanning and printing of forms, the "bi-level" (threshold)
> mode makes sense for both. Do we want to rename "print-color-mode" to
> "imaging-color-mode" in anticipation of using is for other MFD services in
> IPP?
>

---

From: "Tom Hastings" <[email-masked]>
Date: Tue, 19 Apr 2011 11:45:45 -0700

I agree with Ira.  On the other hand, one other alternative for the name
would just to drop the "print-" prefix and call it "color-mode".

Tom

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ira
McDonald
Sent: Monday, April 18, 2011 15:35
To: Michael Sweet; Ira McDonald
Cc: [email-masked]
Subject: Re: [IPP] "print-color-mode" or "imaging-color-mode"?

Hi Mike,

My two cents.

Cheers,
- Ira

 <http://sites.google.com/site/highnorthinc>

All,

-- 
This message has been scanned for viruses and 
dangerous content by  <http://www.mailscanner.info/> MailScanner, and is 
believed to be clean.

---

From: "Mitchell, Andrew (Solutions Architect)" <[email-masked]>
Date: Tue, 19 Apr 2011 18:59:41 +0000

OK, my 2¢.

We need to decide if naming a NEW attribute that applies to more then just print with the print- prefix makes sense. A agree that renaming existing attributes does not make sense, and using the print- attributes in scan (and fax) rather then renaming them is logical. But if we are going to say attributes that are originally defined in Scan (or Fax) start with imaging- while if they first show up in IPP Everywhere (or some other doc like JPS3) we name them print- that doesn't seam quite right. My preference would be either:

 1.  Call everything that is not scan (or fax) specific print-, no matter where it is first defined. For scan or fax specific, call them scan- and fax-.
 2.  Start using the imaging- prefix everywhere that the term is NOT print specific.

We are going to expand the model which is heavily rooted in print to other services, I'd just like to have a consistent naming convention for how we move forward. 1 seems more confusing to me since it means keeping the print- name moving forward, and we'll have to maintain the table as to what is print specific and what isn't, but 1 also seems more true to the roots of IPP. I however personally vote for 2 since it clearly implies our broader scope of the protocol moving forward.

As for just dropping the print- prefix, while it works for color-mode, I think we need to take a harder look to make sure it makes sense everywhere. Note that I view this as simply a different way of naming option 2. If we pick option 2 we need to then pick the naming convention.

OK, so that was a bit more the 2¢ worth.

Andrew

From: Tom Hastings <[email-masked]<mailto:[email-masked]>>
Reply-To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Tue, 19 Apr 2011 18:45:45 +0000
To: 'Ira McDonald' <[email-masked]<mailto:[email-masked]>>, 'Michael Sweet' <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [IPP] "print-color-mode" or "imaging-color-mode"?

I agree with Ira.  On the other hand, one other alternative for the name would just to drop the "print-" prefix and call it "color-mode".

Tom

________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Ira McDonald
Sent: Monday, April 18, 2011 15:35
To: Michael Sweet; Ira McDonald
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [IPP] "print-color-mode" or "imaging-color-mode"?

Hi Mike,

My two cents.

Cheers,
- Ira

mailto:[email-masked]<mailto:[email-masked]>

On Mon, Apr 18, 2011 at 4:52 PM, Michael Sweet <[email-masked]<mailto:[email-masked]>> wrote:
All,

_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp

--
This message has been scanned for viruses and
dangerous content by MailScanner<http://www.mailscanner.info/>, and is
believed to be clean.

--
This message has been scanned for viruses and
dangerous content by MailScanner<http://www.mailscanner.info/>, and is
believed to be clean.

---

From: "Petrie, Glen" <[email-masked]>
Date: Tue, 19 Apr 2011 12:06:50 -0700

If the "color-mode" refers to the capability (setting) of the scanner or the fax; then I vote for 1. below to clearly denote this.   An image does not have a "color-mode"; it has a color space.  Mode implies functionality not a state.

Glen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mitchell, Andrew (Solutions Architect)
Sent: Tuesday, April 19, 2011 12:00 PM
To: [email-masked]; 'Ira McDonald'; 'Michael Sweet'
Cc: [email-masked]
Subject: Re: [IPP] "print-color-mode" or "imaging-color-mode"?

OK, my 2¢.

Andrew

Tom

Hi Mike,

My two cents.

Cheers,
- Ira

---

From: Ira McDonald <[email-masked]>
Date: Tue, 19 Apr 2011 15:48:53 -0400

Hi,

On reflection, I tend to agree with Andrew that we should
(in general) use the 'imaging-' prefix for our new attributes.

But I *think* we meant the new 'print-color-mode' property
to refer specifically to hardcopy output (print).

I don't think it fits well w/ scan (output image format) or fax.

All - note that we generally *drop* the 'print-' or 'job-' or
whatever prefix in the PWG Semantic Model XML Schema
in order to reuse the "same" (well similar) attribute at more
than one level of the system/service/job/document hierarchy.

Pete - please chime in with your opinion here.

Cheers,
- Ira

On Tue, Apr 19, 2011 at 3:06 PM, Petrie, Glen <[email-masked]>wrote:

> If the "color-mode" refers to the capability (setting) of the scanner or
> the fax; then I vote for 1. below to clearly denote this.   An image does
> not have a "color-mode"; it has a color space.  Mode implies functionality
> not a state.
>
> Glen
>
>
> Mitchell, Andrew (Solutions Architect)
> We need to decide if naming a NEW attribute that applies to more then just
> print with the print- prefix makes sense. A agree that renaming existing
> attributes does not make sense, and using the print- attributes in scan (and
> fax) rather then renaming them is logical. But if we are going to say
> attributes that are originally defined in Scan (or Fax) start with imaging-
> while if they first show up in IPP Everywhere (or some other doc like JPS3)
> we name them print- that doesn't seam quite right. My preference would be
> either:
>
>
>  1.  Call everything that is not scan (or fax) specific print-, no matter
> where it is first defined. For scan or fax specific, call them scan- and
> fax-.
> We are going to expand the model which is heavily rooted in print to other
> services, I'd just like to have a consistent naming convention for how we
> move forward. 1 seems more confusing to me since it means keeping the print-
> name moving forward, and we'll have to maintain the table as to what is
> print specific and what isn't, but 1 also seems more true to the roots of
> IPP. I however personally vote for 2 since it clearly implies our broader
> scope of the protocol moving forward.
>
> As for just dropping the print- prefix, while it works for color-mode, I
> think we need to take a harder look to make sure it makes sense everywhere.
> Note that I view this as simply a different way of naming option 2. If we
> pick option 2 we need to then pick the naming convention.
>
> Reply-To: "[email-masked]<mailto:[email-masked]>" <
> [email-masked]<mailto:[email-masked]>>
> To: 'Ira McDonald' <[email-masked]<mailto:[email-masked]>>,
> 'Michael Sweet' <[email-masked]<mailto:[email-masked]>>
> From: [email-masked]<mailto:[email-masked]> [mailto:
> [email-masked]] On Behalf Of Ira McDonald

---

From: "Petrie, Glen" <[email-masked]>
Date: Tue, 19 Apr 2011 13:05:56 -0700

Ira, I believe the property refers to the functional mode the printer is to use or was used to produce the output.  That is; the printer is printing in or instructed to print in a ""color mode"".   If this property was meant to represent the "state" of the output; then for print, and later for scan and fax, it should be (have been) called "color-space".   Then it would make more sense to have used the prefix "image" (versus even the word "imaging"); so we have image-color-space (the printed image, the scanned image, the fax image - the key here it is the image and the device functionality or device capabilities or device mode.). 

So the device is instructed (or uses) to have a specific

print-color-mode, scan-color-mode or fax-color-mode to produce an (hard or electronic) image that has an image-color-space

what about "device-color-mode"

Glen

From: Ira McDonald [mailto:[email-masked]] 
Sent: Tuesday, April 19, 2011 12:49 PM
To: Petrie, Glen; Ira McDonald
Cc: Mitchell, Andrew (Solutions Architect); [email-masked]; Michael Sweet; [email-masked]
Subject: Re: [IPP] "print-color-mode" or "imaging-color-mode"?

Hi,

Cheers,
- Ira

http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc> 

On Tue, Apr 19, 2011 at 3:06 PM, Petrie, Glen <[email-masked]> wrote:

Glen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mitchell, Andrew (Solutions Architect)
Sent: Tuesday, April 19, 2011 12:00 PM
To: [email-masked]; 'Ira McDonald'; 'Michael Sweet'
Cc: [email-masked]
Subject: Re: [IPP] "print-color-mode" or "imaging-color-mode"?

OK, my 2¢.

Andrew

Tom

Hi Mike,

My two cents.

Cheers,
- Ira

--

---

From: Michael Sweet <[email-masked]>
Date: Tue, 19 Apr 2011 13:16:41 -0700

All,

I've done some research (mainly going back through the MFD Scan and Model documents) and both define the ColorEntry job ticket element to control the corollary of print-color-mode for scanning. So, for purposes of IPP Scan I would opt to use color-entry and the corresponding mapped keywords from the MFD Scan/Model specs.

In general I think we can stick with the existing names. If something new applies to multiple services and doesn't have a logical prefix of its own, add "imaging-" to the front. If something is service-specific, put the service name on the front..

All that said, here is another wrinkle: copy, which has input and output job ticket elements...  I'm thinking we just use collections, but we have time to discuss the actual binding...

---

From: "Petrie, Glen" <[email-masked]>
Date: Tue, 19 Apr 2011 13:18:38 -0700

Ira, if by chance, the prefix "print" was meant to be a verb versus denoting the device (printer, scanner, fax) does it really change the idea that it is still referring to the device ""color-mode"".   The prefix "imaging", I assume, is being used verb as a verb; but still, I believe it leads to ambiguity about the attribute while the prefix's scan and fax are clear and concise.  

glen

From: [email-masked] [mailto:[email-masked]] On Behalf Of Petrie, Glen
Sent: Tuesday, April 19, 2011 1:06 PM
To: Ira McDonald
Cc: [email-masked]
Subject: RE: [IPP] "print-color-mode" or "imaging-color-mode"?

Glen

Hi,

Cheers,
- Ira

Glen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mitchell, Andrew (Solutions Architect)
Sent: Tuesday, April 19, 2011 12:00 PM
To: [email-masked]; 'Ira McDonald'; 'Michael Sweet'
Cc: [email-masked]
Subject: Re: [IPP] "print-color-mode" or "imaging-color-mode"?

OK, my 2¢.

Andrew

Tom

Hi Mike,

My two cents.

Cheers,
- Ira

--

-- 
This message has been scanned for viruses and 
dangerous content by MailScanner <http://www.mailscanner.info/> , and is 
believed to be clean.

---

From: "William Wagner" <[email-masked]>
Date: Tue, 19 Apr 2011 16:21:34 -0400

All,

First, I agree that "imaging" is an poor term for us to use, although for me
it is because it invokes too board a spectrum (e.g., MRI's and conceptual
imaging) rather than being photographic specific. I liked "Hardcopy", since
that reasonably covers the MFD services, but I understand that some envision
PWG activity to extend to non-hardcopy devices, as it has to an extent with
the projector group. And we have been using "Imaging" for a while in other
PWG activities. However, I suggest that, if someone can come up with a
different, good inclusive term, we consider using it in this envisioned
extension of IPP to other services. One problem I see is that we have not
defined what services we intend IPP to extent to beyond the MFD "Hardcopy"
services, and I think this open-ended applicability is going to create
confusion.

Second, I would be inclined to prefer Andrew's option 2 (if indeed "imaging"
is the best term) except that I wonder if we always understand whether a
term is service specific, at least in its details if not in the board sense.
The idea of preceding everything with "print", or whatever service with
which it was first identified, regardless of the service it is being applied
to is a recipe for confusion, if indeed that is what is being  suggested. In
the MFD approach, command names are preceded by the service to which they
apply. I would have assumed that the same would apply to attributes, which
would allow distinctions to be made between  "print-color-mode",
"scan-color-mode", "copy-color-mode" etc., if such distinctions were
necessary (or later because necessary). Not including any prefix but
understanding the service from context would also work, but might make
defining the differences depending on service more cumbersome and would be
inconsistent with the current "print" prefixed terms.

Thanks, 
Bill Wagner

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Petrie,
Glen
Sent: Tuesday, April 19, 2011 3:07 PM
To: Mitchell, Andrew (Solutions Architect); [email-masked]; Ira
McDonald; Michael Sweet
Cc: [email-masked]
Subject: RE: [IPP] "print-color-mode" or "imaging-color-mode"?

If the "color-mode" refers to the capability (setting) of the scanner or the
fax; then I vote for 1. below to clearly denote this.   An image does not
have a "color-mode"; it has a color space.  Mode implies functionality not a
state.

Glen

-----Original Message-----

OK, my 2¢.

 1.  Call everything that is not scan (or fax) specific print-, no matter
where it is first defined. For scan or fax specific, call them scan- and
fax-.
 2.  Start using the imaging- prefix everywhere that the term is NOT print
specific.

Andrew

From: Tom Hastings
<[email-masked]<mailto:[email-masked]>>
Reply-To: "[email-masked]<mailto:[email-masked]>"
<[email-masked]<mailto:[email-masked]>>
Date: Tue, 19 Apr 2011 18:45:45 +0000
To: 'Ira McDonald'
<[email-masked]<mailto:[email-masked]>>, 'Michael Sweet'
<[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [IPP] "print-color-mode" or "imaging-color-mode"?

Tom

________________________________
From: [email-masked]<mailto:[email-masked]>
[mailto:[email-masked]] On Behalf Of Ira McDonald
Sent: Monday, April 18, 2011 15:35
To: Michael Sweet; Ira McDonald
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [IPP] "print-color-mode" or "imaging-color-mode"?

Hi Mike,

My two cents.

Cheers,
- Ira

On Mon, Apr 18, 2011 at 4:52 PM, Michael Sweet
<[email-masked]<mailto:[email-masked]>> wrote:
All,

--

---

From: Ira McDonald <[email-masked]>
Date: Tue, 19 Apr 2011 16:20:00 -0400

Hi Glen,

I think we're looking at the name of this attribute too literally.

The *function* of this attribute was strictly meant to decide
to do specific image processing before printing on media.

Conflating this 'xxx-color-mode' with 'xxx-color-space' (with
a disjoint set of keywords and usage) wouldn't be good.

Having just read Mike's reply about 'color-entry', it may apply
to scan and fax, but I don't think we should lump it with this
'print-color-mode'.

Cheers,
- Ira

On Tue, Apr 19, 2011 at 4:05 PM, Petrie, Glen <[email-masked]>wrote:

>  Ira, I believe the property refers to the functional mode the printer is
> to use or was used to produce the output.  That is; the printer is printing
> in or instructed to print in a “”color mode””.   If this property was meant
> to represent the “state” of the output; then for print, and later for scan
> and fax, it should be (have been) called “color-space”.   Then it would make
> more sense to have used the prefix “image” (versus even the word “imaging”);
> so we have image-color-space (the printed image, the scanned image, the fax
> image – the key here it is the image and the device functionality or device
> capabilities or device mode.).
>
>
>
> print-color-mode, scan-color-mode or fax-color-mode to produce an (hard or
> electronic) image that has an image-color-space
>
>
>
> what about “device-color-mode”
>
>
>
> Glen
>
>
>  ------------------------------
>
> *From:* Ira McDonald [mailto:[email-masked]]
> *Sent:* Tuesday, April 19, 2011 12:49 PM
> *To:* Petrie, Glen; Ira McDonald
> *Cc:* Mitchell, Andrew (Solutions Architect); [email-masked];
> Michael Sweet; [email-masked]
>
> *Subject:* Re: [IPP] "print-color-mode" or "imaging-color-mode"?
>
>
>
> Hi,
>

---

From: Michael Sweet <[email-masked]>
Date: Tue, 19 Apr 2011 14:16:11 -0700

Given that we have another attribute for scan (ColorEntry) that has slightly different semantics than print-color-mode, I'm thinking we should keep the print attribute named "print-color-mode".

On Apr 19, 2011, at 11:45 AM, Tom Hastings wrote:

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Ira McDonald