Subject: [IPP] IPP Agenda - 1pm EDT Monday 18 April 2011

From: Ira McDonald <[email-masked]>
Date: Sun, 17 Apr 2011 23:39:08 -0400

Hi,

Our next IPP WG call will be on Monday.

 Monday 18 April 10-11am US PST / 1-2pm US EST

 Call-in toll-free number (US/Canada): 1-866-469-3239
 Call-in toll number (US/Canada): 1-650-429-3300 (Primary)
 Call-in toll number (US/Canada): 1-408-856-9570 (Backup)

 Attendee Access Code: *******#
 Attendee ID Code: # (empty)

If you need the Attendee Access code, please email me a request.

*** Main Objective - Review IPP JPS3 and PWG Raster specs ***

Agenda:

(1) PWG IP Policy and Minute Taker
     - Mike?

(2) Approve IPP minutes from previous meeting
     - ftp://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-f2f-minutes-20110405.pdf

(3) Review IPP Job and Printer Extensions - Set 3 (JPS3) (Mike)
     -
ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext3v10-20110330-rev.pdf

(4) Review PWG Raster (Mike)
     - ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippraster10-20110327-rev.pdf

(5) Discussion of IPP Everywhere (Mike/Ira)
     - http://pwg-wiki.wikispaces.com/IPP+Everywhere
     - Review use cases from IPP/Cloud Imaging mailing lists

(6) Next Steps
     - IPP WG teleconference on Monday 2 May
     - Review IPP Scan and IPP over USB drafts
     - All - post more use cases to IPP/Cloud Imaging mailing lists

Cheers,
- Ira (IPP WG Co-Chair)

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Hardcopy WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Christmas through April:
  579 Park Place  Saline, MI  48176
  734-944-0094
May to Christmas:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 18 Apr 2011 08:54:17 -0700

Here is my expanded outline for JPS3 and PWG Raster (based on the F2F slides):
IP Policy and Minute Taker
Policy accepted with Mike taking the minutes
Approve IPP minutes from last meeting
ftp://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-f2f-minutes-20110405.pdf
JPS3 Review
ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext3v10-20110330-rev.pdf
Issue: How should we express an unknown printer-geo-location?
Issue: Need well-known URIs for standard colorspace profiles
Issue: How do we register media-col member attributes with IANA?
Issue: Need to flesh out the conformance requirements for the printer-supply attribute
PWG Raster Review
ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippraster10-20110327-rev.pdf
Issue: Would be nice to have total page count (if known)
Proposal: Add PageCount (integer, 0 to 2^31-1) to page header ("cupsInteger[0]" from CUPS Raster), which is already used by several CUPS Raster printer drivers
0 means "I don't know how many pages"
> 0 means "this is how many pages are in the entire document"
Every page gets the same value
Issue: Need coordinate space of image (flip/rotate on back side)
Proposal: Add HorizontalTransform(integer, -1 or 1) and VerticalTransform(integer, -1 or 1) to the page header (“cupsInteger[1]” and “cupsInteger[2]” from CUPS Raster)
“Normal” pages have values of 1 and 1
“Rotated” pages have values of -1 and -1 (180 degree rotation)
“Flipped” pages have values of 1 and -1 (vertical flip) or -1 and 1 (horizontal flip)
Issue: Need bounding rectangle of any content to be imaged on the page (ImageBox)
Proposal 1: • Use existing ImagingBBox (4 x integer) from page header - simple bounding box in (integer) points
Proposal 2: Add ImageBottom (integer, 0-2^32-1), ImageLeft (integer, 0-2^32-1), ImageRight (integer, 0-2^32-1), and ImageTop (integer, 0-2^32-1) to the page header (“cupsInteger[3]” through “cupsInteger[6]” from CUPS Raster) - simple bounding box in pixels/lines
Issue: Some confusion about why we need pwg-raster-resolutions-support
Will be adding explanatory text to the definition
Basically supported raster resolutions can be different than supported hardware resolutions
Issue: Some confusion about the compression algorithm
Will be adding examples for 1-bit grayscale and 32-bit CMYK images to clarify
Also have sample raster files available for download
Samples files:
Currently at http://ftp.easysw.com/pub/cups/examples/PWGRasterSamples.zip
40MB download, 80MB worth of data
150dpi files for black-1, cmyk-8, sgray-8, sgray-16, srgb-8, and srgb-16
Representative documents for email, line art, maps, photos, and web pages
Issue: Where to place sample raster files?
On Apr 17, 2011, at 8:39 PM, Ira McDonald wrote:

>      - ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext3v10-20110330-rev.pdf
> 

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair