Subject: [IPP] Re: PWG Raster comtinue

From: Michael Sweet <[email-masked]>
Date: Tue, 17 May 2011 20:40:55 -0700

[Realized I hadn't responded to this one...]

On Apr 26, 2011, at 4:05 PM, Petrie, Glen wrote:
> Mike,
>  
> We still seem to differ on the adding page number and flip/orientation.   I hope we agree on adding the driver data fields to the PWG Raster.
>  
> An unusual request:  I would like to understand better the need for flip/orientation in a raster.    Since I do not know who or what company may have requested the flip/orientation data, would it be possible for you to send an email to the individuals who requested the flip/orientation asking if they can state why they need the data and why they are not expecting the raster to be in the correct flip/orientation that the printer would need to print the specified print job.

Glen, *I* added this because support for flip/rotate for duplex printing has been in CUPS for about 12 years now. I have used it for CUPS Raster drivers for that length of time in order to support shipping printers (back then a bunch of HP DeskJet printers) that didn't have enough memory to cache two sides of raster data and "do the right thing".

The printer tells the client what to do for the back side images of duplex raster jobs, and the proposed additions to the page header allow the client to tell the printer what it generated. The printer can ignore it, error out (if the values are wrong), or fix it (again, if the values are wrong) as desired.

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Tue, 17 May 2011 20:44:58 -0700

[Again, haven't been keeping up with my email...]

On Apr 27, 2011, at 7:43 AM, Petrie, Glen wrote:
> After thinking on it I decided I should explain in more detail my objection to flip/orientation specification in the raster in more detail.
>  
> All printers should be able to consume (PWG) Raster but it more likely that most mid and higher end printer will consume PDF.  It is also more likely that it will be lower end printers, those with limited resources, which will directly consume (PWG) Raster.  Since by definition they have limited resources it would be burden to have these printers perform flip/orientation transforms that require very large buffers that would basically have to hold an entire page worth of raster data.

That's why the header fields just tell the printer what transform was used by the client when they generated the image. The printer doesn't have to do anything with it - see my prior reply about this subject.

I'll add some more explanatory text and examples to make this clearer. In the end, the transform fields would just be a check for the printer to know that it has what it needs. The printer doesn't have to support re-transforming the raster data - that would go against the primary goal of PWG Raster to support streaming.