Subject: [IPP] Comment on JPS3

From: "Zehler, Peter" <[email-masked]>
Date: Mon, 9 May 2011 04:01:42 -0700

All,

I do not see why printer-mandatory-job-attributes is needed.  (It
doesn't even make sense to me.)  I was under the impression that all the
attributes required to be supplied by the client in order to create a
job in IPP are mandatory.  Any remaining attributes are taken from
printer defaults or supplied by the system.  What did I miss?

Pete

Peter Zehler

Xerox Research Center Webster
Email: [email-masked] <mailto:[email-masked]> 
Voice: (585) 265-8755
FAX: (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701 

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 09 May 2011 08:36:57 -0700

On May 9, 2011, at 4:01 AM, Zehler, Peter wrote:
> All,
> I do not see why printer-mandatory-job-attributes is needed.  (It doesn’t even make sense to me.)  I was under the impression that all the attributes required to be supplied by the client in order to create a job in IPP are mandatory.  Any remaining attributes are taken from printer defaults or supplied by the system.  What did I miss?

The reasoning was that we needed an attribute to tell the client which attributes were required for a successful print job, particularly for attributes *without* default values (e.g. job-accounting-user-id, etc.) that might be used for the paid print scenario.

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair