Subject: [IPP] Media Standard Document

From: "Petrie, Glen" <[email-masked]>
Date: Fri, 5 Aug 2011 15:58:21 -0700

Media Types;

cardstock => card-stock 

            [ I have only seen it as two words not one.]

hagaki => drop from list

            [ I talked with people in Japan and they only consider this
a size.  Hagaki literally means "postcard".  There a different type,
photo, plain, etc. but these would be handled by existing media types. ]

glen

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Fri, 5 Aug 2011 23:50:14 -0400

Hi Glen,

IPP keywords cannot have embedded dashes, so
"card-stock" doesn't work.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - IEEE-ISTO PWG IPP WG
Chair - TCG Embedded Systems Hardcopy SWG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Christmas through April:
  579 Park Place  Saline, MI  48176
  734-944-0094
May to Christmas:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

On Fri, Aug 5, 2011 at 6:58 PM, Petrie, Glen <[email-masked]>wrote:

> ** **
>
> Media Types;****
>
> ** **
>
> cardstock => card-stock ****
>
>             [ I have only seen it as two words not one.]****
>
> ** **
>
> hagaki => drop from list****
>
>             [ I talked with people in ****Japan**** and they only consider
> this a size.  Hagaki literally means “postcard”.  There a different type,
> photo, plain, etc. but these would be handled by existing media types. ]**
> **
>
> ** **
>
> glen****
>
> ** **
>
>  ****
>
> --
> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
> believed to be clean.
>

---

From: Michael Sweet <[email-masked]>
Date: Fri, 05 Aug 2011 21:03:34 -0700

Ira,

IPP keywords can indeed have embedded dashes, and many existing media types already do...

Glen,

I'm OK with your proposed changes.

On Aug 5, 2011, at 8:50 PM, Ira McDonald wrote:

> On Fri, Aug 5, 2011 at 6:58 PM, Petrie, Glen <[email-masked]> wrote:
> Media Types;
> 
>  
> 
> cardstock => card-stock
> 
>             [ I talked with people in Japan and they only consider this a size.  Hagaki literally means “postcard”.  There a different type, photo, plain, etc. but these would be handled by existing media types. ]
> 
>  
> 
> glen
> 
>  
> 
>  
> 
> 
> -- 
> believed to be clean. _______________________________________________
> ipp mailing list
> [email-masked]

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: "Zehler, Peter" <[email-masked]>
Date: Mon, 8 Aug 2011 04:39:09 -0700

Ira,

There was a time when certain WSDL/SOAP code generators had an issue
with the embedded dash.  I don't recall if the issue was only with
element names or element names and values.  I would expect those tools
to be fixed by now.  And as Glen stated there are already many
occurrences in MediaType as well as Media, Charset, DocumentFormat,
OperatingSystemName, OutputBin and the extensions patterns.

Pete

Peter Zehler

Xerox Research Center Webster
Email: [email-masked]
Voice: (585) 265-8755
FAX: (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701 

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Michael Sweet
Sent: Saturday, August 06, 2011 12:04 AM
To: Ira McDonald
Cc: [email-masked]
Subject: Re: [IPP] Media Standard Document

Ira,

IPP keywords can indeed have embedded dashes, and many existing media
types already do...

Glen,

Hi Glen,

Cheers,
- Ira

<http://sites.google.com/site/highnorthinc> 

On Fri, Aug 5, 2011 at 6:58 PM, Petrie, Glen
<[email-masked]> wrote:

Media Types;

cardstock => card-stock 

hagaki => drop from list

glen

-- 
This message has been scanned for viruses and 
dangerous content by MailScanner <http://www.mailscanner.info/> , and is

believed to be clean. 

-- 
This message has been scanned for viruses and 
dangerous content by MailScanner <http://www.mailscanner.info/> , and is

-- 
This message has been scanned for viruses and 
dangerous content by MailScanner <http://www.mailscanner.info/> , and is

believed to be clean.

---

From: Michael Sweet <[email-masked]>
Date: Mon, 29 Aug 2011 09:29:24 -0700

Glen,

After going through the existing IANA registration list for media-type, we already have "cardstock" (one word) from PWG 5100.3...

Something to discuss at the IPP telecon...

---

From: "Petrie, Glen" <[email-masked]>
Date: Mon, 29 Aug 2011 09:30:40 -0700

Ok, lets not change the existing IANA value

________________________________

From: Michael Sweet [mailto:[email-masked]] 
Sent: Monday, August 29, 2011 9:29 AM
To: Petrie, Glen
Cc: [email-masked]
Subject: Re: [IPP] Media Standard Document

Glen,

After going through the existing IANA registration list for media-type,
we already have "cardstock" (one word) from PWG 5100.3...

Media Types;

cardstock => card-stock 

hagaki => drop from list

glen

believed to be clean.