Subject: [IPP] job-originating-user-uri Where is it defined?

From: "Zehler, Peter" <[email-masked]>
Date: Thu, 11 Aug 2011 09:09:39 -0700

All,

I have looked around to see if job-originating-user-uri is in some PWG
specification. The  job-originating-user-uri  is the URI of the User
originating the Job.  Does anyone know where this is defined?  If it is
not defined anyplace in an existing specification, will it be added to
JPS3?  If not, should it be deleted from the Semantic Model?

Pete

Peter Zehler

Xerox Research Center Webster
Email: [email-masked] <mailto:[email-masked]> 
Voice: (585) 265-8755
FAX: (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701 

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Thu, 11 Aug 2011 11:54:23 -0700

On Aug 11, 2011, at 9:09 AM, Zehler, Peter wrote:
> All,
>  
> I have looked around to see if job-originating-user-uri is in some PWG specification. The  job-originating-user-uri  is the URI of the User originating the Job.  Does anyone know where this is defined?  If it is not defined anyplace in an existing specification, will it be added to JPS3?  If not, should it be deleted from the Semantic Model?

Just checked the registry and don't see it listed. I'm happy to add it to JPS3 if you can supply a definition for me to use... :)

__________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Ira McDonald <[email-masked]>
Date: Thu, 11 Aug 2011 15:11:14 -0400

Hi Pete,

JobOriginatingUserURI is defined in MFD Model in Table 47 and
Table 66 - the IETF/PWG reference column is blank.

Yes, it should be added to JPS3,

We also need an IPP definition for JobSenderURI (the remote host's
URI for Fax, Email, etc.) - this could also be used for the remote dumb
client's URI (for LPR, Port 9100, etc.) - for IPP, the JobSenderURI
would be defined to be synonymous with JobOriginatingUserURI
- right?

Cheers,
- Ira

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - IEEE-ISTO PWG IPP WG
Chair - TCG Embedded Systems Hardcopy SWG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Christmas through April:
  579 Park Place  Saline, MI  48176
  734-944-0094
May to Christmas:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

On Thu, Aug 11, 2011 at 12:09 PM, Zehler, Peter <[email-masked]>wrote:

> All,****
> ** **
> originating the Job.  Does anyone know where this is defined?  If it is not
> defined anyplace in an existing specification, will it be added to JPS3?  If
> not, should it be deleted from the Semantic Model?****
>
> ** **
>
> Pete****
>
> ** **
>
> ** **
>
> Peter Zehler
>
> Email: [email-masked]
> Voice: (585) 265-8755
> FAX: (585) 265-7441
> US Mail: Peter Zehler
> Xerox Corp.
> 800 Phillips Rd.
> M/S 128-25E
> Webster NY, 14580-9701 ****
>
> ** **
>
> --
> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
> believed to be clean.
>

---

From: Michael Sweet <[email-masked]>
Date: Thu, 11 Aug 2011 12:51:16 -0700

> Yes, it should be added to JPS3, 

Here is my proposed text for JPS3 based on the description in MFD Common:

[operation attributes]

requesting-user-uri (uri)

This RECOMMENDED attribute contains the URI of the end user that is submitting the job or subscription creation request.

[job description attributes]

job-originating-user-uri (uri)

This RECOMMENDED attribute contains the URI of the end user that submitted the job creation request.  The Printer object sets this attribute to the most authenticated URI that it can obtain from the authentication service over which the IPP operation was received. Only if such is not available, does the Printer object use the value supplied by the client in the "requesting-user-uri" operation attribute of the create operation (see Sections 4.4.2, 4.4.3, and 8 of RFC 2911).

[subscription description attributes]

notify-subscriber-user-uri (uri)

This RECOMMENDED attribute contains the URI of the end user that submitted the subscription creation request.  The Printer object sets this attribute to the most authenticated URI that it can obtain from the authentication service over which the IPP operation was received. Only if such is not available, does the Printer object use the value supplied by the client in the "requesting-user-uri" operation attribute of the create operation (see Sections 4.4.2, 4.4.3, and 8 of RFC 2911).

> would be defined to be synonymous with JobOriginatingUserURI

Where is JobSenderUri defined? I'm not seeing it in the schema or any of the MFD/SM documents?

---

From: Ira McDonald <[email-masked]>
Date: Thu, 11 Aug 2011 13:20:29 -0700

Hi Mike,

JobSenderURI is in your notes from FaxIn review last week.  It's needed
for FaxInMetrics to allow selection from AvailableJobTickets based on
the remote phone number (PSTN) or email address (Internet Fax) of the
incoming Fax.  This is not the same as RequestingUser, because there's
no in-band RequestingUser.

The lack of JobSenderURI is one of the current list of todo's for the
updated MFD Model (because it will apply to EmailIn as well).

In the near term, it will be defined in my next draft of FaxIn.

For pure IPP Print, it's not necessary.  For future IPP FaxIn, it's needed.

Cheers,
- Ira

On Thu, Aug 11, 2011 at 12:51 PM, Michael Sweet <[email-masked]> wrote:

> This RECOMMENDED attribute contains the URI of the end user that is
> submitting the job or subscription creation request.
>
> This RECOMMENDED attribute contains the URI of the end user that submitted
> the job creation request.  The Printer object sets this attribute to the
> most authenticated URI that it can obtain from the authentication service
> over which the IPP operation was received. Only if such is not available,
> does the Printer object use the value supplied by the client in the
> "requesting-user-uri" operation attribute of the create operation (see
> Sections 4.4.2, 4.4.3, and 8 of RFC 2911).
>
> This RECOMMENDED attribute contains the URI of the end user that submitted
> the subscription creation request.  The Printer object sets this attribute
> to the most authenticated URI that it can obtain from the authentication
> service over which the IPP operation was received. Only if such is not
> available, does the Printer object use the value supplied by the client in
> the "requesting-user-uri" operation attribute of the create operation (see
> Sections 4.4.2, 4.4.3, and 8 of RFC 2911).
>