Subject: [IPP] Fwd: [IANA #480842] General Request for Assignment (ipp-registrations)

From: Ira McDonald <[email-masked]>
Date: Tue, 23 Aug 2011 18:12:33 -0400

Hi Mike,

Amanda finished our recent IANA IPP Registry request.

- 'media-material' (non-existent) is deleted
- 'media-sol' (typo) is changed to 'media-col'

Cheers,
- Ira

---------- Forwarded message ----------
From: Amanda Baber via RT <[email-masked]>
Date: Tue, Aug 23, 2011 at 5:50 PM
Subject: [IANA #480842] General Request for Assignment (ipp-registrations)
To: [email-masked]

Hi Ira,

This request is complete:

http://www.iana.org/assignments/ipp-registrations

thanks,

Amanda Baber
IANA

On Fri Aug 12 17:53:14 2011, [email-masked] wrote:
>
> Contact Name:
> Ira McDonald
>
> Contact Email:
> [email-masked]
>
> Type of Assignment:
> Permanent registration error corrections in IANA IPP Registry:
> (1) DELETE "media-material" (no such attribute)
> (2) CHANGE "media-sol" to "media-col" (spelling error)
>
> Registry:
> IANA IPP Registry
> http://www.iana.org/assignments/ipp-registrations/ipp-
> registrations.xml
>
> Description:
> Proposed: Ira McDonald (High North) and Mike Sweet (Apple)
> Reviewed: PWG Meeting during IPP WG session 4 August 2011
> Approved: 12 August 2011
> By: Ira McDonald (IETF Designated Expert for IPP Registry)
>
> Background:
> (1) When PWG 5100.5 was recently added to the IANA IPP
> Registry, Mike and I missed this error:
> PWG 5100.5 registered "media-material" as a "media-col"
> member attribute, but PWG 5100.5 did NOT define it.
> -> Please DELETE the line for "media-material"
>
> (2) When PWG 5100.5 was added, Mike and I missed this spelling error
> in Document Attributes for all the members of "media-col"
> -> Please change "media-sol" to "media-col"
>
> Additional Info:
> -> erroneous IANA registration of "media-material"
> -> erroneous spelling of "media-col" as "media-sol"
>
> PWG 5100.5 IPP Document Object
> ftp://ftp.pwg.org/pub/pwg/candidates/cs-ippdocobject10-20031031-
> 5100.5.pdf
>

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Harry Lewis <[email-masked]>
Date: Thu, 25 Aug 2011 11:36:56 -0600

... which prompted me to look... which resulted in discovery of this 
remaining minor typo

Regards,
Harry

Harry Lewis
President AFPC, AFP Architect, Program Manager IP & Standards
Phone: 720-663-3456
Email: [email-masked]
infoprint.com

Ricoh Production Print Solutions LLC

Nisi credideritis, non intelligetis 

Ira McDonald <[email-masked]> 
Sent by: [email-masked]
08/23/2011 04:16 PM

To
Michael R Sweet <[email-masked]>, Ira McDonald <[email-masked]>
cc
[email-masked]
Subject
[IPP] Fwd: [IANA #480842] General Request for Assignment 
(ipp-registrations)

Hi Mike,

Cheers,
- Ira

---------- Forwarded message ----------
From: Amanda Baber via RT <[email-masked]>
Date: Tue, Aug 23, 2011 at 5:50 PM
Subject: [IANA #480842] General Request for Assignment (ipp-registrations)
To: [email-masked]

Hi Ira,

thanks,

Amanda Baber
IANA

-- 
This message has been scanned for viruses and 
dangerous content by MailScanner, and is 
believed to be clean. _______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

_____________________________________________________________________________
"This message and any attachments are solely for the intended recipient and may contain confidential or privileged information. If you are not the intended recipient, any disclosure, copying, use, or distribution of the information included in this message and any attachments is prohibited. If you have received this communication in error, please notify us by reply e-mail and immediately and permanently delete this message and any attachments. Thank you." _____________________________________________________________________________
-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

---

From: Michael Sweet <[email-masked]>
Date: Thu, 25 Aug 2011 12:54:07 -0700

Man, did we actually make this text(127)?!? printer-device-id (from the command set spec) is text(1023)...

(oh, and Ira we need to get that attribute registered as well...)

On Aug 25, 2011, at 10:36 AM, Harry Lewis wrote:

> 
> ... which prompted me to look... which resulted in discovery of this remaining minor typo 
> 
> <Mail Attachment.gif> 
> 
> Regards, 
> Harry
> <Mail Attachment.gif>
> Harry Lewis
> [IPP] Fwd: [IANA #480842] General Request for Assignment        (ipp-registrations)
> 
> 
> 
> 
> 
> Hi Mike,
> 

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Michael Sweet <[email-masked]>
Date: Thu, 25 Aug 2011 13:14:45 -0700

Also they don't have the reference for the document object. For the "original" XML they are using:

    <record>
      <name>Document</name>
      <xref type="uri" data="ftp://ftp.pwg.org/pub/pwg/candidates/cs-ippdocobject10-20031031-5100.5.pdf">PWG5100.5</xref>
    </record>

---

From: "Zehler, Peter" <[email-masked]>
Date: Fri, 26 Aug 2011 04:30:59 -0700

The Semantic Model used a length of 1023 for DeviceId.  It is the length
in the command set spec and in WS-Print.

Peter Zehler

Xerox Research Center Webster
Email: [email-masked]
Voice: (585) 265-8755
FAX: (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701 

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Michael Sweet
Sent: Thursday, August 25, 2011 3:54 PM
To: Harry Lewis
Cc: [email-masked]
Subject: Re: [IPP] Fwd: [IANA #480842] General Request for
Assignment(ipp-registrations)

Man, did we actually make this text(127)?!? printer-device-id (from the
command set spec) is text(1023)...

<Mail Attachment.gif> 

Regards, 
Harry
<Mail Attachment.gif>

Harry Lewis
President AFPC, AFP Architect, Program Manager IP & Standards
Phone: 720-663-3456
Email: [email-masked]
infoprint.com <http://www.infoprint.com/> 

08/23/2011 04:16 PM 

To

Michael R Sweet <[email-masked]>, Ira McDonald
<[email-masked]> 

cc

[email-masked] 

Subject

		

Hi Mike,

Cheers,
- Ira

---------- Forwarded message ----------
From: Amanda Baber via RT <[email-masked]>
Date: Tue, Aug 23, 2011 at 5:50 PM
Subject: [IANA #480842] General Request for Assignment
(ipp-registrations)

Hi Ira,

thanks,

Amanda Baber
IANA

-- 
This message has been scanned for viruses and 
dangerous content by MailScanner <http://www.mailscanner.info/> , and is

________________________________________________________________________
_____
"This message and any attachments are solely for the intended recipient
and may contain confidential or privileged information. If you are not
the intended recipient, any disclosure, copying, use, or distribution of
the information included in this message and any attachments is
prohibited. If you have received this communication in error, please
notify us by reply e-mail and immediately and permanently delete this
message and any attachments. Thank you."
________________________________________________________________________
_____

-- 
This message has been scanned for viruses and 
dangerous content by MailScanner <http://www.mailscanner.info/> , and is

believed to be clean.