Subject: [IPP] Fwd: Lost IPP Color spec (from 2002)

From: Ira McDonald <[email-masked]>
Date: Mon, 15 Aug 2011 13:11:51 -0400

---------- Forwarded message ----------
From: Ira McDonald <[email-masked]>
Date: Tue, Aug 9, 2011 at 2:38 PM
Subject: Re: Thanks Ira<eom>
To: "Zehler, Peter" <[email-masked]>, Ira McDonald <
[email-masked]>

Hi Pete,

Inline.

Cheers,
- Ira

On Tue, Aug 9, 2011 at 1:24 PM, Zehler, Peter <[email-masked]>wrote:

> Ira,****
>
> We’ll have a chance to rectify that soon.  I have two unrelated questions*
> ***
>
> **1)      **Do you know what ever became of <
> ftp://ftp.pwg.org/pub/pwg/ipp/new_COLOR/pwg-ipp-color-and-imaging-v02-021205.pdf>
> ?
>
<ira> EEK!  No, I think this spec just got lost - we should share this with
Mike and the IPP folks.

According the IPP and SM mail archives, it was discussed on 5 Dec 2002
at an SM telecon - but there are NO SM minutes after 7 Nov 2002 and
before 23 January 2003 in the SM ftp minutes archive - hmm...
</ira>

> ****
>
> **2)      **Do you think the title of the PWG Print Job Ticket
> specification should be “PWG Print Job Ticket for Cloud Based Printing”?
>
<ira> No - Instead, I suggest "PWG Print Job Ticket Semantic Model"
with use case(s), design requirements, and implementation notes for
Cloud Printing (and IPP Everywhere?).
Because we don't want to keep rewriting a core SM spec for different
audiences, IMHO.
</ira>

> ****
>
> Pete****
>
> ** **
>
> ** **
>
> Peter Zehler
>
> Xerox Research Center Webster
> Email: [email-masked]
> Voice: (585) 265-8755
> FAX: (585) 265-7441
> US Mail: Peter Zehler
> Xerox Corp.
> 800 Phillips Rd.
> M/S 128-25E
> Webster NY, 14580-9701 ****
>
> ** **
>
> *From:* Ira McDonald [mailto:[email-masked]]
> *Sent:* Tuesday, August 09, 2011 12:58 PM
> *To:* Zehler, Peter; Ira McDonald
> *Subject:* Re: Thanks Ira<eom>****
>
> ** **
>
> Hi Pete,
>
> You're welcome - and thanks for the reminder yesterday.
>
> Reading Nancy's section in FaxIn 14.1 (your new FaxOut 13.1)
> about protecting the End User's data, I'm thinking that the
> Security Considerations section in MFD Model is defective
> in punting so completely about security - certainly neither
> Cloud Print nor IPP Everywhere can blithely ignore security
> requirements.
>
> Cheers,
> - Ira
>
>
> Ira McDonald (Musician / Software Architect)
> Chair - Linux Foundation Open Printing WG
> Co-Chair - IEEE-ISTO PWG IPP WG
> Chair - TCG Embedded Systems Hardcopy SWG
> IETF Designated Expert - IPP & Printer MIB
> Blue Roof Music/High North Inc
> http://sites.google.com/site/blueroofmusic
> http://sites.google.com/site/highnorthinc
> mailto:[email-masked]
> Christmas through April:
>   579 Park Place  Saline, MI  48176
>   734-944-0094
> May to Christmas:
>   PO Box 221  Grand Marais, MI 49839
>   906-494-2434****
>
>
>
> ****
>
> On Tue, Aug 9, 2011 at 12:47 PM, Zehler, Peter <[email-masked]>
> wrote:****
>
>  ****
>
>  ****
>
>  ****
>
> Peter Zehler
>
> Xerox Research Center Webster
> Email: [email-masked]
> Voice: (585) 265-8755
> FAX: (585) 265-7441
> US Mail: Peter Zehler
> Xerox Corp.
> 800 Phillips Rd.
> M/S 128-25E
> Webster NY, 14580-9701 ****
>
>  ****
>
> *From:* Ira McDonald [mailto:[email-masked]]
> *Sent:* Tuesday, August 09, 2011 12:47 PM
> *To:* Michael R Sweet; Paul Tykodi; Zehler, Peter; Ira McDonald
> *Subject:* PWG MFD FaxOut Service Formal Vote-<High
> North>-<McDonald>-<Yes>****
>
>  ****
>
> Hi,                                              Tuesday (9 August 2011)
>
> Based on the FaxIn review at last week's PWG meeting, High North votes
> YES with the following editorial comments:
>
> Cheers,
> - Ira
>
> ------------------------------------------------------------------------
>             [Comments on "wd-mfdfaxoutmodel10-20110705.pdf"]
>
> Line 242-244 - inaccurate out-of-scope
> - per FaxIn review - change section 4.2, item 1 to:
>   "Semantics of any compound service that creates separate Jobs for each
>   transform service or destination URI specified in the original Job."
>
>
> Line 308-311 - PSTN Fax multiple document jobs issue
> - per FaxIn review - add sentence to end of section 6, last paragraph:
>   "Note that PSTN FaxOut jobs either: (a) do not support multiple
>   documents; or (b) do not distinguish the document boundaries in the
>   FaxOut transmission."
>
> Line 386-389 - call out FaxLogURI as location of durable log
> - per FaxIn review - add sentence to end of section 6.5, last paragraph:
>   "Note that FaxLogURI specifies the location of the durable log that is
>   REQUIRED for all FaxOutService implementations (see section 7)."
>
> Line 409 - call out FaxLogURI as location of durable log
> - change "MUST be durably logged." to:
>   "MUST be durably logged to the location specified in FaxLogURI
>   (see section 6.5)."
>
> Line 509-510 - PSTN Fax multiple document jobs issue
> - per FaxIn review - insert new third sentence in section 8:
>   "Note that PSTN FaxOut jobs either: (a) do not support multiple
>   documents; or (b) do not distinguish the document boundaries in the
>   FaxOut transmission."
>
> Line 599-600 - clarity in conformance requirements
> - per FaxIn review - revised first sentence in section 10.2.1
>   - change "all of the model objects" to
>   "all of the REQUIRED model objects"
>
> Line 607-610 - PSTN Fax multiple document jobs issue
> - per FaxIn review - add sentence in section 10.2.2, last paragraph:
>   "Note that PSTN FaxOut jobs either: (a) do not support multiple
>   documents; or (b) do not distinguish the document boundaries in the
>   FaxOut transmission."
>
> Line 633-634 - protection of Fax user data issue
> - per FaxIn review - add entire section 14.1 from FaxIn as new section
>   13.1 Protection of End User's FaxOut Data, change "FaxIn" to "FaxOut"
>
> ------------------------------------------------------------------------**
> **
>
>  ****
>
> ** **
>

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 15 Aug 2011 14:30:27 -0700

Ira,

Thanks for forwarding this...

On Aug 15, 2011, at 10:11 AM, Ira McDonald wrote:
> On Tue, Aug 9, 2011 at 1:24 PM, Zehler, Peter <[email-masked]> wrote:
> Ira,
> 
> We’ll have a chance to rectify that soon.  I have two unrelated questions
> 
> 1)      Do you know what ever became of <ftp://ftp.pwg.org/pub/pwg/ipp/new_COLOR/pwg-ipp-color-and-imaging-v02-021205.pdf> ?
> 

After doing a quick scan of this document, I really don't think we want to bring it back from its shallow grave - much of the content doesn't match up with a managed color workflow. However, there are a few things we can take from it:

3.3 black-overprint
3.14 trapping

Both of these *do* have applications in prepress to deal with registration issues between separate color planes, however I haven't had registration issues on a printer in years - still needed? If we do add these to JPS3, they should be booleans.

3.12 Color rendering intent attributes

Should we fold the notion of separate rendering intents for graphics, text, and images into print-rendering-intent?

> 2)      Do you think the title of the PWG Print Job Ticket specification should be “PWG Print Job Ticket for Cloud Based Printing”?
> 

Or "PWG Semantic Model Print Job Ticket"?

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair