Subject: [IPP] ISSUE: MustHonor/job-mandatory-attributes at different levels of a JobTicket/job template

From: "Zehler, Peter" <[email-masked]>
Date: Wed, 10 Aug 2011 09:36:50 -0700

All,

While updating the PWG Semantic Model and adding some missing MustHonor
attributes I came across a bit of an issue.  I was adding MustHonor to
the elements directly under DocumentProcessing.  When I got to elements
like CoverBack and MediaCol I noticed that some of the contained
elements are also directly under DocumentProcessing (e.g. Media,
MediaType).    It seems rather inconsistent to  control fidelity for a
subset of a collection's members.

The issues comes down to which elements can be decorated with  MustHonor
and what limitations on attribute names  are made for the
job-mandatory-elements.  

My opinion is that it MustHonor should be placed on every processing
element and any job template attribute can be used in
job-mandatory-element.  I would expect that fidelity would work similar
to documents inheriting job level attributes in multi-document jobs.
The "MustHonor" attribute at a node in the tree (e.g., MediaCol) applies
to all subordinate nodes (e.g., MediaTooth) unless explicitly
overridden.  The same semantics would apply for job-mandatory-elements.

Comments?

Pete 

Peter Zehler

Xerox Research Center Webster
Email: [email-masked]
Voice: (585) 265-8755
FAX: (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701 

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Thu, 11 Aug 2011 12:26:41 -0700

On Aug 10, 2011, at 9:36 AM, Zehler, Peter wrote:
> All,
>  
> While updating the PWG Semantic Model and adding some missing MustHonor attributes I came across a bit of an issue.  I was adding MustHonor to  the elements directly under DocumentProcessing.  When I got to elements like CoverBack and MediaCol I noticed that some of the contained elements are also directly under DocumentProcessing (e.g. Media, MediaType).    It seems rather inconsistent to  control fidelity for a subset of a collection’s members.
>  
> The issues comes down to which elements can be decorated with  MustHonor and what limitations on attribute names  are made for the job-mandatory-elements.

I did some reading this morning; section 3.1.2 of PWG 5100.7 has this to say about member attributes:

The values of the “job-mandatory-attributes” attribute are the keyword attribute names that identify Job Template attributes; for example, ‘job-hold-until’, ‘job-finishings’ (see section 4.1.3.3), ‘copies’ and ‘media’. In order to identify a member attribute of a collection attribute, the keyword names of both the collection attribute and the member attribute are given separated by a period (.) character. For example, to make the “media” attribute of the “cover- front” collection attribute mandatory, supply the keyword value: ‘cover-front.media’. 

So it seems that the current IPP definition does, in fact, allow a client to make only certain member attributes mandatory in a collection. Thus if you specified "media-col" by itself then all member attributes in the collection are required while "media-col.media-size" would only make the size a mandatory element.

> My opinion is that it MustHonor should be placed on every processing element and any job template attribute can be used in job-mandatory-element.  I would expect that fidelity would work similar to documents inheriting job level attributes in multi-document jobs.  The “MustHonor” attribute at a node in the tree (e.g., MediaCol) applies to all subordinate nodes (e.g., MediaTooth) unless explicitly overridden.  The same semantics would apply for job-mandatory-elements.

I believe that is ultimately what the current IPP definition says, now that I've re-read it.

__________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair