Subject: [IPP] printer-input-tray and printer-output-tray proposals posted to wiki...

From: Michael Sweet <[email-masked]>
Date: Tue, 29 Nov 2011 17:21:00 -0800

All,

I have posted Ira's proposals for printer-input-tray and printer-output-tray to:

	http://pwg-wiki.wikispaces.com/printer-input-tray
	http://pwg-wiki.wikispaces.com/printer-output-tray

For discussion at the F2F...

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Zehler, Peter" <[email-masked]>
Date: Wed, 30 Nov 2011 04:55:37 -0800

All,
I added the SM keywords to wiki tables.  (You can always delete it in
the official specification.)  Found a couple missing elements and some
possible modeling issues with Feed & XFeed sizes.  Now that the model
has MediaSize (XDimension and YDimension) perhaps that should be used
instead of MediaSizeName in the SM mapping for the MIB.  It would line
up better with the proposed IPP mapping as well.
Pete

Peter Zehler

Xerox Research Center Webster
Email: [email-masked]
Voice: (585) 265-8755
FAX: (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Michael Sweet
Sent: Tuesday, November 29, 2011 8:21 PM
To: [email-masked]
Subject: [IPP] printer-input-tray and printer-output-tray proposals
postedto wiki...

All,

I have posted Ira's proposals for printer-input-tray and
printer-output-tray to:

--
This message has been scanned for viruses and dangerous content by
MailScanner, and is believed to be clean.

---

From: Ira McDonald <[email-masked]>
Date: Wed, 30 Nov 2011 08:03:52 -0500

Hi Pete,

There are *lots* of missing elements in these
input and output trays - on purpose - as I said
when I posted them, they follow the WIMS/CIM
mapping rank table from 2006 - low priority
elements were all *intentionally* omitted.

Whereas in the CIM classes, the mapping is
complete - but the CIM Profile would use the
same ranking for conformance (i.e., only
priority 1's would ever be considered for a
REQUIRED in the CIM Profile).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - TCG Embedded Systems Hardcopy SG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

---

From: "Zehler, Peter" <[email-masked]>
Date: Wed, 30 Nov 2011 06:08:11 -0800

Ira,

The missing elements I referred to were SM Schema elements.  It seems to
me the subset of Input Tray/Output Bin elements selected for the IPP
view should also be covered in the PWG SM Schema.

Pete 

Peter Zehler

From: Ira McDonald [mailto:[email-masked]] 
Sent: Wednesday, November 30, 2011 8:04 AM
To: Zehler, Peter; Ira McDonald
Cc: Michael Sweet; [email-masked]
Subject: Re: [IPP] printer-input-tray and printer-output-tray proposals
postedto wiki...

Hi Pete,

Cheers,
- Ira

<http://sites.google.com/site/blueroofmusic> 
<http://sites.google.com/site/highnorthinc> 

On Wed, Nov 30, 2011 at 7:55 AM, Zehler, Peter <[email-masked]>
wrote:

All,

Peter Zehler

Xerox Research Center Webster
Email: [email-masked]
Voice: (585) 265-8755 <tel:%28585%29%20265-8755> 
FAX: (585) 265-7441 <tel:%28585%29%20265-7441> 
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701

-----Original Message-----

All,

---

From: Ira McDonald <[email-masked]>
Date: Wed, 30 Nov 2011 10:01:44 -0500

Hi Pete,

My mistake.

I *thought* the SM schema elements for input/output trays
were 100% coverage - I originally derived the Subunits.xsd
by machine-translation from Printer MIB during WIMS effort.

So I'm curious specifically what got left out and how it maps
to the WIMS/CIM ranking table?

Cheers,
- Ira

On Wed, Nov 30, 2011 at 9:08 AM, Zehler, Peter <[email-masked]>wrote:

> Ira,****
> me the subset of Input Tray/Output Bin elements selected for the IPP view
> should also be covered in the PWG SM Schema.****
>
> Pete ****
>
> ** **
>
> ** **
>
> Peter Zehler
>
> Webster NY, 14580-9701 ****
>
> ** **
>
> *From:* Ira McDonald [mailto:[email-masked]]
> *Sent:* Wednesday, November 30, 2011 8:04 AM
> *To:* Zehler, Peter; Ira McDonald
> *Cc:* Michael Sweet; [email-masked]
> *Subject:* Re: [IPP] printer-input-tray and printer-output-tray proposals
> postedto wiki...****
>
> ** **
>
> Hi Pete,
>
> Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434****
>
>
>
> ****
>
> wrote:****
> Webster NY, 14580-9701****
>
>
> https://www.pwg.org/mailman/listinfo/ipp****
>
> ** **
>