Subject: [IPP] media-size unit problem in rfc3382

From: "Zehler, Peter" <[email-masked]>
Date: Tue, 8 Nov 2011 04:31:30 -0800

All,

The units for media-size in rfc3382 are incorrect.  The examples in
rfc3382 are inconsistent.  It is my understanding that current
implementations from multiple vendors use hundredth of a millimeter.

Rfc3382:

3.1  4a - example is in mm

5.1.2.1 - defines units as inches

5.1.2.2 - defines units as inches

7.2 - example in inches

Appendix A - example in inches

Appendix B - example in inches

PWG5100.3:

3.13.8.1 - defines units as hundredths of a millimeter

3.13.8.1 - defines units as hundredths of a millimeter

3.13.8.3.1 - defines units as hundredths of a millimeter

3.13.8.3.2 - defines units as hundredths of a millimeter

PWG5105.1:

7.1 - defines units as hundredths of a millimeter (references 5100.3)

PWG5108.1:

4.3.1 - does not call out unit but references 5100.3

5.2.1 - defines units as hundredths of a millimeter (references 5100.3)

 

Peter Zehler

Xerox Research Center Webster
Email: [email-masked] <mailto:[email-masked]> 
Voice: (585) 265-8755
FAX: (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701 

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Tue, 08 Nov 2011 08:34:52 -0800

Pete,

The media-col definition in 3382 was informative and never registered.

(and yes this is confusing)

On Nov 8, 2011, at 4:31 AM, Zehler, Peter wrote:

> All,
> The units for media-size in rfc3382 are incorrect.  The examples in rfc3382 are inconsistent.  It is my understanding that current implementations from multiple vendors use hundredth of a millimeter.
>  
> Rfc3382:
> 3.1  4a – example is in mm
> 5.1.2.1 – defines units as inches
> 7.2 – example in inches
> Appendix A – example in inches
> Appendix B – example in inches
>  
> PWG5100.3:
> 4.3.1 – does not call out unit but references 5100.3
> Email: [email-masked]
> Voice: (585) 265-8755
> FAX: (585) 265-7441
> US Mail: Peter Zehler
> Xerox Corp.
> 800 Phillips Rd.
> M/S 128-25E
> Webster NY, 14580-9701
>  
> 
> -- 
> believed to be clean. _______________________________________________
> ipp mailing list
> [email-masked]

__________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: "Zehler, Peter" <[email-masked]>
Date: Tue, 8 Nov 2011 08:48:24 -0800

Mike,

I know it's confusing; it confused some people here.  One thing, other
than the inconsistent differences, that contributed to their confusion
was that RFC3382 was publish in September of 2002 and PWG5100.3 was
published in February of 2001.  Their initial assumption was that newer
spec should be correct.  They did not read the fine print in section 5
that indicates the definitions are informative.  Furthermore there is no
reference, normative or informative, that points to the official
definition.

I'd like to see the 6 mistakes in rfc3382 corrected.  It might also be a
good idea to include at least an informative reference to PWG5100.3.

Pete

Peter Zehler

From: Michael Sweet [mailto:[email-masked]] 
Sent: Tuesday, November 08, 2011 11:26 AM
To: Zehler, Peter
Subject: Re: [IPP] media-size unit problem in rfc3382

Pete,

All,

Rfc3382:

7.2 - example in inches

PWG5100.3:

PWG5105.1:

PWG5108.1:

 

Peter Zehler

-- 
This message has been scanned for viruses and 
dangerous content by MailScanner <http://www.mailscanner.info/> , and is

believed to be clean. _______________________________________________
ipp mailing list
[email-masked] <mailto:[email-masked]> 
https://www.pwg.org/mailman/listinfo/ipp
<https://www.pwg.org/mailman/listinfo/ipp>

---

From: Michael R Sweet <[email-masked]>
Date: Tue, 08 Nov 2011 09:17:58 -0800

Pete,

I'll post an errata for 3382.

Sent from my iPhone

On Nov 8, 2011, at 8:48 AM, "Zehler, Peter" <[email-masked]> wrote:

> Mike,
>  
> I know it’s confusing; it confused some people here.  One thing, other than the inconsistent differences, that contributed to their confusion was that RFC3382 was publish in September of 2002 and PWG5100.3 was published in February of 2001.  Their initial assumption was that newer spec should be correct.  They did not read the fine print in section 5 that indicates the definitions are informative.  Furthermore there is no reference, normative or informative, that points to the official definition.
>  
> I’d like to see the 6 mistakes in rfc3382 corrected.  It might also be a good idea to include at least an informative reference to PWG5100.3.
>  
> Pete
>  
>  
> Peter Zehler
>

---

From: Ira McDonald <[email-masked]>
Date: Tue, 8 Nov 2011 12:41:59 -0500

Hi,

Thanks Mike!

RFC 3382 was simply one of the many IPP RFCs delayed in IETF process.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - TCG Embedded Systems Hardcopy SG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, Nov 8, 2011 at 12:17 PM, Michael R Sweet <[email-masked]> wrote:

> Mike,****
> ** **
> I know it’s confusing; it confused some people here.  One thing, other
> than the inconsistent differences, that contributed to their confusion was
> that RFC3382 was publish in September of 2002 and PWG5100.3 was published
> in February of 2001.  Their initial assumption was that newer spec should
> be correct.  They did not read the fine print in section 5 that indicates
> the definitions are informative.  Furthermore there is no reference,
> normative or informative, that points to the official definition.****
>
> ** **
>
> I’d like to see the 6 mistakes in rfc3382 corrected.  It might also be a
> good idea to include at least an informative reference to PWG5100.3.****
>
> ** **
>
> Pete****
>
> ** **
>
> ** **
>
> Peter Zehler
>
> Webster NY, 14580-9701 ****
>
> ** **
>
> *From:* Michael Sweet [mailto:[email-masked]]
> *Sent:* Tuesday, November 08, 2011 11:26 AM
> *To:* Zehler, Peter
> *Subject:* Re: [IPP] media-size unit problem in rfc3382****
>
> ** **
>
> Pete,****
>
> ** **
>
> The media-col definition in 3382 was informative and never registered.****
>
> ** **
>
> (and yes this is confusing)****
>
> ** **
>
> On Nov 8, 2011, at 4:31 AM, Zehler, Peter wrote:****
>
>
>
> ****
>
> All,****
>
> implementations from multiple vendors use hundredth of a millimeter.****
>
>  ****
>
> Rfc3382:****
>
> 3.1  4a – example is in mm****
>
> 5.1.2.1 – defines units as inches****
>
> 5.1.2.2 - defines units as inches****
>
> 7.2 – example in inches****
>
> Appendix A – example in inches****
>
> Appendix B – example in inches****
>
>  ****
>
> PWG5100.3:****
>
> 3.13.8.1 - defines units as hundredths of a millimeter****
>
> 3.13.8.1 - defines units as hundredths of a millimeter****
>
> 3.13.8.3.1 - defines units as hundredths of a millimeter****
>
> 3.13.8.3.2 - defines units as hundredths of a millimeter****
>
>  ****
>
> PWG5105.1:****
>
> 7.1 - defines units as hundredths of a millimeter (references 5100.3)****
>
>  ****
>
> PWG5108.1:****
>
> 4.3.1 – does not call out unit but references 5100.3****
>
> 5.2.1 - defines units as hundredths of a millimeter (references 5100.3)***
> *
>
>  ****
>
>  ****
>
>  ****
>
>  ****
>
> Peter Zehler
>
> Webster NY, 14580-9701****
>
>  ****
>
>
> --
> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
> https://www.pwg.org/mailman/listinfo/ipp****
>
> ** **
>
> __________________________________________________****
>
> Michael Sweet, Senior Printing System Engineer, PWG Chair****
>
> ** **
>
>
> --
> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
> believed to be clean.
>

---

From: Michael Sweet <[email-masked]>
Date: Thu, 10 Nov 2011 22:57:37 -0800

All,

I have submitted a boatload of errata for 3382 to fix all of the spots where the wrong units were used and to add a normative reference to PWG 5100.3.

On Nov 8, 2011, at 3:29 PM, Tom Hastings wrote:

> I agree that it would be good to fix RFC 3382 to use the same 100th of mm units that are used in other IETF Recommendations and PWG standards for media sizes. 
>  
> But to understand how this happened, RFC 3382 was written many years before other standards in order to define how the ‘collection’ data type could be used to define attributes.  Because it was an RFC, it had to go through the lengthy IETF process (much longer than the PWG standards process), so it was published after the other PWG standards that defined attributes with media size units for the first time using the 100th of mm units.  The idea we had in writing up the “media-col” example in RFC 3382, was to show how the ‘collection’ data type “could” be used.  That is why we used the subjunctive (“might”) for the description of the “media-size-supported” (1setOf collection) attribute:
>  
>          For example, "media-size-supported" might have the values {{x-
>          dimension:210, y-dimension:297},{x-dimension:297, y-
>          dimension:420}} to show that it supports two values of "media
>          size": A4 (210x297) and A3 (297x420).  It does not support
>          other combinations of "x-dimension" and "y-dimension" member
>          attributes, such as 210x420 or 297x297, and it does not support
>          non-enumerated values, such as 420x595.
>  
> Tom
>  
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Zehler, Peter
> Sent: November 08, 2011 08:48
> To: Michael Sweet
> Cc: [email-masked]
> Subject: RE: [IPP] media-size unit problem in rfc3382
>  
> Mike,
>