Subject: RE: [IPP] Update to the update for JPS3...

From: "Zehler, Peter" <[email-masked]>
Date: Tue, 29 Nov 2011 08:35:26 -0800

All,

I'd prefer to have all the Dublin Core elements and terms (that's
keywords to us). Dublin Core has two namespaces
<http://purl.org/dc/elements/1.1/>  and <http://purl.org/dc/terms/>. The
namespace <http://purl.org/dc/elements/1.1/> maps to RFC5013 and the
namespace <http://purl.org/dc/terms/> maps to
<http://dublincore.org/documents/dcmi-terms/> .  The "DCMI Metadata
Terms" specification at  <http://dublincore.org/documents/dcmi-terms/>
contains all the term names and definitions.

I'd either like to change the dc-keyword definition to:

dc-keyword = "title" / "creator" / "subject" /

             "description" / "publisher" / "contributor" /

             "date" / "type" / "format" / "identifier" /

             "source" / "language" / "relation" /

             "coverage" / "rights" / "alternative" /

             "tableOfContents" / "abstract" / "created" /

             "valid" / "available" / "issued" / "modified" /

             "dateAccepted" / "dateCopyrighted" / "dateSubmitted" /

             "extent" / "medium" / "isVersionOf" / "hasVersion" /

             "isReplacedBy" / "replaces" / "isRequiredBy" /

             "requires" / "isPartOf" / "hasPart" /

             "isReferencedBy" / "references" / "isFormatOf" /

             "hasFormat" / "conformsTo" / "spatial" /

             "temporal" / "audience" / "accrualMethod" /

             "accrualPeriodicity" / "accrualPolicy" /

             "instructionalMethod" / "provenance" /

             "rightsHolder" / "mediator" / "educationLevel" /

             "accessRights" / "license" / "bibliographicCitation"

Or keep the elements and terms separate and change the definition to:

(Note: terms actually contains all elements but I deleted them to
delineate RFC5013 keyword subset.)

document-dc-metadata = dc-elements "=" *utf8-char / 

                       dc-terms "=" *utf8-char /

                       x-keyword "=" *utf8-char

dc-elements = "contributor" / "coverage" / "creator" /

             "date" / "description" / "format" /

             "identifier" / "language" / "publisher" /

             "relation" / "rights" / "source" /

             "subject" / "title" / "type"

dc-terms =   "alternative" / "tableOfContents" /

             "abstract" / "created" / "valid" / "available" /

             "issued" / "modified" / "dateAccepted" /

             "dateCopyrighted" / "dateSubmitted" /

             "extent" / "medium" / "isVersionOf" / "hasVersion" /

             "isReplacedBy" / "replaces" / "isRequiredBy" /

             "requires" / "isPartOf" / "hasPart" /

             "isReferencedBy" / "references" / "isFormatOf" /

             "hasFormat" / "conformsTo" / "spatial" /

             "temporal" / "audience" / "accrualMethod" /

             "accrualPeriodicity" / "accrualPolicy" /

             "instructionalMethod" / "provenance" /

             "rightsHolder" / "mediator" / "educationLevel" /

             "accessRights" / "license" / "bibliographicCitation"

x-keyword  = "x-" 1*(ALPHA / DIGIT / "." / "-" / "_")

utf8-char  = %x20-7E /

             %xC0-DF.80-BF /

             %xE0-EF.80-BF.80-BF /

             %xF0-F7.80-BF.80-BF.80-BF

Peter Zehler

Xerox Research Center Webster
Email: [email-masked] <mailto:[email-masked]> 
Voice: (585) 265-8755
FAX: (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701 

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Michael Sweet
Sent: Monday, November 28, 2011 6:09 PM
To: [email-masked]
Subject: [IPP] Update to the update for JPS3...

All,

I have posted yet another update to JPS to:

ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext3v10-20111128.docx

ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext3v10-20111128.pdf

ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext3v10-20111128-rev.pd
f

The only changes are to add document-dc-metadata and the associated
semantic support.

________________________________________________________________________

Michael Sweet, Senior Printing System Engineer, PWG Chair

-- 
This message has been scanned for viruses and 
dangerous content by MailScanner <http://www.mailscanner.info/> , and is

believed to be clean. 

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Tue, 29 Nov 2011 09:37:14 -0800

Pete,

I like the second form and will update JPS3 accordingly.

On Nov 29, 2011, at 8:35 AM, Zehler, Peter wrote:

> All,
>  
> I’d prefer to have all the Dublin Core elements and terms (that’s keywords to us). Dublin Core has two namespaces <http://purl.org/dc/elements/1.1/>  and <http://purl.org/dc/terms/>. The namespace <http://purl.org/dc/elements/1.1/> maps to RFC5013 and the namespace <http://purl.org/dc/terms/> maps to <http://dublincore.org/documents/dcmi-terms/> .  The “DCMI Metadata Terms” specification at  <http://dublincore.org/documents/dcmi-terms/> contains all the term names and definitions.
>  
> I’d either like to change the dc-keyword definition to:
> (Note: terms actually contains all elements but I deleted them to delineate RFC5013 keyword subset.)
>  
> Email: [email-masked]
> Voice: (585) 265-8755
> FAX: (585) 265-7441
> US Mail: Peter Zehler
> Xerox Corp.
> 800 Phillips Rd.
> M/S 128-25E
> Webster NY, 14580-9701
>  
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael Sweet
>             ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext3v10-20111128-rev.pdf
>  
> The only changes are to add document-dc-metadata and the associated semantic support.
>  

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair