Subject: [IPP] RFC 5013 - 15 simple DC elements

From: Ira McDonald <[email-masked]>
Date: Mon, 28 Nov 2011 14:40:54 -0500

Hi Pete and Mike,

I suggest that, since the IETF seems to heavily rely on this one, we just
take
the plain keyword names for the 15 DC v1.1 elements defined in RFC 5013
and say they're what goes into values of a new single IPP attribute:

  document-dc-metadata (1setOf (octetString (MAX))

where each value is:

  keyword=value (utf-8 string)

Note that no paths or qualifiers are needed - the elements are
free-standing.
RFC 5013 is technically equivalent to DCMI v1.1 and the XML schema.

WDYT?

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - TCG Embedded Systems Hardcopy SG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 28 Nov 2011 13:36:42 -0800

Ira,

That works for me, and if you like I can add this to JPS3 before the F2F.

I assume we also want to add "document-dc-metadata" as Document Description, Job Description, and Operation attributes - we already do this for the document-xxx attributes defined in RFC 2911 and PWG 5100.7...

On Nov 28, 2011, at 11:40 AM, Ira McDonald wrote:
> Hi Pete and Mike,
> 
> I suggest that, since the IETF seems to heavily rely on this one, we just take
> Note that no paths or qualifiers are needed - the elements are free-standing.

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Ira McDonald <[email-masked]>
Date: Mon, 28 Nov 2011 16:59:18 -0500

Hi Mike,

You got it.

Yes - I like this clean and simple approach.  It really hardly needs
ABNF (though I could write a closed one for the 15 keywords in
about 20 minutes).

One LAST question - do we want to stack these critters
(keyword=value;keyword=value), so that each
document-dc-metadata value is one *set* of related metadata
(creator, date, etc.)?

I vote no - keep it simple - it's just a flat list - 2 creators is 2 creator
array values.

Cheers,
- Ira

On Mon, Nov 28, 2011 at 4:36 PM, Michael Sweet <[email-masked]> wrote:

> I assume we also want to add "document-dc-metadata" as Document
> Description, Job Description, and Operation attributes - we already do this
> for the document-xxx attributes defined in RFC 2911 and PWG 5100.7...
>
>

---

From: Michael Sweet <[email-masked]>
Date: Mon, 28 Nov 2011 14:48:57 -0800

> ABNF (though I could write a closed one for the 15 keywords in

I did an ABNF anyways, and allow the fixed set of 15 keyword in 5013 or any "x-foo" keyword for vendor/client-defined values that need to be propagated.

> document-dc-metadata value is one *set* of related metadata 

That would open up quoting issues for the values - we could certainly do this, but given that we have a list of key/value pairs applying to the current document I don't see any advantage...

---

From: Ira McDonald <[email-masked]>
Date: Mon, 28 Nov 2011 17:53:18 -0500

Hi Mike,

I agree - let's not introduce quoting/escaping issues.

All lowercase keywords (what RFC 5013 calls the 'Elment Name'
in section 6) followed by a single literal equal sign '=', followed
by zero or more UTF-8 characters (which can be multi-octet).
Allow for the zero characters for the explict empty string value
being passed through from another document metadata interface.

Cheers,
- Ira

On Mon, Nov 28, 2011 at 5:48 PM, Michael Sweet <[email-masked]> wrote:

> I did an ABNF anyways, and allow the fixed set of 15 keyword in 5013 or
> any "x-foo" keyword for vendor/client-defined values that need to be
> propagated.
>
> That would open up quoting issues for the values - we could certainly do
> this, but given that we have a list of key/value pairs applying to the
> current document I don't see any advantage...
>