Subject: [IPP] Re: Error in Production Printing Set 1 (5100.3)

From: Michael Sweet <[email-masked]>
Date: Wed, 07 Dec 2011 21:16:16 -0600

FWIW, this also applies to "media-input-check-default" (which shouldn't exist).

On Dec 7, 2011, at 9:02 PM, Michael Sweet wrote:

> All,
> 
> While going through the IPP registration one last (!) time before we send another round of updates to IANA, I noticed that the "force-front-side" Job Template attribute has inappropriate -default and -supported registrations.
> 
> The "force-front-side-default (1setOf integer(1:MAX))" attribute should not exist. Like "overrides", the only default that makes sense is to omit the attribute.  Similarly, the "force-front-side-supported (rangeOfInteger(1:MAX))" should really be a boolean to indicate that the attribute is supported.
> 
> Sadly the only place this is defined or talked about is in Table 1 (Page 18) - there is no explanatory text and both attributes are not included in the IANA registration section, although they did make it into the IANA registry, probably when Ira updated the registration info originally...
> 
> So, does anyone support the current definition of "force-front-side-default" or "force-front-side-supported"?  If so, how do you deal with having a default value?  If not, would there be any objection to including this in the list of errata for 5100.3 and fixing the corresponding IANA registrations?
> 
> _________________________________________________________
> Michael Sweet, Senior Printing System Engineer, PWG Chair
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Wed, 07 Dec 2011 21:02:36 -0600

All,

---

From: Michael Sweet <[email-masked]>
Date: Wed, 07 Dec 2011 22:22:05 -0600

Also "proof-print-default" in 5100.11... sigh...

---

From: Michael Sweet <[email-masked]>
Date: Thu, 08 Dec 2011 07:42:12 -0600

Err, make that "media-input-tray-check-default"...