Subject: [IPP] Question for FaxOut Service

From: Michael Sweet <[email-masked]>
Date: Tue, 08 Jan 2013 09:55:29 -0500

[Cross-posted to IPP and Semantic Model]

All,

Canon's latest comments bring up a question about how the FaxOut service populates the transmission header at the top of each page. The source and destination phone numbers are easy, as are date, time, and page number. However, where do we get the sender's name?

Normally this information is configured into the MFD as part of the installation/setup, e.g., "Foo Corp". However, I don't see a corresponding SM element for the service owner name or device owner name that would be used here.

Thoughts?

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Tue, 8 Jan 2013 10:02:23 -0500

Hi,

Take a look at "DeviceOwnerVCard" (which of course
contains a human-readable name) element.

There are no comparable "ServiceOwner[Uri/VCard]"
elements - this is a bug, IMHO.

Also, I think we need "[Device/Service]OwnerName"
simple elements that inherit from RequestingUserName
that created / administered them.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - TCG Embedded Systems Hardcopy SG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, Jan 8, 2013 at 9:55 AM, Michael Sweet <[email-masked]> wrote:

> Canon's latest comments bring up a question about how the FaxOut service
> populates the transmission header at the top of each page. The source and
> destination phone numbers are easy, as are date, time, and page number.
> However, where do we get the sender's name?
>
> Normally this information is configured into the MFD as part of the
> installation/setup, e.g., "Foo Corp". However, I don't see a corresponding
> SM element for the service owner name or device owner name that would be
> used here.
>
> Thoughts?
>
> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
> believed to be clean.
>
> mfd mailing list
> [email-masked]
> https://www.pwg.org/mailman/listinfo/mfd
>
>

---

From: Michael Sweet <[email-masked]>
Date: Tue, 08 Jan 2013 10:46:56 -0500

Ira,

Thanks, I will look and expose the corresponding Printer attributes in the next update of the IPP FaxOut spec.

---

From: Michael Sweet <[email-masked]>
Date: Tue, 08 Jan 2013 10:55:16 -0500

Ira,

One more question, below...

>From the perspective of the fax header information, we want the organization name from the vcard, which should be the same as the "printer-organization (1setOf text(MAX))" value(s) we added in JPS3, correct? The person name is only useful for personal devices, but there the organization can be the same as the person's full name, e.g., "John Doe".

So I think the correct action here is to require printer-organization in IPP FaxOut, and document its usage. The rest of the device/service elements can be addressed later, perhaps as part of the System Control Service and/or IPP Multifunction specs.

---

From: Ira McDonald <[email-masked]>
Date: Tue, 8 Jan 2013 10:57:58 -0500

Hi,

I agree w/ all of your comments below.

Cheers,
- Ira

On Tue, Jan 8, 2013 at 10:55 AM, Michael Sweet <[email-masked]> wrote:

> From the perspective of the fax header information, we want the
> organization name from the vcard, which should be the same as the
> "printer-organization (1setOf text(MAX))" value(s) we added in JPS3,
> correct? The person name is only useful for personal devices, but there the
> organization can be the same as the person's full name, e.g., "John Doe".
>
> So I think the correct action here is to require printer-organization in
> IPP FaxOut, and document its usage. The rest of the device/service elements
> can be addressed later, perhaps as part of the System Control Service
> and/or IPP Multifunction specs.
>