Subject: [IPP] RFC: Proposed errata for PWG 5100.3 (Production Printing)

From: Michael Sweet <[email-masked]>
Date: Tue, 21 May 2013 10:45:11 -0400

All,

As discussed in last week's session, there is no easy migration from the finishings attribute (1setOf type2 enum) to the finishings-col attribute (1setOf collection).

The primary issue is that the finishing-template member attribute is defined as a name value and does not support well-known keyword values.  I propose that we amend the definition of the finishing-template member attribute and finishing-template-supported Printer attribute to include type2 keywords, e.g.:

    "finishings-col (1setOf collection)"
        "finishing-template (name(MAX) | type2 keyword)"  <--- NEW
        "stitching (collection)"
            "stitching-locations (1setOf integer(0:MAX))"
            "stitching-offset (integer(0:MAX))"
            "stitching-reference-edge (type2 keyword)"

    "finishing-template-supported (1setOf (name(MAX) | type2 keyword))"  <--- NEW
    "finishings-col-supported (1setOf type2 keyword)"
    "stitching-locations-supported (1setOf (integer(0:MAX) | rangeOfInteger(0:MAX)))"
    "stitching-offset-supported (1setOf (integer(0:MAX) | rangeOfInteger(0:MAX)))"
    "stitching-reference-edge-supported (1setOf type2 keyword)"

The keyword values would correspond to the finishings enum names (staple, punch, bale, etc.).

Longer term we should also probably extend the finishings-col Job Template attribute to include fold, punch, and trim member attributes, which would make use of the same kinds of values as as the current "stitching" member attribute (which IIRC handles bind, edge stitch, and staple, although that too could be made explicit), for example:

    "finishings-col (1setOf collection)"
        "fold (1setOf collection)" (list of folds)
            "fold-direction (type2 keyword)" (in/out or up/down)
            "fold-location (integer(0:MAX))"
            "fold-reference-edge (type2 keyword)"
        "punch (collection)"
            "punch-locations (1setOf integer(0:MAX))"
            "punch-offset (integer(0:MAX))"
            "punch-reference-edge (type2 keyword)"
        "trim (1setOf collection)" (list of cuts)
            "trim-location (1setOf integer(0:MAX))"
            "trim-reference-edge (type2 keyword)"

    "fold-direction-supported (1setOf type2 keyword)"
    "fold-location-supported (1setOf (integer(0:MAX) | rangeOfInteger(0:MAX)))"
    "fold-reference-edge-supported (1setOf type2 keyword)"

    "punch-locations-supported (1setOf (integer(0:MAX) | rangeOfInteger(0:MAX)))"
    "punch-offset-supported (1setOf (integer(0:MAX) | rangeOfInteger(0:MAX)))"
    "punch-reference-edge-supported (1setOf type2 keyword)"

    "trim-location-supported (1setOf (integer(0:MAX) | rangeOfInteger(0:MAX)))"
    "trim-reference-edge-supported (1setOf type2 keyword)"

That said, I think extending finishings-col needs to happen in a separate (small) spec, and we should look to other specs (e.g. JDF and MSPS) to make sure we aren't defining something completely out in left field.

Thoughts?

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Paul Tykodi" <[email-masked]>
Date: Tue, 21 May 2013 12:25:22 -0400

Hi Mike,

For this particular specification, I think we should consult information
from the UP³I and potentially PODi organizations as well.

Best Regards,

/Paul

--

Paul Tykodi
Principal Consultant
TCS - Tykodi Consulting Services LLC

Tel/Fax: 603-343-1820
Mobile:  603-866-0712
E-mail:  [email-masked]
WWW:   <http://www.tykodi.com/> http://www.tykodi.com

From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael
Sweet
Sent: Tuesday, May 21, 2013 10:45 AM
To: [email-masked]
Subject: [IPP] RFC: Proposed errata for PWG 5100.3 (Production Printing)

All,

As discussed in last week's session, there is no easy migration from the
finishings attribute (1setOf type2 enum) to the finishings-col attribute
(1setOf collection).

The primary issue is that the finishing-template member attribute is defined
as a name value and does not support well-known keyword values.  I propose
that we amend the definition of the finishing-template member attribute and
finishing-template-supported Printer attribute to include type2 keywords,
e.g.:

        "stitching (collection)"

    "finishing-template-supported (1setOf (name(MAX) | type2 keyword))"
<--- NEW

    "stitching-locations-supported (1setOf (integer(0:MAX) |
rangeOfInteger(0:MAX)))"

    "stitching-offset-supported (1setOf (integer(0:MAX) |
rangeOfInteger(0:MAX)))"

The keyword values would correspond to the finishings enum names (staple,
punch, bale, etc.).

Longer term we should also probably extend the finishings-col Job Template
attribute to include fold, punch, and trim member attributes, which would
make use of the same kinds of values as as the current "stitching" member
attribute (which IIRC handles bind, edge stitch, and staple, although that
too could be made explicit), for example:

        "punch (collection)"

    "fold-location-supported (1setOf (integer(0:MAX) |
rangeOfInteger(0:MAX)))"

    "punch-locations-supported (1setOf (integer(0:MAX) |
rangeOfInteger(0:MAX)))"

    "punch-offset-supported (1setOf (integer(0:MAX) |
rangeOfInteger(0:MAX)))"

    "trim-location-supported (1setOf (integer(0:MAX) |
rangeOfInteger(0:MAX)))"

That said, I think extending finishings-col needs to happen in a separate
(small) spec, and we should look to other specs (e.g. JDF and MSPS) to make
sure we aren't defining something completely out in left field.

Thoughts?

-- 
This message has been scanned for viruses and 
dangerous content by  <http://www.mailscanner.info/> MailScanner, and is 
believed to be clean.

---

From: Ira McDonald <[email-masked]>
Date: Tue, 21 May 2013 12:49:41 -0400

Hi Paul,

Looking at PODI et al would open endless possibilities.

I agree with Mike that defining the low-hanging fruit for finishing that
specifically map to the most commonly used JDF and MSPS finishing
should be our limited and practical scope.

BTW - the Open Printing JTAPI spec specifically chose a small subset
of finishing types to standardize in the JTAPI abstract Job model - these
are already harmonized with JDF.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - TCG Embedded Systems Hardcopy SG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, May 21, 2013 at 12:25 PM, Paul Tykodi <[email-masked]> wrote:

> Hi Mike,****
> ** **
> from the UP³I and potentially PODi organizations as well.****
>
> ** **
>
> Best Regards,****
>
> ** **
>
> /Paul****
>
> --****
>
> Paul Tykodi
> Principal Consultant
> WWW:  http://www.tykodi.com****
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *Michael
> Sweet
> *Sent:* Tuesday, May 21, 2013 10:45 AM
> *To:* [email-masked]
> *Subject:* [IPP] RFC: Proposed errata for PWG 5100.3 (Production Printing)
> ****
>
> ** **
>
> All,****
>
> ** **
>
> (1setOf collection).****
> ** **
> The primary issue is that the finishing-template member attribute is
> defined as a name value and does not support well-known keyword values.  I
> propose that we amend the definition of the finishing-template member
> attribute and finishing-template-supported Printer attribute to include
> type2 keywords, e.g.:****
>
> ** **
>
>     "finishings-col (1setOf collection)"****
>
>         "finishing-template (name(MAX) | type2 keyword)"  <--- NEW****
>
>         "stitching (collection)"****
>
>             "stitching-locations (1setOf integer(0:MAX))"****
>
>             "stitching-offset (integer(0:MAX))"****
>
>             "stitching-reference-edge (type2 keyword)"****
>
> ** **
>
>  <--- NEW****
>     "finishings-col-supported (1setOf type2 keyword)"****
>
> rangeOfInteger(0:MAX)))"****
>
> rangeOfInteger(0:MAX)))"****
>
>     "stitching-reference-edge-supported (1setOf type2 keyword)"****
>
> ** **
>
> punch, bale, etc.).****
> ** **
> too could be made explicit), for example:****
>
> ** **
>
>     "finishings-col (1setOf collection)"****
>
>         "fold (1setOf collection)" (list of folds)****
>
>             "fold-direction (type2 keyword)" (in/out or up/down)****
>
>             "fold-location (integer(0:MAX))"****
>
>             "fold-reference-edge (type2 keyword)"****
>
>         "punch (collection)"****
>
>             "punch-locations (1setOf integer(0:MAX))"****
>
>             "punch-offset (integer(0:MAX))"****
>
>             "punch-reference-edge (type2 keyword)"****
>
>         "trim (1setOf collection)" (list of cuts)****
>
>             "trim-location (1setOf integer(0:MAX))"****
>
>             "trim-reference-edge (type2 keyword)"****
>
> ** **
>
>     "fold-direction-supported (1setOf type2 keyword)"****
>
> rangeOfInteger(0:MAX)))"****
>
>     "fold-reference-edge-supported (1setOf type2 keyword)"****
>
> ** **
>
> rangeOfInteger(0:MAX)))"****
>
> rangeOfInteger(0:MAX)))"****
>
>     "punch-reference-edge-supported (1setOf type2 keyword)"****
>
> ** **
>
> rangeOfInteger(0:MAX)))"****
>
>     "trim-reference-edge-supported (1setOf type2 keyword)"****
>
> ** **
>
> sure we aren't defining something completely out in left field.****
>
> ** **
>
> Thoughts?****
>
> ** **
>
> Michael Sweet, Senior Printing System Engineer, PWG Chair****
>
> ** **
>
>
> --
> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
> believed to be clean. ****
>
> --
> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
> believed to be clean.
>

---

From: "Paul Tykodi" <[email-masked]>
Date: Tue, 21 May 2013 12:56:10 -0400

Hi Ira,

What I was thinking about in mentioning the other organizations was to
review the elements we want to map (stapling, folding, punching, trimming)
to see what values the specifications from these organizations support for
these limited items.

Best Regards,

/Paul

--

Paul Tykodi
Principal Consultant

Tel/Fax: 603-343-1820
Mobile:  603-866-0712

From: Ira McDonald [mailto:[email-masked]] 
Sent: Tuesday, May 21, 2013 12:50 PM
To: Paul Tykodi
Cc: Michael Sweet; [email-masked]
Subject: Re: [IPP] RFC: Proposed errata for PWG 5100.3 (Production Printing)

Hi Paul,

Cheers,

- Ira

 <http://sites.google.com/site/blueroofmusic>
 <http://sites.google.com/site/highnorthinc>

Hi Mike,

Best Regards,

/Paul

--

Paul Tykodi
Principal Consultant

Tel/Fax: 603-343-1820
Mobile:  603-866-0712

All,

        "stitching (collection)"

        "punch (collection)"

Thoughts?

---

From: Ira McDonald <[email-masked]>
Date: Tue, 21 May 2013 14:23:59 -0400

Hi Paul,

I understand the more limited scope of your proposal to look at
PODI and friends.

But I simply don't want to expand any IPP existing attributes and
finishing types unless they're needed and important for higher
fidelity PJT mappings from JDF or MSPS.  Even looking ahead
to MODCA should be deferred.  Standard numbers and revision
year numbers are cheap.

I prefer not to open that can of worms (endless world of finishing
type-specific option details) in the near term.

The objective is just to define the one finishing-template attribute
(keyword type names) and the enclosed finishing type-specific
members in an IPP 'collection' work, particular for IPP Implementors
Guide v2 to recommend best practice for finishings-col.

Narrower scope is better, I suggest.

Cheers,
- Ira

On Tue, May 21, 2013 at 12:56 PM, Paul Tykodi <[email-masked]> wrote:

> Hi Ira,****
> these limited items.****
> *From:* Ira McDonald [mailto:[email-masked]]
> *Sent:* Tuesday, May 21, 2013 12:50 PM
> *To:* Paul Tykodi
> *Cc:* Michael Sweet; [email-masked]
> *Subject:* Re: [IPP] RFC: Proposed errata for PWG 5100.3 (Production
> Printing)****
>
> ** **
>
> Hi Paul,****
>
> Looking at PODI et al would open endless possibilities.****
>
> specifically map to the most commonly used JDF and MSPS finishing****
>
> should be our limited and practical scope.****
>
> BTW - the Open Printing JTAPI spec specifically chose a small subset****
>
> are already harmonized with JDF.****
>
> Cheers,****
>
> - Ira****
>
> ** **
>
>
> ****
>
> Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434****
>
> ** **
>
> On Tue, May 21, 2013 at 12:25 PM, Paul Tykodi <[email-masked]> wrote:*
> ***
>
> Hi Mike,****
>
>  ****
>
> https://www.pwg.org/mailman/listinfo/ipp****
>
> ** **
>

---

From: Michael Sweet <[email-masked]>
Date: Tue, 21 May 2013 15:00:43 -0400

Paul,

My $.02 CDN: what Ira said, but also my whole point was not to import what has been done in the other job tickets but to make sure what we did was not incompatible - we should be able to a) express what the simple enums expand to and b) allow for a /slightly/ better mapping to/from other job tickets for use on typical office equipment, without obvious incompatibilities.

For example, I don't want to see IPP support the complex origami that is possible with JDF's Fold Catalogue, but I *do* want to support the various 2, 3, and 4-panel folding patterns that are common when printing brochures and maps on office equipment.  These currently are covered by the new finishings values in the IPP Paid Printing Extensions, but the fold positions, directions, and edges are assumed/calculated by the printer based on the media used.  It would be nice to specify where these folds occur on the output media, e.g., to fold so that a "tab" is left exposed in a 3-fold design.

    +----+----+------+          +----+-+
    |    |    |      |          |    | |
    |    |    |      |          |    | |
    | A  | B  |     C|  ----->  | AB |C|
    |    |    |      |          |    | |
    |    |    |      |          |    | |
    +----+----+------+          +----+-+

On 2013-05-21, at 2:23 PM, Ira McDonald <[email-masked]> wrote:

> What I was thinking about in mentioning the other organizations was to review the elements we want to map (stapling, folding, punching, trimming) to see what values the specifications from these organizations support for these limited items.
> 
>  
> 
> Best Regards,
> 
>  
> 
> /Paul
> 
> --
> 
> Paul Tykodi
> Principal Consultant
> WWW:  http://www.tykodi.com
> 
> For this particular specification, I think we should consult information from the UP³I and potentially PODi organizations as well.
> 
>  
> 
> Best Regards,
> 
>  
> 
> /Paul
> 
> --
> 
> Paul Tykodi
> Principal Consultant
> WWW:  http://www.tykodi.com
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael Sweet