Subject: [IPP] Does IPP have a float / double attribute syntax?

From: "Manchala, Daniel" <[email-masked]>
Date: Fri, 28 Jun 2013 19:29:40 +0000

Does IPP support a float or a double data type attribute syntax? I know it supports boolean, integer, text, name, uri, etc. I know that CUPS which is an IPP implementation supports float.

Thanks,
Daniel.

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Fri, 28 Jun 2013 15:57:40 -0400

Daniel,

On 2013-06-28, at 3:29 PM, "Manchala, Daniel" <[email-masked]> wrote:
> Does IPP support a float or a double data type attribute syntax? I know it supports boolean, integer, text, name, uri, etc.

No, there are no floating-point data types in IPP.

> I know that CUPS which is an IPP implementation supports float.

No, it actually doesn't.  CUPS passes floating point numbers as name values (strings).

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair