Subject: [IPP] IPP Finishings 2.0: Presets?

From: Michael Sweet <[email-masked]>
Date: Tue, 08 Oct 2013 20:53:59 -0400

All,

Something I've been thinking about for IPP Finishings 2.0 is the notion of "presets" for finishings-col - there is already a "template-name" member attribute, but what about combining multiple finishings for standard post-processing (e.g., booklet + cover + saddlestitch + bale)?

There is also the question of default values - right now we don't have a "finishings-col-database" attribute that provides the defaults for each template-name.  But there is a finishings-col-ready attribute. Should we add a finishings-col-database attribute to list all of the defaults for each template-name? Or is finishings-col-ready sufficient?

I think we should make it clear that the presence of the corresponding member attribute is what activates a particular finisher and not the use of a specific template-name - that will make it clear that vendor, user, or site-defined template-name values can apply one or more finishing options just by setting the corresponding member attributes (stitching, punching, folding, etc.)  And by having finishings-col-ready/database there with all of the details, it will be possible for Client UI to visually simulate the results of finishing instructions in addition to the usual selection-by-name.

Thoughts?

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Wed, 9 Oct 2013 04:18:20 +0000

Hi Mike,

HP supports pursuing this idea.

The printing ecosystem already has this now  but it must be provided by the driver.  I suppose an enterprising IPP Client could fabricate its own presets from job template attributes receives from the printer, but it would have to do this based on its own a priori information rather than simply receiving them from the printer. Whether finishings-col-ready is a good choice or not, I'm not prepared to say.

Smith
--
Smith Kennedy
Hewlett-Packard Co.

On Oct 8, 2013, at 6:54 PM, "Michael Sweet" <[email-masked]<mailto:[email-masked]>> wrote:

All,

Thoughts?

_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp