Subject: [IPP] Outline of IPP System Control Service spec

From: Ira McDonald <[email-masked]>
Date: Tue, 15 Oct 2013 17:44:00 -0400

Hi Mike,

For IPP SCS slides for next week:

1. Introduction
- relationship of System object and System Control Service to IPP Printer
- synopsis of rationale
2. Terminology
- conformance, imaging, other, acronyms, etc.
3. Requirements
- rationale, use cases, out-of-scope, design requirements
4. IPP System Model
- System Object
- Subunit Object
- Printer Object
- Job Object
- Subscription Object
- etc.
5. System Object
- configuration (subunits)
- description (charset, language, name, UUID, location, etc.)
-- power calendar/events ???
- status (state, health, alerts, configured services/resources, counters,
etc.)
-- power log/meters ???
6. System Control Service
- description (charset, language, name, UUID, location, etc.)
- status (state, alerts, etc.)
7. System Control Service Operations
- GetSystemElements
- ListAllServices
- PauseAllServices
- RestartAllServices ???
- ResumeAllServices
- SetSystemElements
- ShutdownAllServices ???
- StartupAllServices ???
8. Conformance Requirements
- IPP Client
- IPP Printer
9. Internationalization Considerations
10. Security Considerations
11. IANA Considerations
12. References
13. Authors' Addresses
14. Change History

Comments?

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - TCG Embedded Systems Hardcopy SG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Wed, 16 Oct 2013 10:25:12 -0400

Hi,

Several corrections:

(1) Rename GetSystemElements to GetSystemAttributes (IPP-style)
(2) Delete SetSystemElements (out-of-scope for version 1 because of writes)

Cheers,
- Ira

---

From: Michael Sweet <[email-masked]>
Date: Wed, 16 Oct 2013 08:25:43 -0700

Ira,

While we are on the topic of renaming, in the spirit of IPP we should be calling everything a Printer, not a Service.  And instead of ListAllServices/Printers it should be Get-Printers to match Get-Jobs, Get-Documents, Get-Subscriptions, and Get-Notifications.

Operations for 1.0 spec:

- Disable-Printers
- Enable-Printers
- Get-Printers
- Get-System-Attributes
- Pause-Printers
- Pause-Printers-After-Current-Job
- Restart-Printers
- Resume-Printers
- Shutdown-Printer (extend RFC 3998)
- Shutdown-Printers
- Startup-Printers

Additional operations for 2.0 spec:

- Delete-Printer
- Get-Security-Attributes
- Request-Security-Attributes
- Restart-Printer (extend RFC 3998)
- Set-System-Attributes
- Startup-Printer (extend RFC 3998)

Thoughts?

On Oct 16, 2013, at 7:25 AM, Ira McDonald <[email-masked]> wrote:

> On Tue, Oct 15, 2013 at 5:44 PM, Ira McDonald <[email-masked]> wrote:
> Hi Mike,
> 
> - status (state, health, alerts, configured services/resources, counters, etc.)
> -- power log/meters ???

---

From: Ira McDonald <[email-masked]>
Date: Wed, 16 Oct 2013 19:49:42 -0400

Hi Mike,

Agreed - Service(s) --> Printer(s) in IPP.

But this locks us in forever to only output services (like FaxOut), right?

The IPP URI scheme (and IPPS URI scheme) allow URIs to reference any
object (not just IPP Printer), e.g., Subscription.

So I think we ought to at least briefly discuss this (Service-->Printer)
closing the future off at the F2F, before finalizing.

I'm thinking about modelling IPP attributes for ConfiguredPrinters and
ConfiguredResources (in the System object) and some of the other
complex attributes (presumably they'll become collections?).

Cheers,
- Ira

On Wed, Oct 16, 2013 at 11:25 AM, Michael Sweet <[email-masked]> wrote:

> Ira,
>
> While we are on the topic of renaming, in the spirit of IPP we should be
> calling everything a Printer, not a Service.  And instead of
> ListAllServices/Printers it should be Get-Printers to match Get-Jobs,
> Get-Documents, Get-Subscriptions, and Get-Notifications.
>
> Operations for 1.0 spec:
>
> - Disable-Printers
> - Enable-Printers
> - Get-Printers
> - Get-System-Attributes
> - Pause-Printers

---

From: Michael Sweet <[email-masked]>
Date: Wed, 16 Oct 2013 17:17:37 -0700

Ira,

> But this locks us in forever to only output services (like FaxOut), right?

I don't think so - it just means that we start calling scanners and other imaging services "Printers" since the protocol started life to support printing.

Alternately we go back and define aliases for the original print-centric operation codes to use Service instead of Printer, but then we also would want to rename printer-xxx attributes to service-xxx which would impact the on-the-wire encoding (whereas adding a name that has the same operation code doesn't...)

> object (not just IPP Printer), e.g., Subscription.

Sure.

> closing the future off at the F2F, before finalizing.

Absolutely, and something we should be discuss during our SCS time slot.

> complex attributes (presumably they'll become collections?).

That would be my preference, yes.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair