Subject: [IPP] printer-state-reasons Customer Replaceable Unit Missing

From: "Hills, Lee D" <[email-masked]>
Date: Wed, 20 Nov 2013 02:13:12 +0000

Hi,

When a customer forgets to replace a CRU on a printer, such as waste tray, I need to post status indicating such. 

What is the recommended printer-state-reason for such as event.  I was thinking there would be something marker-xxx-missing, but there seems to not be.

Reviewing the printer-state-reasons, I see where it might be useful to have the following additional reasons:

marker-developer-missing
marker-fuser-missing
marker-supply-missing
marker-waste-ink-receptacle-missing
marker-waste-toner-receptacle-missing

Your suggestions would be greatly appreciated.

Thanks,
  Lee
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Thu, 21 Nov 2013 12:16:33 -0500

Lee,

While we haven’t defined keywords for these conditions, I think that is a clear omission that needs to be addressed.  The following are my suggested registrations for new “printer-state-reason” keyword values, with a preference to following the RFC 2911 naming for a few:

Attributes (attribute syntax)
  Keyword Attribute Value			Reference
  -----------------------			---------
printer-state-reasons (1setOf type2 keyword)	[RFC2911]
    cleaner-missing
    developer-missing
    fuser-missing
    marker-ink-missing
    marker-print-ribbon-missing
    marker-supply-missing
    marker-waste-missing
    marker-waste-ink-receptacle-missing
    marker-waste-toner-receptacle-missing
    opc-missing
    toner-missing

For completeness we should also register PrtAlertCodeTC values to cover all of the RFC 2911 and new keywords above:

    -- Marker Supplies group
      markerCleanerMissing(1116),     #### CAUTION, PRELIMINARY VALUES NOT REGISTERED
      markerDeveloperMissing(1117),
      markerFuserMissing(1118),
      markerInkMissing(1119),
      markerOpcMissing(1120),
      markerPrintRibbonMissing(1121),
      markerSupplyAlmostEmpty(1122),
      markerSupplyEmpty(1123),
      markerSupplyMissing(1124),
      markerWasteAlmostFull(1125),
      markerWasteFull(1126),
      markerWasteMissing(1127),
      markerWasteInkReceptacleMissing(1128),
      markerWasteTonerReceptacleMissing(1129),

Note: it appears that PWG 5100.9 defined a few keywords with duplicate semantics for existing 2911 keywords; I think we should deprecate them as part of an errata for 5100.9 (which can correct the table errors):

    RFC 2911					PWG 5100.9
    --------------------------------------	---------------------------------
    developer-low				marker-developer-almost-empty
    developer-empty				marker-developer-empty
    media-needed				input-manual-input-request

Thoughts?

> Your suggestions would be greatly appreciated.

_______________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: "Hills, Lee D" <[email-masked]>
Date: Thu, 21 Nov 2013 17:21:05 +0000

This sounds reasonable to me. 

Lee

-----Original Message-----
From: Michael Sweet [mailto:[email-masked]] 
Sent: Thursday, November 21, 2013 9:17 AM
To: Hills, Lee D
Cc: [email-masked]; [email-masked]
Subject: Re: [IPP] printer-state-reasons Customer Replaceable Unit Missing

Lee,

While we haven't defined keywords for these conditions, I think that is a clear omission that needs to be addressed.  The following are my suggested registrations for new "printer-state-reason" keyword values, with a preference to following the RFC 2911 naming for a few:

    -- Marker Supplies group

    RFC 2911					PWG 5100.9

Thoughts?