Subject: Re: [IPP] Join Conference Call (IPP & Cloud) Monday 14 OCT at 3PM EST

From: "William A Wagner" <[email-masked]>
Date: Sat, 7 Dec 2013 11:09:53 -0500

There will be a Cloud conference call on Monday, 9 December at 3PM EST (Noon PDT). This will probably be the last Cloud conference call of the year.

  Call-in toll-free number (US/Canada): 1-866-469-3239
  Call-in toll number (US/Canada): 1-650-429-3300 (Primary)
  Call-in toll number (US/Canada): 1-408-856-9570 (Backup)

  Attendee Access Code: *******#
  Attendee ID Code: # (empty)

If you need the Attendee Access code, please email me a request.

PWG WebEx. 

Topic: IPP/Cloud WG 

Date: Every Monday, from Monday, September 23, 2013 to no end date 

Time: 3:00 pm, Eastern Daylight Time (New York, GMT-04:00) 

Meeting Number: 682 763 393 

Meeting Password: Printing123 

------------------------------------------------------- 

To join the online meeting (Now from mobile devices!) 

------------------------------------------------------- 

1. Go to https://ieee-isto.webex.com/ieee-isto/j.php?ED=152699422 <https://ieee-isto.webex.com/ieee-isto/j.php?ED=152699422&UID=1183762542&PW=NYTM5NTNhNjUy&RT=MiMxMQ%3D%3D> &UID=1183762542&PW=NYTM5NTNhNjUy&RT=MiMxMQ%3D%3D 

2. If requested, enter your name and email address. 

3. If a password is required, enter the meeting password: Printing123 

4. Click "Join". 

To view in other time zones or languages, please click the link: 

https://ieee-isto.webex.com/ieee-isto/j.php?ED=152699422 <https://ieee-isto.webex.com/ieee-isto/j.php?ED=152699422&UID=1183762542&PW=NYTM5NTNhNjUy&ORT=MiMxMQ%3D%3D> &UID=1183762542&PW=NYTM5NTNhNjUy&ORT=MiMxMQ%3D%3D 

------------------------------------------------------- 

For assistance 

------------------------------------------------------- 

1. Go to https://ieee-isto.webex.com/ieee-isto/mc 

2. On the left navigation bar, click "Support". 

To add this meeting to your calendar program (for example Microsoft Outlook), click this link: 

https://ieee-isto.webex.com/ieee-isto/j.php?ED=152699422 <https://ieee-isto.webex.com/ieee-isto/j.php?ED=152699422&UID=1183762542&ICS=MI&LD=1&RD=2&ST=1&SHA2=AAAAAgN0HgWlP05sWLy7lRjCXMtc9FsW9s-XNPklCRd8QoYu&RT=MiMxMQ%3D%3D> &UID=1183762542&ICS=MI&LD=1&RD=2&ST=1&SHA2=AAAAAgN0HgWlP05sWLy7lRjCXMtc9FsW9s-XNPklCRd8QoYu&RT=MiMxMQ%3D%3D 

Agenda:

(1) PWG IP Policy and Minute Taker 
(2) Approve Cloud minutes from November 18 (ftp://ftp.pwg.org/pub/pwg/cloud/minutes/cloud-concall-minutes-20131118.pdf)

(3) Review update to the Cloud Requirements and Model document at 

               ftp://ftp.pwg.org/pub/pwg/cloud/wd/wd-cloudimagingmodel10-20131125.pdf 

ftp://ftp.pwg.org/pub/pwg/cloud/wd/wd-cloudimagingmodel10-20131125.docx

(also accessible at http://xxx)

This update reflects comments from the November 18 conference call reviewing  Cloud Imaging Requirements and Model  ftp://ftp.pwg.org/pub/pwg/cloud/wd/wd-cloudimagingmodel10-20131115-rl.pdf.

Extracting from the minutes of that call, actions/comments are in red.

b. Page 28: Still have signal duration listed for Identify Printer - Replaced with IdentifyActions

c. 4.2.1.2: must -> MUST for items 3 and 4 – Reworded to avoid use of  conformance terms.

d. 4.2.1.2 IdentifyDevice

Q: Do we want the Cloud Imaging Service to be able to cancel 

identify operations?

A: Maybe

How to do it with IPP?

‘cancel’ keyword for identify-actions? OK

IIG2: provide guidance on recommended durations, each 

identify-printer operation replaces the previous actions (if not 

expired), what to do for display (replace, alternate, ??? 

discuss in IPP WG)

Action: Mike to post adding identify-actions = ‘cancel’ and 

‘identifying-printer’ printer-state-reasons to IPP list

e. Global: fix lowercase musts OK

f. Global: check spelling OK

g. 4.2.2.1:

Lines 894-897 should be numbered list OK

Expand a bit on the kinds of notifications that are supplied: jobs are 

fetchable, identify device is pending, jobs were canceled, etc. OK

Line 950: end -> cancel, capitalize identify actions OK

Item 4: Include job elements instead of separate UpdateJobState 

operation Job State should be adequate

Item 5: IdentifyActions instead of DeviceIdentifyRequest OK

GetSystemNotifications should return basic event information, like IPP Get-Notifications: job state changes include new job state, job UUID, service URI Only include job state changes as indicated. Isn't Job UUID sufficiently unique so that service URI is unnecessary?

o   I remain uncomfortable with this change. GetSystemNotify was not intended to parallel IPP Get-Notification.  Indeed,  I am not overjoyed at the GetSystemNotifications name  because it is as much a send system notifications as it is a get system notifications operation. It  is directed to System Control Service, not individual imaging services and was intended only to flag to Proxy that Job status should be checked for identified Imaging Services.  Communicating Job specific status at the System Control Service level seems inappropriate to me.  The need to add this job specific information to the GetSystemNotifify comes from the objection to a Cloud Imaging  Service responding with its Job State in response to an Update Job State operation. I am inclined to think that this response is still necessary, although adding GetJobState would be a (cumbersome) alternative. 

identify actions include new set of actions OK

h. Table 2:   

⁃

Add GetJobElements, GetDocumentElements (standard SM 

operations) Question need for these if job status changes are now reported in GetSystemNotitications

On another point,  considering that the who PJT mapping effort was started as a response to Google Cloud Print using  PPDs and MSPS for printer capability and job tickets, I was surprised that there was virtually no interest in considering the current Google Cloud Print documentation as a Cloud WG project. I wonder of this reflects the opinion of just the few work group members who attended the conference call or whether it is consensus among all members.

Thanks,

Bill Wagner

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "William A Wagner" <[email-masked]>
Date: Sat, 7 Dec 2013 11:12:35 -0500

Resend – Sorry about  wrong subject!

PWG WebEx. 

Topic: IPP/Cloud WG 

 

4. Click "Join". 

 

For assistance 

Agenda:

identify operations?

A: Maybe

How to do it with IPP?

discuss in IPP WG)

g. 4.2.2.1:

h. Table 2:   

⁃

 

Thanks,

Bill Wagner