Subject: Re: [IPP] printer-state-reasons Customer Replaceable Unit Missing

From: Ira McDonald <[email-masked]>
Date: Wed, 4 Dec 2013 12:14:04 -0500

Hi Lee,

During Monday's PWG IPP call, we agreed to accept your proposed updates
for missing CRUs (as further clarified by Mike Sweet) - these should be
applied
to IPP printer-state-reasons and PrtAlertCodeTC.  Mike and I have action
items
to get these registered with IANA for IPP and Printer MIB.

Thanks very much for this good catch!

Cheers,
- Ira (co-chair of IPP WG)

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Thu, Nov 21, 2013 at 12:21 PM, Hills, Lee D <[email-masked]> wrote:

> This sounds reasonable to me.
>
> Lee
>
> -----Original Message-----
> From: Michael Sweet [mailto:[email-masked]]
> Sent: Thursday, November 21, 2013 9:17 AM
> To: Hills, Lee D
> Cc: [email-masked]; [email-masked]
> Subject: Re: [IPP] printer-state-reasons Customer Replaceable Unit Missing
>
> Lee,
>
> While we haven't defined keywords for these conditions, I think that is a
> clear omission that needs to be addressed.  The following are my suggested
> registrations for new "printer-state-reason" keyword values, with a
> preference to following the RFC 2911 naming for a few:
>
> Attributes (attribute syntax)
>   Keyword Attribute Value                       Reference
>   -----------------------                       ---------
> printer-state-reasons (1setOf type2 keyword)    [RFC2911]
>     cleaner-missing
>     developer-missing
>     fuser-missing
>     marker-ink-missing
>     marker-print-ribbon-missing
>     marker-supply-missing
>     marker-waste-missing
>     marker-waste-ink-receptacle-missing
>     marker-waste-toner-receptacle-missing
>     opc-missing
>     toner-missing
>
> For completeness we should also register PrtAlertCodeTC values to cover
> all of the RFC 2911 and new keywords above:
>
>     -- Marker Supplies group
>       markerCleanerMissing(1116),     #### CAUTION, PRELIMINARY VALUES NOT
> REGISTERED
>       markerDeveloperMissing(1117),
>       markerFuserMissing(1118),
>       markerInkMissing(1119),
>       markerOpcMissing(1120),
>       markerPrintRibbonMissing(1121),
>       markerSupplyAlmostEmpty(1122),
>       markerSupplyEmpty(1123),
>       markerSupplyMissing(1124),
>       markerWasteAlmostFull(1125),
>       markerWasteFull(1126),
>       markerWasteMissing(1127),
>       markerWasteInkReceptacleMissing(1128),
>       markerWasteTonerReceptacleMissing(1129),
>
> Note: it appears that PWG 5100.9 defined a few keywords with duplicate
> semantics for existing 2911 keywords; I think we should deprecate them as
> part of an errata for 5100.9 (which can correct the table errors):
>
>     RFC 2911                                    PWG 5100.9
>     --------------------------------------
>  ---------------------------------
>     developer-low
> marker-developer-almost-empty
>     developer-empty                             marker-developer-empty
>     media-needed                                input-manual-input-request
>
>
> Thoughts?
>
>
> _______________________________________________
> ipp mailing list
> [email-masked]
> https://www.pwg.org/mailman/listinfo/ipp
>
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Wed, 04 Dec 2013 14:46:53 -0500

Lee,

These are now listed on the PWG copy of the registrations at:

    http://www.pwg.org/ipp/ipp-registrations.xml

Once IANA finishes processing the updates for IPP FaxOut and Transaction-Based Printing I will send another update for these...

On Dec 4, 2013, at 12:14 PM, Ira McDonald <[email-masked]> wrote:

> for missing CRUs (as further clarified by Mike Sweet) - these should be applied
> to IPP printer-state-reasons and PrtAlertCodeTC.  Mike and I have action items 
> While we haven't defined keywords for these conditions, I think that is a clear omission that needs to be addressed.  The following are my suggested registrations for new "printer-state-reason" keyword values, with a preference to following the RFC 2911 naming for a few:
> 
> For completeness we should also register PrtAlertCodeTC values to cover all of the RFC 2911 and new keywords above:
> 
>     -- Marker Supplies group
>       markerCleanerMissing(1116),     #### CAUTION, PRELIMINARY VALUES NOT REGISTERED
> Note: it appears that PWG 5100.9 defined a few keywords with duplicate semantics for existing 2911 keywords; I think we should deprecate them as part of an errata for 5100.9 (which can correct the table errors):
> 
>     RFC 2911                                    PWG 5100.9
>     --------------------------------------      ---------------------------------
>     developer-low                               marker-developer-almost-empty

_______________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair