Subject: [IPP] named services

From: "Norbert Schade" <[email-masked]>
Date: Mon, 27 Jan 2014 09:03:22 -0800

I am heavily working with the scan service these days.
So my note comes out of that effort.
But I think this is a rather general question after all.

A service is typically quite a complex object.
A name that identifies a service on the highest level would in many cases ease the management and debugging of functionality that deals with services.
And if I had more than one service in my scan service xml instance I'd prefer one to be the default (services have their own defaults, but a service itself cannot be the default within a services group).

I helped myself by adding a vendor extension (a simple attribute) to the ScanServices and ScanService objects.

I could even imagine to add an ID attribute to a ScanService object and an IDREF attribute to the ScanServices object.
But I can't really do that with vendor extensions.

Just wondering if other people also feel that a named service and a default reference to such a named service might improve the situation.
Regards
Norbert

Norbert Schade
Systems Engineer (printing)
Imaging Solutions
Conexant Systems, Inc.
201 Jones Road
Waltham, MA 02451
U.S.A.
Tel: 1-781-370-8929
Email: [email-masked]<mailto:[email-masked]>

Conexant E-mail Firewall (Conexant.Com) made the following annotations
---------------------------------------------------------------------
********************** Legal Disclaimer **************************** 

"This email may contain confidential and privileged material for the sole use of the intended recipient. Any unauthorized review, use or distribution by others is strictly prohibited. If you have received the message in error, please advise the sender by reply email and delete the message. Thank you." 

********************************************************************** 

---------------------------------------------------------------------

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 27 Jan 2014 12:18:13 -0500

Norbert,

Doesn't the existing IPP printer-name attribute (SM ServiceName element) already provide this?

On Jan 27, 2014, at 12:03 PM, Norbert Schade <[email-masked]> wrote:

> And if I had more than one service in my scan service xml instance I’d prefer one to be the default (services have their own defaults, but a service itself cannot be the default within a services group).
>  
> But I can’t really do that with vendor extensions.
>  
> Email: [email-masked]
>  

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Norbert Schade <[email-masked]>
Date: Mon, 27 Jan 2014 09:41:27 -0800

There's always the chance that I misinterpret something.
But the excerpt below is from the ScanService.xsd schema. I can't find anything that looks like what you have in mind.
And so far I think I'm looking at the right object.

                <!-- ScanServices - set of Scan services -->
                <xs:complexType name="ScanServicesType">
                                <xs:sequence>
                                                <xs:element ref="ScanService" minOccurs="0" maxOccurs="unbounded"/>
                                </xs:sequence>
                                <xs:anyAttribute namespace="##other" processContents="lax"/>
                                <!-- ScanServices - set of Scan services -->
                </xs:complexType>
                <xs:element name="ScanServices" type="ScanServicesType"/>
                <!-- ScanService - object -->
                <xs:complexType name="ScanServiceBaseType">
                                <xs:sequence>
                                                <xs:element ref="ScanServiceCapabilities" minOccurs="0"/>
                                                <xs:element ref="ScanServiceCapabilitiesReady" minOccurs="0"/>
                                                <xs:element ref="ScanServiceConfiguration" minOccurs="0"/>
                                                <xs:element ref="ScanServiceDefaults" minOccurs="0"/>
                                                <xs:element ref="ScanServiceDescription"/>
                                                <xs:element ref="ScanServiceStatus"/>
                                                <xs:any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
                                </xs:sequence>
                                <xs:anyAttribute namespace="##other" processContents="lax"/>
                                <!-- ScanService - object -->
                </xs:complexType>
                <xs:complexType name="ScanServiceType">
                                <xs:complexContent>
                                                <xs:extension base="ScanServiceBaseType">
                                                                <xs:sequence>
                                                                                <xs:element name="JobTable">
                                                                                                <xs:complexType>
                                                                                                                <xs:sequence>
                                                                                                                                <xs:element name="ActiveJobs" type="ScanJobsType"/>
                                                                                                                                <xs:element name="JobHistory" type="ScanJobsType" minOccurs="0"/>
                                                                                                                                <xs:any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
                                                                                                                </xs:sequence>
                                                                                                </xs:complexType>
                                                                                </xs:element>
                                                                </xs:sequence>
                                                </xs:extension>
                                </xs:complexContent>
                </xs:complexType>
                <xs:element name="ScanService" type="ScanServiceType"/>

From: Michael Sweet [mailto:[email-masked]]
Sent: Monday, January 27, 2014 12:18 PM
To: Norbert Schade
Cc: [email-masked]
Subject: Re: [IPP] named services

Norbert,

On Jan 27, 2014, at 12:03 PM, Norbert Schade <[email-masked]<mailto:[email-masked]>> wrote:

Norbert Schade

Conexant E-mail Firewall (Conexant.Com<http://Conexant.Com>) made the following annotations
---------------------------------------------------------------------
********************** Legal Disclaimer ****************************

---------------------------------------------------------------------
_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Mon, 27 Jan 2014 13:23:01 -0500

Hi Norbert,

In the "ServiceTypes.xsd" file, you'll find "ServiceName" which (for an IPP
Scan service)
should map one-to-one to IPP printer-name.

The base "ImagingServiceXxx" classes are in "ServiceTypes.xsd", including
(for name)
"ImagingServiceDescriptionType" used in "ScanServiceDescription"

OK?

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Mon, Jan 27, 2014 at 12:41 PM, Norbert Schade <
[email-masked]> wrote:

> There’s always the chance that I misinterpret something.
>
> But the excerpt below is from the ScanService.xsd schema. I can’t find
> anything that looks like what you have in mind.
>
> And so far I think I’m looking at the right object.
>
>
>
>                                                 <xs:element
> ref="ScanService" minOccurs="0" maxOccurs="unbounded"/>
>
>                                 </xs:sequence>
>
>                                                 <xs:element
> ref="ScanServiceCapabilities" minOccurs="0"/>
>
>                                                 <xs:element
> ref="ScanServiceCapabilitiesReady" minOccurs="0"/>
>
>                                                 <xs:element
> ref="ScanServiceConfiguration" minOccurs="0"/>
>
>                                                 <xs:element
> ref="ScanServiceDefaults" minOccurs="0"/>
>
>                                                 <xs:element
>                                                 <xs:any
> namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
>
>                                 </xs:sequence>
>
> *From:* Michael Sweet [mailto:[email-masked]]
> *Sent:* Monday, January 27, 2014 12:18 PM
> *To:* Norbert Schade
> *Cc:* [email-masked]
> *Subject:* Re: [IPP] named services
>
>
>
> Norbert,
>
>
>
> A name that identifies a service on the highest level would in many cases
> ease the management and debugging of functionality that deals with services.
>
> And if I had more than one service in my scan service xml instance I’d
> prefer one to be the default (services have their own defaults, but a
> service itself cannot be the default within a services group).
>
>
>
> I could even imagine to add an ID attribute to a ScanService object and an
> IDREF attribute to the ScanServices object.
>
> Just wondering if other people also feel that a named service and a
> default reference to such a named service might improve the situation.
>
> Regards
>
> Norbert
>
>
>
>
>
> Norbert Schade
>
> "This email may contain confidential and privileged material for the sole
> use of the intended recipient. Any unauthorized review, use or distribution
> by others is strictly prohibited. If you have received the message in
> error, please advise the sender by reply email and delete the message.
> Thank you."
>

---

From: Norbert Schade <[email-masked]>
Date: Mon, 27 Jan 2014 10:23:27 -0800

Ok, found a ServiceName under ImagingServiceDescriptionType.
I guess that will help me with the name.

You have another idea how to make one of many services the default?

From: Norbert Schade
Sent: Monday, January 27, 2014 12:41 PM
To: 'Michael Sweet'
Cc: [email-masked]
Subject: RE: [IPP] named services

From: Michael Sweet [mailto:[email-masked]]
Sent: Monday, January 27, 2014 12:18 PM
To: Norbert Schade
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [IPP] named services

Norbert,

Norbert Schade

---

From: Michael Sweet <[email-masked]>
Date: Mon, 27 Jan 2014 13:47:53 -0500

Norbert,

Look here (the current version of the browsable SM2.0 schema):

    http://www.pwg.org/mfd/navigate/PwgSmRev1-185_ScanServiceDescription.html#Link5D6

You'll see ServiceName is a required element.

On Jan 27, 2014, at 12:41 PM, Norbert Schade <[email-masked]> wrote:

> But the excerpt below is from the ScanService.xsd schema. I can’t find anything that looks like what you have in mind.

---

From: Michael Sweet <[email-masked]>
Date: Mon, 27 Jan 2014 13:56:13 -0500

Norbert,

Currently there is no notion of a default service in (standard) IPP or the SM.  CUPS has a pair of extension operations for getting and setting the default printer (and at one point even allowed a server to advertise it as a sort-of "default network printer" that clients could prefer, with the usual security caveats), however those operations are now rarely used as mobile computing has made the notion of a default printer location-specific.

What are you trying to do?

---

From: "Zehler, Peter" <[email-masked]>
Date: Mon, 27 Jan 2014 18:58:34 +0000

Norbert,
When we talked I thought you were trying to have a named set of processing attributes (i.e. job ticket) that could be referenced when submitting a job.  I may have misunderstood.
Pete

Peter Zehler

Xerox Research Center Webster
Email: [email-masked]<mailto:[email-masked]>
Voice: (585) 265-8755
FAX: (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701

From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael Sweet
Sent: Monday, January 27, 2014 1:56 PM
To: Norbert Schade
Cc: [email-masked]
Subject: Re: [IPP] named services

Norbert,

On Jan 27, 2014, at 1:23 PM, Norbert Schade <[email-masked]<mailto:[email-masked]>> wrote:

From: Norbert Schade

Norbert,

Norbert Schade

Conexant E-mail Firewall (Conexant.Com<http://conexant.com/>) made the following annotations
---------------------------------------------------------------------
********************** Legal Disclaimer ****************************

---

From: Norbert Schade <[email-masked]>
Date: Mon, 27 Jan 2014 11:01:21 -0800

Michael,
I do not see any support for constraints in the SM.
For eSCL I have to provide a set of PlatenInputCaps and at least one AdfInputCaps.
One way to get out of that dilemma is to provide two full scan device descriptions -> two services.
If I do it that way we have to tell our MFP LCD which of the services (resp sets of caps) is default. Or just go by alphabetical order and show the first or something similar.
Norbert

Norbert,

From: Norbert Schade

Norbert,

Norbert Schade

---

From: Michael Sweet <[email-masked]>
Date: Mon, 27 Jan 2014 14:06:28 -0500

Norbert,

IPP does have a notion of constraints (job-constraints-supported and job-resolvers-supported); I don't know whether the SM has incorporated those yet or not.

---

From: Ira McDonald <[email-masked]>
Date: Mon, 27 Jan 2014 14:10:55 -0500

Hi Norbert,

Look at "JobConstraintsSupported" and "JobResolversSupported" in
SM "ServiceTypes.xsd"

Cheers,
- Ira

On Mon, Jan 27, 2014 at 2:06 PM, Michael Sweet <[email-masked]> wrote:

> Norbert,
>
> IPP does have a notion of constraints (job-constraints-supported and
> job-resolvers-supported); I don't know whether the SM has incorporated
> those yet or not.
>
>
> If I do it that way we have to tell our MFP LCD which of the services
> (resp sets of caps) is default. Or just go by alphabetical order and show
> the first or something similar.
>
> Norbert
>
>
>
> *From:* Michael Sweet [mailto:[email-masked] <[email-masked]>]
> *Sent:* Monday, January 27, 2014 1:56 PM
> *To:* Norbert Schade
> *Cc:* [email-masked]
> Currently there is no notion of a default service in (standard) IPP or the
> SM.  CUPS has a pair of extension operations for getting and setting the
> default printer (and at one point even allowed a server to advertise it as
> a sort-of "default network printer" that clients could prefer, with the
> usual security caveats), however those operations are now rarely used as
> mobile computing has made the notion of a default printer location-specific.
>
>
>
> *From:* Norbert Schade
> *Sent:* Monday, January 27, 2014 12:41 PM
> *To:* 'Michael Sweet'
> *Cc:* [email-masked]
> *Subject:* RE: [IPP] named services
>
>
>
> ref="ScanServiceDescription"/>
>
>                                                 <xs:element
> ref="ScanServiceStatus"/>
>
>                                                 <xs:any
> *From:* Michael Sweet [mailto:[email-masked] <[email-masked]>]
> Conexant E-mail Firewall (Conexant.Com <http://conexant.com/>) made the
> following annotations

---

From: "Manchala, Daniel" <[email-masked]>
Date: Mon, 27 Jan 2014 19:12:03 +0000

Yes, both JobResolversSupported and JobConstraintsSupported have been incorporated in SM.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael Sweet
Sent: Monday, January 27, 2014 11:06 AM
To: Norbert Schade
Cc: [email-masked]
Subject: Re: [IPP] named services

Norbert,

On Jan 27, 2014, at 2:01 PM, Norbert Schade <[email-masked]<mailto:[email-masked]>> wrote:

Michael,

Norbert,

From: Norbert Schade

Norbert,

Norbert Schade

---

From: Norbert Schade <[email-masked]>
Date: Mon, 27 Jan 2014 11:13:43 -0800

I'll check, thanks for your feedback.

From: Manchala, Daniel [mailto:[email-masked]]
Sent: Monday, January 27, 2014 2:12 PM
To: 'Michael Sweet'; Norbert Schade
Cc: [email-masked]'
Subject: RE: [IPP] named services

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Michael Sweet
Sent: Monday, January 27, 2014 11:06 AM
To: Norbert Schade
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [IPP] named services

Norbert,

Michael,

Norbert,

From: Norbert Schade

Norbert,

Norbert Schade

---

From: Norbert Schade <[email-masked]>
Date: Mon, 27 Jan 2014 11:23:16 -0800

The version I'm working with (1.185) does list a JobResolversSupported object as an extension of ImagingServicesDescriptionType within the print service, not within the scan service (that extension is much shorter).
Is there a merge of some sort going on right now?

Norbert,

Michael,

Norbert,

From: Norbert Schade

Norbert,

Norbert Schade

---

From: "Manchala, Daniel" <[email-masked]>
Date: Mon, 27 Jan 2014 19:31:52 +0000

Norman,

Yes, we are looking into consolidating common attributes in all imaging services - maybe into PwgCommon.xsd. Right now, both "JobResolversSupported" and "JobConstraintsSupported" are in ServiceTypes.xsd (as Ira mentioned, and perhaps my email crossed with his).

Daniel.

From: Norbert Schade [mailto:[email-masked]]
Sent: Monday, January 27, 2014 11:23 AM
To: Manchala, Daniel; 'Michael Sweet'
Cc: [email-masked]'
Subject: RE: [IPP] named services

Norbert,

Michael,

Norbert,

From: Norbert Schade

Norbert,

Norbert Schade