Subject: [IPP] IPPScan vs IPPSIX issue for "document-format-accepted

From: "Zehler, Peter" <[email-masked]>
Date: Mon, 10 Feb 2014 18:00:15 +0000

All,

In IPP Scan the "document-format-accepted" operational attribute is an ordered list of the preferred document format for the Scan Service to emit for the Documents within a Job.  The default behavior for this attribute, if left unspecified, will be to emit the Document data in the format specified by the "document-format-default"
In IPP SIX no mention is made of the list being ordered.  The default value in IPP Scan is "document-format-default" whereas the default value in IPP SIX is "document-format-supported".  (That does not make sense to me.)

I have changes the IPP Scan operational attribute name to "scan-output-document-format-accepted"

Pete

Peter Zehler

Xerox Research Center Webster
Email: [email-masked]<mailto:[email-masked]>
Office: +1 (585) 265-8755
Mobile: +1 (585) 329-9508
FAX: +1 (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701

IPP Scan:
8.1.1    scan-output-document-format-accepted" (1 set of mimeMediaType)
The OPTIONAL "scan-output-document-format-accepted" operation attribute SHOULD be supplied by the client.  It identifies the acceptable formats of the Document data to be emitted by the IPP Scan Service for the Job. It is an ordered list starting with the preferred format.  The IPP Scan Service MUST use the first supported value in the list. The default value that MUST be used, if left unspecified by the request, is the value of the "document-format-default".
IPP SIX:
The Proxy OPTIONALLY supplies this attribute. The Infrastructure Printer MUST support this attribute. It identifies the acceptable formats of the Document data to fetch. The default is the value of the "document-format-supported" Printer attribute reported by the Proxy in a previous Set-Output-Device-Attributes (section 5.7) request.
_________________________________________________________________

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 10 Feb 2014 13:33:25 -0500

Pete,

I will make sure to update the definition of document-format-accepted to state it is an ordered list of formats to accept.

The default value can be operation-specific, so I don't see the need to create a new operation attribute just for scan - let's keep it document-format-accepted for both IPPSIX and IPP Scan and document the default value in the corresponding operations that use it.

Thanks!

On Feb 10, 2014, at 1:00 PM, Zehler, Peter <[email-masked]> wrote:

> All,
>  
> In IPP Scan the “document-format-accepted” operational attribute is an ordered list of the preferred document format for the Scan Service to emit for the Documents within a Job.  The default behavior for this attribute, if left unspecified, will be to emit the Document data in the format specified by the "document-format-default"
> I have changes the IPP Scan operational attribute name to “scan-output-document-format-accepted”
>  
> Pete
>  
> Peter Zehler
> 
> Email: [email-masked]
> 8.1.1    scan-output-document-format-accepted” (1 set of mimeMediaType)
> The OPTIONAL “scan-output-document-format-accepted” operation attribute SHOULD be supplied by the client.  It identifies the acceptable formats of the Document data to be emitted by the IPP Scan Service for the Job. It is an ordered list starting with the preferred format.  The IPP Scan Service MUST use the first supported value in the list. The default value that MUST be used,  if left unspecified by the request, is the value of the "document-format-default". 
> IPP SIX:

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Ira McDonald <[email-masked]>
Date: Mon, 10 Feb 2014 17:49:37 -0500

Hi,

I concur with Mike about common use of document-format-accepted and
operation/service-specific defaults for document-format.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Mon, Feb 10, 2014 at 1:33 PM, Michael Sweet <[email-masked]> wrote:

> Pete,
>
> I will make sure to update the definition of document-format-accepted to
> state it is an ordered list of formats to accept.
>
> The default value can be operation-specific, so I don't see the need to
> create a new operation attribute just for scan - let's keep it
> document-format-accepted for both IPPSIX and IPP Scan and document the
> default value in the corresponding operations that use it.
>
> Thanks!
>
>
> In IPP Scan the "document-format-accepted" operational attribute is an
> *ordered* list of the preferred document format for the Scan Service to
> emit for the Documents within a Job.  The default behavior for this
> attribute, if left unspecified, will be to emit the Document data in the
> format specified by the "document-format-default"
>
> In IPP SIX no mention is made of the list being ordered.  The default
> value in IPP Scan is "document-format-default" whereas the default value in
> IPP SIX is "document-format-supported".  (That does not make sense to me.)
>
>
>
> The OPTIONAL "scan-output-document-format-accepted" operation attribute
> SHOULD be supplied by the client.  It identifies the acceptable formats of
> the Document data to be emitted by the IPP Scan Service for the Job. It is
> an ordered list starting with the preferred format.  The IPP Scan Service
> MUST use the first supported value in the list. The default value that MUST
> be used, if left unspecified by the request, is the value of the
> "document-format-default".
>
> IPP SIX:
>
> The Proxy OPTIONALLY supplies this attribute. The Infrastructure Printer
> MUST support this attribute. It identifies the acceptable formats of the
> Document data to fetch. The default is the value of the
> "document-format-supported" Printer attribute reported by the Proxy in a
> previous Set-Output-Device-Attributes (section 5.7) request.
>