Subject: [IPP] Potential errata/update for PWG Raster Format and/or IPP Everywhere specs

From: Michael Sweet <[email-masked]>
Date: Wed, 21 May 2014 09:42:16 -0400

All,

It has come to my attention that neither the IPP Everywhere nor the PWG Raster Format specs explicitly call out required values for the "pdl-override-supported" Printer attribute. This attribute specifies whether the Printer can override embedded job ticket information (such as media size) when requested in a Job via the "ipp-attribute-fidelity" or "job-mandatory-attributes" Job Template attributes.

Generally speaking, Printers SHOULD support PDL override for the standard PDLs in IPP Everywhere, including PWG Raster, JPEG, and PDF.  Typically this means forcing prints to a single media/size or forcing simplex/duplex output, and is particularly important for JPEG.

My recommendation is for us to add the following conformance statement in a future revision of the IPP Everywhere specification:

    pdl-override-supported (type2 keyword)

    When reporting capabilities for the 'application/pdf', 'image/jpeg', or 'image/pwg-raster'
    MIME media types, Printers MUST report either 'attempted' or 'guaranteed' for the
    "pdl-override-supported" Printer attribute, 

Thoughts?

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Wed, 21 May 2014 15:22:05 +0000

Hi Mike,

Since “attempted” is so squishy, why not mandate “guaranteed”?  Including “attempted” seems like a loophole.

Smith

/**
    Smith Kennedy
    ATB Wireless Architect - PPS
    Hewlett-Packard Co.
*/

---

From: Michael Sweet <[email-masked]>
Date: Wed, 21 May 2014 11:36:55 -0400

Smith,

> Since “attempted” is so squishy, why not mandate “guaranteed”?  Including “attempted” seems like a loophole.

If there is sufficient support for "guaranteed", then certainly.  But I have yet to see a printer report "guaranteed"...

---

From: Ira McDonald <[email-masked]>
Date: Wed, 21 May 2014 11:42:28 -0400

Hi Smith,

We've never made "pdl-override-supported" have 'guaranteed' as REQUIRED
(even in IPP/2.1 or IPP/2.2 levels), because it's binary.

If you claim that your Printer supports 'guaranteed' then you have to be
able to
*successfully* intercept and override everything in your interpreters
(vanishingly
unlikely in PDF, for example).

I agree with Mike that I've never seen a printer in the wild that actually
supported
'guaranteed'.

I also agree that should make 'attempted' a REQUIRED value and 'guaranteed'
a RECOMMENDED value (explaining in the Implementors Guide that there are
practical limitations w/ third-party interpreters to perfect override).

Cheers,
- Ira

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Wed, May 21, 2014 at 11:22 AM, Kennedy, Smith (Wireless Architect) <
[email-masked]> wrote:

> > It has come to my attention that neither the IPP Everywhere nor the PWG
> Raster Format specs explicitly call out required values for the
> "pdl-override-supported" Printer attribute. This attribute specifies
> whether the Printer can override embedded job ticket information (such as
> media size) when requested in a Job via the "ipp-attribute-fidelity" or
> "job-mandatory-attributes" Job Template attributes.
> >
> > Generally speaking, Printers SHOULD support PDL override for the
> standard PDLs in IPP Everywhere, including PWG Raster, JPEG, and PDF.
>  Typically this means forcing prints to a single media/size or forcing
> simplex/duplex output, and is particularly important for JPEG.
> >
> > My recommendation is for us to add the following conformance statement
> in a future revision of the IPP Everywhere specification:
> >

---

From: "William A Wagner" <[email-masked]>
Date: Wed, 21 May 2014 12:26:36 -0400

As Ira suggests, I believe that it is very difficult to “guarantee” successful override, considering the potential complexity and variations in the PDL.  But ‘attempted’ is squishy  and making it REQUIRED  might tempt some to report ‘attempted’ even when the attempt is halfhearted (or non-existent). That would make the value even more unreliable. Perhaps we should have allowed a value of ‘best effort’  meaning that the printer will really try. But I think making ‘attempted’ a minimum REQUIRED response may just increase uncertainty. Better that the User understand that he is stuck with what is in the PDL  if there is not  very good likelihood that  the overrides will be completely successful.

Thanks,

Bill Wagner

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ira McDonald
Sent: Wednesday, May 21, 2014 11:42 AM
To: Kennedy, Smith (Wireless Architect); Ira McDonald
Cc: <[email-masked]>
Subject: Re: [IPP] Potential errata/update for PWG Raster Format and/or IPP Everywhere specs

Hi Smith,

If you claim that your Printer supports 'guaranteed' then you have to be able to
*successfully* intercept and override everything in your interpreters (vanishingly 
unlikely in PDF, for example).

I agree with Mike that I've never seen a printer in the wild that actually supported

'guaranteed'.

Cheers,

- Ira

Cheers,

- Ira

 <http://sites.google.com/site/blueroofmusic> http://sites.google.com/site/blueroofmusic
 <http://sites.google.com/site/highnorthinc> http://sites.google.com/site/highnorthinc

On Wed, May 21, 2014 at 11:22 AM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:

Hi Mike,

Smith

/**
    Smith Kennedy

---

From: Ira McDonald <[email-masked]>
Date: Wed, 21 May 2014 12:48:08 -0400

Hi,

I agree with Bill's comments.

I suggest that the Implementors Guide should document that the intended
meaning of 'attempted' in RFC 2911 was and is 'best-effort'.  There is no
wiggle room in RFC 2911 (page 139), in my reading, that the Printer can
say 'attempted' and then NOT make the attempt.

I agree that making 'attempted' REQUIRED is cold comfort to Clients.

I suggest that the definition of 'guaranteed' (NOT defined in RFC 2911,
but rather in section 11 of JSP2, PWG 5100.11-2010) is so convoluted
that it is not practical to implement.

Cheers,
- Ira

On Wed, May 21, 2014 at 12:26 PM, William A Wagner <[email-masked]>wrote:

> As Ira suggests, I believe that it is very difficult to “guarantee”
> successful override, considering the potential complexity and variations in
> the PDL.  But ‘attempted’ is squishy  and making it REQUIRED  might tempt
> some to report ‘attempted’ even when the attempt is halfhearted (or
> non-existent). That would make the value even more unreliable. Perhaps we
> should have allowed a value of ‘best effort’  meaning that the printer will
> really try. But I think making ‘attempted’ a minimum REQUIRED response may
> just increase uncertainty. Better that the User understand that he is stuck
> with what is in the PDL  if there is not  very good likelihood that  the
> overrides will be completely successful.
>
> Thanks,
>
> Bill Wagner
>
>
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *Ira
> McDonald
> *Sent:* Wednesday, May 21, 2014 11:42 AM
> *To:* Kennedy, Smith (Wireless Architect); Ira McDonald
> *Cc:* <[email-masked]>
> *Subject:* Re: [IPP] Potential errata/update for PWG Raster Format and/or
> IPP Everywhere specs
>
>
>
> Hi Smith,
>

---

From: Michael Sweet <[email-masked]>
Date: Wed, 21 May 2014 13:34:06 -0400

Ira,

> say 'attempted' and then NOT make the attempt.

The wiggle room is that the printer can make the attempt and fail, leading to inconsistent results and (likely) no logging of/state changes for the issue. But if we can document things properly in the Implementor's Guide I think we'll be in a lot better shape.

FWIW, I don't think it would be hard to support 'guaranteed' for JPEG or PWG Raster, but PDF is another matter... :/

(and older PDLs like PostScript and PCL are a lost cause for that sort of thing...)

---

From: "Zehler, Peter" <[email-masked]>
Date: Wed, 21 May 2014 18:05:30 +0000

All,
I don’t believe that that the definition of 'guaranteed'  is so convoluted that it is not practical to implement.  It is implemented in some high end production environments.  I believe that 'guaranteed' value is applicable to a small segment of the printing market and not applicable to the IPP everywhere or PWG Raster discussion.
Pete

Peter Zehler

Xerox Research Center Webster
Email: [email-masked]<mailto:[email-masked]>
Office: +1 (585) 265-8755
Mobile: +1 (585) 329-9508
FAX: +1 (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ira McDonald
Sent: Wednesday, May 21, 2014 12:48 PM
To: William A Wagner; Ira McDonald
Cc: [email-masked]
Subject: Re: [IPP] Potential errata/update for PWG Raster Format and/or IPP Everywhere specs

Hi,

mailto: [email-masked]<mailto:[email-masked]>

On Wed, May 21, 2014 at 12:26 PM, William A Wagner <[email-masked]<mailto:[email-masked]>> wrote:
As Ira suggests, I believe that it is very difficult to “guarantee” successful override, considering the potential complexity and variations in the PDL.  But ‘attempted’ is squishy  and making it REQUIRED  might tempt some to report ‘attempted’ even when the attempt is halfhearted (or non-existent). That would make the value even more unreliable. Perhaps we should have allowed a value of ‘best effort’  meaning that the printer will really try. But I think making ‘attempted’ a minimum REQUIRED response may just increase uncertainty. Better that the User understand that he is stuck with what is in the PDL  if there is not  very good likelihood that  the overrides will be completely successful.
Thanks,
Bill Wagner

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Ira McDonald
Sent: Wednesday, May 21, 2014 11:42 AM
To: Kennedy, Smith (Wireless Architect); Ira McDonald
Cc: <[email-masked]<mailto:[email-masked]>>
Subject: Re: [IPP] Potential errata/update for PWG Raster Format and/or IPP Everywhere specs

Hi Smith,

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]<mailto:[email-masked]>
Winter  579 Park Place  Saline, MI  48176  734-944-0094<tel:734-944-0094>
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434<tel:906-494-2434>

On Wed, May 21, 2014 at 11:22 AM, Kennedy, Smith (Wireless Architect) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Mike,

Smith

/**
    Smith Kennedy

On 2014-05-21, at 7:42 AM, Michael Sweet <[email-masked]<mailto:[email-masked]>> wrote:

> [email-masked]<mailto:[email-masked]>

_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Wed, 21 May 2014 15:23:39 -0400

Hi Pete,

But what Mike just said is that it is feasible to implement 'guaranteed'
for PWG Raster and JPEG, but hard for PDF, PostScript, PCL, etc.

I agree with Mike.  There are a lot of embedded processing features
in these "higher-level" PDLs that mean really supporting 'guaranteed'
requires access to (and probably modification of) the source code of
the PDL interpreters.

And 'attempted' isn't a useful feature (for Clients), because it's basically
unreliable.

Although one could do tricks with Client submitting a Job on hold and
Printer sending "successful-ok-ignored-or-substituted-attributes" (so
that the client could tell that the override was partial and WHERE it
wasn't performed).

Cheers,
- Ira

On Wed, May 21, 2014 at 2:05 PM, Zehler, Peter <[email-masked]>wrote:

>  All,
>
> I don’t believe that that the definition of 'guaranteed'  is so convoluted
> that it is not practical to implement.  It is implemented in some high end
> production environments.  I believe that 'guaranteed' value is applicable
> to a small segment of the printing market and not applicable to the IPP
> everywhere or PWG Raster discussion.
>
> Pete
>
>
>
> Peter Zehler
>
> Email: [email-masked]
> *Sent:* Wednesday, May 21, 2014 12:48 PM
> *To:* William A Wagner; Ira McDonald
>
> *Cc:* [email-masked]

---

From: Michael Sweet <[email-masked]>
Date: Wed, 21 May 2014 16:23:52 -0400

Ira,

On May 21, 2014, at 3:23 PM, Ira McDonald <[email-masked]> wrote:
> ...

... and in cases where job hold/release is not supported, the xxx-actual attributes can be used to track things as well - I think Smith already says something about this in the 'guide.  Of course, that presumes that the IPP Printer has access to the values used by the PDL for a given job - probably more likely than being able to do PDL override from my experience, but still not 'guaranteed' (there's that word again...)

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Wed, 21 May 2014 20:33:44 +0000

> ... and in cases where job hold/release is not supported, the xxx-actual attributes can be used to track things as well - I think Smith already says something about this in the 'guide.  Of course,…

And as we have discussed, since the Printer doesn’t bind values to xxx-actual until processing time or perhaps slightly earlier in some cases, this is basically “after the fact”.  This may tell the Client whether something was used or not, but doesn’t allow the Client to try to do something about it or have a sense before processing of what will happen at processing time.

Smith

---

From: Ira McDonald <[email-masked]>
Date: Fri, 23 May 2014 11:21:44 -0400

Hi Smith,

Actually, the Printer doesn't have to bind values to "xxx-actual" until the
Job
completes.

This reply is not about 'guaranteed'.

This reply is about the usability of 'attempted'.

An IPP Client could use Validate-Job with "document-format" and
"pdl-override" and,
when it receives the response that says ignored or substituted, examine the
values
of "preferred-attributes" (from JPS3, PWG 5100.13-2012) to find out the
extent to
which the Printer *could* and *could not* successfully 'attempt' to do the
overrides.

The IPP Client wants to know if the particular PDL interpreter is
instrumented to
support overrides, not that any particular (unsent) document data actually
contains,
for example, "number-up" (which the client can't know if it didn't generate
the
document data).

Mike - I think this is a useful idea - WDYT?

Cheers,
- Ira

On Wed, May 21, 2014 at 4:33 PM, Kennedy, Smith (Wireless Architect) <
[email-masked]> wrote:

> ... and in cases where job hold/release is not supported, the xxx-actual
> attributes can be used to track things as well - I think Smith already says
> something about this in the 'guide.  Of course, that presumes that the IPP
> Printer has access to the values used by the PDL for a given job - probably
> more likely than being able to do PDL override from my experience, but
> still not 'guaranteed' (there's that word again...)
>
>
> And as we have discussed, since the Printer doesn’t bind values to
> xxx-actual until processing time or perhaps slightly earlier in some cases,
> this is basically “after the fact”.  This may tell the Client whether
> something was used or not, but doesn’t allow the Client to try to do
> something about it or have a sense before processing of what will happen at
> processing time.
>
> Smith
>