Subject: [IPP] MIME attachments in IPP

From: "Zehler, Peter" <[email-masked]>
Date: Fri, 13 Jun 2014 11:50:10 +0000

All,
I just wanted to check that IPP uses HTTP chunking and that the document data is inline in the request and not in a separate MIME attachment. I was asked and I don't see anything in the encoding specification that puts the data in a MIME attachment.  I think WS-Print/scan did it that way.  The confusion is over the Get-Next-Document-Images operation that  includes

-----------------------------------------------
Group 3: Document content

The document content is sent as a MIME attachment. Note that the IPP Scan Client
MUST be ready to accept a chunked response.
-----------------------------------------------

I think I should strike the clause "The document content is sent as a MIME attachment."

Pete

Peter Zehler

[parc]
Email: [email-masked]<mailto:[email-masked]>
Office: +1 (585) 265-8755
Mobile: +1 (585) 329-9508
FAX: +1 (585) 265-7441
US Mail: Peter Zehler
Palo Alto Research Center Incorporated
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Fri, 13 Jun 2014 10:38:05 -0400

Pete,

On Jun 13, 2014, at 7:50 AM, Zehler, Peter <[email-masked]> wrote:

> All,
> I just wanted to check that IPP uses HTTP chunking and that the document data is inline in the request and not in a separate MIME attachment.

Correct, application/ipp allows for trailing document data, per RFC 2910/2911.  This better allows for alternate transports (although the focus is obviously on HTTP).

>  I was asked and I don’t see anything in the encoding specification that puts the data in a MIME attachment.  I think WS-Print/scan did it that way.  The confusion is over the Get-Next-Document-Images operation that  includes
>  
> I think I should strike the clause “The document content is sent as a MIME attachment.”

Right, we should just say that the document content follows the end-of-attributes-tag.  You can probably steal the Print-Job example from RFC 2910 (http://tools.ietf.org/html/rfc2910#page-33).

> Pete
>  
> Peter Zehler
> 
> Email: [email-masked]

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair