Subject: [IPP] "job-password-encryption-supported" - PWG specifications mandating support for specific keywords?

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Wed, 25 Jun 2014 11:43:33 +0000

Greetings,

I was looking at the “job-password-encryption-supported” attribute definition in 5100.11 and also looking at 5100.14 (IPP Everywhere) to see if there was some normative language requiring support for specific keywords.  But I couldn’t seem to find anywhere that mandates specific keyword support if the attribute is implemented.  IPP Everywhere just says this in section 9.3:
> Printers that support the Print to a Recipient use case (section 3.2.2.8) MUST support:
> 
> The"job-password-supported"and"job-password-encryption-supported"Printer Description attributes as defined in section 5.3, and
> 
> The"job-password"and"job-password-encryption"Operationattributesas defined in section 5.4. 
> 

The referenced sections don’t call out keyword values.  So is there nowhere that says basically ‘if you support “job-password-encryption-supported” you MUST support the following keywords’?

Thanks for any help,

Smith

/**
    Smith Kennedy
    Hewlett-Packard Co.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Wed, 25 Jun 2014 07:59:14 -0400

Smith,

Correct, we haven't required a specific hash algorithm.

My own personal experience is that "none" is widely supported for PIN printing.  I haven't seen the other algorithms used at all.

> The referenced sections don’t call out keyword values.  So is there nowhere that says basically ‘if you support “job-password-encryption-supported” you MUST support the following keywords’?

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair