Subject: [IPP] IPP Finishings 2.0: "finishings-col-database"

From: Michael Sweet <[email-masked]>
Date: Wed, 18 Jun 2014 11:21:17 -0400

All,

My prototype experience shows that "pre-composed" finishing operations selected using the finishing-template member attribute are the most important/useful for non-expert UI.

Since finishings-col-ready is defined to list only those finishing operations that are available at any given time, I would like to propose adding a "finishings-col-database" attribute that holds all of the named finishing operations that are configured on a given Printer - this would provide a necessary vendor and site configuration attribute, with the finishings-col-ready attribute reflecting which finishing operations are possible based on the current subunit state.

Your comments are appreciated!

....

The added text is:

6.9 finishings-col-database (1setOf collection)

The RECOMMENDED "finishings-col-database" Printer attribute lists the "finishings-col" member attributes corresponding to each "finishing-template" value. For example, a Printer that supports the 'staple' value might report:

    finishings-col-database={
        finishing-template='staple'
        stitching={
            stitching-locations=635
            stitching-offset=635
            stitching-reference-edge='left'
        }
    }

The same values SHOULD be reported in the "finishings-col-ready" Printer attribute for each finisher sub-unit that is available.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Thu, 19 Jun 2014 10:28:54 -0400

Hi Mike,

I like "finishings-col-database".

I agree that this is necessary for practical non-expert use of pre-composed
finishings options.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Wed, Jun 18, 2014 at 11:21 AM, Michael Sweet <[email-masked]> wrote:

> All,
>
> My prototype experience shows that "pre-composed" finishing operations
> selected using the finishing-template member attribute are the most
> important/useful for non-expert UI.
>
> Since finishings-col-ready is defined to list only those finishing
> operations that are available at any given time, I would like to propose
> adding a "finishings-col-database" attribute that holds all of the named
> finishing operations that are configured on a given Printer - this would
> provide a necessary vendor and site configuration attribute, with the
> finishings-col-ready attribute reflecting which finishing operations are
> possible based on the current subunit state.
>
> The RECOMMENDED "finishings-col-database" Printer attribute lists the
> "finishings-col" member attributes corresponding to each
> "finishing-template" value. For example, a Printer that supports the
> 'staple' value might report:
>
> The same values SHOULD be reported in the "finishings-col-ready" Printer
> attribute for each finisher sub-unit that is available.
>

---

From: "Paul Tykodi" <[email-masked]>
Date: Thu, 19 Jun 2014 13:15:55 -0400

Hi Mike and Ira,

In my experience, Finishing options have always been one of the areas in device specific printer drivers with significant UI constraint entries. What I really like about this proposal is that it fully supports our IPP Everywhere work to significantly reduce the need for device specific drivers in that it allows the device to effectively advertise all of the current UI constraint information typically contained in a device specific driver via the IPP defined finishings-col-ready attribute.

Nice work!

Best Regards,

/Paul

--

Paul Tykodi
Principal Consultant
TCS - Tykodi Consulting Services LLC

Tel/Fax: 603-343-1820
Mobile:  603-866-0712
E-mail:  [email-masked]
WWW:   <http://www.tykodi.com/> http://www.tykodi.com

This e-mail reply and any attachments are confidential and may be privileged.

If you are not the intended recipient, please notify Tykodi Consulting Services LLC 

immediately by replying to this message and destroying all copies of this message 

and any attachments. Thank you

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ira McDonald
Sent: Thursday, June 19, 2014 10:29 AM
To: Michael Sweet; Ira McDonald
Cc: <[email-masked]>
Subject: Re: [IPP] IPP Finishings 2.0: "finishings-col-database"

Hi Mike,

finishings options.

Cheers,

- Ira

 <http://sites.google.com/site/blueroofmusic> http://sites.google.com/site/blueroofmusic
 <http://sites.google.com/site/highnorthinc> http://sites.google.com/site/highnorthinc

All,

....

The added text is: