Subject: Re: [IPP] Fwd: [Printing-architecture] pwgtoraster vs calibrated spaces

From: Michael Sweet <[email-masked]>
Date: Mon, 02 Jun 2014 07:50:01 -0400

Ira,

The gamma value 2.2 is an approximation for sRGB, and since sGray has never been formally defined we went with "just like sRGB just grayscale".  The following plot shows a gamma 2.2 line (dotted blank line) against the sRGB curve (solid red line). You'll notice that the values are almost exactly the same.

	http://en.wikipedia.org/wiki/File:SRGB_gamma.svg

A search for any specifications on sGray turns up nothing, and all of the other "hits" on the term points to sGray using the same transfer curve as sRGB.

So I'd be interested in seeing what reference James is referring to, because *I* haven't seen it and the CUPS raster definition goes back quite a few years...

On May 31, 2014, at 10:46 AM, Ira McDonald <[email-masked]> wrote:

> Hi Mike,
> 
> From Open Printing mailing list - apparent discrepancy in 
> PWG Raster spec definition for "sGray".
> 
> Please take a look at this.
> 
> Cheers,
> - Ira
> 
> 
> ---------- Forwarded message ----------
> From: James Cloos <[email-masked]>
> Date: Sat, May 31, 2014 at 5:30 AM
> Subject: [Printing-architecture] pwgtoraster vs calibrated spaces
> To: [email-masked]
> 
> 
> I was wrong about sGray.  It turns out that sGray is not defined as
> having the same curve as sRGB, but rather it always has gamma 2.2.
> 
> The cupsraster document says srgb gamma/whitepoint, and the pwg raster
> doc says srgb grayscale.  But everything else I've found says 2.2.
> And it seems a D50 illuminate.
> 
> That being said, this colorspace dictionary:
> 
> [ /CalGray
>   <<  /WhitePoint [ 0.96420288 1.0 0.82490540 ]
>       /Gamma 2.2
>   >>
> ]
> 
> in stead of /DeviceGray should work for converting sGray pages to pdf.
> 
> For AdobeRGB, you can use this:
> 
> [ /CalRGB
>   << /WhitePoint [ 0.95045471 1.0 1.08905029 ]
>      /Gamma [ 2.2 2.2 2.2 ]
>   >>
> endobj
> 
> For sRGB, though, you'll have to embed the icc file.
> 
> AFAICT, put the space in an object and specify a ref to that object
> where you currently specify /DeviceRGB, usw.
> 
> -JimC
> --
> James Cloos <[email-masked]>         OpenPGP: 0x997A9F17ED7DAEA6
> _______________________________________________
> Printing-architecture mailing list
> [email-masked]
> https://lists.linuxfoundation.org/mailman/listinfo/printing-architecture
> 
> _______________________________________________
> ipp mailing list
> [email-masked]
> https://www.pwg.org/mailman/listinfo/ipp

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: James Cloos <[email-masked]>
Date: Mon, 02 Jun 2014 19:57:03 -0400

We wrote a bit today about this.

My searches showed several 2.2 gamma icc files and discussion about
printing black-white photographs which also said 2.2.

Today, using the string Mike mentioned I found one sGray.icc which is
not a 2.2, but most still match gs's.

Since I brought it up, I will create one for cups-filters, using the
sRGB curve.

I *think* this works:  (verification appreciated)

-JimC