Subject: [IPP] Request to have 2 new keywords defined for "output-bin": 'job-separator' and 'collator'

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Tue, 8 Jul 2014 17:19:20 +0000

Greetings,

Hewlett-Packard would like to request that 2 new keywords be defined for the “output-bin” attribute defined in PWG 5100.2: ‘job-separator’ and ‘collator’.  Each of them are described below.

‘job-separator’
Jobs are delivered to an available (empty) output bin (a job can include the original and its copies), starting from the top bin and continuing to the bottom bin. If no bins are empty, a job is delivered first to the top bin and, if the top bin is full, then to subsequent bins, continuing to the bottom bin. The bin that the job is sent to is considered the destination bin. When the Job Separator mode is selected, you cannot select which bin to send your job to.

’collator’
Each copy of a single print or copy job is delivered to a separate output bin, starting with the top bin and continuing to the bottom bin. When a copy is delivered to the lowest bin, the next copy is delivered to the top bin and the delivery process is repeated. When this mode is selected, you cannot select which bin to send your job to.

Please reply with any comments or questions.  We can discuss these briefly in the next IPP WG con call,

Cheers,
Smith

/**
    Smith Kennedy
    Hewlett-Packard Co.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Wed, 09 Jul 2014 16:40:21 -0400

No objections here, although the descriptions could be made simpler and less tied to a particular implementation, e.g.:

    'job-separator'; All of the output for the job is placed in an empty output tray. If no trays are empty, the Printer chooses an output tray in an implementation-defined manner.

    'collator'; Each copy is placed in an empty output tray. If all trays are full, the Printer cycles through each of the trays in an implementation-defined manner.

Since you can only specify one "output-bin" value, I don't think you need the "When this mode is selected" user manual verbiage.

> Please reply with any comments or questions.  We can discuss these briefly in the next IPP WG con call,

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Wed, 9 Jul 2014 21:01:19 +0000

Fair enough.  :)  How about this:

‘job-separator’
Jobs are delivered to an available (empty) output bin, starting from the top bin and continuing to the bottom bin. If no bins are empty, a job is delivered first to the top bin and, if the top bin is full, then to subsequent bins, continuing to the bottom bin.

’collator’
Each copy of a single print or copy job is delivered to a separate output bin, starting with the top bin and continuing to the bottom bin. When a copy is delivered to the lowest bin, the next copy is delivered to the top bin and the delivery process is repeated.

Smith

---

From: Michael Sweet <[email-masked]>
Date: Wed, 09 Jul 2014 17:20:12 -0400

I'm still not sure about the explicit ordering (top to bottom); let's see if others have a problem with it...

(also, "or copy job" doesn't make sense since we have no copy service in IPP...)

---

From: Ira McDonald <[email-masked]>
Date: Wed, 9 Jul 2014 17:39:41 -0400

Hi Smith,

I agree with Mike's much simpler definitions.

I don't like this explicit ordering from "top" to "bottom" bin, because
it's hardware architecture specific and doesn't even mean anything
if the only two bins are side by side (they sometimes are).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Wed, Jul 9, 2014 at 5:20 PM, Michael Sweet <[email-masked]> wrote:

> Jobs are delivered to an available (empty) output bin, starting from the
> top bin and continuing to the bottom bin. If no bins are empty, a job is
> delivered first to the top bin and, if the top bin is full, then to
> subsequent bins, continuing to the bottom bin.
>
> ’collator’
> Each copy of a single print or copy job is delivered to a separate output
> bin, starting with the top bin and continuing to the bottom bin. When a
> copy is delivered to the lowest bin, the next copy is delivered to the
> top bin and the delivery process is repeated.
>
>
>
> Smith
>
>
>
> No objections here, although the descriptions could be made simpler and
> less tied to a particular implementation, e.g.:
>
>     'job-separator'; All of the output for the job is placed in an empty
> output tray. If no trays are empty, the Printer chooses an output tray in
> an implementation-defined manner.
>
>     'collator'; Each copy is placed in an empty output tray. If all trays
> are full, the Printer cycles through each of the trays in an
> implementation-defined manner.
>
> Since you can only specify one "output-bin" value, I don't think you need
> the "When this mode is selected" user manual verbiage.
>
>
> Hewlett-Packard would like to request that 2 new keywords be defined for
> the “output-bin” attribute defined in PWG 5100.2: ‘job-separator’ and
> ‘collator’.  Each of them are described below.
>
> ‘job-separator’
> Jobs are delivered to an available (empty) output bin (a job can include
> the original and its copies), starting from the top bin and continuing to
> the bottom bin. If no bins are empty, a job is delivered first to the top
> bin and, if the top bin is full, then to subsequent bins, continuing to the
> bottom bin. The bin that the job is sent to is considered the destination
> bin. When the Job Separator mode is selected, you cannot select which bin
> to send your job to.
>
> ’collator’
> Each copy of a single print or copy job is delivered to a separate output
> bin, starting with the top bin and continuing to the bottom bin. When a
> copy is delivered to the lowest bin, the next copy is delivered to the
> top bin and the delivery process is repeated. When this mode is selected,
> you cannot select which bin to send your job to.
>

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Wed, 9 Jul 2014 22:29:20 +0000

I’m fine with going with Mike’s descriptions.

Smith