Subject: [IPP] Reporting loaded custom sizes

From: "Hills, Lee D" <[email-masked]>
Date: Thu, 28 Aug 2014 13:52:53 +0000

Hi,

When I load a custom cut sheet size, say 4.125 x 11 inch, into the multipurpose tray of my printer, which, if any, of the following IPP attributes should the printer report the 'ready' / loaded size in?

media-supported
  custom_current.tray-1_4.125x11in
  custom_min_3x5in, custom_max_8.5x14in

media-ready
  custom_current.tray-1_4.125x11in

media-size-supported
  ...
  { x-dimension 10477 y-dimension 27940}
  { x-dimension 7620-12700 y-dimension 21590-35560 }

media-col-database
  ...
  { media-size {x-dimension 10477 y-dimension 27940} ... }
  { media-size {x-dimension 7620-12700 y-dimension 21590- 35560 } ... }

media-col-ready
  { media-size {x-dimension 10477 y-dimension 27940} ... }

5100.14.pdf says to not include manual feed.  To clarify, this is not a manual feed media.

Lee

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Thu, 28 Aug 2014 10:16:05 -0400

Lee,

On Aug 28, 2014, at 9:52 AM, Hills, Lee D <[email-masked]> wrote:
> Hi,
>  
> When I load a custom cut sheet size, say 4.125 x 11 inch, into the multipurpose tray of my printer, which, if any, of the following IPP attributes should the printer report the ‘ready’ / loaded size in?

We haven't been explicit about this sort of usage, but generally one-off custom sizes (that are created by the printer) should only be reported in the "media*-ready" attributes, while custom sizes created by the user/administrator (i.e. a site-specific form size) that can be loaded in any tray should also get reported in the "media*-supported" and "media-col-database" attributes.  This is because a Client can still specify the custom size using the min/max information in the "media*-supported" and "media-col-database" attributes and can discover the currently loaded media in the "media-ready" and "media-col-ready" attributes.

>   custom_min_3x5in, custom_max_8.5x14in

Don't report the printer-synthesized size in media-supported...

>   custom_current.tray-1_4.125x11in

But *do* report it here.
 
>   { x-dimension 7620-12700 y-dimension 21590-35560 }

Don't report the printer-synthesized size in media-size-supported...

>   { media-size {x-dimension 7620-12700 y-dimension 21590- 35560 } ... }

And don't report the printer-synthesized size in media-col-database...
 
>   { media-size {x-dimension 10477 y-dimension 27940} ... }

But *do* report it here.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair