Subject: [IPP] Collected ABNF for PWG 5100.9 (State) and 5100.13 (JPS3) posted

From: Michael Sweet <[email-masked]>
Date: Tue, 19 Aug 2014 11:54:39 -0400

All,

Since we didn't already have this, I went ahead and extracted the ABNF from 5100.9 and 5100.13 and posted them alongside the MSN ABNF at:

	http://ftp.pwg.org/pub/pwg/informational/pwg5100.9-abnf.txt
	http://ftp.pwg.org/pub/pwg/informational/pwg5100.13-abnf.txt

We'll treat these as authoritative (just as we do for MSN) and I've added these to the list of errata for the specs as well.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Tue, 19 Aug 2014 18:28:07 +0000

Hi Mike,

My ABNF is pretty rusty, but it seems that these enhancements don’t resolve the issues I was discussing with the PWG in earlier email threads to the reflector (“JPS3 “printer-output-tray” - supporting additional optional keywords from”).  We discussed fixing the ABNF to allow arbitrary keys to be allowable by the ABNF for “printer-output-tray”, because there were fields from prtOutputTable that we agreed should also be available or at least encodable, such as prtOutputModel.  That doesn’t seem to be a possibility with this ABNF draft or PWG 5100.13 (JPS3).

It seems like if we were going to support this and we were to limit the size of the custom key to some value (24 in this case) then we would make the following changes or something similar?

output-opt          = output-index /
                      output-unit /
                      output-stacking-order /
                      output-page-delivery /
                      output-offset-stacking /
                      custom-key

; allow a custom key to be 1-24 characters in length, composed of ASCII letters, digits, or “-“
custom-key        = 1ALPHA [*23(DIGIT / ALPHA / “-“)]

Thoughts?

Smith

---

From: Michael Sweet <[email-masked]>
Date: Tue, 19 Aug 2014 14:42:23 -0400

Smith,

On Aug 19, 2014, at 2:28 PM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> Hi Mike,
> 
> My ABNF is pretty rusty, but it seems that these enhancements don’t resolve the issues I was discussing with the PWG in earlier email threads to the reflector (“JPS3 “printer-output-tray” - supporting additional optional keywords from”).

Nope, I haven't tackled extending the ABNF yet.

As for a length limit, I think the size limit of an octetString value (1023 bytes) takes care of that pretty well.  I think we do have some proposed changes for this (either in the meeting minutes or on the mailing list), so as soon as I am caught up (ha!) I'll put together a draft ABNF for folks to review.

---

From: Ira McDonald <[email-masked]>
Date: Tue, 19 Aug 2014 15:32:29 -0400

Hi,

Thanks Mike - I didn't have an ABNF validator when I wrote 5100.9,
so the ABNF is probably got syntax error(s).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, Aug 19, 2014 at 2:42 PM, Michael Sweet <[email-masked]> wrote:

> > My ABNF is pretty rusty, but it seems that these enhancements don’t
> resolve the issues I was discussing with the PWG in earlier email threads
> to the reflector (“JPS3 “printer-output-tray” - supporting additional
> optional keywords from”).
>
> As for a length limit, I think the size limit of an octetString value
> (1023 bytes) takes care of that pretty well.  I think we do have some
> proposed changes for this (either in the meeting minutes or on the mailing
> list), so as soon as I am caught up (ha!) I'll put together a draft ABNF
> for folks to review.
>

---

From: Michael Sweet <[email-masked]>
Date: Tue, 19 Aug 2014 20:01:34 -0400

Ira,

My ABNF parser (on msweet.org) didn't seem to have a problem with it, so I think we're good on the syntax.

The only outstanding issues are ABNF errors for printer-output-tray (some required parameters show up under the optional section) and the extensibility stuff we've talked about before.