Subject: Re: [PWG-Announce] PWG Last Call of IPP Finishings 2.0 (FIN2) (28 July 2014 to 22 August 2014)

From: Ira McDonald <[email-masked]>
Date: Sun, 17 Aug 2014 13:15:33 -0400

Hi,

ENDS THIS FRIDAY 22 August!  Please send your response.

Cheers,
- Ira (IPP WG Co-Chair, PWG Secretary)

On Mon, Jul 28, 2014 at 5:00 PM, Michael Sweet <[email-masked]> wrote:

> All,
>
> [This PWG Last Call starts today, Monday 28 July 2014, and ends Friday, 22
> August 2014 at 10pm US Pacific.]
>
> This is the formal announcement of the PWG Last Call for the IPP
> Finishings 2.0 (FIN2) specification, located at:
>
>         http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings20-20140701.pdf
>
> All required attributes and values defined in this document have been
> prototyped by Apple and/or other vendors. The IPP WG has completed
> extensive review of the various revisions of this document and an IPP WG
> last call.
>
> The PWG Process/3.0 requires that a quorum (30%) of PWG members must
> acknowledge a PWG Last Call (with or without comments), before any document
> can progress to PWG Formal Vote.  This PWG Last Call is NOT a Formal Vote
> but it DOES require your review acknowledgment.
>
>
> HOW TO RESPOND
>
> Send an email with *exactly* the following subject line format:
> Subject: <Company Name> has reviewed the IPP Finishings 2.0 specification
> and has [no] comments
>
>
> WHERE TO SEND YOUR RESPONSE
>
> Please send your response to *all* of the following email addresses
> (replacing "dot" with '.' and "at" with '@'):
>
> ipp "at" pwg "dot" org (IPP WG mailing list - you must be subscribed!)
> blueroofmusic "at" gmail "dot" com (Ira McDonald, IPP WG Co-Chair)
> ptykodi "at" tykodi "dot" com (Paul Tykodi, IPP WG Co-Chair)
> msweet "at" apple "dot" com (Michael Sweet, IPP WG Secretary, author)
>
>
> Note that you must be subscribed to the IPP WG mailing list to send email
> there - otherwise your email will be silently discarded.
>
> Please do NOT simply reply to this note on the PWG-Announce list.
>
> Note: The PWG Definition of the Standards Development Process Version 3.0
> is located at:
>
>         http://www.pwg.org/chair/membership_docs/pwg-process30.pdf
>
> _________________________________________________________
> Michael Sweet, Senior Printing System Engineer, PWG Chair
>
>
> _______________________________________________
> pwg-announce mailing list
> [email-masked]
> https://www.pwg.org/mailman/listinfo/pwg-announce
>
>
_______________________________________________
pwg-announce mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/pwg-announce

---

From: Ira McDonald <[email-masked]>
Date: Wed, 20 Aug 2014 22:02:22 -0400

Hi,

PLEASE take a few minutes to respond to this PWG Last Call for
IPP Finishings 2.0 by this Friday!

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Sun, Aug 17, 2014 at 1:15 PM, Ira McDonald <[email-masked]>
wrote:

>> [This PWG Last Call starts today, Monday 28 July 2014, and ends Friday,
>> 22 August 2014 at 10pm US Pacific.]
>>

---

From: Ira McDonald <[email-masked]>
Date: Fri, 22 Aug 2014 11:18:18 -0400

Hi,

PWG Last Call for IPP Finishings 2.0 ends TODAY (Friday 22 August)!

Please send your response.  Your comments are important.

Cheers,
- Ira (PWG Secretary, IPP WG Co-Chair)

On Wed, Aug 20, 2014 at 10:02 PM, Ira McDonald <[email-masked]>
wrote:

>>> Subject: <Company Name> has reviewed the IPP Finishings 2.0
>>> specification and has [no] comments
>>>
>>>
>>> Note that you must be subscribed to the IPP WG mailing list to send
>>> email there - otherwise your email will be silently discarded.
>>>
>>> Note: The PWG Definition of the Standards Development Process Version
>>> 3.0 is located at:
>>>

---

From: "Manchala, Daniel" <[email-masked]>
Date: Fri, 22 Aug 2014 19:07:42 +0000

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Manchala, Daniel" <[email-masked]>
Date: Fri, 22 Aug 2014 20:35:15 +0000

While these need not be construed as comments, the following questions / suggestions on IPP Finishings 2.0 would certainly help me (or perhaps others) to better understand / read the spec.

1.       Finishing Offset (line 248): Using what units is the distance measured from the Finishing Reference Edge (e.g., mm, in)? Can Printer vendors decide this for their own products?

2.       Finishing Offset (line 248): Might be better to replace the semi-colon with a colon after the term “Finishing Offset”.

3.       Section 3.2.3 Booklet Maker (lines 281-284): Would a typical example be folding several 11x17 sheets along the middle to form a 8.5x11 booklet stapled along the midline (saddle stitched)? Is this the same use case as the one shown in Section 3.2.11 Saddle Stitch (lines 313-316)?

4.       Section 3.2.9 Laminate (lines 305-308): The term “checklist” makes me think of a list of items on a scratch paper (like a grocery list) and puzzles me as to why it should be laminated. Perhaps qualifying it as “airplane operating procedure checklist” or a “restaurant menu card” or a “nursing procedure card” would have helped me better visualize what it meant, and the importance of laminating such a document.

5.       Section 3.2.16 Finishing Multiple Copies (lines 334-338): Is it true that in order to print multiple copies of a raster (only) document, a Client needs to send to the Printer (number of copies as specified by copy count * pages per copy) number of pages, whereas in case of a PDF document, the Client needs to send only one copy, and the Printer iterates over the single copy N number of times specified by copy count?

6.       Section 3.4 Out of Scope – item 2 (line 351): It is hard for me to visualize how folds are made at 0, 90, 180, 270 degrees, and particularly its relation to Figure 1. I understand how cuts are made though.

7.       Section 3.5 Design Requirements: Wouldn’t it be better to restart numbering (instead of starting at 5) which makes one think requirements 1-4 were in a previous spec? -  until one realizes that the numbering continued from the previous section. A period at the end of item 10 (which would be item 5 if renumbered) would be better.

Thanks,
Daniel.

---

From: Michael Sweet <[email-masked]>
Date: Fri, 22 Aug 2014 22:42:51 -0400

Daniel,

These are all comments that should be included in the last call.

---

From: Ira McDonald <[email-masked]>
Date: Sat, 23 Aug 2014 14:55:32 -0400

Hi,

I agree with Mike - these should all be treated as Xerox comments
on the IPP Finishings 2.0 spec.

Cheers,
- Ira

On Fri, Aug 22, 2014 at 10:42 PM, Michael Sweet <[email-masked]> wrote:

> > While these need not be construed as comments, the following questions /
> suggestions on IPP Finishings 2.0 would certainly help me (or perhaps
> others) to better understand / read the spec.
> >
> > 1.       Finishing Offset (line 248): Using what units is the distance
> measured from the Finishing Reference Edge (e.g., mm, in)? Can Printer
> vendors decide this for their own products?
>
> > 2.       Finishing Offset (line 248): Might be better to replace the
> semi-colon with a colon after the term “Finishing Offset”.
> > 3.       Section 3.2.3 Booklet Maker (lines 281-284): Would a typical
> example be folding several 11x17 sheets along the middle to form a 8.5x11
> booklet stapled along the midline (saddle stitched)? Is this the same use
> case as the one shown in Section 3.2.11 Saddle Stitch (lines 313-316)?
> > 4.       Section 3.2.9 Laminate (lines 305-308): The term “checklist”
> makes me think of a list of items on a scratch paper (like a grocery list)
> and puzzles me as to why it should be laminated. Perhaps qualifying it as
> “airplane operating procedure checklist” or a “restaurant menu card” or a
> “nursing procedure card” would have helped me better visualize what it
> meant, and the importance of laminating such a document.
> > 5.       Section 3.2.16 Finishing Multiple Copies (lines 334-338): Is it
> true that in order to print multiple copies of a raster (only) document, a
> Client needs to send to the Printer (number of copies as specified by copy
> count * pages per copy) number of pages, whereas in case of a PDF document,
> the Client needs to send only one copy, and the Printer iterates over the
> single copy N number of times specified by copy count?
> > 6.       Section 3.4 Out of Scope – item 2 (line 351): It is hard for me
> to visualize how folds are made at 0, 90, 180, 270 degrees, and
> particularly its relation to Figure 1. I understand how cuts are made
> though.
> > 7.       Section 3.5 Design Requirements: Wouldn’t it be better to
> restart numbering (instead of starting at 5) which makes one think
> requirements 1-4 were in a previous spec? -  until one realizes that the
> numbering continued from the previous section. A period at the end of item
> 10 (which would be item 5 if renumbered) would be better.
> >
> > Thanks,
> > Daniel.

---

From: "Manchala, Daniel" <[email-masked]>
Date: Thu, 28 Aug 2014 02:20:48 +0000

Since the date for submitting comments has been extended, here are a few more:

Section 5.1 (line 436) – the spec says that the client supplies ‘staple-bottom-left’ value to position a staple in the upper left hand corner of a landscape document when held for reading, since landscape is defined as an anti-clockwise rotation from portrait. I am not sure if that is where the staple will land. Either the definition of landscape should be changed to “90 degrees clockwise rotation” from portrait or the staple should be placed at “upper-right” to achieve the effect. Likewise, the next sentence in lines 436-439  may have to be revised.

Section 5.1.1 (lines 454-456) – Does this imply that the cover is supplied from another tray such as a by-pass tray (although we don’t write this in the spec?)

Section 5.1.3 (line 517) – shouldn’t this be 5100.1-YYYY? I haven’t seen these definitions anywhere on PWG site except this document.

Section 5.1.3 (lines 519-561) – might be good to replace “;” with “:” as is the case for all other terms. Likewise, all terms must end with a period. Period is missing for lines 531-561.

Section 5.1.3 (lines 523- 530) – while we have a ‘staple-triple-*’ , we do not have ‘staple-dual-*’ or ‘staple-double-*’. Is this because the same effect can be achieved using ‘staple-top-left’ + ‘staple-bottom-left’ = ‘staple-dual-left’?  Also, do we need a ‘staple-angle-xxx’ with ‘xxx’ = vertical, horizontal, diagonal?

The next 3 comments are probably because I got my ‘vertical’ mixed up with ‘horizontal’ folding.

Section 5.1.3 (lines 548-549) – the definition of ‘fold-double-gate’ might be wrong. It says “Fold the top and bottom quarters of the paper towards the midline, then fold in half *vertically*” shouldn’t this be *horizontally*? See Figure 1.

Section 5.1.3 (lines 551) – the definition of ‘fold-half’ might be wrong. It says “Fold the paper in half *vertically*”. Shouldn’t this be *horizontally*? See Figure 1.  Also adding the phrase “so that crease is horizontal when held in portrait mode”, would help.

Section 5.1.3 (lines 558) – likewise for definition of ‘fold-poster’. The folding should be done first vertically then horizontally.

Section 5.2.3.3 (line 631) – flat. Each of the other terms describe how (using adhesives, plastic tubes, spiral wires, tapes, etc) the binding is done. This particular one doesn’t say ‘how’ it is done.

Section 5.2.6.1 (line 701) – I am not sure if it enhances the readability, but revising the line to something like “value, *the default value may be derived* using an implementation or site defined value.

Section 5.2.7.2 (line 792) – might be a copy-paste error. Replace “specifies the *type of coating to apply* with *type of material to laminate with*.

---

From: Michael Sweet <[email-masked]>
Date: Thu, 28 Aug 2014 07:15:53 -0400

Daniel,

Thank you for these extra comments!