Subject: Re: [IPP] RFC: Consensus on new "output-bin" values: 'collator' and 'job-separator', issue for "output-bin-actual"

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Thu, 21 Aug 2014 16:12:51 +0000

Hi there,

Where are we with the IANA registrations for these keywords?

Smith

On 2014-07-15, at 1:06 PM, Ira McDonald <[email-masked]> wrote:

> Hi,
> 
> I agree.  All of this proposal looks right (with Smith's clarifications).
> 
> Cheers,
> - Ira
> 
> 
> Ira McDonald (Musician / Software Architect)
> Co-Chair - TCG Trusted Mobility Solutions WG
> Chair - Linux Foundation Open Printing WG
> Secretary - IEEE-ISTO Printer Working Group
> Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
> IETF Designated Expert - IPP & Printer MIB
> Blue Roof Music / High North Inc
> http://sites.google.com/site/blueroofmusic
> http://sites.google.com/site/highnorthinc
> mailto: [email-masked]
> Winter  579 Park Place  Saline, MI  48176  734-944-0094
> Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434
> 
> 
> 
> On Tue, Jul 15, 2014 at 1:04 PM, Michael Sweet <[email-masked]> wrote:
> Smith,
> 
> True about output-bin-actual being optional, so I agree with the proposed tweaks.
> 
> 
> On Jul 15, 2014, at 12:14 PM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
> > Hi Mike,
> >
> > A few tweaks:
> >
> >   'collator'; Each copy is placed in an empty output tray. If all trays are full, the Printer cycles through each of the trays in an implementation-defined manner. The chosen output trays MUST be reported in the “output-bin-actual” Job Description attribute if that attribute is supported by the Printer.
> >
> >   'job-separator'; All of the output for the Job is placed in an empty output tray. If no trays are empty, the Printer chooses an output tray in an implementation-defined manner. The chosen output tray MUST be reported in the “output-bin-actual” Job Description attribute if that attribute is supported by the Printer.
> >
> > Since the “xxx-actual” attributes are only required by IPP/2.2 as per 5100.12, it is at least possible that a printer has implemented output bins but hasn’t implemented “xxx-actual” attribute support.
> >
> > Smith
> >
> > /**
> >    Smith Kennedy
> >    ATB Wireless Architect - PPS
> >    Hewlett-Packard Co.
> > */
> >
> >
> >
> > On 2014-07-14, at 3:11 PM, Michael Sweet <[email-masked]> wrote:
> >
> >> All,
> >>
> >> We discussed the proposed values for the "output-bin" attribute at today's IPP concall and have some minor changes to the definitions along with a larger clarification for the "printer-output-tray" attribute.
> >>
> >> However, one of the conclusions may need to change since after further research it appears that PWG 5100.8 did indeed define the "output-bin-actual" attribute as "1setOf (type2 keyword | name(MAX)))".
> >>
> >> Thus, I would like to update the definition of the "output-bin" values to be as follows:
> >>
> >>   'collator'; Each copy is placed in an empty output tray. If all trays are full, the Printer cycles through each of the trays in an implementation-defined manner. The chosen output trays MUST reported in the "output-bin-actual" Job Description attribute.
> >>
> >>   'job-separator'; All of the output for the Job is placed in an empty output tray. If no trays are empty, the Printer chooses an output tray in an implementation-defined manner. The chosen output tray MUST be reported in the "output-bin-actual" Job Description attribute.
> >>
> >> That would also imply that the 'auto' value should assign the chosen tray as well:
> >>
> >>   'auto'; All of the output for the Job is sent to an implementation-defined output tray based on the Job Template and Document Template attributes. The chosen output tray MUST be reported in the "output-bin-actual" Job Description attribute.
> >>
> >> ....
> >>
> >> Since the "printer-output-tray" attribute is linked to the "output-bin-supported" attribute, we discussed how to report logical trays such as 'auto', 'collator', and 'job-separator'. We decided the following:
> >>
> >> 1. Logical trays are provided by the service, so while they will be listed in the "printer-output-tray" attribute they will NOT be listed in the Printer MIB prtOutputTray table.
> >>
> >> 2. Logical trays are reported in "printer-output-tray" using a 'type' value of 'other' (1). The values of the other fields are calculated in an implementation-defined behavior (roll-up status, etc.)
> >>
> >> 3. The same behavior should be applied to "printer-input-tray" for the "media-source" value of 'auto'.
> >>
> >> Comments?
> >>
> >> _________________________________________________________
> >> Michael Sweet, Senior Printing System Engineer, PWG Chair
> >>
> >> _______________________________________________
> >> ipp mailing list
> >> [email-masked]
> >> https://www.pwg.org/mailman/listinfo/ipp
> >
> 
> _________________________________________________________
> Michael Sweet, Senior Printing System Engineer, PWG Chair
> 
> 
> _______________________________________________
> ipp mailing list
> [email-masked]
> https://www.pwg.org/mailman/listinfo/ipp
> 
> 

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Thu, 21 Aug 2014 12:57:26 -0400

In my "pending" queue.  I'll be sending updates to Ira "soon"...

---

From: Michael Sweet <[email-masked]>
Date: Fri, 22 Aug 2014 14:35:35 -0400

Smith,

I've sent this to Ira and posted the new PWG registrations on pwg.org...

---

From: Ira McDonald <[email-masked]>
Date: Sat, 23 Aug 2014 15:11:20 -0400

Hi Smith,

Both of these new values for "output-bin" are included in the latest
IANA registrations file that Mike sent me on Friday.

Mike - I assume we should talk about IPP deprecation policy on
Monday?  Should I wait to send this latest IANA registrations file
to Amanda until after our discussion at Monday's IPP meeting?

Cheers,
- Ira

On Thu, Aug 21, 2014 at 12:12 PM, Kennedy, Smith (Wireless Architect) <
[email-masked]> wrote:

>> >   'collator'; Each copy is placed in an empty output tray. If all trays
>> are full, the Printer cycles through each of the trays in an
>> implementation-defined manner. The chosen output trays MUST be reported in
>> the “output-bin-actual” Job Description attribute if that attribute is
>> supported by the Printer.
>> >
>> >   'job-separator'; All of the output for the Job is placed in an empty
>> output tray. If no trays are empty, the Printer chooses an output tray in
>> an implementation-defined manner. The chosen output tray MUST be reported
>> in the “output-bin-actual” Job Description attribute if that attribute is
>> supported by the Printer.
>> >
>> > Since the “xxx-actual” attributes are only required by IPP/2.2 as per
>> 5100.12, it is at least possible that a printer has implemented output bins
>> but hasn’t implemented “xxx-actual” attribute support.
>> >
>> > Smith
>> >
>> > /**
>> >    Smith Kennedy
>> >> We discussed the proposed values for the "output-bin" attribute at
>> today's IPP concall and have some minor changes to the definitions along
>> with a larger clarification for the "printer-output-tray" attribute.
>> >>
>> >> However, one of the conclusions may need to change since after further
>> research it appears that PWG 5100.8 did indeed define the
>> "output-bin-actual" attribute as "1setOf (type2 keyword | name(MAX)))".
>> >>
>> >>   'collator'; Each copy is placed in an empty output tray. If all
>> trays are full, the Printer cycles through each of the trays in an
>> implementation-defined manner. The chosen output trays MUST reported in the
>> "output-bin-actual" Job Description attribute.
>> >>
>> >>   'job-separator'; All of the output for the Job is placed in an empty
>> output tray. If no trays are empty, the Printer chooses an output tray in
>> an implementation-defined manner. The chosen output tray MUST be reported
>> in the "output-bin-actual" Job Description attribute.
>> >>
>> >>   'auto'; All of the output for the Job is sent to an
>> implementation-defined output tray based on the Job Template and Document
>> Template attributes. The chosen output tray MUST be reported in the
>> "output-bin-actual" Job Description attribute.
>> >>
>> >> ....
>> >>
>> >> Since the "printer-output-tray" attribute is linked to the
>> "output-bin-supported" attribute, we discussed how to report logical trays
>> such as 'auto', 'collator', and 'job-separator'. We decided the following:
>> >>
>> >> 1. Logical trays are provided by the service, so while they will be
>> listed in the "printer-output-tray" attribute they will NOT be listed in
>> the Printer MIB prtOutputTray table.
>> >>
>> >> 2. Logical trays are reported in "printer-output-tray" using a 'type'
>> value of 'other' (1). The values of the other fields are calculated in an
>> implementation-defined behavior (roll-up status, etc.)
>> >>

---

From: Mike Sweet <[email-masked]>
Date: Sat, 23 Aug 2014 21:39:43 -0400

Ira,

Yes let's discuss the policy on Monday. But don't hold back on sending the registrations...

Sent from my iPhone

> On Aug 23, 2014, at 3:11 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Smith,
> 
>> On Thu, Aug 21, 2014 at 12:12 PM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
>> Hi there,
>>