Subject: [IPP] Proposed definition of "protocol binding"

From: Ira McDonald <[email-masked]>
Date: Wed, 13 Aug 2014 21:05:04 -0400

Hi,

There are hundreds of self-contradictory, informal definitions
of "protocol binding" around the Internet.  Many IETF RFCs
use this term just as we do in PWG, but none define it (that
I've found so far).

The following excerpt from WSDL/1.1 is illustrative of the
conventional computer science use of "protocol binding":

"Abstract: WSDL is an XML format for describing network
services as a set of endpoints operating on messages
containing either document-oriented or procedure-oriented
information. The operations and messages are described
abstractly, and then bound to a concrete network protocol
and message format to define an endpoint. Related concrete
endpoints are combined into abstract endpoints (services).
WSDL is extensible to allow description of endpoints and
their messages regardless of what message formats or
network protocols are used to communicate."

Thus, my proposed definition:

Protocol Binding:  The combination of a network protocol
with a set of message formats, operations, and attributes
that constitutes a concrete data model for implementation
of an abstract information model and an associated set of
abstract operations and attributes.

The above definition fits the usage of this term in every
IETF RFC that I looked at this evening (several dozen).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Thu, 14 Aug 2014 07:57:56 -0400

Ira,

I dislike using the term in the definition - makes for circular definitions. Seems like we are talking about a transport mechanism.

And while we do normally focus on networking the existence of IPP USB also can allow non-traditional data paths to use our stuff.

Finally, "attributes" has specific meaning in both IPP and XML, so how about "data elements"?

That would make the definition:

Protocol Binding: The combination of a transport mechanism with a set of message formats, operations, and data elements that implement an abstract information model and associated set of abstract operations and data elements.

and for the IPP Binding definition in IPP Scan and IPPINFRA:

IPP Binding: The Internet Printing Protocol implementation of an abstract information model and associated set of abstract operations and data elements.

Thoughts?

> Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Ira McDonald <[email-masked]>
Date: Thu, 14 Aug 2014 08:51:29 -0400

Hi Mike,

I like your definitions better.

Cheers,
- Ira

On Thu, Aug 14, 2014 at 7:57 AM, Michael Sweet <[email-masked]> wrote:

> Ira,
>
> I dislike using the term in the definition - makes for circular
> definitions. Seems like we are talking about a transport mechanism.
>
> And while we do normally focus on networking the existence of IPP USB also
> can allow non-traditional data paths to use our stuff.
>
> Protocol Binding: The combination of a transport mechanism with a set of
> message formats, operations, and data elements that implement an abstract
> information model and associated set of abstract operations and data
> elements.
>
>
> IPP Binding: The Internet Printing Protocol implementation of an abstract
> information model and associated set of abstract operations and data
> elements.
>
>
> Thoughts?
>
>