Subject: [IPP] IPP Scan: Updated Get-Next-xxx naming, updated xxx-wait-mode attribute name?

From: Michael Sweet <[email-masked]>
Date: Sun, 26 Oct 2014 23:53:49 -0400

All,

One of the comments during the Formal Vote for IPP Scan Service concerned multiple document handling in the scan service and some confusion concerning the naming of the Get-Next-Document-Images operation.

We would like to change the name of the operation (same operation code) to Get-Next-Document-Data for the final publication of the specification.

In addition, while making this change I noticed that the operation accepts a boolean operation attribute called get-next-images-wait-mode, however given that the operation no longer has "images" in the name, the value is true/false (true to wait, false to not wait), and the inspiration from the ippget operation Get-Notifications is called "notify-wait", I would like to change the name of this attribute to "wait-for-data".

In summary:

1. The Get-Next-Document-Images operation will be renamed to Get-Next-Document-Data.

2. The "get-next-images-wait-mode (boolean)" operation attribute will be renamed to "wait-for-data (boolean)".

Please let me know if you object to either of these changes.  We will review these and all other changes for the final draft of the IPP Scan Service specification at the November F2F meeting.

Thanks!

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 27 Oct 2014 00:04:48 -0400

Sorry, follow up since I noticed there is also the next-image-get-interval.

The amended proposal is as follows (with a slight naming change for #2 for consistency):

2. The "get-next-images-wait-mode (boolean)" operation attribute will be renamed to "wait-for-document-data (boolean)".

3. The "next-image-get-interval (integer)" operation attribute will be renamed to "document-data-get-interval (integer)".

> On Oct 26, 2014, at 11:53 PM, Michael Sweet <[email-masked]> wrote:
> 
> All,
>

---

From: "Zehler, Peter" <[email-masked]>
Date: Mon, 27 Oct 2014 12:00:15 +0000

A simple name change that allows operations/attributes to be used across services that require the same semantic elements works for me.

Peter Zehler

PARC, A Xerox Company
800 Phillips Rd, 128-27E
Webster NY, 14580-9701
Email: [email-masked]
Office: +1 (585) 265-8755
Mobile: +1 (585) 329-9508
FAX: +1 (585) 265-7441

---

From: Ira McDonald <[email-masked]>
Date: Mon, 27 Oct 2014 09:56:24 -0400

Hi,

I'm happy with the operation name change.

For more consistent naming with Subscriptions and also between the two
boolean
attributes, I suggest changing "wait-for-document-data (boolean)" to put
the subject
first and therefore "document-data-wait (boolean)", consistent with the
proposed
"document-data-get-interval (integer)".

Cheers,
- ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Mon, Oct 27, 2014 at 12:04 AM, Michael Sweet <[email-masked]> wrote:

> 2. The "get-next-images-wait-mode (boolean)" operation attribute will be
> renamed to "wait-for-document-data (boolean)".
>
> 3. The "next-image-get-interval (integer)" operation attribute will be
> renamed to "document-data-get-interval (integer)".
>
>
> > One of the comments during the Formal Vote for IPP Scan Service
> concerned multiple document handling in the scan service and some confusion
> concerning the naming of the Get-Next-Document-Images operation.
> >
> > We would like to change the name of the operation (same operation code)
> to Get-Next-Document-Data for the final publication of the specification.
> >
> > In addition, while making this change I noticed that the operation
> accepts a boolean operation attribute called get-next-images-wait-mode,
> however given that the operation no longer has "images" in the name, the
> value is true/false (true to wait, false to not wait), and the inspiration
> from the ippget operation Get-Notifications is called "notify-wait", I
> would like to change the name of this attribute to "wait-for-data".
> >
> > In summary:
> >
> > Please let me know if you object to either of these changes.  We will
> review these and all other changes for the final draft of the IPP Scan
> Service specification at the November F2F meeting.
> >
> > Thanks!
> >

---

From: Michael Sweet <[email-masked]>
Date: Mon, 27 Oct 2014 10:43:34 -0400

Fine with me.

> On Oct 27, 2014, at 9:56 AM, Ira McDonald <[email-masked]> wrote:
> 
> Hi,
> 
> For more consistent naming with Subscriptions and also between the two boolean
> attributes, I suggest changing "wait-for-document-data (boolean)" to put the subject
> first and therefore "document-data-wait (boolean)", consistent with the proposed