Subject: [IPP] IPP Everywhere Printer Self-Certification Prototype Experience

From: "Rodriguez, Eren" <[email-masked]>
Date: Wed, 14 Jan 2015 20:32:18 +0000

Hello,

I would like to challenge another failure (last one, hopefully) seen with our IPP printers at HP while running the IPP Everywhere Printer Self-Certification test suite.
More specifically, inside ipp-tests.test, it is expected that "job-preferred-attributes-supported" is returned as a boolean as part of a Get-Printer-Attributes response.

EXPECT job-preferred-attributes-supported OF-TYPE boolean IN-GROUP printer-attributes-tag COUNT 1

This leads to a failure like this:

I-9. Get-Printer-Attributes Operation (default)                      [FAIL]
...
status-code = successful-ok (successful-ok)
EXPECTED: job-preferred-attributes-supported

I could not find the definition of this attribute in a PWG specification. I used the IANA IPP Registrations link and found no results.
http://www.iana.org/assignments/ipp-registrations/ipp-registrations.xml
Did the test script mean "preferred-attributes-supported" which is also defined as a boolean?

When I used the internal Google search at PWG.org, I found a reference to "job-preferred-attributes-supported" on page 58 in PWG 5100.13:
https://ftp.pwg.org/pub/pwg/candidates/cs-ippjobprinterext3v10-20120727-5100.13.pdf

"Printers indicate their support for this functionality by listing the Job Template attributes
that may be returned in the "job-preferred-attributes-supported" Printer attribute (section
5.5.4)."

This hints that it is a 1setOf keyword, a new kind of attribute...unfortunately, section 5.5.4 does not reference it.
Smith Kennedy had reported this typo in May 2013, but the path forward is unclear to me.
http://www.pwg.org/archives/ipp/2013/017519.html

Thank you in advance,
Eren Rodriguez @ HP inkjet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Wed, 14 Jan 2015 16:37:49 -0500

Eren,

> On Jan 14, 2015, at 3:32 PM, Rodriguez, Eren <[email-masked]> wrote:
> 
> Hello,
>  
> More specifically, inside ipp-tests.test, it is expected that “job-preferred-attributes-supported” is returned as a boolean as part of a Get-Printer-Attributes response.
>  
> http://www.iana.org/assignments/ipp-registrations/ipp-registrations.xml <http://www.iana.org/assignments/ipp-registrations/ipp-registrations.xml>
> Did the test script mean “preferred-attributes-supported” which is also defined as a boolean?

Yes, fixed now in CUPS SVN.

> When I used the internal Google search at PWG.org, I found a reference to “job-preferred-attributes-supported” on page 58 in PWG 5100.13:
> https://ftp.pwg.org/pub/pwg/candidates/cs-ippjobprinterext3v10-20120727-5100.13.pdf <https://ftp.pwg.org/pub/pwg/candidates/cs-ippjobprinterext3v10-20120727-5100.13.pdf>
Logged this on the PWG.org issues page as issue #25 so we can track for and errata update.
 
> “Printers indicate their support for this functionality by listing the Job Template attributes
> 5.5.4).”
> This hints that it is a 1setOf keyword, a new kind of attribute…unfortunately, section 5.5.4 does not reference it.
> http://www.pwg.org/archives/ipp/2013/017519.html <http://www.pwg.org/archives/ipp/2013/017519.html>
Which is now logged as issue #26.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair