Subject: [IPP] IPP Everywhere Printer Self-Certification Prototype Experience

From: "Rodriguez, Eren" <[email-masked]>
Date: Mon, 12 Jan 2015 23:10:37 +0000

Hello,

I have been playing with the IPP Everywhere Printer Self-Certification test suite and I would like to challenge another failure seen with our IPP printers at HP.
I apologize if these experience reports seem staggered, but I needed to investigate this issue further before reporting them as possible test error.

More specifically, inside ipp-tests.test, there are test cases around printer-resident URIs and their hostname expectations.

I-9. Get-Printer-Attributes Operation (default)                      [FAIL]
        RECEIVED: 12508 bytes in response
        status-code = successful-ok (successful-ok)
        EXPECTED: printer-icons WITH-ALL-VALUES "HP6451060F1496.local."
        GOT: printer-icons="http://HP6451060F1496.local/webApps/images/printer-small.png"
        GOT: printer-icons="http://HP6451060F1496.local/webApps/images/printer.png"
        GOT: printer-icons="http://HP6451060F1496.local/webApps/images/printer-large.png"
        EXPECTED: printer-supply-info-uri WITH-VALUE "HP6451060F1496.local."
        GOT: printer-supply-info-uri=http://HP6451060F1496.local/#hId-pgInkConsumables

According to the IPP Everywhere specification, Section 8.4, "Printers SHOULD use the HTTP Host: header value when generating URIs for use in Client responses."
Internally, we have captured a WireShark trace while running the tests and noticed that none of the incoming HTTP/IPP packets included the '.' at the end. This is why our responses never included it either. See attached screenshot for more details.

Mike, Ira, if you want to see the actual .pcap file, I can send it to you privately.

Thank you in advance,
Eren Rodriguez @ HP inkjet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Wed, 14 Jan 2015 14:36:28 -0500

Eren,

Thanks, this looks like a bug in ipptool. Filed CUPS STR #4563 to track a fix:

	http://www.cups.org/str.php?L4563

> On Jan 12, 2015, at 6:10 PM, Rodriguez, Eren <[email-masked]> wrote:
> 
> Hello,
>  
>         GOT: printer-icons="http://HP6451060F1496.local/webApps/images/printer-small.png <http://hp6451060f1496.local/webApps/images/printer-small.png>"
>         GOT: printer-icons="http://HP6451060F1496.local/webApps/images/printer.png <http://hp6451060f1496.local/webApps/images/printer.png>"
>         GOT: printer-icons="http://HP6451060F1496.local/webApps/images/printer-large.png <http://hp6451060f1496.local/webApps/images/printer-large.png>"
>         GOT: printer-supply-info-uri=http://HP6451060F1496.local/#hId-pgInkConsumables <http://hp6451060f1496.local/#hId-pgInkConsumables>
>  
> According to the IPP Everywhere specification, Section 8.4, “Printers SHOULD use the HTTP Host: header value when generating URIs for use in Client responses.”
> Internally, we have captured a WireShark trace while running the tests and noticed that none of the incoming HTTP/IPP packets included the ‘.’ at the end. This is why our responses never included it either. See attached screenshot for more details.
>  

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair