Subject: [IPP] Initial draft of IPP 3D Printing Extensions posted

From: Michael Sweet <[email-masked]>
Date: Fri, 23 Jan 2015 17:32:55 -0500

All,

I have posted an initial draft of a white paper describing a potential extension to IPP for 3D Printing to:

	http://ftp.pwg.org/pub/pwg/BOFs/3d-printing/wd-apple-ipp3d-20150123.docx
	http://ftp.pwg.org/pub/pwg/BOFs/3d-printing/wd-apple-ipp3d-20150123.pdf

For discussion at the 3D Printing BOF on February 4th during the F2F.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Paul Tykodi" <[email-masked]>
Date: Sat, 24 Jan 2015 08:50:08 -0500

Hi Mike,

Editorial Comments as follows:

Line 307 - suggest standardize rather than standardized.

Best Regards,

/Paul
--
Paul Tykodi
Principal Consultant
TCS - Tykodi Consulting Services LLC

Tel/Fax: 603-343-1820
Mobile:  603-866-0712
E-mail:  [email-masked]
WWW:  http://www.tykodi.com

This e-mail reply and any attachments are confidential and may be
privileged.
If you are not the intended recipient, please notify Tykodi Consulting
Services LLC 
immediately by replying to this message and destroying all copies of this
message 
and any attachments. Thank you

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael
Sweet
Sent: Friday, January 23, 2015 5:33 PM
To: <[email-masked]>; [email-masked]
Subject: [IPP] Initial draft of IPP 3D Printing Extensions posted

All,

I have posted an initial draft of a white paper describing a potential
extension to IPP for 3D Printing to:

---

From: "Manchala, Daniel" <[email-masked]>
Date: Mon, 26 Jan 2015 05:18:07 +0000

I am not an expert in 3D printing but the following sentence seemed a little confusing:

3.2.3 Filament Feed Jam
While printing a 3D object, the filament jams and cannot be fed into the extruder.

I thought a filament jams the extruder and hence cannot be fed 'through' the extruder rather than 'into' the extruder. This is where I got information on extruder jams from:

https://www.matterhackers.com/articles/how-to-clear-and-prevent-jams

Daniel.

________________________________________
From: [email-masked] [[email-masked]] on behalf of Paul Tykodi [[email-masked]]
Sent: Saturday, January 24, 2015 5:50 AM
To: 'Michael Sweet'
Cc: [email-masked]; [email-masked]
Subject: Re: [IPP] Initial draft of IPP 3D Printing Extensions posted

Hi Mike,

Best Regards,

/Paul

Tel/Fax: 603-343-1820
Mobile: 603-866-0712

-----Original Message-----

All,

---

From: Michael Sweet <[email-masked]>
Date: Mon, 26 Jan 2015 07:32:32 -0500

Daniel,

> On Jan 26, 2015, at 12:18 AM, Manchala, Daniel <[email-masked]> wrote:
> 

We can debate wording at the F2F, and I'll probably want to add some figures showing the different subunits and different implementations.  One of the issues we will need to address is clearly defining terminology and functional components.  There is a lot of non-authoritative information online about 3D printers and very little standardization of terminology, partly due to the relative immaturity of the technology and partly because there are so many enthusiasts trying different things right now.

For filament jams, I am referring to a jam in the feed of the filament from the source (typically a spool) to the hot end (the actual extruder) and not specifically the drive mechanism which can be located at any point leading up to the hot end.  Most jams happen inside the Bowden Tube (for printers that use them), but it is also possible to jam at the point of entry to the hot end or even in the drive mechanism depending on the design and the print settings.  Perhaps a (helpful?) ASCII art diagram showing a few common designs?

    |vvvvvvvvvvvv FILAMENT PATH vvvvvvvvvvvv| |EXTRUDER|
    SPOOL ----> DRIVE ----> BOWDEN TUBE -----> HOT END -----> PLATFORM
    SPOOL ----> BOWDEN TUBE ----> DRIVE -----> HOT END -----> PLATFORM
    SPOOL ----------------------> DRIVE -----> HOT END -----> PLATFORM

    |^^^^^^^^^^^^ FILAMENT JAMS ^^^^^^^^^^^^| | CLOGS |

I am also thinking about extruded food printers, since there the source material is either liquid or melted and then pumped through the extruder head.  By separating the feed/input from the place where the material comes out in a different form, we can provide fairly specific feedback/status information in a logical way.

So, a filament can be jammed only as long as it is filament (solid).  Once melted, it can only get clogged.  (or at least that's how I am looking at it...)