Subject: [IPP] IPP Everywhere Printer Self-Certification test query

From: "Rodriguez, Eren" <[email-masked]>
Date: Thu, 8 Jan 2015 19:51:31 +0000

Hi,

I have been playing with the IPP Everywhere Printer Self-Certification test suite and I would like to challenge a failure seen with our IPP printers at HP.

More specifically, inside ipp-tests.test, before test I-28, the tester is asked to remove any paper from the printer. So far so good.
This test sends a JPEG Print-Job request before sending a Get-Printer-Attributes request right afterwards with the expectation that "media-needed" keyword should be in "printer-state-reasons"
Due to hardware limitations, there may be printers in the world that cannot detect out of paper at the time when this Get-Printer-Attributes request arrives.  For example, on this printer, we currently have "spool-area-full-report" to reflect we are working on the job.

Since this is a JPEG, this printer will take in the data and reply back to the Print-Job request fairly quickly. However, it does not have media presence capabilities so it needs some time, beyond the time given by the test script, to go through the mechanical motions to detect out of paper.

Let me know what you think of my observation.

Thank you in advance,
Eren Rodriguez @ HP inkjet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Thu, 08 Jan 2015 15:25:18 -0500

Eren,

We can probably add a delay and perhaps a repeat (with limit) to verify that we (eventually) get the right printer-state-reason value.

If you can include this comment with any other observations you have about the test suite in an "official" message titled "IPP Everywhere Printer Self-Certification Prototype Experience" then we can advance the self-certification document to "stable" status while we work out the kinks in the software...

Thanks!

> On Jan 8, 2015, at 2:51 PM, Rodriguez, Eren <[email-masked]> wrote:
> 
> Hi,
>  
> This test sends a JPEG Print-Job request before sending a Get-Printer-Attributes request right afterwards with the expectation that “media-needed” keyword should be in “printer-state-reasons”
> Due to hardware limitations, there may be printers in the world that cannot detect out of paper at the time when this Get-Printer-Attributes request arrives.  For example, on this printer, we currently have “spool-area-full-report” to reflect we are working on the job.
>  

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Thu, 8 Jan 2015 21:39:48 +0000

Hi Mike,

By “official” do you mean as feedback on the IPP Everywhere Printer Self-Certification Manual 1.0?

Smith

/**
    Smith Kennedy
    Hewlett-Packard Co.
*/

> On 2015-01-08, at 1:25 PM, Michael Sweet <[email-masked]> wrote:
> 
> Eren,
> 
>> On Jan 8, 2015, at 2:51 PM, Rodriguez, Eren <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi,
>>  
>> [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>

---

From: Ira McDonald <[email-masked]>
Date: Thu, 8 Jan 2015 16:46:28 -0500

Hi Smith,

By "offiical", Mike just meant to resend with Mike's suggested title - we
need an
IPP email archive of a prototype experience report in order to advance the
spec
from Prototype draft to Stable draft for PWG Last Call.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Thu, Jan 8, 2015 at 4:39 PM, Kennedy, Smith (Wireless Architect) <
[email-masked]> wrote:

> We can probably add a delay and perhaps a repeat (with limit) to verify
> that we (eventually) get the right printer-state-reason value.
>
> If you can include this comment with any other observations you have about
> the test suite in an "official" message titled "IPP Everywhere Printer
> Self-Certification Prototype Experience" then we can advance the
> self-certification document to "stable" status while we work out the kinks
> in the software...
>
> Thanks!
>
>
> I have been playing with the IPP Everywhere Printer Self-Certification
> test suite and I would like to challenge a failure seen with our IPP
> printers at HP.
>
>
> More specifically, inside *ipp-tests.test*, before test I-28, the tester
> is asked to remove any paper from the printer. So far so good.
> This test sends a JPEG Print-Job request before sending a
> Get-Printer-Attributes request right afterwards with the expectation that
> “media-needed” keyword should be in “printer-state-reasons”
> Due to hardware limitations, there may be printers in the world that
> cannot detect out of paper at the time when this Get-Printer-Attributes
> request arrives.  For example, on this printer, we currently have
> “spool-area-full-report” to reflect we are working on the job.
>
>
> Since this is a JPEG, this printer will take in the data and reply back to
> the Print-Job request fairly quickly. However, it does not have media
> presence capabilities so it needs some time, beyond the time given by the
> test script, to go through the mechanical motions to detect out of paper.
>
>