Subject: [IPP] New draft of 'IPP “job-password-policy-supported” attribute' whitepaper posted

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Mon, 13 Apr 2015 21:04:26 +0000

Greetings,

I have just posted an updated draft of the IPP “job-password-policy-supported” attribute whitepaper, in preparation for further discussion at the April 2015 F2F IDS WG and IPP WG sessions.  It is available here:

   http://ftp.pwg.org/pub/pwg/ipp/wd/wp-job-password-policy-supported-20150413.pdf
   http://ftp.pwg.org/pub/pwg/ipp/wd/wp-job-password-policy-supported-20150413.docx
   http://ftp.pwg.org/pub/pwg/ipp/wd/wp-job-password-policy-supported-20150413-rev.pdf
   http://ftp.pwg.org/pub/pwg/ipp/wd/wp-job-password-policy-supported-20150413-rev.docx

Cheers,

Smith

/**
    Smith Kennedy
    Hewlett-Packard Co.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Manchala, Daniel" <[email-masked]>
Date: Thu, 23 Apr 2015 20:23:33 +0000

Thank you Smith for posting the whitepaper that we could discuss at the next F2F PWG meeting in Cupertino (either the IDS or the IPP WG). A few comments (so that I don't forget to bring them at the next meeting - I will be attending them in person).

1. job-password-policy-supported(1setOf type2 keyword). The draft specifies 3 keywords. It would be good to add a fourth (or perhaps a fifth) keyword to accommodate other (non US) character sets or other constraints on password. So, the semantics would be like:

'digits': digits from 0 to 9
'alphanumeric': US ASCII letters and numbers
'aphanumeric-complex': US ASCII letters and numbers with at least one uppercase, one lowercase and one digit.
'character-set': points to an attribute that defines the character set (e.g., cryllic, latin, indic, Japanese, etc).
'system-defined': similar to alphanumeric, but with other system administrator defined constraints such as one upper, one lower, one digit, one special character, or something like that. 

2. job-password-minimum-length(integer(0:255)) - this attribute specifies the minimum length of the password that the Printer would satisfactorily accept per policy. Any smaller length would be rejected by the client itself as the user specifies at the console/UI. The client would of course obtain this value by querying the printer. 
It might be good to include the maximum length acceptable to the printer as well, thus changing the attribute to 'job-password-length(rangeOfInteger(0:255))' -- a minor change would help tremendously.

Thanks,
Daniel.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Kennedy, Smith (Wireless Architect)
Sent: Monday, April 13, 2015 2:04 PM
To: <[email-masked]>
Subject: [IPP] New draft of 'IPP “job-password-policy-supported” attribute' whitepaper posted

Greetings,

Cheers,

Smith

/**
    Smith Kennedy
    Hewlett-Packard Co.
*/