Subject: [IPP] Minutes posted from today's concall

From: Michael Sweet <[email-masked]>
Date: Mon, 06 Jul 2015 19:52:20 -0400

All,

I have posted the minutes from today's IPP WG conference call to:

	http://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20150706.pdf

Our next conference call is July 20, 2015 at 3pm ET.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: <[email-masked]>
Date: Mon, 13 Jul 2015 16:47:33 +0000

The term " Conditionally Required" or "Conditionally Mandatory" has been used extensively, usually without a special definition. In many cases, it was not defined as a specific compliance term, but used in a context that included specifying the condition. For example, in Candidate Standard 5102.1-2003, XHTML™-Print

"Support for Inline Image Data is conditionally mandatory; i.e. any device supporting Inline Image Data shall support this method."

It was defined under compliance terminology in Candidate Standard 5100.6-2003 - Standard for The Internet Printing Protocol (IPP): Page Overrides and in Candidate Standard 5100.5-2003, Standard for The Internet Printing Protocol (IPP): Document Object

"The term CONDITIONALLY REQUIRED means that the Printer MUST support the feature, if the specified condition is true."

The term was defined in a way similar to the current definition in Candidate Standard 5110.1-2014, PWG Hardcopy Device Health Assessment Attributes.

"The term CONDITIONALLY REQUIRED is additionally defined for a conformance requirement that applies to a particular capability or feature."

Although this definition was clarified in the section of the text dealing with conditionally mandatory elements by:

"HCDs MUST support the attributes in this section if the particular capability, as described before each attribute, is implemented on the HCD."

I am unhappy with "... conformance requirement that applies to a particular capability or feature." as a general statement because:

            a. Most conformance requirements apply to a particular capability or feature. I assume that one is to infer that the requirement applies only if that capability or feature exists in the subject implementation seeking to be conformant.

            b. A requirement is conditional to an implementation because the implementation includes a particular capability or feature, but is not necessarily a requirement of the capability or feature itself, which is suggested by "applies to".

            c. In a general sense, the condition may not be the inclusion of a feature or capability. Conceivably, the condition may be how or where the implementation is used or when it was created.

There is there is the additional question as to whether the term should 'Conditionally Required" or "Conditionally Mandatory". Since the basic compliance term is "Required", "Conditionally Required" seems more appropriate.

A reasonable variation on the 2003 definition and the RFC2119 definition of requirement levels is :

CONDITIONALLY REQUIRED: definition is a requirement of the specification if the specified condition is true.

One might prefer a term other than "definition", such as capability or feature, and consider a requirement of the implementation rather than of the specification, but RFC 2119 wording  is:" … definition is an absolute requirement of the specification."

Alternatively, we could modify the current definition to:

CONDITIONALLY REQUIRED: A conformance requirement that applies if the specified condition is true.

Bill Wagner

---

From: Michael Sweet <[email-masked]>
Date: Mon, 13 Jul 2015 17:21:04 -0400

Bill,

Comments inline...

> On Jul 13, 2015, at 12:47 PM, [email-masked] wrote:
> ...
> 
Per RFC 2119, REQUIRED, MUST, and MUST NOT are unconditional by themselves.  You make them conditional by making the statement containing them conditional, e.g., 'If the Printer supports two-sided printing, the Printer MUST support the "sides" Job Template attribute.'

> ...
Agreed.

> CONDITIONALLY REQUIRED: definition is a requirement of the specification if the specified condition is true.
I'm not super happy with this...

> CONDITIONALLY REQUIRED: A conformance requirement that applies if the specified condition is true.
I like this better, or the definition you quoted from 5100.6:

---

From: Ira McDonald <[email-masked]>
Date: Mon, 13 Jul 2015 18:26:18 -0400

Hi,

I second all of Mike's comments.

I'd rather have no definition at all than have one that is obscure or has
too much latitude in interpretation.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Mon, Jul 13, 2015 at 5:21 PM, Michael Sweet <[email-masked]> wrote:

> I am unhappy with "... conformance requirement that applies to a
> particular capability or feature." as a general statement because:
>
>             a. Most conformance requirements apply to a particular
> capability or feature. I assume that one is to infer that the requirement
> applies only if that capability or feature exists in the subject
> implementation seeking to be conformant.
>
> Per RFC 2119, REQUIRED, MUST, and MUST NOT are unconditional by
> themselves.  You make them conditional by making the statement containing
> them conditional, e.g., 'If the Printer supports two-sided printing, the
> Printer MUST support the "sides" Job Template attribute.'
>
> ...
>
> There is there is the additional question as to whether the term should
> 'Conditionally Required" or "Conditionally Mandatory". Since the basic
> compliance term is "Required", "Conditionally Required" seems more
> appropriate.
>
> Agreed.
>
> *CONDITIONALLY REQUIRED*: definition is a requirement of the
> specification if the specified condition is true.
>
> One might prefer a term other than "definition", such as capability or
> feature, and consider a requirement of the implementation rather than of
> the specification, but RFC 2119 wording  is:" … definition is an absolute
> requirement of the specification."
>
> *CONDITIONALLY REQUIRED*: A conformance requirement that applies if the
> specified condition is true.
>
> "The term CONDITIONALLY REQUIRED means that the Printer MUST support the
> feature, if the specified condition is true."
>
>
>
>

---

From: <[email-masked]>
Date: Tue, 14 Jul 2015 03:59:17 +0000

Michael,

 1.  I am unsure of the intent of your reference to RFC2119, and indeed find no use of the word “conditional” in that standard. To the contrary, item 1 states :

 “MUST This word, or the terms "REQUIRED" or "SHALL", mean that the definition is an absolute requirement of the specification. ”

From: Michael Sweet
Sent: ‎Monday‎, ‎July‎ ‎13‎, ‎2015 ‎5‎:‎21‎ ‎PM
To: William A Wagner
Cc: ipp

Bill,

Comments inline...

...

...

---

From: <[email-masked]>
Date: Tue, 14 Jul 2015 04:04:20 +0000

Sorry for the premature send.

From: [email-masked]
Sent: ‎Monday‎, ‎July‎ ‎13‎, ‎2015 ‎11‎:‎59‎ ‎PM
To: Michael Sweet
Cc: ipp

Michael,

2. My problem with the 5100.6 definition is that it is unclear that the  requirement is always for supporting a feature, and indeed it is unclear what the term “feature” encompasses.

So, unless there is objection,  I suggest:

With respect to Ira’s comment, I think that this is clear and concise.  And if we are going to be consistent over PWG specs, the definition should not include the term “Printer”. Also, the rest of the compliance terms are defined by reference to RFC2119, which is general and deals with requirements.

But I do not have a strong position of this and will concur with the consensus.

Thanks,

Bill Wagner

From: Michael Sweet

Bill,

Comments inline...

...

...

---

From: Michael Sweet <[email-masked]>
Date: Tue, 14 Jul 2015 10:54:06 -0400

Bill,

> On Jul 14, 2015, at 12:04 AM, [email-masked] wrote:
> ...
> Michael,

Right, that was my point.

> 2. My problem with the 5100.6 definition is that it is unclear that the  requirement is always for supporting a feature, and indeed it is unclear what the term “feature” encompasses.

I agree "feature" should be avoided.  However, the 5100.6 definition also talks about the specified condition being true which I thought was the key change...

> CONDITIONALLY REQUIRED: A conformance requirement that applies if the specified condition is true.

I think we are in agreement.  I'll prepare an updated template for review next Monday.