Subject: [IPP] RasterView 1.4

From: Michael Sweet <[email-masked]>
Date: Wed, 26 Aug 2015 19:01:07 -0400

RasterView 1.4 is now available for download from:

	http://www.msweet.org/projects.php/rasterview

The new release adds support for viewing Device-N files and improves the display of PWG Raster page attributes.

Enjoy!

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Tim Waugh <[email-masked]>
Date: Thu, 27 Aug 2015 12:03:14 +0100

On Wed, 2015-08-26 at 19:01 -0400, Michael Sweet wrote:
> The new release adds support for viewing Device-N files and improves 
> the display of PWG Raster page attributes.

Hi,

It doesn't build on platforms that don't provide strlcpy().

Tim.
*/

---

From: Ira McDonald <[email-masked]>
Date: Thu, 27 Aug 2015 08:36:18 -0400

Hi Tim,

While not available in glibc, strlcpy is in libbsd (and corrects design
flaws in strncpy according to several C programming books).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

---

From: Tim Waugh <[email-masked]>
Date: Thu, 27 Aug 2015 16:11:02 +0100

On Thu, 2015-08-27 at 08:36 -0400, Ira McDonald wrote:
> While not available in glibc, strlcpy is in libbsd (and corrects
> design flaws in strncpy according to several C programming books).

Oh I understand the background to it, I was just noting that the build
fails -- it doesn't have an autoconf check to account for platforms
without that symbol and take appropriate action.

Tim.
*/