Subject: [IPP] Registration template for "jpeg-features-supported (1setOf type2 keyword)"

From: Michael Sweet <[email-masked]>
Date: Wed, 21 Oct 2015 07:56:21 -0400

All,

Apple would like to register a new "jpeg-features-supported (1setOf type2 keyword)" attribute for the purpose of describing the optional features that a Printer supports in the JPEG file interchange format (JFIF, image/jpeg MIME media type). The following keyword values will initially be registered:

- 'none': The Printer only supports the baseline JFIF format; this keyword only appears by itself.
- 'arithmetic': The Printer supports arithmetic encoding.
- 'cmyk': The Printer supports CMYK images.
- 'deep': The Printer supports more than 8 bits per component.
- 'icc': The Printer supports embedded ICC profiles.
- 'lossless': The Printer supports lossless JPEG encoding.
- 'progressive': The Printer supports progressive encoding.

The primary purpose of this attribute is to allow the Client to determine whether a JPEG file can be printed directly or must be converted to an alternate form (e.g. PWG Raster) prior to printing.  Because of the way many printers process JPEG files, some features (ICC and CMYK support in particular) are silently ignored if not supported, leading to incorrect output (otherwise we could look for a document-format error and retry...)

....

Printer Description attributes:					Reference
------------------------------					---------
jpeg-features-supported (1setOf type2 keyword)			[APPLE20151021]

Attributes (attribute syntax)
  Keyword Attribute Value					Reference
  -----------------------					---------
jpeg-features-supported (1setOf type2 keyword)			[APPLE20151021]
  arithmetic				 			[APPLE20151021]
  cmyk				 				[APPLE20151021]
  deep				 				[APPLE20151021]
  icc				 				[APPLE20151021]
  lossless				 			[APPLE20151021]
  none				 				[APPLE20151021]
  progressive				 			[APPLE20151021]

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Wed, 21 Oct 2015 11:37:11 -0400

Harry,

Thanks for this.  After reviewing the section on JPEG, it looks like the only keyword I haven't covered is 'hierarchical'.  The referenced document also includes some good information on how each of the features is implemented in JPEG...

> On Oct 21, 2015, at 11:10 AM, [email-masked] wrote:
> 
> Hi Michael. I think the "jpeg-features-supported" attribute is a good idea and your registered keywords make sense. I don't know how useful anyone in the PWG will find this but, in the same wheelhouse, the AFPC has defined (print) "subsets" for several widely available formats TIFF, JPEG, PNG and SVG (not published yet). The AFP subset for JPEG was submitted to ISO in 2011 and became or formed the basis for ISO/IEC 10918-6 Application to printing systems <https://www.iso.org/obp/ui/#iso:std:iso-iec:10918:-6:ed-1:v1:en> now a published ISO standard. I'm not suggesting this intersects 100% with Apple's attributes but mention it as FYI in case you might find it helpful in general. It has been a while since ISO published and I don't recall what additions or changes may have occurred so persons really interested are advised to purchase the ISO standard. Meanwhile, the AFPC document is freely available <http://afpcinc.org/wp-content/uploads/2014/04/AFPC-Subsets-v2.0.pdf> and the PWG is free to reference the document if that ever makes sense.   
> 
> Harry Lewis
> AFPC President & Secretary
> Program Manager IP & Standards
> Phone: 720-663-3456
> e-mail: [email-masked]
> <Mail Attachment.gif> 
> 
> 
> 
> From:        Michael Sweet <[email-masked]> 
> To:        ipp <[email-masked]> 
> Date:        10/21/2015 05:56 AM 
> Subject:        [IPP] Registration template for "jpeg-features-supported (1setOf type2 keyword)" 
> Sent by:        [email-masked] 
> 
> 
> 
> All,
> 
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
>

---

From: Ira McDonald <[email-masked]>
Date: Wed, 21 Oct 2015 19:50:05 -0400

Hi Harry,

Thanks!  Very useful AFPC document.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Wed, Oct 21, 2015 at 11:37 AM, Michael Sweet <[email-masked]> wrote:

> Harry,
>
> Thanks for this.  After reviewing the section on JPEG, it looks like the
> only keyword I haven't covered is 'hierarchical'.  The referenced document
> also includes some good information on how each of the features is
> implemented in JPEG...
>
>
> Hi Michael. I think the "jpeg-features-supported" attribute is a good idea
> and your registered keywords make sense. I don't know how useful anyone in
> the PWG will find this but, in the same wheelhouse, the AFPC has defined
> (print) "subsets" for several widely available formats TIFF, JPEG, PNG and
> SVG (not published yet). The AFP subset for JPEG was submitted to ISO in
> 2011 and became or formed the basis for *ISO/IEC 10918-6 Application to
> printing systems*
> <https://www.iso.org/obp/ui/#iso:std:iso-iec:10918:-6:ed-1:v1:en> now a
> published ISO standard. I'm not suggesting this intersects 100% with
> Apple's attributes but mention it as FYI in case you might find it helpful
> in general. It has been a while since ISO published and I don't recall what
> additions or changes may have occurred so persons really interested are
> advised to purchase the ISO standard. Meanwhile, the AFPC document is freely
> available
> <http://afpcinc.org/wp-content/uploads/2014/04/AFPC-Subsets-v2.0.pdf> and
> the PWG is free to reference the document if that ever makes sense.
>
> *Harry Lewis*
> ------------------------------
>
>
>
> All,
>
> Apple would like to register a new "jpeg-features-supported (1setOf type2
> keyword)" attribute for the purpose of describing the optional features
> that a Printer supports in the JPEG file interchange format (JFIF,
> image/jpeg MIME media type). The following keyword values will initially be
> registered:
>
> The primary purpose of this attribute is to allow the Client to determine
> whether a JPEG file can be printed directly or must be converted to an
> alternate form (e.g. PWG Raster) prior to printing.  Because of the way
> many printers process JPEG files, some features (ICC and CMYK support in
> particular) are silently ignored if not supported, leading to incorrect
> output (otherwise we could look for a document-format error and retry...)
>
> ....
>
>  cmyk
> [APPLE20151021]
>  deep
> [APPLE20151021]
>  icc
> [APPLE20151021]
>  lossless
>                                                        [APPLE20151021]
>  none
> [APPLE20151021]