Subject: [IPP] Fwd: [Printing-architecture] CMD: field of device ID, which entry for PWG Raster?

From: Ira McDonald <[email-masked]>
Date: Tue, 10 Nov 2015 09:24:50 -0500

Hi Till,

Forwarding to the PWG IPP WG list for comment.  I'm not sure what the
best practice would be for the IEEE 1284 Device ID CMD field for PWG
Raster.

Mike - suggestions?

Cheers,
- Ira

PS - I'll forward responses back to the Open Printing mailing list.

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

---------- Forwarded message ----------
From: Till Kamppeter <[email-masked]>
Date: Tue, Nov 10, 2015 at 9:08 AM
Subject: [Printing-architecture] CMD: field of device ID, which entry for
PWG Raster?
To: Open Printing <[email-masked]>

Hi,

the IEEE-1284 device ID has a CMD: field to list the page description
languages (PDLs) which a printer supports. What does it have to contain
according to the standards when the printer supports PWG Raster as input
data format?

   Till
_______________________________________________
Printing-architecture mailing list
[email-masked]
https://lists.linuxfoundation.org/mailman/listinfo/printing-architecture
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Tue, 10 Nov 2015 11:03:46 -0500

Ira/Till,

> On Nov 10, 2015, at 9:24 AM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Till,
> 

Per PWG 5107.2:

Conforming implementations of this specification SHOULD use IANA Printer MIB Interpreter Types (primary) or MIME Media Types (secondary) instead of private types, for interoperability.

The current IANA Printer MIB (http://www.iana.org/assignments/ianaprinter-mib/ianaprinter-mib) has the following:

PrtInterpreterLangFamilyTC ::= TEXTUAL-CONVENTION
...
        langPWGRaster(84),   -- Not in RFC 1759
                             -- PWG 5102.4: PWG Raster Format
                             -- ftp://ftp.pwg.org/pub/pwg/candidates/
                             --   cs-ippraster10-20120420-5102.4.pdf
                             -- MIME type "image/pwg-raster"
which means that the CMD field SHOULD contain either 'PWGRaster' (preferred) or 'image/pwg-raster'.

> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> From: Till Kamppeter <[email-masked] <mailto:[email-masked]>>
> Subject: [Printing-architecture] CMD: field of device ID, which entry for PWG Raster?
> To: Open Printing <[email-masked] <mailto:[email-masked]>>
> 
> 
> Hi,
> 
> the IEEE-1284 device ID has a CMD: field to list the page description languages (PDLs) which a printer supports. What does it have to contain according to the standards when the printer supports PWG Raster as input data format?
> 
>    Till
> [email-masked] <mailto:[email-masked]>
> https://lists.linuxfoundation.org/mailman/listinfo/printing-architecture <https://lists.linuxfoundation.org/mailman/listinfo/printing-architecture>
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: Michael Sweet <[email-masked]>
Date: Tue, 10 Nov 2015 12:00:33 -0500

Till,

It SHOULD be "PWGRaster" (as registered), but clients that are examining CMD values MUST compare as case-insensitive.  The SHOULD part is insurance because historically there have been client applications that don't do a case-insensitive comparison...

> On Nov 10, 2015, at 11:44 AM, Till Kamppeter <[email-masked]> wrote:
> 
> Thank you very much, I have forwarded this to the manufacturer.
> 
> Does upper/lower case matter in the CMD: field? Or can I also use "PWGRASTER"?
> 
>   Till
> 
> On 11/10/2015 02:03 PM, Michael Sweet wrote:
>> Per PWG 5107.2:
>> 
>>    Conforming implementations of this specification SHOULD use IANA
>>    Printer MIB Interpreter Types (primary) or MIME Media Types
>>    (secondary) instead of private types, for interoperability.
>> 
>> 
>> The current IANA Printer MIB
>> (http://www.iana.org/assignments/ianaprinter-mib/ianaprinter-mib) has
>> the following:
>>