Subject: [IPP] RFC: Template for subunit collection attributes

From: Michael Sweet <[email-masked]>
Date: Mon, 25 Jan 2016 15:36:13 -0500

[For discussion during today's WG concall]

All,

One of the decisions at the last 3D concall was to use collections for subunit status information. What follows is a general template for all of these attributes, which we will discuss before I apply it to the various subunit attributes in the current draft.

....

"printer-<subunitname>-col (1setOf collection)"

This CONDITIONALLY REQUIRED Printer Status attribute provides the status of the <subunitname> sub-units that are managed by the Printer. Printers that support <subunitname> sub-units MUST support this attribute.

"<subunitname>-info (text)"

This member attribute provides a human-readable description for the sub-unit.

"<subunitname>-info-uri (uri)"

This member attribute provides a web page for the sub-unit.

"<subunitname>-name (name)"

This member attribute provides a human-readable name for the sub-unit.

"<subunitname>-make-and-model (text)"

This member attribute provides a human-readable make and model for the sub-unit.

"<subunitname>-security (boolean)"

This member attribute indicates whether the sub-unit has some security associated with it.

"<subunitname>-serial-number (text)"

This member attribute provides a human-readable serial number for the sub-unit.

"<subunitname>-state (type1 enum)"

This member attribute provides the current state of the sub-unit. Values are:

    '3' ('idle'): The sub-unit is available and either idle or in standby mode.
    '4' ('processing'): The sub-unit is available and either active or busy.
    '5' ('stopped'): The sub-unit is unavailable.

Additional information concerning the state can be found in the "printer-state-reasons" Printer Status attribute [RFC2911].

"<subunitname>-version (text)"

This member attribute provides a human-readable version for the sub-unit.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 25 Jan 2016 17:18:21 -0500

To close the loop on this, we decided to drop <subunitname>-security as it is poorly defined, even in the original RFC 3805 text.  I will have formal definitions for all 3D sub-units included in the next draft of the IPP 3D spec.

> On Jan 25, 2016, at 3:36 PM, Michael Sweet <[email-masked]> wrote:
>

---

From: Ira McDonald <[email-masked]>
Date: Tue, 26 Jan 2016 13:42:41 -0500

Hi,

Links to the Printer MIB objects for DMTF CIM Schema mapping spreadsheet
and rationale documents from the WIMS WG in 2006:

http://ftp.pwg.org/pub/pwg/wims/cim/PrinterMibObjectsToAdd_conclusions_20060921_F.xls

http://ftp.pwg.org/pub/pwg/wims/cim/PrinterMibObjectsToAdd_conclusions_20060921_F_Rationale.pdf

Useful for the IPP 3D subunit template as well as for general Printer MIB
firmware planning.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Mon, Jan 25, 2016 at 5:18 PM, Michael Sweet <[email-masked]> wrote:

> To close the loop on this, we decided to drop <subunitname>-security as it
> is poorly defined, even in the original RFC 3805 text.  I will have formal
> definitions for all 3D sub-units included in the next draft of the IPP 3D
> spec.
>
>
> > One of the decisions at the last 3D concall was to use collections for
> subunit status information. What follows is a general template for all of
> these attributes, which we will discuss before I apply it to the various
> subunit attributes in the current draft.
> >
> > ....
> >
> > This CONDITIONALLY REQUIRED Printer Status attribute provides the status
> of the <subunitname> sub-units that are managed by the Printer. Printers
> that support <subunitname> sub-units MUST support this attribute.
> >
> >
> > Additional information concerning the state can be found in the
> "printer-state-reasons" Printer Status attribute [RFC2911].
> >
> >

---

From: Michael Sweet <[email-masked]>
Date: Tue, 26 Jan 2016 14:29:57 -0500

Ira,

Thanks for this.

Based on the spreadsheet, it looks like the make, model, version, and serial number information was rated a C by every person that cast a vote, so I am inclined to limit the base subunit member attributes to:

    <subunitname>-info (REQUIRED)
    <subunitname>-info-uri (RECOMMENDED)
    <subunitname>-name (REQUIRED)
    <subunitname>-state (REQUIRED)
    <subunitname>-state-reasons (CONDITIONALLY REQUIRED when there are multiple sub-units of a given type, added during the concall)

Plus the following as needed (another common one from the Printer MIB):

    <subunitname>-type (REQUIRED)

> On Jan 26, 2016, at 1:42 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi,
> 
> Links to the Printer MIB objects for DMTF CIM Schema mapping spreadsheet and rationale documents from the WIMS WG in 2006:
> 
> http://ftp.pwg.org/pub/pwg/wims/cim/PrinterMibObjectsToAdd_conclusions_20060921_F.xls <http://ftp.pwg.org/pub/pwg/wims/cim/PrinterMibObjectsToAdd_conclusions_20060921_F.xls>
> 
> http://ftp.pwg.org/pub/pwg/wims/cim/PrinterMibObjectsToAdd_conclusions_20060921_F_Rationale.pdf <http://ftp.pwg.org/pub/pwg/wims/cim/PrinterMibObjectsToAdd_conclusions_20060921_F_Rationale.pdf>
> 
> Useful for the IPP 3D subunit template as well as for general Printer MIB firmware planning.
> 
> Cheers,
> - Ira
> 
> 
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> On Mon, Jan 25, 2016 at 5:18 PM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
> > On Jan 25, 2016, at 3:36 PM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
> >
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
>