Subject: [IPP] First draft of IPP Finishings 2.1 available for review

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Mon, 11 Apr 2016 18:11:37 +0000

Hello,

I have just posted a first draft of IPP Finishings 2.1 to the PWG FTP site.  It is available here:

http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160411.pdf
http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160411.docx
http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160411-rev.pdf
http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160411-rev.docx

We are meeting in less than an hour so I don't expect anybody to have time to review it, and there are still additions needed for the orientation / feed direction issue (which we can discuss in the call or at the F2F) but I wanted to get a first pass out there.

Cheers,

Smith

/**
    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
    PWG Chair
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Mon, 11 Apr 2016 14:17:51 -0400

Hi Smith,

Speaking of meeting in 45 minutes, Mike sent a note this afternoon that
he got stuck in an out of town meeting and can't attend today.

We need a volunteer to take at least basic minutes, if we're to look at the
Finishings 2.1 draft (my preference) or more of System Service (where I'd
really like Mike's eyes if we're moving into a fresh section).

Smith?  Bill?

We can also cancel, but what with one thing and another, our last regular
IPP WG call was in late February.

WDYT?

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Mon, Apr 11, 2016 at 2:11 PM, Kennedy, Smith (Wireless Architect) <
[email-masked]> wrote:

> We are meeting in less than an hour so I don't expect anybody to have time
> to review it, and there are still additions needed for the orientation /
> feed direction issue (which we can discuss in the call or at the F2F) but I
> wanted to get a first pass out there.
>
> Cheers,
>
> Smith
>
> /**
>     Smith Kennedy

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Mon, 11 Apr 2016 18:32:06 +0000

Hi Ira,

I think we should hold the call, and I would be happy to take minutes.  I'm likely not as good at it as Mike at tracking all the suggested changes. I don't have a preference of which document to review.
 
Smith

/**
    Smith Kennedy

> On 2016-04-11, at 12:17 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Smith,
> 
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> On Mon, Apr 11, 2016 at 2:11 PM, Kennedy, Smith (Wireless Architect) <[email-masked] <mailto:[email-masked]>> wrote:
> Hello,
> 
> http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160411.pdf <http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160411.pdf>
> http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160411.docx <http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160411.docx>
> http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160411-rev.pdf <http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160411-rev.pdf>
> http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160411-rev.docx <http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160411-rev.docx>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
> 
>

---

From: <[email-masked]>
Date: Thu, 14 Apr 2016 16:06:26 -0400

Hi Smith,
My notes indicated that EcoStaple (perhaps as “crimp”) and Engineering Z Fold values would be  included in Finishings 2.1, but I do not see them. Am I just missing tem or was there a change of approach?
Thanks,
Bill Wagner

From: Kennedy, Smith (Wireless Architect)
Sent: Monday, April 11, 2016 2:11 PM
To: [email-masked]
Subject: [IPP] First draft of IPP Finishings 2.1 available for review

Hello,

Cheers,

Smith

/**
    Smith Kennedy

---

From: Michael Sweet <[email-masked]>
Date: Thu, 14 Apr 2016 16:32:27 -0400

Bill,

> On Apr 14, 2016, at 4:06 PM, [email-masked] wrote:
> 
> Hi Smith,

Yes, I think these should be in there but currently are not.

The changes that are needed are:

1. Figure 1: Add 'fold-engineering-z' (I owe you this one Smith)

2. New Section 5.1.x PWG 5100.1-YYYY "finishings Values"

   - New "finishings" enum value 101 with keyword name 'fold-engineering-z'
   - "Fold the hardcopy output vertically into three sections, forming a Z but leaving room for binding, punching, or stapling along the top edge."

3. Section 5.2.6.4 “folding” Examples

   `fold-engineering-z’
   folding = { folding-direction=’inward’ folding-offset=11593
               folding-reference-edge=’top’ },
             { folding-direction=’outward’ folding-offset=20646
               folding-reference-edge=’top’ }

4. New Section 5.2.12.5 stitching-type (type2 keyword)

   The "stitching-type" member attribute specifies the type of stitching to use. The following values are defined by this specification:

       'auto': Automatically choose a stitching type based on the Set being finished.
       'crimp': Crimp the Set together.
       'wire': Use wire staples.

5. New Section 6.x stitching-type-supported (1setOf type2 keyword)

   The "stitching-type-supported" Printer attribute lists the supported values for the "stitching-type" (section 5.2.12.5) member attribute.

Note: JDF has a "stitching type" with values "corner", "saddle", and "side".  Perhaps we should use the name "stitching-kind" instead to avoid confusion (since JDF doesn't currently support crimping/eco-staples)???

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Thu, 14 Apr 2016 20:55:53 +0000

I wasn't sure whether the registrations posted earlier to the reflector were sufficient or if they needed to be included.  I will make these changes in the next draft, to be posted hopefully by EOD tomorrow, in preparation for the F2F.

Smith

> On 2016-04-14, at 2:32 PM, Michael Sweet <[email-masked]> wrote:
> 
> Bill,
> 
>> On Apr 14, 2016, at 4:06 PM, [email-masked] <mailto:[email-masked]> wrote:
>> 
>> Hi Smith,

---

From: Michael Sweet <[email-masked]>
Date: Thu, 14 Apr 2016 16:58:27 -0400

Smith,

I think we want to include the finishings registrations in the latest standard document.

> On Apr 14, 2016, at 4:55 PM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
>> On 2016-04-14, at 2:32 PM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Bill,
>>

---

From: "Yardumian, Rick" <[email-masked]>
Date: Fri, 15 Apr 2016 00:12:42 +0000

Hi Smith, Mike & Bill,

For completeness should we add the new ‘draw-line’ value to trimming-type in Finishing 2.1?

Thanks,
Rick

From: ipp [mailto:[email-masked]] On Behalf Of Kennedy, Smith (Wireless Architect)
Sent: Thursday, April 14, 2016 1:56 PM
To: Michael Sweet
Cc: [email-masked]
Subject: Re: [IPP] First draft of IPP Finishings 2.1 available for review

Smith

On 2016-04-14, at 2:32 PM, Michael Sweet <[email-masked]<mailto:[email-masked]>> wrote:

Bill,

On Apr 14, 2016, at 4:06 PM, [email-masked]<mailto:[email-masked]> wrote:

Hi Smith,

   `fold-engineering-z’

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Fri, 15 Apr 2016 00:30:06 +0000

I'll add that as well. 

Cheers,
Smith
---

    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Standards - PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum
    PWG Chair
    HP Inc.

> On Apr 14, 2016, at 6:13 PM, Yardumian, Rick <[email-masked]> wrote:
> 
> Hi Smith, Mike & Bill,
>

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Fri, 15 Apr 2016 21:16:53 +0000

> Note: JDF has a "stitching type" with values "corner", "saddle", and "side".  Perhaps we should use the name "stitching-kind" instead to avoid confusion (since JDF doesn't currently support crimpin…

I don't have a problem calling it "stitching-kind".  Any objections from anybody else?  Rick / Ira / Bill?

---

From: Ira McDonald <[email-masked]>
Date: Fri, 15 Apr 2016 21:03:17 -0400

Hi,

Maybe "stitching-method"?  I find "kind" a little vague.

Cheers,
- Ira

On Fri, Apr 15, 2016 at 5:16 PM, Kennedy, Smith (Wireless Architect) <
[email-masked]> wrote:

>    The "stitching-type-supported" Printer attribute lists the supported
> values for the "stitching-type" (section 5.2.12.5) member attribute.
>
>
> Note: JDF has a "stitching type" with values "corner", "saddle", and
> "side".  Perhaps we should use the name "stitching-kind" instead to avoid
> confusion (since JDF doesn't currently support crimping/eco-staples)???
>
>