Subject: [IPP] [PWG5100.20] Issue #36: No test for "LOC" DNS records mandated by 5100.14 section 4.2.2

From: [email-masked]
Date: Fri, 13 May 2016 17:47:58 +0000 (UTC)

[Issue Unconfirmed]

PWG 5100.14 section 4.2.2 requires Printer objects to publish LOC records
for their service.  But 5100.20 lacks a requirement to test for them. 
(Should we eliminate them from 5100.14 or make them optional?)

Link: http://www.pwg.org/issues/36

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Sun, 15 May 2016 11:23:35 -0400

Hi,

I am strongly opposed to reducing requirements in PWG 5100.14 (or any
other IETF or PWG IPP spec) just because there is not a current test for
the requirement in the self-cert tools.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Mon, 16 May 2016 04:36:21 +0000

Hi Ira,

I completely agree with your statement.  Just because we are lacking tests validating a requirement doesn't mean we should withdraw the requirement - we should add tests.  I shouldn't have conflated my identifying this issue with my query about whether we should be requiring LOC records in 5100.14.  I should have raised that in a separate context so that the two issues didn't get associated with one another.

Smith

/**
    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
    PWG Chair
    HP Inc.
*/

> On 2016-05-15, at 9:23 AM, Ira McDonald <[email-masked]> wrote:
> 
> Hi,
> 
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> On Fri, May 13, 2016 at 1:47 PM, <[email-masked] <mailto:[email-masked]>> wrote:
> [Issue Unconfirmed]
> 
> Link: http://www.pwg.org/issues/36 <http://www.pwg.org/issues/36>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
>