Subject: [IPP] [PWG5100.6] Issue #30: "overrides-supported": 'document-numbers' should be conditionally required depending on "multiple-document-jobs-supported" = 'true'

From: [email-masked]
Date: Wed, 4 May 2016 20:26:45 +0000 (UTC)

[Issue Unconfirmed]

PWG 5100.6-2004 section 4.1.7 says:

   This attribute MUST contain the keywords “pages” and
“document-numbers” because
   a Printer MUST support these attributes.

But the 'document-numbers' attribute should not be required
unconditionally; it should be conditionally required depending on whether
the Printer reports "multiple-document-jobs-supported" = 'true'.  If it
doesn't support "multiple-document-jobs-supported" or reports
"multiple-document-jobs-supported" = 'false' then 'document-numbers' should
not be required.

Link: http://www.pwg.org/issues/30

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Zehler, Peter" <[email-masked]>
Date: Thu, 5 May 2016 15:11:07 +0000

All,

If I remember correctly, the printer must accept the “document-numbers” in a client request even if the printer only supports single document jobs.  For a single document job, and a printer that supports either single or multiple document jobs,  the following attribute values in request containing an "overrides" attribute would all be equivalent:
"document-numbers": '1: 2147483647', (i.e., all my documents)
"document-numbers": '1: 1', (i.e., my first document)
"document-numbers" omitted (i.e. all my documents)

The client may specify a subset of documents to which the override is applied.  The implication of not specifying is that the overrides applies to all.    The printer must accept and understand all of these.  A client specifying a document number that does not exist is ignored since the override applies only to the pages/documents/document-copies specified for the override.

I think it is simpler and cleaner to keep the primary specification of the override target (i.e., pages and document) mandatory for the printer to support in a request while the edge case (i.e., document-copies) remains optional.

Peter Zehler
Xerox Corp.
Global Development Group
800 Phillips Rd, 111-04A
Webster NY, 14580-9701
Email: [email-masked]
Office: +1 (585) 265-8755
Fax: +1 (585) 422-0238
Mobile: +1 (585) 329-9508

-----Original Message-----
From: ipp [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 04, 2016 4:27 PM
To: [email-masked]
Subject: [IPP] [PWG5100.6] Issue #30: "overrides-supported": 'document-numbers' should be conditionally required depending on "multiple-document-jobs-supported" = 'true'

[Issue Unconfirmed]

   This attribute MUST contain the keywords “pages” and “document-numbers” because
   a Printer MUST support these attributes.

But the 'document-numbers' attribute should not be required unconditionally; it should be conditionally required depending on whether the Printer reports "multiple-document-jobs-supported" = 'true'.  If it doesn't support "multiple-document-jobs-supported" or reports "multiple-document-jobs-supported" = 'false' then 'document-numbers' should not be required.

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Fri, 6 May 2016 22:56:21 +0000

Hi Pete,

Thanks for providing the background on this.  But it still seems a bit odd to me to require support for an attribute when the feature itself isn't supported.  As you say, if "document-numbers" is omitted, that is semantically equivalent to "all my documents" and on these products that is equivalent to "my first document" since it only supports one document per job.

Is your concern that there could be clients out there that would have their jobs rejected because they expect the printer to always support "document-numbers" and they don't?  There are certainly a lot of printers out there that do not support it.

Smith

/**
    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
    PWG Chair
    HP Inc.
*/

> On 2016-05-05, at 9:11 AM, Zehler, Peter <[email-masked]> wrote:
> 
> All,
>

---

From: "Zehler, Peter" <[email-masked]>
Date: Mon, 9 May 2016 11:03:05 +0000

Smith,
My concern is that clients that implement page overrides will break.  The long standing specification explicitly states the printer must accept document number in a request.  I know there are some clients that do not ask the printer first to see if the page number or document number are permitted in the request.  The specification does not say that the printer must support the document object, and therefore "document-number" , in order to support page overrides.  It only says that the printer must support the document number in the request.  I would prefer to keep the requirements as specified not only to prevent client interoperability problems but also to keep the implementations simplified and not have to accommodate special case processing.  The simplified implementation would be true not only on the client side but the printer side as well.  I have no problem with the client checking to see if the "document-copies" is supported since the use of it is a corner condition.  I would also argue that by definition even a printer implementation that supports only single document jobs does implement a document object and its associated number.  It is just not exposed through the IPP protocol.  
Pete

Peter Zehler
Xerox Corp.
Global Development Group
800 Phillips Rd, 111-04A
Webster NY, 14580-9701

-----Original Message-----
From: Kennedy, Smith (Wireless Architect) [mailto:[email-masked]] 
Sent: Friday, May 06, 2016 6:56 PM
To: Zehler, Peter <[email-masked]>
Cc: [email-masked]
Subject: Re: [IPP] [PWG5100.6] Issue #30: "overrides-supported": 'document-numbers' should be conditionally required depending on "multiple-document-jobs-supported" = 'true'

Hi Pete,

Smith

/**
    Smith Kennedy

---

From: [email-masked]
Date: Thu, 12 May 2016 20:06:50 +0000 (UTC)

[Issue Unconfirmed]

Consensus from 2015-05-09 IPP WG conference call was to leave 5100.6 as it
is, but rather clarify 5100.14 can conditionally require it depending on
"multiple-document-jobs-supported" = 'true', since 5100.14 may define its
own normative requirements and doesn't need to simply adopt all 5100.6
normative requirements.

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Thu, 12 May 2016 20:23:33 +0000

Hi Pete,

I wanted to provide you with an update.  We discussed this on Monday in the IPP WG meeting, and we all agreed with you that we should not be changing 5100.6.  It will remain as it is.

However, since 5100.14 isn't requiring normative compliance with 5100.6 but is rather simply adopting attributes defined therein, we agreed that within the context of IPP Everywhere making "overrides-supported"/"document-copies" it was reasonable to conditionally require depending on "multiple-document-jobs-supported".

Please let me know if you see problems with this direction.
 
Smith

/**
    Smith Kennedy

> On 2016-05-09, at 5:03 AM, Zehler, Peter <[email-masked]> wrote:
> 
> Smith,

---

From: "Zehler, Peter" <[email-masked]>
Date: Mon, 16 May 2016 12:08:19 +0000

Smith,

I don't understand your response.  Especially your comment " rather simply adopting attributes defined therein".  A feature, such as overrides, can't be taken in bits and pieces.  A feature like this stands on its own and is either supported or not.  I'd also point out that the overrides feature is the second version and has significant implementation experience behind it.  It has been greatly simplified.  

If your intention is to modify the test suite to permit to permit certain implementations to pass, I have no objection.  The test suite was never intended to be comprehensive and rigorous. But you must not change the mandatory semantics of 5100.6 in a subsequent specification such as 5100.14.  There is no association between  overrides and  "multiple-document-jobs-supported".  I believe that was discussed and rejected.  The "overrides-supported" attribute has two mandatory values if overrides is supported.  Most important is that a printer MUST accept, and honor, "document-numbers" in a request.  Of course the job level attributes (e.g., “multiple-document-handling”) are ignored. But the “ipp-attribute-fidelity” attribute MUST be honored.  If it is true, a single document printer that supports overrides MUST NOT reject a job with an override that includes '1' in its "document-numbers" attribute.

I can probably make myself available for a PWG IPP meeting if this subject is on the agenda.  Typing is not the most efficient way carry on a discussion.  As you may of guessed, I strongly believe it would be a mistake to change a mandatory attribute/value to conditional.

Pete

Peter Zehler
Xerox Corp.
Global Development Group
800 Phillips Rd, 111-04A
Webster NY, 14580-9701

-----Original Message-----
From: Kennedy, Smith (Wireless Architect) [mailto:[email-masked]] 
Sent: Thursday, May 12, 2016 4:24 PM
To: Zehler, Peter <[email-masked]>
Cc: [email-masked]
Subject: Re: [IPP] [PWG5100.6] Issue #30: "overrides-supported": 'document-numbers' should be conditionally required depending on "multiple-document-jobs-supported" = 'true'

Hi Pete,

 
Smith

/**
    Smith Kennedy

---

From: Michael Sweet <[email-masked]>
Date: Mon, 16 May 2016 09:32:01 -0400

All,

I think we have consensus to relax the IPP Everywhere Printer Self-Certification test suite WRT requiring the value 'document-numbers' in the "overrides-supported" attribute, at least for printers that do not support multiple document jobs (the majority of IPP printers by far).  We can discuss whether to add a test for overrides on PDF printers...

We also have consensus to NOT update PWG 5100.6 since doing so will introduce interoperability issues.

As for errata updates to PWG 5100.14, we have consensus to:

1. List the specific "overrides" member attributes that are required ("overrides.document-numbers", "overrides.page-numbers", plus each of the required/conditionally required Job Template attributes), which is consistent with how "media-col" is handled in the currently published specification; and

2. Update the "overrides" and "overrides-supported" member attributes to "Note 5" since the intent was not to require overrides support for all printers, but just for PDF printers since PWG Raster offers per-page media and duplex overrides as part of the format.

Based on your feedback below and what is required for conformance with PWG 5100.6, I feel that any further clarification in 5100.14 should be limited to adding a note explaining that Printers that do not support multiple document jobs MUST still accept a "document-numbers" member attribute with the value '1', and the Clients SHOULD NOT send the "document-numbers" member attribute unless submitting a multiple-document job.

Thoughts?

> On May 16, 2016, at 8:08 AM, Zehler, Peter <[email-masked]> wrote:
> 
> Smith,
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: "Zehler, Peter" <[email-masked]>
Date: Mon, 16 May 2016 14:09:06 +0000

Mike,

I am fine with relaxing the IPP Everywhere Printer Self-Certification test suite as described.   I have only minor objections to the errata updates to 5100.14. (I don’t see overrides bound to a document format, but I can live with it for the purposes of conformance.)  I also don’t mind the clarification that “Clients SHOULD NOT send the "document-numbers" member attribute unless submitting a multiple-document job.”

I would be more comfortable with explaining that “Printers that do not support multiple document jobs MUST still accept a "document-numbers" member attribute that include the value '1' “ . I would also include something like “in accordance with the “ipp-attributes-fidelity” value”.  I mention that since the printer’s behavior with regards to accepting any attribute/value depends not only on whether it is supported, but also any conflicts exist, and especially the user intent as specified by “ipp-attributes-fidelity”.

Pete

Pete

Peter Zehler
Xerox Corp.
Global Development Group
800 Phillips Rd, 111-04A
Webster NY, 14580-9701
Email: [email-masked]<mailto:[email-masked]>
Office: +1 (585) 265-8755<tel:%2B1%20%28585%29%20265-8755>
Fax: +1 (585) 422-0238<tel:%2B1%20%28585%29%20265-8755>
Mobile: +1 (585) 329-9508<tel:%2B1%20%28585%29%20329-9508>

From: [email-masked] [mailto:[email-masked]]
Sent: Monday, May 16, 2016 9:32 AM
To: Zehler, Peter <[email-masked]>
Cc: Smith Kennedy <[email-masked]>; [email-masked]
Subject: Re: [IPP] [PWG5100.6] Issue #30: "overrides-supported": 'document-numbers' should be conditionally required depending on "multiple-document-jobs-supported" = 'true'

All,

Thoughts?

On May 16, 2016, at 8:08 AM, Zehler, Peter <[email-masked]<mailto:[email-masked]>> wrote:

Smith,

Pete

Peter Zehler
Xerox Corp.
Global Development Group
800 Phillips Rd, 111-04A
Webster NY, 14580-9701
Email: [email-masked]<mailto:[email-masked]>
Office: +1 (585) 265-8755
Fax: +1 (585) 422-0238
Mobile: +1 (585) 329-9508

-----Original Message-----
From: Kennedy, Smith (Wireless Architect) [mailto:[email-masked]]
Sent: Thursday, May 12, 2016 4:24 PM
To: Zehler, Peter <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [IPP] [PWG5100.6] Issue #30: "overrides-supported": 'document-numbers' should be conditionally required depending on "multiple-document-jobs-supported" = 'true'

Hi Pete,

Smith

/**
   Smith Kennedy

On 2016-05-09, at 5:03 AM, Zehler, Peter <[email-masked]<mailto:[email-masked]>> wrote:

Smith,

Peter Zehler
Xerox Corp.
Global Development Group
800 Phillips Rd, 111-04A
Webster NY, 14580-9701
Email: [email-masked]<mailto:[email-masked]>
Office: +1 (585) 265-8755
Fax: +1 (585) 422-0238
Mobile: +1 (585) 329-9508

-----Original Message-----
From: Kennedy, Smith (Wireless Architect) [mailto:[email-masked]]
Sent: Friday, May 06, 2016 6:56 PM
To: Zehler, Peter <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [IPP] [PWG5100.6] Issue #30: "overrides-supported": 'document-numbers' should be conditionally required depending on "multiple-document-jobs-supported" = 'true'

Hi Pete,

Smith

/**
  Smith Kennedy

On 2016-05-05, at 9:11 AM, Zehler, Peter <[email-masked]<mailto:[email-masked]>> wrote:

All,

Peter Zehler
Xerox Corp.
Global Development Group
800 Phillips Rd, 111-04A
Webster NY, 14580-9701
Email: [email-masked]<mailto:[email-masked]>
Office: +1 (585) 265-8755
Fax: +1 (585) 422-0238
Mobile: +1 (585) 329-9508

-----Original Message-----
From: ipp [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Wednesday, May 04, 2016 4:27 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [IPP] [PWG5100.6] Issue #30: "overrides-supported": 'document-numbers' should be conditionally required depending on "multiple-document-jobs-supported" = 'true'

[Issue Unconfirmed]

_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp

_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 16 May 2016 10:44:38 -0400

Pete,

I am fine with your proposed wording changes about the value, and we can reference section 4.1.4 of PWG 5100.6 which already discusses how "ipp-attribute-fidelity" interacts with the "overrides" Job Template attribute...

As for binding "overrides" support to a document format, that *was* the original intent when we developed IPP Everywhere and is also used for "copies" and "page-ranges".  Sadly, with all of those notes we've managed to introduce errors that weren't caught during the last call and formal approval, so we do need to do an errata update at some point... :/

> On May 16, 2016, at 10:09 AM, Zehler, Peter <[email-masked]> wrote:
> 
> Mike,
>

---

From: "Zehler, Peter" <[email-masked]>
Date: Mon, 16 May 2016 15:50:04 +0000

Mike,
As I said I only had a minor objection, which can be interpreted as a personal opinion with no intent to revisit the decision.  I just prefer a clean separation between content and user intent.  :)
Pete 

Peter Zehler
Xerox Corp.
Global Development Group
800 Phillips Rd, 111-04A
Webster NY, 14580-9701

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, May 16, 2016 10:45 AM
To: Zehler, Peter <[email-masked]>
Cc: Smith Kennedy <[email-masked]>; [email-masked]
Subject: Re: [IPP] [PWG5100.6] Issue #30: "overrides-supported": 'document-numbers' should be conditionally required depending on "multiple-document-jobs-supported" = 'true'

Pete,

> 1. List the specific "overrides" member attributes that are required 
> ("overrides.document-numbers", "overrides.page-numbers", plus each of 
> the required/conditionally required Job Template attributes), which is 
> consistent with how "media-col" is handled in the currently published 
> specification; and
>  
> “document-numbers” because a Printer MUST support these attributes.
>