Subject: [IPP] PWG 5100.19 (IPP Implementor's Guide v2): Incorrect "job-constraints-supported" example in section 5.9?

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Sun, 29 May 2016 13:02:45 +0000

Hi there,

I was working on resolving the finishings limitations using "job-constraints-supported" and "job-resolvers-supported", and was referring to the example I had put in the IPP Implementor's Guide v2 section 5.9 and to the definition of "job-constraints-supported" in 5100.13, and had some questions.

The example is this:

job-constraints-supported=
{
  resolver-name=“A”
  sides=
  {
    "two-sided-long-edge"
    "two-sided-short-edge"
  }
  media-col=
  {
    media-type="transparency"
  }
}

job-resolvers-supported=
{
  resolver-name=“A”
  sides="one-sided"
  media-col=
  {
    media-type="stationery"
  }
}

The part of this example that seems odd, if it is correct, is that "sides" is defined to be "type2 keyword" but the representation above makes it look like a collection.  So either the definition of "job-constraints-supported" needs to be clarified, or we need an errata fix to this example, to look like so:

job-constraints-supported=
{
  resolver-name=“A”
  sides="two-sided-short-edge"
  media-col=
  {
    media-type="transparency"
  }
}

job-constraints-supported=
{
  resolver-name=“A”
  sides="two-sided-long-edge"
  media-col=
  {
    media-type="transparency"
  }
}

job-resolvers-supported=
{
  resolver-name=“A”
  sides="one-sided"
  media-col=
  {
    media-type="stationery"
  }
}

Thoughts?

Smith

/**
    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
    PWG Chair
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 30 May 2016 09:39:27 -0400

Smith,

This is a typo in the example, it should be either a 1setOf keyword value:

    sides='two-sided-long-edge','two-sided-short-edge'

or broken out as you describe (both syntaxes are supported, the 1setOf syntax is just more compact...)

> On May 29, 2016, at 9:02 AM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
> Hi there,
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer