Subject: [IPP] Justification for IPP Everywhere to require Printer to support "Cancel-My-Jobs"?

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Wed, 11 May 2016 20:57:38 +0000

Hi there,

Can someone recall the value of requiring IPP Everywhere printers to support the Cancel-My-Jobs operation?  For less capable printers that have little notion of "users" or of queued / pending jobs, this operation seems really quite unnecessary, or at the least a no-op that would simply "alias" Cancel-Jobs.  Doesn't that dilute the operation's value?

Thanks for any help,

Smith

/**
    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
    PWG Chair
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Wed, 11 May 2016 22:49:35 -0400

Smith,

Cancel-Jobs is an admin operation, while Cancel-My-Jobs is a user operation (like Cancel-Job).

The reason for requiring it is to provide a way to cancel all pending jobs, even if you don't know the job-id(s).

> On May 11, 2016, at 4:57 PM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
> Hi there,
>