Subject: [IPP] "trimming-when" member attribute - why no keyword corresponding to 'no-trimming'?

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Tue, 4 Oct 2016 21:19:30 +0000

Hi there,

In Finishings 2.0 / 2.1, the "trimming-when" member attribute has 4 keywords defined 'after-documents', 'after-job', 'after-sets', and 'after-sheets'. But what keyword would the user provide if they don't want the paper cut at all?

Smith

/**
    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Manchala, Daniel" <[email-masked]>
Date: Tue, 4 Oct 2016 21:37:13 +0000

A related question. 

Does 'trimming-type' include crease in addition to scoring, perforation, partial and full?

Thanks,
Daniel.

________________________________________
From: ipp [[email-masked]] on behalf of Kennedy, Smith (Wireless Architect) [[email-masked]]
Sent: Tuesday, October 04, 2016 2:19 PM
To: [email-masked]
Subject: [IPP] "trimming-when" member attribute - why no keyword corresponding to 'no-trimming'?

Hi there,

Smith

/**
    Smith Kennedy

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Tue, 4 Oct 2016 21:53:00 +0000

Hi Daniel,

The IANA IPP registry (http://www.iana.org/assignments/ipp-registrations/ipp-registrations.xml) has the following keywords registered for "trimming-type":

draw-line
full
partial
perforate
score
tab

What would you say is the nature of the difference between 'crease' and 'score'?

Smith

> On Oct 4, 2016, at 3:37 PM, Manchala, Daniel <[email-masked]> wrote:
> 
> A related question. 
>

---

From: "Manchala, Daniel" <[email-masked]>
Date: Tue, 4 Oct 2016 22:03:48 +0000

Smith,

I think scoring is usually done by rolling a circular (semi blunt) object on paper - much like a pizza cutter, except it is not that sharp.

Creasing is done by folding paper, and pressing it - much like placing an anvil over it. 

The effects are probably different - scoring results in cracking (peeling of toner) at the fold.

But, todays finishers might do a better job of scoring and call it creasing; so may be they are defined to be the same.

Daniel. 
________________________________________
From: Kennedy, Smith (Wireless Architect) [[email-masked]]
Sent: Tuesday, October 04, 2016 2:53 PM
To: Manchala, Daniel
Cc: [email-masked]
Subject: Re: "trimming-when" member attribute - why no keyword corresponding to 'no-trimming'?

Hi Daniel,

draw-line
full
partial
perforate
score
tab

Smith

---

From: "Yardumian, Rick" <[email-masked]>
Date: Tue, 4 Oct 2016 22:23:18 +0000

Hi Smith,

In April 2016, Canon wanted to add "crease" as a trimming-type value but the PWG said the score value was the same as crease so Canon dropped the request.

Best regards,
Rick

-----Original Message-----
From: ipp [mailto:[email-masked]] On Behalf Of Kennedy, Smith (Wireless Architect)
Sent: Tuesday, October 04, 2016 2:53 PM
To: Manchala, Daniel
Cc: [email-masked]
Subject: Re: [IPP] "trimming-when" member attribute - why no keyword corresponding to 'no-trimming'?

Hi Daniel,

draw-line
full
partial
perforate
score
tab

Smith

---

From: Michael Sweet <[email-masked]>
Date: Tue, 04 Oct 2016 21:10:01 -0400

Smith,

If you don't want trimming done, you omit the trimming collection.

> On Oct 4, 2016, at 5:19 PM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
> Hi there,
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Wed, 5 Oct 2016 03:31:05 +0000

Hi Mike,

That won't work if the printer has the following, right? (Taken from ipptool output and slightly reformatted)

finishings-col-default =
{
  finishing-template=after-sheets
  trimming-type=full
  trimming-offset=500
  trimming-when=after-sheets
  trimming-reference-edge=bottom
}

I guess a Client could send "finishings" = 'none' and not include "finishings-col". Is that how the Client is expected to disable trimming in this case?

Smith

> On Oct 4, 2016, at 7:10 PM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
>

---

From: Michael Sweet <[email-masked]>
Date: Wed, 05 Oct 2016 06:42:35 -0400

Smith,

Sent from my iPad

> On Oct 4, 2016, at 11:31 PM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
> Hi Mike,
> 

Yes, or pass 'no-value' or an empty collection in "finishings-col".

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Wed, 5 Oct 2016 18:00:59 +0000

Thanks, Mike! That answers my questions, and I don't think we need any new keywords for "trimming-when".

Smith

> On Oct 5, 2016, at 4:42 AM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
> 
> Sent from my iPad
> 
> On Oct 4, 2016, at 11:31 PM, Kennedy, Smith (Wireless Architect) <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> Hi Mike,
>> 
>>> On Oct 4, 2016, at 7:10 PM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> Smith,
>>> 
>>>> On Oct 4, 2016, at 5:19 PM, Kennedy, Smith (Wireless Architect) <[email-masked] <mailto:[email-masked]>> wrote:
>>>> 
>>>> Hi there,
>>>> 
>>>> [email-masked] <mailto:[email-masked]>
>>>> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
>>>