Subject: [IPP] Finishings 2.1 : mapping "finSupplyDescription" into IPP? Alternatives to consider

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Mon, 17 Oct 2016 19:56:58 +0000

Hi there,

As you may have noticed in the most recent draft of Finishing 2.1, Ira and I added a new "printer-finisher-supplies" attribute to convey information about finisher supplies, which was absent before. It is structurally similar to "printer-finisher" but contains mappings from "finSupplyTable" / "finSupplyEntry" rather than "finDeviceTable" / "finDeviceEntry". 

But one of the fields that we added in that first draft was a field for "finSupplyDescription". This is inconsistent with how we support "finDeviceDescription" in 5100.1 - that OID from RFC 3806 is conveyed in IPP via  a separate IPP attribute "printer-finisher-description 1setOf text(MAX))". The difference seems to be that the key/value pairs in "printer-finisher" are non-localized, whereas "finDeviceDescription" is a localized string, so "printer-finisher-description" contains localized strings. But this strikes me as odd - we have "printer-strings-supported" now, which could contain localized strings that don't have to be conveyed via IPP attribute values directly.

So, how to support "finSupplyDescription"? There are 3 different ways I can imagine:

1. Keep the mapping of "finSupplyDescription" in "printer-finisher-supplies", and embed a localized string within the value of "printer-finisher-supplies"?

2. Keep the mapping of "finSupplyDescription" in "printer-finisher-supplies", but have the value be a key into a string in the string catalog pointed to by "printer-strings-uri"?

3. Remove the mapping of "finSupplyDescription" from "printer-finisher-supplies" and instead be consistent with "printer-finisher" / "printer-finisher-description" by creating a new "printer-finisher-supplies-description" attribute that is syntactically nearly identical to "printer-finisher-description".

In this next draft I will do #3 because I can copy / paste quite easily. But I'm not confident that is the right choice.

Thoughts?

Smith

/**
    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Mon, 17 Oct 2016 18:05:25 -0400

Hi Smith,

This is NOT a choice.  If you want the localized description, then
it MUST be in a separate IPP attribute (like existing mappings
for Alert, Input, Output, etc. from Printer/Finisher MIB).

This is not just a style issue.  This is a strict IPP requirement that
a given attribute is either completely a localized IPP datatype (text)
or is not localized (octetString).

Prior art in MIB to IPP mapping had a good reason.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434

On Mon, Oct 17, 2016 at 3:56 PM, Kennedy, Smith (Wireless Architect) <
[email-masked]> wrote:

> Hi there,
>
> As you may have noticed in the most recent draft of Finishing 2.1, Ira and
> I added a new "printer-finisher-supplies" attribute to convey information
> about finisher supplies, which was absent before. It is structurally
> similar to "printer-finisher" but contains mappings from "finSupplyTable" /
> "finSupplyEntry" rather than "finDeviceTable" / "finDeviceEntry".
>
> But one of the fields that we added in that first draft was a field for
> "finSupplyDescription". This is inconsistent with how we support
> "finDeviceDescription" in 5100.1 - that OID from RFC 3806 is conveyed in
> IPP via  a separate IPP attribute "printer-finisher-description 1setOf
> text(MAX))". The difference seems to be that the key/value pairs in
> "printer-finisher" are non-localized, whereas "finDeviceDescription" is a
> localized string, so "printer-finisher-description" contains localized
> strings. But this strikes me as odd - we have "printer-strings-supported"
> now, which could contain localized strings that don't have to be conveyed
> via IPP attribute values directly.
>
> 1. Keep the mapping of "finSupplyDescription" in
> "printer-finisher-supplies", and embed a localized string within the value
> of "printer-finisher-supplies"?
>
> 2. Keep the mapping of "finSupplyDescription" in
> "printer-finisher-supplies", but have the value be a key into a string in
> the string catalog pointed to by "printer-strings-uri"?
>
> 3. Remove the mapping of "finSupplyDescription" from
> "printer-finisher-supplies" and instead be consistent with
> "printer-finisher" / "printer-finisher-description" by creating a new
> "printer-finisher-supplies-description" attribute that is syntactically
> nearly identical to "printer-finisher-description".
>
> In this next draft I will do #3 because I can copy / paste quite easily.
> But I'm not confident that is the right choice.
>
> Thoughts?
>
> Smith
>
> /**
>     Smith Kennedy

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Mon, 17 Oct 2016 22:10:50 +0000

Thanks Ira! 

I'll also add that to my list of stuff to be covered in the "PWG & IPP Design Principles and Ethos" whitepaper (whenever we get to that...).

Smith

> On Oct 17, 2016, at 4:05 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Smith,
> 
> 
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> On Mon, Oct 17, 2016 at 3:56 PM, Kennedy, Smith (Wireless Architect) <[email-masked] <mailto:[email-masked]>> wrote:
> Hi there,
> 
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
> 
>

---

From: Michael Sweet <[email-masked]>
Date: Mon, 17 Oct 2016 21:38:57 -0400

Smith,

What Ira said...

> On Oct 17, 2016, at 6:05 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Smith,
> 
> 
> On Mon, Oct 17, 2016 at 3:56 PM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> Hi there,
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer