Subject: [IPP] Fwd: Fwd: First IPP Everywhere Self-Certified Printers !!!

From: Ira McDonald <[email-masked]>
Date: Wed, 5 Oct 2016 16:03:23 -0400

Hi,

Per our brief discussion during today's IPP WG call, please consider
Till's comments and feature request (IEEE 1284 DeviceID values for
certified printers).   Please reply here on IPP mailing list and copy
Till on your response.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434

---------- Forwarded message ----------
From: Till Kamppeter <[email-masked]>
Date: Tue, Oct 4, 2016 at 9:11 PM
Subject: Re: Fwd: First IPP Everywhere Self-Certified Printers !!!
To: Ira McDonald <[email-masked]>, "
[email-masked]" <
[email-masked]>, Matthew Morikawa <
[email-masked]>

On 10/04/2016 01:45 PM, Ira McDonald wrote:

> Hi,
>
> I'm very pleased to announce the HP has successfully self-certified
> twenty (20) IPP Everywhere Printer models!
>
>
Thank you very much for the info.

And congrats to HP to certify the first ones.

> The following new IPP Everywhere Printers have been submitted to the PWG
> web site:
>
>   - HP DesignJet T730 36-in Printer
>   - HP DesignJet T830 Multifunction Printer
>   - HP OfficeJet 8702 All-in-One Printer
>   - HP OfficeJet Pro 8710 All-in-One Printer
>   - HP OfficeJet Pro 8712 All-in-One Printer
>   - HP OfficeJet Pro 8714 All-in-One Printer
>   - HP OfficeJet Pro 8715 All-in-One Printer
>   - HP OfficeJet Pro 8716 All-in-One Printer
>   - HP OfficeJet Pro 8717 All-in-One Printer
>   - HP OfficeJet Pro 8718 All-in-One Printer
>   - HP OfficeJet Pro 8719 All-in-One Printer
>   - HP OfficeJet Pro 8720 All-in-One Printer
>   - HP OfficeJet Pro 8722 All-in-One Printer
>   - HP OfficeJet Pro 8723 All-in-One Printer
>   - HP OfficeJet Pro 8724 All-in-One Printer
>   - HP OfficeJet Pro 8725 All-in-One Printer
>   - HP OfficeJet Pro 8726 All-in-One Printer
>   - HP OfficeJet Pro 8727 All-in-One Printer
>   - HP OfficeJet Pro 8728 All-in-One Printer
>
>
When I look through them, these are actually only 5 models:

   - HP DesignJet T730 36-in Printer
   - HP DesignJet T830 Multifunction Printer
   - HP OfficeJet 8702 All-in-One Printer
   - HP OfficeJet Pro 8710 All-in-One Printer Series
   - HP OfficeJet Pro 8720 All-in-One Printer Series

When only the last digit of the number differs, these are only variants
with regional adaptations. The printer itself is the same but the power
supply can be 110 V or 220 V, the power cord can be with different plug and
the printers front panel (what is printed on the printer's shell) can be in
different languages.

So I would like to see the IEEE-1284 device IDs for that printers, as for
listing them on OpenPrinting.org, there should be one printer entry per
device ID.

I would then add a driver entry called "IPP Everywhere" and make it the
recommended "driver" for these printers.

I have also discovered a bug on

http://www.pwg.org/dynamo/eveprinters.php

The link of the HP OfficeJet 8702 All-in-One Printer leads to HP's page of
the HP OfficeJet Pro 8710 All-in-One Printer series.

   Till
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Wed, 5 Oct 2016 20:30:39 +0000

Hi Ira and Till,

The submission web form and the site includes fields for both model name and family name. Once the page has more printers, we could consider a more sophisticated way of presenting them.  For instance, the top level list might only listing family names, and clicking on the link would take you to a sub-page for that family / filter the view on that family / reveal additional sub-rows that list the individual model strings.

On that subject, Mike, is there any logic that checks the fields in the web form against the content of the .plist files?

I fixed the URL for the OfficeJet 8702.

Smith

/**
    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

> On Oct 5, 2016, at 2:03 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi,
> 
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> From: Till Kamppeter <[email-masked] <mailto:[email-masked]>>
> To: Ira McDonald <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, Matthew Morikawa <[email-masked] <mailto:[email-masked]>>
> 
> 
> When only the last digit of the number differs, these are only variants with regional adaptations. The printer itself is the same but the power supply can be 110 V or 220 V, the power cord can be with different plug and the printers front panel (what is printed on the printer's shell) can be in different languages.
> 
> So I would like to see the IEEE-1284 device IDs for that printers, as for listing them on OpenPrinting.org, there should be one printer entry per device ID.
> 
> I would then add a driver entry called "IPP Everywhere" and make it the recommended "driver" for these printers.
> 
> http://www.pwg.org/dynamo/eveprinters.php <http://www.pwg.org/dynamo/eveprinters.php>
> 
> The link of the HP OfficeJet 8702 All-in-One Printer leads to HP's page of the HP OfficeJet Pro 8710 All-in-One Printer series.
> 
>    Till
> 
> 
>

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Wed, 5 Oct 2016 21:00:37 +0000

Oh, and I just noticed that the site will already filter the list based on values in the (invisible) model family field.

Smith

> On Oct 5, 2016, at 2:30 PM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
> Hi Ira and Till,
> 
>> On Oct 5, 2016, at 2:03 PM, Ira McDonald <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi,
>> 
>> So I would like to see the IEEE-1284 device IDs for that printers, as for listing them on OpenPrinting.org <http://openprinting.org/>, there should be one printer entry per device ID.
>>

---

From: Michael Sweet <[email-masked]>
Date: Thu, 06 Oct 2016 09:57:53 -0400

Smith,

> On Oct 5, 2016, at 4:30 PM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
> Hi Ira and Till,
> 

No.  I considered checking that at least one of the make/model strings matched the printer-make-and-model string, but because vendors are allowed to submit results for a whole product family (or submit new models within the product family using the same test results) I decided against it.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: Michael Sweet <[email-masked]>
Date: Thu, 06 Oct 2016 10:10:40 -0400

All,

> On Oct 5, 2016, at 4:03 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi,
> 
> ...

While we did decide to require printer-device-id for IPP Everywhere, it was done for interoperability with legacy operating systems and print spoolers that use printer drivers - there is nothing in there that says "this is an IPP Everywhere Printer".  The closest you will get is to see "image/pwg-raster" or "PWGRaster" in the "CMD" field of the 1284 device ID, which indicates that the printer supports the required raster format for IPP Everywhere.  Clients know a printer supports IPP Everywhere by the presence of the 'ipp-everywhere' string in the "ipp-features-supported" Printer Description attribute.

So I don't see any point in adding the 1284 device ID to the IPP Everywhere printer database.  You only need it to match with a non-IPP Everywhere printer driver instead of the generic driver.

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Tue, 11 Oct 2016 05:40:29 +0000

Hi Mike,

I agree that putting the 1284 Device ID should be unnecessary. An IPP Everywhere driver should match the general case, not be whitelisted in based on model info matching values in a white list. 

Smith

> On Oct 6, 2016, at 8:10 AM, Michael Sweet <[email-masked]> wrote:
> 
> All,
>