Subject: [IPP] High-level changes section for IPP Finishings v2.1?

From: Michael Sweet <[email-masked]>
Date: Wed, 09 Nov 2016 08:29:28 -0500

All,

It occurs to me, after looking at the current stable draft of IPP Finishings 2.1, that we don't have a high-level "Changes" section detailing the changes between published versions of PWG 5100.1 like we do for RFC2910bis and RFC2911bis, and that such a section would help our discussions at the F2F as well as providing useful context for readers once the update is published.

Proposed content:

11. Overview of Changes

11.1 Changes in IPP Finishings v2.1

The following changes were made for IPP Finishings v2.1:

- Added finishing enums and templates for multiple-hole punching and an engineering Z fold.
- Defined an extension naming convention for the "finishing-template" member attribute.
- Added the "media-sheets-supported" member attribute for the "finishings-col-database" and "finishings-col-ready" attributes.
- Added the "stitching-method" member attribute for the "finishings-col", "finishings-col-database", and "finishings-col-ready" attributes.
- Added the "printer-finisher-supplies" and "printer-finisher-supplies-description" attributes.

11.2 Changes in IPP Finishings v2.0

The following changes were made for IPP Finishings v2.0:

- Moved definition of PWG 5100.3 "finishings-col" attribute to this document and added new member attributes for all finishings processes.
- Added finishing enums and templates for coating, lamination, triple stapling, different kinds of punching, and common folds.
- Added the "finishings-col-database" and "job-pages-per-set" attributes.
- Added the "media-size" and "media-size-name" member attributes for the "finishings-col-database" and "finishings-col-ready" attributes.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Wed, 9 Nov 2016 09:57:19 -0500

Hi Mike,

I like your suggestion and agree with your initial suggested content.

These "Changes Since" sections are important for new readers and
those who've "been away for awhile."

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434

On Wed, Nov 9, 2016 at 8:29 AM, Michael Sweet <[email-masked]> wrote:

> All,
>
> It occurs to me, after looking at the current stable draft of IPP
> Finishings 2.1, that we don't have a high-level "Changes" section detailing
> the changes between published versions of PWG 5100.1 like we do for
> RFC2910bis and RFC2911bis, and that such a section would help our
> discussions at the F2F as well as providing useful context for readers once
> the update is published.
>
> Proposed content:
>
> 11. Overview of Changes
>
> - Added the "media-sheets-supported" member attribute for the
> "finishings-col-database" and "finishings-col-ready" attributes.
> - Added the "stitching-method" member attribute for the "finishings-col",
> "finishings-col-database", and "finishings-col-ready" attributes.
> - Moved definition of PWG 5100.3 "finishings-col" attribute to this
> document and added new member attributes for all finishings processes.
> - Added finishing enums and templates for coating, lamination, triple
> stapling, different kinds of punching, and common folds.
> - Added the "media-size" and "media-size-name" member attributes for the
> "finishings-col-database" and "finishings-col-ready" attributes.
>

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Wed, 9 Nov 2016 16:45:16 +0000

I think that is a good idea as well. I'll add that and post a new release here in a few minutes. But should it be that late in the document? Wouldn't it be better if it was inserted in between the current section 3 "Requirements" and section 4 "Overview of Finishing", or the current section 4 "Overview of Finishing" and section 5 "Job Template Attributes"?

Smith

> On Nov 9, 2016, at 7:57 AM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Mike,
> 
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> On Wed, Nov 9, 2016 at 8:29 AM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
> All,
> 
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
>

---

From: Ira McDonald <[email-masked]>
Date: Wed, 9 Nov 2016 11:51:30 -0500

Hi Smith,

At least in IETF and ISO documents the "Changes Since" section is
an appendix with a forward reference from section 1 Intro.

Cheers,
- Ira

On Wed, Nov 9, 2016 at 11:45 AM, Kennedy, Smith (Wireless Architect) <
[email-masked]> wrote:

> I think that is a good idea as well. I'll add that and post a new release
> here in a few minutes. But should it be that late in the document? Wouldn't
> it be better if it was inserted in between the current section 3
> "Requirements" and section 4 "Overview of Finishing", or the current
> section 4 "Overview of Finishing" and section 5 "Job Template Attributes"?
>
> Smith
>
>
>

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Wed, 9 Nov 2016 17:15:46 +0000

Update just posted here:

http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20161109.docx
http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20161109.pdf
http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20161109-rev.pdf
http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20161109-rev.docx

Smith

/**
    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

> On Nov 9, 2016, at 9:51 AM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Smith,
> 
> On Wed, Nov 9, 2016 at 11:45 AM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote: