Subject: [IPP] PDF Raster and IPP Scan

From: Paul Tykodi <[email-masked]>
Date: Fri, 1 Sep 2017 08:34:17 -0400

Hi,

I saw this announcement this morning.

Should we consider adding support for this format in IPP Scan?

http://www.prweb.com/releases/2017/08/prweb14644230.htm

Best Regards,

/Paul

Sent from my iPhone

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Fri, 1 Sep 2017 13:50:50 +0000

Just playing devil's advocate here. What does PDF/raster provide that the existing formats do not? Why did a new subset format need to be defined?

Cheers,
Smith
---

   Smith Kennedy
   Wireless Architect - Client Software - IPG-PPS
   Standards - PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum
   Chair, IEEE ISTO Printer Working Group
   HP Inc.

On Sep 1, 2017, at 6:35 AM, Paul Tykodi <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Best Regards,

/Paul

Sent from my iPhone
_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Paul Tykodi <[email-masked]>
Date: Fri, 1 Sep 2017 10:35:02 -0400

Hi Smith,

I don't know.

I will review new TWAIN cloud model this weekend to see whether IPP Scan and IPP Infra might be useful for TWAIN to use for connecting TWAIN cloud applications to TWAIN enabled network scanning devices.

Best Regards,

/Paul

Sent from my iPhone

> On Sep 1, 2017, at 9:50 AM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
> On Sep 1, 2017, at 6:35 AM, Paul Tykodi <[email-masked]> wrote:
> 
>> Hi,
>>

---

From: <[email-masked]>
Date: Fri, 1 Sep 2017 10:37:58 -0400

By quick skim, PDF/Raster appears to be the raster capability the exists within PDF, with some additional restrictions. Not quite sure why it requires a separate specification, except for  the comment that it is the file format required by “TWAIN Working Group’s new TWAIN Direct specification -- the first zero-footprint, cloud-based version of its royalty free open standard protocol that allows applications to talk directly to document scanners without the need for vendor specific drivers.” That us the rub and would suggest that IPP Everwhere/Scan  would have some very serious competition, if we ever formalized it. The scanner industry has a long history using TWAIN and, as in other areas, it will tend to continue with what is familiar. Still, a common imaging protocol for MFDs may find some support.

The IPP Scan Service spec appears to require that Scan Services support PDF.  Modifying that to allow lower end devices to support a PDF subset not be a major effort and might have some benefit in showing some degree of universality. Is there any product that uses IPP Scan?

Thanks, Bill Wagner

From: Kennedy, Smith (Wireless Architect)
Sent: Friday, September 1, 2017 9:51 AM
To: Paul Tykodi
Cc: [email-masked]
Subject: Re: [IPP] PDF Raster and IPP Scan

Smith

---

   Smith Kennedy

   HP Inc.

Best Regards,

/Paul

Sent from my iPhone

---

From: James Cloos <[email-masked]>
Date: Mon, 04 Sep 2017 18:22:54 -0400

They put the spec up at http://www.pdfraster.org/specification/

At least it lacks the obsurd licensing issues IFX's pdf had.

-JimC
-- 
James Cloos <[email-masked]>         OpenPGP: 0x997A9F17ED7DAEA6

---

From: Michael Sweet <[email-masked]>
Date: Tue, 05 Sep 2017 08:12:36 -0400

Bill,

> On Sep 1, 2017, at 10:37 AM, [email-masked] wrote:
> 

I can't answer that specifically, but given that IPP Scan requires PDF support and this is a strict PDF subset, there would be no problems supporting it in an IPP Scan implementation.  We could even register this spec using a pdf-versions-supported keyword value - no spec updates needed.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: Michael Sweet <[email-masked]>
Date: Tue, 05 Sep 2017 08:44:10 -0400

Paul,

As this is a strict subset of PDF and IPP Scan requires PDF support, nothing needs to be added unless you want the Client to be able to explicitly ask for a particular subset of PDF...  We could add a pdf-versions-supported keyword, but that is strictly informative...

That said, this subset is almost exactly the same as the PDF/is specification the PWG published 13 years ago:

    http://ftp.pwg.org/pub/pwg/candidates/cs-ifxpdfis10-20040315-5102.3.pdf

The main differences appear to be:

1. No JBIG2 support (?!?)
2. Different file format identification methods: PDF/is adds a new object, while PDF Raster uses a comment in the trailer.
3. PDF Raster supports encryption while PDF/is does not, but that doesn't really matter - PDF encryption is a joke because key generation is weak.
4. PDF Raster adds an XML (Adobe XMP) metadata object.

Both PDF/is and PDF Raster support banding, digital signing, and incremental/streamed writing.  Both also support the same bi-level, grayscale, and RGB color color spaces and bit depths.

The PDF Raster spec claims that it can be consumed by a simple parser, but I don't see how given that images can be banded - you will still need to implement a minimal page stream interpreter along with random access to the image objects.

Finally, it looks like a PDF writer could generate a PDF file that conforms to BOTH PDF/is and PDF Raster - thus an IPP Scan implementation could (as part of the general PDF support requirement) produce PDF scan files compatible with both standards.  But again, I don't think we need to update IPP Scan for this...

> On Sep 1, 2017, at 8:34 AM, Paul Tykodi <[email-masked]> wrote:
> 
> Hi,
>

---

From: <[email-masked]>
Date: Tue, 5 Sep 2017 15:57:34 -0400

Mike,
Understood that IPPScan requires PDF. My comment was that downgrading that requirement for scan services to PDF Raster would allow the lower end scanners that do not support full PDF (i.e. those devices for which PDF Raster is intended) to still implement and  claim support for IPP Scan.  Understood that it is unclear whether PDF Scan really allows for a significantly simpler scanner, it would appear that this TWAIN effort would enable a class of cloud-capable  scanner that could not use IPP Scan. Indeed, it is unclear whether that would bother anyone.

Thanks, Bill Wagner

Sent from Mail for Windows 10

From: Michael Sweet
Sent: Tuesday, September 5, 2017 8:12 AM
To: William Wagner
Cc: Smith Kennedy; Paul Tykodi; [email-masked]
Subject: Re: [IPP] PDF Raster and IPP Scan

Bill,

---

From: Michael Sweet <[email-masked]>
Date: Tue, 05 Sep 2017 16:01:43 -0400

Bill,

But PDF Raster *IS* PDF, and meets the requirements of IPP Scan.

> On Sep 5, 2017, at 3:57 PM, [email-masked] wrote:
> 
> Mike,

---

From: Ira McDonald <[email-masked]>
Date: Tue, 5 Sep 2017 16:54:33 -0400

Hi,

Two cents - Till has been wanting to do GSoC projects for a couple of years
to replace the not very secure, not very capable Network TWAIN protocol
with IPP Scan (possibly preserving the apparent TWAIN local interfaces).
He's been waiting for a few MFPs that support IPP Scan to begin prototyping.

I agree w/ Mike - PDF Raster is just another conforming subset of PDF.  IPP
Scan doesn't need any update to support it.

Note that PWG PDF/is was co-written by Adobe folks.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, Sep 5, 2017 at 4:01 PM, Michael Sweet <[email-masked]> wrote:

> > Understood that IPPScan requires PDF. My comment was that downgrading
> that requirement for scan services to PDF Raster would allow the lower end
> scanners that do not support full PDF (i.e. those devices for which PDF
> Raster is intended) to still implement and  claim support for IPP Scan.
> Understood that it is unclear whether PDF Scan really allows for a
> significantly simpler scanner, it would appear that this TWAIN effort would
> enable a class of cloud-capable  scanner that could not use IPP Scan.
> Indeed, it is unclear whether that would bother anyone.
> >
> > Thanks, Bill Wagner
> >
> > > By quick skim, PDF/Raster appears to be the raster capability the
> exists within PDF, with some additional restrictions. Not quite sure why it
> requires a separate specification, except for  the comment that it is the
> file format required by “TWAIN Working Group’s new TWAIN Direct
> specification -- the first zero-footprint, cloud-based version of its
> royalty free open standard protocol that allows applications to talk
> directly to document scanners without the need for vendor specific
> drivers.” That us the rub and would suggest that IPP Everwhere/Scan  would
> have some very serious competition, if we ever formalized it. The scanner
> industry has a long history using TWAIN and, as in other areas, it will
> tend to continue with what is familiar. Still, a common imaging protocol
> for MFDs may find some support.
> > >
> > > The IPP Scan Service spec appears to require that Scan Services
> support PDF.  Modifying that to allow lower end devices to support a PDF
> subset not be a major effort and might have some benefit in showing some
> degree of universality. Is there any product that uses IPP Scan?
> >
> > I can't answer that specifically, but given that IPP Scan requires PDF
> support and this is a strict PDF subset, there would be no problems
> supporting it in an IPP Scan implementation.  We could even register this
> spec using a pdf-versions-supported keyword value - no spec updates needed.
> >

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Tue, 5 Sep 2017 21:57:03 +0000

Is the XML metadata addition being used as a replacement for what might be conveyed over IPP as IPP attributes (e.g. "job ticket" type info)?

> On Sep 5, 2017, at 6:44 AM, Michael Sweet <[email-masked]> wrote:
> 
> Paul,
>

---

From: <[email-masked]>
Date: Wed, 6 Sep 2017 00:44:38 -0400

Mike,
OK. Then you are saying that a scanner implementing PDF/Raster satisfies the IPP Scan requirement that  “Scan Services MUST support generating Documents conforming to Document management — Portable document format — Part 1: PDF 1.7 [ISO32000] " ? In that case, one wonders why TWAIN /PDF would bother generating a new spec.
Thanks, BillW. 

From: Michael Sweet
Sent: Tuesday, September 5, 2017 4:01 PM
To: [email-masked]
Cc: Smith Kennedy; Paul Tykodi; [email-masked]
Subject: Re: [IPP] PDF Raster and IPP Scan

Bill,

---

From: Michael Sweet <[email-masked]>
Date: Wed, 06 Sep 2017 09:50:21 -0400

Smith,

It is more of a receipt of the settings that were used for the scan - the PDF file is the result/output from the scan job.

> On Sep 5, 2017, at 5:57 PM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
>

---

From: Michael Sweet <[email-masked]>
Date: Wed, 06 Sep 2017 10:00:28 -0400

Bill,

> On Sep 6, 2017, at 12:44 AM, [email-masked] wrote:
> 
> Mike,

PWG Raster is a raster-only subset of PDF 1.7/ISO 32000-1.  A program that can consume PDF 1.7 can consume PDF Raster, but the reverse is not necessarily true since PDF 1.7 includes other things like text, vector graphics, etc.

(now, I can't answer the "why" for why they didn't just adopt PDF/is, but perhaps they just were not aware of it...)