Subject: [IPP] IPP WG Agenda 3:00-4:30pm US Eastern (14 September 2017)

From: Ira McDonald <[email-masked]>
Date: Wed, 13 Sep 2017 20:05:20 -0400

Hi,

Our next IPP WG call will be Thursday 14 September 2017 at
12:00-1:30pm US Pacific / 3:00pm-4:30pm US Eastern

NOTE: Please USE the *new* WebEx and Audio Bridge below

-------------------------------------------------------
Meeting information
-------------------------------------------------------
Topic: IPP WG
Every 2 weeks on Thursday, from Thursday, May 11, 2017, to no end date
3:00 pm  |  Eastern Standard Time (New York, GMT-05:00)  |  1 hr 30 mins

-------------------------------------------------------
WebEx online meeting (join first, before audio bridge)
-------------------------------------------------------
1. Go to https://ieee-isto.webex.com/ieee-isto/j.php?MTID=m0359478143
ca01e059a570ada91f3573
2. If requested, enter your name and email address.
3. If a password is required, enter the meeting password: Printing123
4. Click "Join".

-------------------------------------------------------
Audio Bridge (join second w/ unique access code from WebEx)
-------------------------------------------------------
Call-in toll-free number (US/Canada): +1 866 469-3239 <%28866%29%20469-3239>
Call-in toll number (US/Canada): +1 650 429-3300 <%28650%29%20429-3300>
Call-in toll number (US/Canada): +1 408 856-9570 <%28408%29%20856-9570>

Global toll-free call in numbers and other audio options ("Call Me Back" or
VoIP) are listed once you join the WebEx meeting.

Unique attendee access code:  Displayed in the WebEx meeting

Agenda:
(1) PWG IP Policy, Minute Taker, Roll Call, and Agenda Review
- Mike as minute taker?

(2) Approve IPP minutes from previous meetings
- http://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20170817.pdf
-- IPP WG call on 08/17/17

(3) Status of Errata
- http://www.pwg.org/archives/ipp/2017/019302.html
-- ippserver: line number error
- http://www.pwg.org/archives/ipp/2017/019303.htm
<http://www.pwg.org/archives/ipp/2017/019303.html>
-- ipptool: host name shouldn't be case sensitive
- http://www.pwg.org/archives/ipp/2017/019324.html
-- PWG 5100.7: [jobx] and [ippdoc] references
- http://www.pwg.org/archives/ipp/2017/019333.html
-- PWG 5100.7: overloaded use of "defaults"

(4) Status of AMSC and ISO liaisons w/ PWG (Paul)
- http://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20170803.htm
-- see PWG SC minutes from 08/03/17

(5) Status of PWG 3D Print Job Ticket (Mike)
- http://ftp.pwg.org/pub/pwg/informational/bp-smpjt3d10-20170818.pdf
-- PWG Best Practices (18 August 2017)

(6) Status of Mapping of CIP4 JDF to PWG PJT (JDFMAP) (Ira, Rick)
- http://ftp.pwg.org/pub/pwg/informational/bp-smjdfmap10-20170828.pdf
-- PWG Best Practices (28 August 2017)

(7) Status of Get-User-Printer-Attributes (Smith)
- http://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-userop-20170801-rev.pdf
-- IPP WG adopted for registration track
-- Schedule - TBD

(8) Status of IPP Presets whitepaper (Smith)
- https://ftp.pwg.org/pub/pwg/ipp/wd/tb-ipp-preset-20170912-rev.pdf
-- IPP WG adopted for registration track
-- Schedule - TBD

(9) Status of IPP HTTP Authentication whitepaper (Smith)
- http://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-ippauth-20170803.pdf
-- PWG F2F review on 08/10/17
-- Schedule - TBD

(10) Status of "job-password" and "job-save-disposition" (Smith)
- http://www.pwg.org/archives/ipp/2017/019238.html
-- discussed at IPP WG on 06/29/17 and mailing list through 08/17/17
-- Schedule - awaiting further input from Smith, Mike, Ira

(11) Review of IPP System Service (Ira/Mike)
- http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippsystem10-20170910-rev.pdf
-- Prototype draft - PWG F2F review on 08/09/17 - completed
-- Schedule - prototype in "ippserver" - Stable draft in Q4 2017

(12) Next steps
- IPP WG call on Thu 28 September 2017 at 3:00-4:30pm US Eastern
-- regular topics

- IPP WG call on Thu 12 October 2017 at 3:00-4:30pm US Eastern
-- regular topics

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Thu, 14 Sep 2017 15:27:30 +0000

Hi Ira,

As you know, I won't make the call today. But I'd like to make sure that Github pull requests are also added to the agenda in the future. If I recall correctly, we needed to review these in the IPP WG meetings for WG approval. I'd like to finalize IPP Everywhere Self Certification 1.0 Update 2 soon and we need to approve some fixes before that can be made, IMHO. Releasing a "beta" build would be helpful as well.

Smith

/**
    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

> On Sep 13, 2017, at 6:05 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi,
> 
> 1. Go to https://ieee-isto.webex.com/ieee-isto/j.php?MTID=m0359478143ca01e059a570ada91f3573 <https://ieee-isto.webex.com/ieee-isto/j.php?MTID=m0359478143ca01e059a570ada91f3573>
> Call-in toll-free number (US/Canada): +1 866 469-3239 <tel:%28866%29%20469-3239>
> Call-in toll number (US/Canada): +1 650 429-3300 <tel:%28650%29%20429-3300>
> Call-in toll number (US/Canada): +1 408 856-9570 <tel:%28408%29%20856-9570>
> 
> Global toll-free call in numbers and other audio options ("Call Me Back" or VoIP) are listed once you join the WebEx meeting.
> 
> - http://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20170817.pdf <http://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20170817.pdf>
> - http://www.pwg.org/archives/ipp/2017/019302.html <http://www.pwg.org/archives/ipp/2017/019302.html> 
> - http://www.pwg.org/archives/ipp/2017/019303.htm <http://www.pwg.org/archives/ipp/2017/019303.html>
> - http://www.pwg.org/archives/ipp/2017/019324.html <http://www.pwg.org/archives/ipp/2017/019324.html>
> - http://www.pwg.org/archives/ipp/2017/019333.html <http://www.pwg.org/archives/ipp/2017/019333.html>
> - http://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20170803.htm <http://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20170803.htm>
> - http://ftp.pwg.org/pub/pwg/informational/bp-smpjt3d10-20170818.pdf <http://ftp.pwg.org/pub/pwg/informational/bp-smpjt3d10-20170818.pdf>
> - http://ftp.pwg.org/pub/pwg/informational/bp-smjdfmap10-20170828.pdf <http://ftp.pwg.org/pub/pwg/informational/bp-smjdfmap10-20170828.pdf>
> - http://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-userop-20170801-rev.pdf <http://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-userop-20170801-rev.pdf>
> - https://ftp.pwg.org/pub/pwg/ipp/wd/tb-ipp-preset-20170912-rev.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/tb-ipp-preset-20170912-rev.pdf>
> - http://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-ippauth-20170803.pdf <http://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-ippauth-20170803.pdf>
> - http://www.pwg.org/archives/ipp/2017/019238.html <http://www.pwg.org/archives/ipp/2017/019238.html>
> - http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippsystem10-20170910-rev.pdf <http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippsystem10-20170910-rev.pdf>
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>

---

From: Ira McDonald <[email-masked]>
Date: Thu, 14 Sep 2017 16:13:50 -0400

Hi Smith,

Look at Mike's minutes.

We did review all the Github pull requests and all the other errata reports.

Then we talked at length about Saved Jobs and the need for something
"better" (more flexible) than mere "job-password" to protect those Saved
Jobs from resubmission by unauthorized parties.

We also talked about the wider topic of "defense-in-depth", e.g., TLS does
good protection (w/ encryption) of data-in-transit and OPAL SEDs do quite
good protection (by automatic encryption) of data-at-rest.  Nonetheless,
security best practice would be to use another layer of encryption on the
wire and another layer of encryption at rest.  Needs LOTS more thought.

Without your good coments, we decided not to spend 25 minutes on the
review of a bit of IPP System Service.  Mike hopes in two weeks to have
some implementation insights and comments.

Cheers,
- Ira

Cheers,
- Ira

On Thu, Sep 14, 2017 at 11:27 AM, Kennedy, Smith (Wireless Architect) <
[email-masked]> wrote:

> Hi Ira,
>
> As you know, I won't make the call today. But I'd like to make sure that
> Github pull requests are also added to the agenda in the future. If I
> recall correctly, we needed to review these in the IPP WG meetings for WG
> approval. I'd like to finalize IPP Everywhere Self Certification 1.0 Update
> 2 soon and we need to approve some fixes before that can be made, IMHO.
> Releasing a "beta" build would be helpful as well.
>
> Smith
>
> /**
>     Smith Kennedy
> Global toll-free call in numbers and other audio options ("Call Me Back"
> or VoIP) are listed once you join the WebEx meeting.
>
> Jan-April: 579 Park Place
> <https://maps.google.com/?q=579+Park+Place%C2%A0+Saline,+MI%C2%A0+48176%C2%A0+734&entry=gmail&source=g>
> Saline, MI
> <https://maps.google.com/?q=579+Park+Place%C2%A0+Saline,+MI%C2%A0+48176%C2%A0+734&entry=gmail&source=g>
> 48176
> <https://maps.google.com/?q=579+Park+Place%C2%A0+Saline,+MI%C2%A0+48176%C2%A0+734&entry=gmail&source=g>
> 734-944-0094 <(734)%20944-0094>
> <(906)%20494-2434>